15:11:26 <kgriffs> #startmeeting marconi-team
15:11:27 <openstack> Meeting started Tue Jan  7 15:11:26 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:11:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:11:30 <openstack> The meeting name has been set to 'marconi_team'
15:11:34 <flaper87> o/
15:11:35 <kgriffs> #topic Review actions from last time
15:11:46 <flaper87> damnit, I hate that topic
15:11:49 * kgriffs calls on the gentlemen in the red hat
15:12:10 <kgriffs> #link http://eavesdrop.openstack.org/meetings/marconi/2013/marconi.2013-12-17-15.11.html
15:12:30 <kgriffs> kgriffs to create bp for notifications based on brainstorming session
15:12:31 <kgriffs> oops
15:12:33 <flaper87> Client patches, half done
15:12:34 <kgriffs> never happened
15:12:51 <kgriffs> flaper87: kk
15:12:54 <flaper87> BUT
15:12:56 <kgriffs> I wonder what's holding things up?
15:12:57 <flaper87> I've a BUT!
15:13:01 * kgriffs ducks
15:13:13 <flaper87> kgriffs: you're holding half of that action item
15:13:14 <flaper87> :D
15:13:18 <flaper87> the message part was implemented
15:13:18 <alcabrera> :P
15:13:29 <kgriffs> #action kgriffs to finish reviewing client patchez
15:13:36 <flaper87> the claim is still pending BUT in my defense I found a new guy - sebasmagri - that will work on that
15:13:37 <alcabrera> w00t
15:13:42 <kgriffs> there, now I *have* to do it. :D
15:13:45 <flaper87> that's how we roll
15:13:47 <flaper87> :D
15:13:47 <kgriffs> sweet
15:13:57 * kgriffs likes new contributors
15:14:05 <kgriffs> ask yeela to attend to Marconi's meetings
15:14:05 <flaper87> We're lacking of half feature but gained a new contributor
15:14:14 <kgriffs> flaper87: ^^^
15:14:21 <sebasmagri> :)
15:14:24 <sebasmagri> thanks flaper87
15:14:25 <flaper87> ykaplan: please, join the meeting :)
15:14:30 <flaper87> kgriffs: ^^^ just did
15:14:32 <flaper87> :D
15:14:37 <flaper87> huahauhauha
15:14:38 <kgriffs> what's up with sqlite anyway?
15:14:41 <kgriffs> oops
15:14:45 <kgriffs> I meant sqlalchemy
15:14:57 <kgriffs> I guess we'll get to that shortly
15:14:59 <flaper87> so, tables and the datadriver were merged
15:15:10 <flaper87> she's already working on the queue controller
15:15:32 <flaper87> ykaplan: right? ^^^
15:15:51 <ykaplan> flaper87, kgriffs: right :)
15:16:00 <alcabrera> awesome. :)
15:16:03 <kgriffs> excellent
15:16:15 <kgriffs> #action ykaplan to finish up queue controller
15:16:23 <flaper87> ykaplan: so happy you're here! kgriffs had a shotgun in his hands and he was starring at me!
15:16:25 <kgriffs> there, now you have to do it. :D
15:16:31 <alcabrera> lol
15:16:32 <flaper87> Now he can stare at you!
15:16:36 <alcabrera> the power of actions
15:16:36 <flaper87> ykaplan: ^
15:16:38 * kgriffs stares
15:16:38 <flaper87> :D
15:17:00 <kgriffs> one mores
15:17:01 <kgriffs> kgriffs to finish up v1.1 api spec
15:17:09 <ykaplan> flaper87: ;)
15:17:17 <kgriffs> so, I have first draft ready
15:17:17 <kgriffs> https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1
15:17:28 <flaper87> awesome
15:17:29 <kgriffs> please take a look. We will be reviewing it in future meetings
15:17:34 <kgriffs> (piece by piece)
15:17:34 <flaper87> any changes to the API so far?
15:17:38 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1
15:18:55 <kgriffs> flaper87: there is a list
15:18:58 <alcabrera> +1 for x-project-id header change.
15:19:05 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1#Changes_from_v1.0
15:19:16 <alcabrera> "Changes from v1.0"
15:19:26 <alcabrera> I like this section - very concise.
15:19:29 <kgriffs> so, I don't want to spend a lot of time on it just now - let's reserve that for future meetings
15:19:58 <kgriffs> or, feel free to ping my anytime in this channel to discuss parts of it
15:20:10 <flaper87> yeah, I'll read that off-line
15:20:13 <kgriffs> kk
15:20:33 <flaper87> next topic
15:20:34 <kgriffs> #action everyone to review the 1.1 spec and share feedback
15:20:50 <alcabrera> cool
15:20:50 * flaper87 wonders who's that guy....
15:20:54 <alcabrera> yup, let's move along
15:20:58 <kgriffs> Icehouse Roadmap
15:21:01 <kgriffs> #topic Icehouse Roadmap
15:21:09 <kgriffs> so, I guess we already discussed this some last time
15:21:26 <flaper87> #link https://blueprints.launchpad.net/marconi/icehouse
15:21:27 <kgriffs> I'm trying to remember why it was still on the agenda. :p
15:21:31 <flaper87> this is looking good!
15:21:41 <flaper87> kgriffs: I think you didn't remove it
15:21:42 <flaper87> :)
15:21:44 <kgriffs> ah, yes
15:21:48 <kgriffs> well, um...
15:21:51 * kgriffs coughs into hand
15:21:55 <flaper87> next topic
15:21:58 <alcabrera> yup
15:21:58 <kgriffs> one moment
15:22:02 <flaper87> :D
15:22:20 <kgriffs> everyone please note that if you want something in i-2 it needs to be assigned that milestone AND needs an "assignee"
15:22:34 <kgriffs> that is all
15:22:35 <kgriffs> carry on
15:23:05 <kgriffs> I will try to backfill stuff but if you notice something missing a milestone or assignee, please feel free to update it
15:23:22 <kgriffs> Review Graduation BPs/Bugs
15:23:31 <kgriffs> #topic Review Graduation BPs/Bugs
15:23:53 <alcabrera> Graduation check is just a month away!
15:24:03 <kgriffs> #link https://wiki.openstack.org/wiki/Marconi/Incubation/Graduation
15:24:12 <kgriffs> alcabrera: about that
15:24:31 <kgriffs> I think we will be removing the graduation milestone and creating an umbrella blueprint for all of these instead
15:24:40 <kgriffs> (as recommended by ttx)
15:24:53 <kgriffs> #action kgriffs to remove graduation milestone and create umbrella bp
15:24:59 <kgriffs> anyway
15:25:04 <kgriffs> let's go through these
15:25:04 * flaper87 thinks it'll be really hard to make it for Ith
15:25:11 <flaper87> lets keep fighting for that, though
15:25:16 <kgriffs> agreed
15:25:18 <kgriffs> (on both counts)
15:25:19 <alcabrera> yes
15:25:30 <kgriffs> ok,
15:25:35 <kgriffs> so first up in API 1.1
15:25:37 <megan_w> is the umbrella blue print just an organizational thing or does it have an affect on graduation?
15:25:38 <malini> what is blocking us from Ith?
15:25:44 <kgriffs> megan_w: organizational
15:25:47 <megan_w> k
15:25:53 <flaper87> malini: https://wiki.openstack.org/wiki/Marconi/Incubation/Graduation
15:25:58 <flaper87> all that
15:26:01 <kgriffs> it's what the openstack release team would like us to do
15:26:13 <malini> flaper87: :D
15:26:13 <amitgandhi> do we know the progress on each item
15:26:27 <kgriffs> starting with icehouse-2 we are going to be following official release procedures.
15:26:42 <kgriffs> amitgandhi: let's go over that now
15:27:10 <amitgandhi> btw, let me introduce balajiiyer to the team
15:27:16 <kgriffs> ok
15:27:21 * kgriffs give amitgandhi the floor
15:27:34 <amitgandhi> marconi team - meet balajiiyer
15:27:34 <balajiiyer> Hello everyone
15:27:39 <amitgandhi> balajiiyer: meet the marconi team
15:27:48 <flaper87> balajiiyer: yooooooooooooooo
15:27:57 <amitgandhi> balajiiyer: is one of our software managers and senior devs in atl
15:27:57 <flaper87> balajiiyer: please, tell me you're a coder and you'll contribute to marconi
15:27:58 <malini> balajiiyer: welcome o/
15:28:06 <amitgandhi> we are moving him into contributing on marconi
15:28:13 <flaper87> w000000000000000000000000000000000000000000000000000000000000000000000000t
15:28:15 <balajiiyer> Im a coder and will contribute to marconi
15:28:19 <megan_w> :)
15:28:22 <amitgandhi> he spent his christmas break getting up to speed with the code and environment
15:28:26 <alcabrera> balajiiyer: welcome! :D
15:28:41 <flaper87> balajiiyer: awesome, awesome... I'm italian and I'll bring nutella, pasta and many other italian things to ATL just for you!
15:28:42 <malini> balajiiyer: you would have got some poptarts, if not for the health stuff ;)
15:28:53 * flaper87 hopes that means sometihng
15:29:02 <amitgandhi> flaper87: balajiiyer is also our health advocate here
15:29:03 <balajiiyer> flaper87: awesome, I love italian food. I can code for pizza
15:29:13 <kgriffs> welcome man, glad to see you!
15:29:17 <malini> balajiiyer: tht is going to ATL mailing list
15:29:49 <flaper87> ok, back to the grad items
15:29:54 * kgriffs almost made an action item for pasta
15:30:00 <kgriffs> ok, so api 1.1
15:30:06 <kgriffs> I have that targeted to i-3
15:30:15 <kgriffs> and started since I got the spec drafted
15:30:42 <kgriffs> next we have SQL driver
15:31:03 <kgriffs> ykaplan gave her update on that earlier
15:31:38 <kgriffs> next is client lib
15:31:41 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/api-v1.1
15:32:07 <kgriffs> the hot news there is we will have an alpha version on pypi soon-ish!
15:32:22 <flaper87> #link https://blueprints.launchpad.net/python-marconiclient/+spec/python-marconiclient-v1
15:32:28 <flaper87> yeah, so, the client is in good shape
15:32:37 <flaper87> message support is about to be merged
15:32:40 <flaper87> kgriffs: right? ;)
15:32:43 * kgriffs just realized he pasted the wrong link!
15:32:48 <kgriffs> heh
15:32:53 <kgriffs> i certainly hope so
15:32:54 <flaper87> I also added the support shards
15:32:58 * kgriffs tells his clone to get to work
15:33:02 <flaper87> and sebasmagri will work on claims
15:33:07 <kgriffs> cool
15:33:16 <kgriffs> so, sounds like we are making good progress there
15:33:17 <flaper87> which will make the client feature complete
15:33:26 <kgriffs> excellent
15:33:36 <flaper87> yeah, we're like 2 features away from having a complete client
15:33:43 <amitgandhi> W00T
15:33:48 * alcabrera is excited about the client
15:33:59 <flaper87> we really need to release an alpha version, though. The next items depend on that
15:34:03 <kgriffs> yep
15:34:09 <kgriffs> thanks segue dude!
15:34:11 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/heat-template
15:34:23 <kgriffs> blocked by client
15:34:36 <flaper87> kgriffs: last time I checked, he was making some progress but the client blocked him
15:35:11 * kgriffs hates seques. Fell off one once.
15:35:17 <kgriffs> flaper87: kk
15:35:34 <kgriffs> devstack integration is DONE
15:35:48 <alcabrera> sweet
15:35:51 <amitgandhi> =D
15:35:54 <kgriffs> malini...
15:35:58 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/tempest-integration
15:36:04 <malini> thts in progress https://review.openstack.org/#/q/topic:bp/add-basic-marconi-tests,n,z
15:36:26 <malini> I got some feedback y'day on the tempest patch
15:36:33 <kgriffs> would you call it "slow progress" or "good progress" ?
15:36:51 <malini> its slow progress - because of delays in getting reviews
15:36:54 <kgriffs> kk
15:37:33 <kgriffs> next
15:37:40 <kgriffs> balajiiyer...
15:37:42 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/pecan-framework
15:37:57 <balajiiyer> I have started looking at that blueprint
15:38:19 <balajiiyer> Hoping to make that bp started by this week
15:38:26 <kgriffs> ok, cool
15:38:33 <alcabrera> I'll help balajiiyer get ramped up on that. :)
15:38:42 <kgriffs> ok
15:38:42 <flaper87> alcabrera: +1
15:38:55 <kgriffs> remember, we don't have to implement everything
15:38:59 <balajiiyer> alcabrera: thanks
15:39:17 <flaper87> I'd say, lets focus on the base features (creating queues, post messages)
15:39:25 <kgriffs> but, what we do implement we should try to be as "idiomatic" Pecan as possible - meaning, it should do it the "recommended Pecan way"
15:39:35 <kgriffs> sounds good
15:39:37 <flaper87> lest make sure they are both super optimized and that we can test this stuff once and for all
15:39:38 <kgriffs> don't worry about claims
15:39:39 <kgriffs> stats
15:39:41 <kgriffs> etc.
15:39:49 <balajiiyer> kgriffs: ok, sounds good
15:39:53 <kgriffs> I also am planning to count LOC
15:39:55 <kgriffs> ;)
15:40:01 <flaper87> LOOOL
15:40:06 <alcabrera> heh. :P
15:40:11 <balajiiyer> :)
15:40:15 <amitgandhi> what about complexity maccabe scores =P
15:40:20 <alcabrera> pecan is winning right now - 0 LOC
15:40:21 <flaper87> and NOC (number of commits)
15:40:22 <flaper87> :P
15:40:26 <kgriffs> amitgandhi: good idea!
15:40:28 * kgriffs adds to list
15:41:01 <kgriffs> side bar
15:41:19 <kgriffs> Falcon has 445 stars on github. Just sayin'
15:41:25 <flaper87> :D
15:41:40 <alcabrera> lol
15:41:44 <flaper87> 446*
15:41:48 <kgriffs> :D
15:41:59 <flaper87> Just sayin'
15:42:00 <kgriffs> yes, everyone go star it right now
15:42:01 <flaper87> :D
15:42:04 <kgriffs> :D
15:42:04 <flaper87> hahgahahha
15:42:54 <flaper87> next ?
15:42:56 <alcabrera> next BP? :P
15:43:01 <kgriffs> "Get into the service catalog"
15:43:08 <flaper87> mhh, that's done
15:43:10 <kgriffs> so, i found out we just need to document our service name
15:43:18 <kgriffs> it is up to providers to put it in if they want
15:43:25 <flaper87> yeah!
15:43:30 <flaper87> Done in devstack, I mean
15:43:40 <kgriffs> flaper87: can you document the name on the wiki?
15:43:46 <kgriffs> that you used in devstack?
15:43:46 <flaper87> kgriffs: yup
15:43:50 <kgriffs> cook, thanks!
15:43:56 <flaper87> my pleasure!
15:44:05 <kgriffs> #action flaper87 to document service catalog name - make it canonical or whatever
15:44:20 <kgriffs> next is horizon integration
15:44:28 <kgriffs> #link https://blueprints.launchpad.net/marconi/+spec/marconi-horizon-integration
15:44:41 <kgriffs> I am going to make this low priority
15:44:51 <flaper87> erm, everytime I read that BP, I just focus on the "nice to have" part of it
15:44:53 <kgriffs> I think we will have a hard time getting everything else done for icehouse as it is
15:44:54 <flaper87> :P
15:45:28 <alcabrera> agreed re: horizon
15:45:41 <kgriffs> I am going to assign it to balajiiyer
15:45:44 <kgriffs> just for fun.
15:45:47 <flaper87> LOL
15:45:57 <kgriffs> ok, i do have a reason
15:46:14 <amitgandhi> im thinking of potentially pulling one of our UX guys onto that but that cant happen until mid feb probably
15:46:16 <kgriffs> he has the most web frontend experience
15:46:23 <kgriffs> ok
15:46:29 <kgriffs> amitgandhi: let me know and we can reassign
15:46:34 <amitgandhi> ok
15:46:44 <kgriffs> although
15:46:48 <flaper87> TBH, we could also get some horizon dev to do it
15:46:58 <flaper87> I mean, ask if someone would like to stab that
15:46:59 <kgriffs> i have learned that being assigned to a bp just means you are responsible for reporting status each week
15:47:04 <kgriffs> not necessarily implementing all of it
15:47:06 <flaper87> but, cough cough cough, we need the client
15:47:11 <kgriffs> yep
15:47:23 <kgriffs> last item
15:47:24 <kgriffs> "Focus on a single transport - avoid scope creep"
15:47:29 <kgriffs> sort of a meta-blueprint
15:47:39 <kgriffs> we discussed this recently
15:47:42 <kgriffs> I think we are ok there
15:48:04 <flaper87> yeah, lets focus on wsgi for graduation the rest is just R&D for now
15:48:22 <kgriffs> doing multiple-transports is going to run as a side-by-side experiment. If it pans out, cool beans. If not, then we can claim innocence.
15:49:12 <kgriffs> ok, any other bps anyone wants to discuss before we move on to bugs?
15:49:41 <flaper87> mmh, 10 mins left
15:49:45 <flaper87> :/
15:49:48 <kgriffs> yeah
15:50:01 <kgriffs> well, heck, we are in our own channel this week, so no conflicts! :p
15:50:08 <flaper87> LOL
15:50:11 <kgriffs> #topic Updates on bugs
15:50:54 <kgriffs> #link https://bugs.launchpad.net/marconi/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&fie
15:50:54 <kgriffs> ld.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on
15:50:58 <kgriffs> crappies
15:51:02 <alcabrera> yikes
15:51:03 <kgriffs> let me try that again
15:51:04 <mpanetta> MY EYES!
15:51:08 <kgriffs> http://goo.gl/7lIJ4q
15:51:10 <kgriffs> much better
15:51:38 <kgriffs> first three - no changes afaik. I am still tring to get to the autoreconnect one.
15:52:05 <flaper87> I've been working on 3 bugs, I could give updates about those
15:52:09 <kgriffs> ok
15:52:11 <kgriffs> go for it
15:52:24 <flaper87> 1) https://bugs.launchpad.net/marconi/+bug/1261579
15:52:30 <flaper87> I've a quesiton there
15:52:53 <flaper87> We said we're going to count the whole body request and limit based on that
15:53:28 <flaper87> BUT, if we do that, we'll be also counting ttl, {}, [], etc as part of the message
15:53:49 <flaper87> should we iterate over the message list and sum up the size of the message content?
15:54:03 <kgriffs> mmm
15:54:09 <flaper87> that sounds a bit slow
15:54:20 <flaper87> OR
15:54:22 <kgriffs> you might do it using a regex or something, but yeah
15:54:23 <kgriffs> slow
15:54:25 <alcabrera> I think it's fine just counting the content length.
15:54:32 <kgriffs> let's just KISS
15:54:44 <flaper87> alcabrera: yeah, that was my OR
15:54:45 <alcabrera> Considering that the TTLs and symbols that aren't the message body would add maybe 100 bytes.
15:54:48 <kgriffs> if people complain, we can throw in some fudge room
15:54:50 <flaper87> but let me add something
15:55:00 * kgriffs listens
15:55:04 <flaper87> we should also advice users with a +/- valid max_size
15:55:15 <flaper87> for example: If you want the max size to be 256
15:55:37 <flaper87> we recommend using 512 because most of the rquest size is consumed by the json crap
15:55:41 <flaper87> or something like that
15:56:14 <alcabrera> I had another idea when you mentioned +/-, flaper87.
15:56:19 <flaper87> alcabrera: shoot
15:56:21 <alcabrera> When a person goes over the message size limit
15:56:31 <alcabrera> We can return as part of the error message by how much they went over.
15:56:46 <flaper87> +1
15:56:52 <kgriffs> make it so
15:56:59 <flaper87> ok, so, content-length <= max_size
15:57:10 <alcabrera> flaper87: yup
15:57:13 <flaper87> 2) https://bugs.launchpad.net/marconi/+bug/1244228
15:57:14 <kgriffs> megan_w: what do you think about this?
15:57:23 <flaper87> actually
15:57:25 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1244228
15:57:37 <kgriffs> megan_w: we are going to redefine max message size to be much simpler
15:57:37 <flaper87> it's not as simple as it seems
15:57:47 * flaper87 STFU and waits for megan_w
15:58:05 <megan_w> its defined today by the entire message, excluing whitespace, right
15:58:08 <megan_w> ?
15:58:32 <kgriffs> megan_w: today we say the sum of the "body" subdocument in the JSON, excluding whitespace, must be x
15:58:55 <kgriffs> we want to simplify and just say that the entire document you send up, as-is, counts toward the max size
15:59:14 <megan_w> yes, that seems much better
15:59:19 <alcabrera> sweet
15:59:19 <kgriffs> awesome
15:59:23 <flaper87> cool
15:59:29 <flaper87> ok, back to bugs
15:59:35 <flaper87> it's not as simple as it seems
15:59:37 <alcabrera> (20 seconds)
15:59:54 <flaper87> oslo.config makes it really difficult to have lazy options and CLI registered
16:00:02 <flaper87> I have an idea of how to implement that
16:00:09 <flaper87> so, I'll send a patch shortly
16:00:19 <flaper87> it'll need some re-usable hacks
16:00:23 <alcabrera> cool - I'll review that soon after it arrives. :D
16:00:29 <flaper87> #link https://bugs.launchpad.net/marconi/+bug/1266454
16:00:39 <flaper87> ok, that needs some discussion
16:00:52 <alcabrera> agreed
16:01:01 <flaper87> kgriffs: made a good point saying that health is used by LB to know whether marconi is running
16:01:08 <flaper87> that's very useful
16:01:23 <flaper87> however, I think health provides more info than the user is interested in
16:01:31 <flwang> LB=load balancing?
16:01:33 <flaper87> I proposed having a /ping endpoint
16:01:38 <flaper87> returning 200 / 404
16:01:40 <flaper87> flwang: yes
16:01:46 <kgriffs> well, today it doesn't provide more info, but it could
16:01:46 <flwang> got it
16:01:52 <flaper87> and kgriffs proposed adding a ?detailed=true query param
16:01:57 <alcabrera> flaper87: I like this /ping idea.
16:02:03 <flaper87> kgriffs: I'd say it will, TBH
16:02:20 <alcabrera> I've gotta run. I'll be back online in ~30.
16:02:23 <flaper87> ElaseticSearch has a health endpoint and it provides a lot of useful info
16:02:24 <amitgandhi> does ping return the status of the webhead or the backends also?
16:02:33 <kgriffs> so this is what I think
16:02:43 <flaper87> amitgandhi: that specific node
16:02:49 <kgriffs> version 1.0's health endpoint is renamed to /ping in v1.1
16:02:58 <kgriffs> i mean, semantically
16:03:03 <flwang> I think we can return more info in /health, such as all the status of shard point
16:03:06 <kgriffs> so what health does today, ping does in 1.1
16:03:39 <amitgandhi> health today for admins is differnt to health for users (ie for users always returns 204 unless node is down)
16:03:39 <flaper87> kgriffs: sounds good
16:03:52 <kgriffs> ok, let me update the 1.1 bp
16:03:55 <flwang> kgriffs: does mean we won't rename it now, but only semantically?
16:04:02 <flaper87> amitgandhi: mmh, not entirely true, AFAIK
16:04:05 <flaper87> it does the same for both
16:04:09 <kgriffs> and then let's create a new bp for adding a /health endpoint that gives operations info
16:04:14 <amitgandhi> my concern with ping doing the backend checks is the load it will generate
16:04:29 <flwang> kgriffs: i'd like to work on that
16:04:37 <kgriffs> flaper87: ok, feel free to add a bp
16:04:46 <kgriffs> #action kgriffs to update 1.1 spec with ping endpoint
16:05:18 <flaper87> kgriffs: but I'd say the client should point to v1.1
16:05:27 <flwang> kgriffs: are you talking to me? this is flwang
16:05:35 <kgriffs> flwang: Let's target to icehouse-3 - if it gets in, then we can make it part of the 1.1 spec
16:05:55 <flwang> kgriffs: ok, btw, what's the due date of i-3?
16:06:09 <kgriffs> https://wiki.openstack.org/wiki/Icehouse_Release_Schedule
16:06:24 <flwang> kgriffs: got, thanks
16:06:44 <kgriffs> amitgandhi: valid concern. The current code just does a very cheap ping to mongo to see if it is alive
16:06:54 <kgriffs> the ping is for load balancers only
16:07:00 <kgriffs> fwiw
16:07:11 <flaper87> yeah, returns the state of that specific node
16:07:13 <kgriffs> which brings us to this: https://bugs.launchpad.net/marconi/+bug/1242926
16:07:31 <kgriffs> Rackspace does a trick in Cloud Queues to make this work today
16:07:38 <kgriffs> but I want a better solution
16:08:05 <flaper87> At this point it should become /ping
16:08:14 <flaper87> but yeah, I agree
16:08:19 <kgriffs> yes, so that bug will change to reference /ping
16:08:27 <flwang> kgriffs: yep, if we're going to provide more if in /health, then I think we need auth for it
16:08:29 <kgriffs> I would like to schedule this for i-3 as well (this bug)
16:08:54 <flwang> more info
16:09:03 <flaper87> kgriffs: lets do that, I think avoiding auth for this endpoint is good
16:09:07 <kgriffs> so ping would be no auth, but also restricted to LB only (x-forwarded-for) to avoid abuse by end users
16:09:23 <flwang> kgriffs: +1
16:09:23 <flaper87> kgriffs: right
16:09:37 <flaper87> we should have some configurable restrictions for that endpoint
16:09:48 <flaper87> unless no auth is being used at all
16:10:32 <kgriffs> flaper87: can you post your thoughts in a comment on that bug?
16:10:39 <kgriffs> https://bugs.launchpad.net/marconi/+bug/1242926
16:10:51 <flaper87> kgriffs: I'm already doing that :)
16:11:01 <kgriffs> excellent
16:11:32 <kgriffs> last bug real quick that I wanted to cover
16:11:35 <kgriffs> malini...
16:11:35 <kgriffs> https://bugs.launchpad.net/marconi/+bug/1261904
16:12:08 <kgriffs> can anyone confirm this has been fixed?
16:12:30 <malini> kgriffs: I can chk tht
16:12:36 <kgriffs> kk
16:12:40 <kgriffs> thanks!
16:13:46 <kgriffs> ok folks, any parting thoughts, questions, concerns, or rude remarks?
16:14:35 <kgriffs> #endmeeting