15:01:35 <kgriffs> #startmeeting marconi
15:01:36 <openstack> Meeting started Tue Apr 22 15:01:35 2014 UTC and is due to finish in 60 minutes.  The chair is kgriffs. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:37 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:39 <openstack> The meeting name has been set to 'marconi'
15:01:41 <kgriffs> #topic roll call
15:01:43 <kgriffs> o/
15:01:49 <alcabrera> o/
15:02:02 <flaper87> o/
15:02:15 <sriram> o/
15:02:20 <flwang> o/
15:02:25 <mpanetta> o/
15:03:28 <malini> o/
15:03:32 <alcabrera> \\o//
15:03:55 <flaper87> kgriffs: knock knock
15:03:58 <flaper87> :D
15:04:25 <kgriffs> hmmm, seems we are missing a few folks
15:04:42 <flaper87> balajiiyer: raise your hand dude, don't be mean to kgriffs
15:04:48 <flaper87> we know you're there
15:04:49 <kgriffs> if you are here for marconi, please raise your hand. :)
15:05:10 <kgriffs> this is so I know who gets poptarts later
15:05:21 <flaper87> \o/
15:05:26 <kgriffs> 30 seconds
15:05:40 <balajiiyer> o/
15:06:14 <balajiiyer> *stealth mode actiavted*
15:06:16 <flaper87> balajiiyer: you just needed kgriffs to mention poptarts, didn't you?
15:06:18 <vkmc> o/
15:06:24 <flaper87> vkmc: CONGRAAAAAAAAAAAAAATSSSSSSSSSSSSSSSSSSSSSSSSSSS
15:06:26 <kgriffs> alright! The life of the party!
15:06:36 <vkmc> flaper87, :D :D :D :D thanks!
15:06:39 <kgriffs> now we can get this thing started
15:06:40 <alcabrera> w00t
15:06:51 <kgriffs> #link https://wiki.openstack.org/wiki/Meetings/Marconi#Agenda
15:07:05 <kgriffs> #topic Big welcome to our friendly, stylish interns!
15:07:14 <malini> yayyy!!!!
15:07:22 <sriram> w00t :D
15:07:25 <kgriffs> please introduce yourselves for those following along at home. :D
15:07:33 <kgriffs> vkmc: ^^^
15:07:52 <vkmc> kgriffs, Haha sure
15:07:55 <vkmc> Hi everyone!
15:08:02 <flaper87> <big>WELCOME</big> to all the really cool interns
15:08:47 <kgriffs> vkmc: so, your name, where you are from, your favorite ice cream
15:08:50 <kgriffs> :)
15:09:03 <vkmc> Most of Marconi chaps already saw me around, but... I'm Victoria, a Computer Sciences student based in Argentina
15:09:12 <flaper87> vkmc: pls, credit card number and pin too
15:09:15 <alcabrera> lol
15:09:26 <alcabrera> at #marconi, we're *very* thorough
15:09:37 <sriram> lol
15:09:37 <vkmc> I have been selected for GSoC 2014
15:09:47 <flwang> vkmc: welcome :)
15:09:49 <mpanetta> flaper87: and private key.
15:09:54 <vkmc> And I'm hoping to rock Marconi this summer
15:09:57 <malini> I accept cash
15:10:12 <kgriffs> vkmc: excellent. glad to have to on the crew!
15:10:16 * flaper87 accepts whatever can be used to buy malini's trust
15:10:18 <vkmc> I love all icecream flavors btw
15:10:29 <vkmc> Thanks all :)
15:10:39 <malini> Congratulations again vkmc!!
15:10:40 <flwang> alcabrera: seems we have another intern, for the redis idea, is it?
15:10:46 <alcabrera> flwang: yup!
15:10:50 <alcabrera> prashanth
15:10:50 <flaper87> vkmc: you sure? There's a 1k icecream falvor shop in Venezuela and I'm sure there's something you don't like there
15:10:53 <flaper87> :D
15:11:15 <flaper87> vkmc: on a serious note, I'm so thrilled to have you in the team! Welcome!
15:11:28 <vkmc> flaper87, We could try! :) haha
15:11:37 <kgriffs> ok, I don't see AAzza around... anyone want to pretend to be AAzza  for a moment and introduce themselves?
15:11:48 <alcabrera> :P
15:12:01 <vkmc> flaper87, Thanks F, I'm really happy to be able to join you guys (finally!)
15:12:12 <kgriffs> alcabrera: did you just volunteer to introduce AAzza?
15:12:14 <kgriffs> :D
15:12:19 <malini> I can proxy for AAzza ;)
15:12:22 <alcabrera> haha
15:12:26 <alcabrera> I'll let malini do so
15:12:57 <malini> "I am awesome & have already contributed to making the marconi tests better"
15:13:04 <Obulpathi> vkmc: congrats and welcome :)
15:13:16 <alcabrera> AAzza's summary on OPW: "Nataliia Uvarova (AAzza), Gjøvik, Norway / Kiev, Ukraine - Py3K support in Marconi"
15:13:36 <malini> alcabrera has more useful info :D
15:13:58 <flaper87> so, we'll have full support for Py3K
15:14:00 <flaper87> w000t
15:14:02 <alcabrera> in all, I'm grateful to have the opportunity to work with three new contributors/interns. It's going to be a fun summer. :)
15:14:03 <flaper87> :D
15:14:10 <kgriffs> ah, we have 3?
15:14:12 <kgriffs> who is the other?
15:14:15 <alcabrera> yup!
15:14:19 <flaper87> kgriffs: HAHAHAHAHA
15:14:24 <Obulpathi> thats awesome!
15:14:25 <alcabrera> prashanth, who is not here atm. :P
15:14:29 * flaper87 gives kgriffs a glass of wather
15:14:33 <kgriffs> ah, that's right
15:14:41 <flaper87> kgriffs: breath man, breath! In... out...
15:14:41 * kgriffs takes pill
15:14:44 <flaper87> :D
15:14:45 * kgriffs becomes sane again
15:14:53 <flaper87> that's how awesome this project is
15:15:46 <vkmc> lol
15:16:04 <kgriffs> no, that's how awesome you guys are. Our People Make the Difference™.
15:16:12 <kgriffs> ok, moving on...
15:16:21 <kgriffs> #topic Discuss proposed design sessions
15:16:30 * flaper87 ducks
15:16:42 * flaper87 switched the agenda order and none noticed
15:16:44 <flaper87> no one
15:16:47 <kgriffs> lol.
15:16:49 <flaper87> and if someone did, sshh
15:16:51 <kgriffs> switched the link too
15:16:54 <flaper87> let me believe that
15:16:56 <flaper87> :P
15:17:00 <kgriffs> #link https://etherpad.openstack.org/p/marconi-meetings
15:17:20 <kgriffs> so, we have 4 slots.
15:17:25 <flaper87> I put everything in that pad. It's easier to do votes
15:18:47 <kgriffs> I think all of these are great topics. But we need to move two of them to using our "project pod" unconference space
15:19:18 <ametts> State of the Union doesn't sound like a good use of limited time, IMHO
15:19:22 <kgriffs> so, which ones could benefit from increased visibility to other teams (since they will show up on the official schedule
15:20:07 <ametts> (although that one probably has the broadest appeal to outsiders)
15:20:34 <malini> But we'll need ppl from other projects to show up for State of the union to be useful
15:20:47 <sriram> yes, that makes sense
15:20:57 <flaper87> guys, just add +1's
15:21:05 <flaper87> we can assume -1 if no vote was added
15:21:06 <malini> Do we typically get other project teams to show up in our sessions?
15:21:20 <flaper87> malini: yes
15:21:25 <flaper87> we can invite them
15:21:27 <flwang> kgriffs: +1 I like the point
15:21:39 <malini> tht changed my vote
15:21:53 <malini> I might have accidentally removed somebody's −1 from State of Union
15:22:01 <malini> Can the −1 person chk pl?
15:23:27 <kgriffs> "accidentally" ;)
15:23:41 <malini> :D
15:24:17 <alcabrera> all set on my end
15:24:23 <alcabrera> I contributed the Nyan Cat design session
15:27:57 <kgriffs> ok, so signed messages we can do as an unconference
15:28:10 <flaper87> kgriffs: +1
15:28:22 <kgriffs> and state of the union - dang, i wish we could do that since it would be good PR, but we do need to work out the design for those other things
15:28:43 <kgriffs> how about a trifold, science-fair style?
15:28:46 <kgriffs> :D
15:28:55 <malini> I think we need to do the state of the union in a non sessiony way
15:28:58 <flaper87> kgriffs: I actually would prefer to do state of the union with some redbulls in hand and we all sitten somewhere
15:29:30 <Obulpathi> +1
15:29:36 <alcabrera> state of the union over pizza
15:29:43 <alcabrera> with onion on it
15:29:45 <alcabrera> make it cheesy
15:29:45 <flaper87> alcabrera: +1
15:29:52 <flaper87> alcabrera: and beefy
15:29:53 <mpanetta> mmmm pizza
15:29:53 <alcabrera> the pizza and the session
15:29:53 <Obulpathi> alcabrera: +1
15:29:54 <flaper87> :P
15:30:08 <alcabrera> :D
15:31:46 * flaper87 has nothing else to add to this topic
15:31:47 <kgriffs> ok, is everyone cool with this plan?
15:31:54 <ametts> flaper87: s/redbulls/beers/
15:32:06 <alcabrera> +1
15:32:07 <flaper87> ametts: s/beers/wine/
15:32:13 <flaper87> but yeah, I can do beers too
15:32:23 <alcabrera> s/{drink}/water|soda
15:32:46 <flaper87> water = sode = beer
15:32:50 <flaper87> soda*
15:32:59 <kgriffs> I am going to sneak something in to the agenda while we are on the subject of the summit
15:33:16 <kgriffs> #topic Summit publicity stunt
15:33:32 <mpanetta> Please don't jump off a building kgriffs
15:33:42 <malini> mpanetta: :D
15:33:44 <flaper87> lol
15:33:45 <megan_w> i'm intrigued..
15:33:46 <kgriffs> uh, why?
15:33:52 * kgriffs quickly comes up with a different idea
15:34:03 <malini> kgriffs: jumping from a helicopter?
15:34:43 <kgriffs> ok, so here is the proposal (kudos to ametts, mpanetta, and balajiiyer for helping me with this)
15:34:50 * flwang thinking
15:34:59 <kgriffs> we go get a couple cases of Kraft Macaroni and Cheese
15:35:17 <kgriffs> and then we slap a sticker on there that invites people to go visit a landing page
15:35:24 <ametts> s/couple/lots/
15:35:34 <kgriffs> on that page, we have rules for a contest/raffle to give away some sweet ARM hobby boards
15:35:59 <kgriffs> we also have a section on there that we can use to promote the "state of the union" of Marconi
15:36:00 <malini> tht is a great idea :D
15:36:00 <flaper87> wow, sounds really great
15:36:15 <kgriffs> so, we can do one or both of the following
15:36:17 <malini> We can make some macaroni for the really hungry
15:36:24 <kgriffs> 1. a raffle for new contributors
15:36:39 <kgriffs> 2. a contest for coolest app that uses marconi
15:37:00 <megan_w> 2 would probably help us the most
15:37:12 <megan_w> 1 would get have more participation
15:37:17 <malini> 1. a raffle for new contributors ==> Is tht for folks who submit a new marconi patch during the summit?
15:37:18 <kgriffs> in either case, we would give some kind of deadline that is a few weeks out, since people will probably be too busy to hack during the conference
15:38:04 <kgriffs> ok, well, think about it and share your suggestions in #openstack-marconi
15:38:04 <alcabrera> kgriffs: +1 on a few weeks out -- it's considerate of conference go-ers, in my opinion
15:38:20 <Obulpathi> +1
15:38:22 <flaper87> agreed
15:38:29 <kgriffs> alcabrera: plus, that ensures people keep thinking about us when the get home. :D
15:38:43 <malini> hmm..tht is what I am concerned abt
15:38:53 <alcabrera> yup, yup
15:38:54 <malini> will they think of us once they get home?
15:39:12 <kgriffs> they will as soon as they sit down to enjoy a delicious bowl of Mac & Cheese. :D
15:39:16 <malini> If they made a small patch, they will be more inclined to think of us
15:39:52 <malini> But I agree the summit is going to be too busy
15:39:53 <flwang> kgriffs: but what's the award to attract the hackers?
15:40:06 <kgriffs> either wandboard or udoo
15:40:41 <kgriffs> anyway, let's move on
15:40:50 <kgriffs> discuss this further in the program channel
15:40:58 <flwang> kgriffs:  a kiss from flaper87?
15:41:01 <kgriffs> #topic POP Queues - Sign off on Delete a Set of Messages by ID + XOR(pop, ids)
15:41:06 <flaper87> wait, what?
15:41:09 <mpanetta> haha
15:41:16 <kgriffs> ROFL
15:41:35 <kgriffs> wow. That would certainly increase participation by like 1000%
15:41:35 <malini> So this is to get everybody's consensus
15:41:45 * flaper87 will have to wear a pink tutu
15:41:46 * kgriffs shuts up and listens
15:41:56 * flaper87 STFU
15:42:12 <malini> Is everybody ok with using delete messages by id endpoint to do the pop?
15:42:32 <malini> we will validate tht the request has either pop or ids, but not both params
15:42:48 <kgriffs> and return an error if both are present?
15:43:09 <malini> kgriffs: yes 400 with appropriate message
15:43:11 <flaper87> malini: is that GET /id?pop= ?
15:43:24 <malini> #link https://wiki.openstack.org/wiki/Marconi/specs/api/v1.1#Delete_Multiple_Messages
15:43:35 <malini> it will be a new pop param there
15:44:08 <malini> DELETE /v1.1/queues/{queue_name}/messages?pop=x
15:44:22 <malini> where x <max_messages_per_claim
15:44:25 <kgriffs> I think that the proposal isn't perfect, but there is not perfect solution, and this is a pretty sane choice, all things considered
15:44:30 <flaper87> I don't want to start bikeshedding again but why can't it be a /pop endpoint ?
15:44:48 <flaper87> GET|DELETE /messages/pop
15:44:55 <malini> These are the options we considered https://etherpad.openstack.org/p/marconi-pop-operation
15:45:13 <malini> kgriffs: you had some thoughts against a new endpoint, rt?
15:46:01 <alcabrera> I'm in favor of DELETE as the method
15:46:07 <alcabrera> I'm not opposed to a new endpoint
15:46:17 <alcabrera> I'm happy with the current proposed version
15:46:24 <alcabrera> DELETE /v1.1/queues/{queue_name}/messages?pop=x
15:46:32 * alcabrera share sthoughts, wanders off for a bit
15:46:46 <kgriffs> well, a new endpoint violates the REST architectural style, since you are conflating a resource with an action
15:46:50 <flaper87> is it me or etherpad is working bad
15:46:52 <flaper87> ?
15:47:00 <mpanetta> kgriffs++
15:47:01 <kgriffs> flaper87: probably just you. ;)
15:47:01 <flaper87> kgriffs: good point
15:47:03 <malini> flaper87: it looks ok to me
15:47:09 <kgriffs> so, the RESTafarian in me cringes
15:47:17 <kgriffs> that being said, consider:
15:47:18 <kgriffs> DELETE /v1.1/queues/messages/pop?limit=10
15:47:20 <kgriffs> vs.
15:47:21 <flaper87> so, no new endpoint, I think that's a good point
15:47:27 <kgriffs> DELETE /v1.1/queues/messages?pop=10
15:47:39 <kgriffs> not much different, and the second one keeps the RESTafarians happy
15:47:53 <Obulpathi> +1
15:48:06 <flaper87> it's a +1 from me for: DELETE /v1.1/queues/messages?pop=10
15:48:14 <flaper87> shall we vote?
15:48:20 <malini> sure
15:48:41 <malini> though it sounds like all are in favor
15:48:47 <flaper87> or at least set an agreed on this
15:48:50 <mpanetta> aye
15:48:54 <sriram> I agree as well
15:48:55 <kgriffs> ok, any opposed?
15:49:01 <kgriffs> (10 seconds to object)
15:49:18 * ametts thinks kgriffs should have a gavel
15:49:31 <kgriffs> #agreed Implement POP in the API by adding an additional param to DELETE /v1.1/queues/messages
15:49:42 * kgriffs pounds gavel
15:49:51 <malini> awesome!
15:49:54 <malini> Thank You!
15:49:55 <mpanetta> ---()
15:50:02 <kgriffs> so... wrt API docs -
15:50:10 <alcabrera> * /v1.1/queues/{queue}/messages
15:50:13 <alcabrera> minor correction
15:50:18 <kgriffs> I was thinking to reduce confusion, we might want to document that endpoint 2x's, once with each param
15:50:27 <kgriffs> alcabrera: noted
15:50:47 * kgriffs glances at court reporter
15:50:52 <alcabrera> kgriffs: +1 for multi-doc, and I'd also like to see a fail response documented for when both params are provided
15:51:18 <malini> #action: malini will document pop in v1.1 api 2x's, once with each param (pop & ids)
15:51:38 <megan_w> perhaps we should do a quick write up of why we chose this method...may be helpful in future graduation reviews or mailing list convos
15:51:47 <kgriffs> malini: we will need to make sure that gets done in both the WADL and on the wiki
15:51:58 <malini> kgriffs: sure
15:51:59 <kgriffs> megan_w: good idea
15:52:08 <malini> megan_w: I will summarize the etehrpad discussion
15:52:35 <kgriffs> malini: we should make a home on the wiki for "decisions history" or something
15:53:13 <malini> kgriffs: Or maybe just update the bp ?
15:53:33 <megan_w> bp seems like a logical place for it
15:53:52 <kgriffs> mmm. That could work, but we should still have an index to those blueprints to highlight things we think people may raise an eyebrow about
15:54:30 <kgriffs> #topic Identify 'low hanging fruit' bps for new contributors
15:54:51 <malini> I added this one for our last meeting -but never got to it
15:55:12 <kgriffs> ah, ok
15:55:18 <malini> But the idea was to identify small enough tasks, not in high priority list
15:55:23 <kgriffs> +1
15:55:34 <kgriffs> let's put that in the up-and-coming contributor guide on our wiki
15:55:35 <malini> This can be the starting point for any new contributors who come in
15:55:42 <kgriffs> we need to figure out a way to keep it up to date
15:56:00 <kgriffs> maybe find a way to tag bp's when we triage them, then have a script that filters on that
15:56:48 <malini> Also when we add new bps, we should take a step back & analyze if it will be a good first patch
15:56:59 <malini> So label them as you create the bp
15:57:32 <malini> did everybody leave?
15:57:37 <kgriffs> #agreed tag existing and new bp's as "fruity"
15:57:40 <Obulpathi> I am still here
15:57:51 <malini> Obulpathi: thanks :D
15:57:59 <kgriffs> phew, lots of stuff to cover today!
15:58:02 <kgriffs> Last item
15:58:12 <Obulpathi> malini: :)
15:58:12 <kgriffs> #topic sitemap for wiki refactor
15:58:23 <kgriffs> https://etherpad.openstack.org/p/marconi-wiki-sitemap
15:58:25 <kgriffs> #link https://etherpad.openstack.org/p/marconi-wiki-sitemap
15:58:39 <kgriffs> please take a look, and discuss over in #openstack-marconi
15:58:46 <kgriffs> #topic open discussion
15:59:09 <flaper87> PLEASE: https://etherpad.openstack.org/p/draft-marconi-faq
15:59:24 <flaper87> I started moving some Q&A to https://wiki.openstack.org/wiki/Marconi/FAQ
15:59:32 <flaper87> write, read, review, update! Thanks! :)
15:59:36 <malini> We has some actions for tht last week
15:59:47 <malini> lets review those in #openstack-marconi
15:59:57 <kgriffs> ok, cool
15:59:59 <Obulpathi> ok
16:00:04 <kgriffs> oh, one last thing
16:00:15 <kgriffs> someone owns Marconi trademark
16:00:20 <malini> :(
16:00:23 <vkmc> :/
16:00:27 <kgriffs> so we may need to change the name if they can't reach an agreement with the foundation
16:00:37 <sriram> :O
16:00:41 <flaper87> kgriffs: damnit!
16:00:42 <malini> maybe we'll become macaroni !
16:00:48 <flaper87> BIKESHED FTW!
16:01:03 * flaper87 wants to call it Querconi
16:01:11 <kgriffs> malini: LOL. Then our publicity stunt at the summit will be even more awesome.
16:01:12 <malini> I like that flaper87!
16:01:22 <kgriffs> How about "Bob"
16:01:29 <kgriffs> ok, thanks everyone
16:01:30 <flaper87> kgriffs: Jon Doe
16:01:33 <flaper87> kk
16:01:35 <kgriffs> #endmeeting