15:00:11 <tbarron> #startmeeting manila
15:00:11 <openstack> Meeting started Thu Mar 14 15:00:11 2019 UTC and is due to finish in 60 minutes.  The chair is tbarron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:14 <openstack> The meeting name has been set to 'manila'
15:00:47 <amito> hey o/
15:00:49 <tbarron> #info Agenda: https://wiki.openstack.org/wiki/Manila/Meetings#Next_meeting
15:00:57 <tbarron> hi amito!
15:00:59 <gouthamr> o/
15:01:12 <lseki> hi
15:01:16 <jgrosso> hi
15:01:20 <ganso> hello
15:01:48 <tbarron> courtesy-ping: zhongjun xyang  toabctl bswartz  erlon tpsilva vkmc
15:02:15 <bswartz> .o/
15:02:45 <carthaca> Hi
15:03:02 <tbarron> carthaca is still with us for a bit I see ...
15:03:09 <tbarron> Hi all!
15:03:11 <carlos_silva> hi!
15:03:27 <tbarron> carlos_silva: lseki: greetings
15:03:35 <tbarron> #topic Announcements
15:03:54 <tbarron> As probably most of you are aware
15:04:02 <tbarron> we are now in Feature Freeze
15:04:08 <tbarron> and Soft String Freeze
15:04:15 <tbarron> and Requirements Freeze
15:04:33 <tbarron> So we're  only merging bug fixes
15:04:34 <vkmc> o/
15:04:48 <tbarron> Reviewers please be alert for changes in user-facing strings
15:05:06 <tbarron> We can do them but we need to ask for approval on openstack-discuss
15:05:19 <gouthamr> tbarron: only manila-ui is translated, isn't it?
15:05:23 <tbarron> This is to give the translation team time to get their work done before the release
15:05:51 <bswartz> gouthamr: that may be true
15:05:57 <tbarron> gouthamr: I guess that's right but isn't that wrong for our project?
15:06:02 <bswartz> Although it might make sense to translate the client too
15:06:05 <tbarron> gouthamr: do you know why?
15:06:17 <vkmc> only user facing strings
15:06:25 <tbarron> right but
15:06:33 <vkmc> ui, error messages that the users see as well IIRC
15:06:35 <tbarron> vkmc: we have user facing strings in the server
15:06:41 <vkmc> yes
15:06:44 <xyang> hi
15:06:49 <bswartz> IIRC they used to translate log and exception messages but gave up on that because it was too much work
15:07:01 <gouthamr> tbarron: lack of translation resources, and we don't translate logs since a while... the API error messages could be translated, but i haven't seen any in the last few releases
15:07:15 <tbarron> bswartz: well we still put translation markers for API errors, etc.
15:07:18 <vkmc> it has been a while that I don't chat with people in the i18n team
15:07:27 <vkmc> it used to be like that back then
15:07:28 <tbarron> I will seek clarification
15:07:30 <vkmc> it makes sense though
15:07:38 <vkmc> tbarron, let me do that
15:07:40 <tbarron> Anyways, let's notice and talk about it.
15:07:46 <tbarron> vkmc: awesome
15:08:21 <tbarron> #action vkmc will clarify the scope of translation and of string freeze
15:08:42 <tbarron> We go to hard string freeze 21 March.
15:09:10 <tbarron> So within our scope -- whatever that turns out to be, at least the UI -- no changes in user-facing messages after that point.
15:09:32 <tbarron> Release week starts April first
15:09:34 <tbarron> no kidding
15:09:54 <tbarron> After that only release-blocking critical bugs will be merged.
15:10:04 <tbarron> And then we release 8 April.
15:10:05 <ganso> tbarron: isn't RC1 next week?
15:10:13 <tbarron> ganso: thanks
15:10:38 <tbarron> Yes, the first release candidate (didn't mean to leave that out) is 21 March.
15:11:20 <tbarron> So we aim to have all bugs fixed by then but have leeway to cut more release candidates if
15:11:29 <tbarron> we need to untili release week
15:11:43 <tbarron> that is, we could within manila decide to do it
15:11:47 <tbarron> but we don't want to
15:12:06 <tbarron> after 1 April it would require wider agreement with true release blockers
15:12:16 <tbarron> very unlikely cause we're not nova :)
15:12:35 <tbarron> Any questions/comments about schedule?
15:13:20 <tbarron> Anyone else have announcments?
15:13:23 <ganso> tbarron: I do
15:13:30 <tbarron> ganso: please go ahead
15:13:44 <ganso> Last friday March 8th was my last day working for NetApp
15:14:09 * tbarron is glad to see ganso is still working on Manila though :)
15:14:20 <lseki> we miss you ganso
15:14:21 * tbarron tries ....
15:14:30 <ganso> the NetApp proposed features and bugfixes will be handled by the other NetApp team members: carlos_silva, dviroel_ and lseki
15:15:03 <tbarron> carlos_silva: lseki dviroel_ you have big shoes to fill
15:15:29 <ganso> Core work is not among the top priorities of my new employer, so core work will be limited to my free time for the moment
15:15:33 <lseki> tbarron, we have
15:15:49 <carlos_silva> tbarron: surely!
15:16:09 <ganso> corrections: "Manila core work", and "is currently not among the top priorities"
15:16:10 <gouthamr> ganso: canonical? friendship over!
15:16:24 <lseki> lol
15:16:30 <ganso> gouthamr: lol
15:16:37 <tbarron> ganso: I am hoping that you and tpsilva can persuade canonical of manila's strategic value.
15:16:50 <gouthamr> ganso: just kiddling :) Congratulations on the transition, and all the best!
15:17:04 <ganso> gouthamr: thanks! =)
15:17:05 <bswartz> Congrats ganso on new job
15:17:06 <tbarron> ganso: yes, congratulations!
15:17:15 <bswartz> NetApp will miss you
15:17:19 <ganso> bswartz, tbarron: thanks! =D
15:17:25 <carthaca> ganso: all the best from me as well
15:17:36 <ganso> carthaca: thank you =)
15:17:49 <amito> ganso: congrats
15:18:13 <ganso> amito: thanks =)
15:18:25 <xyang> congrats ganso
15:18:34 <ganso> xyang: thanks! =)
15:18:57 <xyang> who is going to Denver
15:19:05 <tbarron> xyang: that's the next topic
15:19:10 <xyang> ok
15:19:11 <tbarron> Any more announcements?
15:19:21 <ganso> tbarron: not from me =) thanks
15:19:32 <tbarron> ganso: that's quite enough from you for one day :)
15:19:48 <tbarron> #topic PTG
15:19:48 <ganso> tbarron: xD
15:19:54 <tbarron> xyang: you are up
15:20:25 <tbarron> She asked: who is going to Denver?
15:20:51 <tbarron> a) For Summit?
15:20:56 <tbarron> b) for PTG?
15:21:13 <tbarron> Our PTG planning etherpad is here:
15:21:29 <tbarron> #link: https://etherpad.openstack.org/p/manila-denver-train-ptg-planning
15:21:40 <xyang> I'm going to Denver, but I just realized the registration fee is so expensive.  First time that I don't have a free pass
15:21:51 <xyang> $999 for summit and $499 for PTG
15:22:13 <tbarron> And there is a place to indicate if you plan to attend, either physically or remotely
15:22:14 <gouthamr> xyang: :( that's steep for a contributor... i.e., we should be able to request an ATC for you?
15:22:48 <gouthamr> s/we/tbarron can i think
15:22:49 <xyang> I think I have passed the deadline to be the extra ATC.  I didn't submit any patch recently so I didn't get any discount from them
15:23:09 <xyang> I sent foundation a question about it but have not heard back yet
15:23:40 <vkmc> xyang, I have a pass for you
15:23:46 <xyang> you do?
15:23:56 <xyang> you have extra free passes?
15:24:11 <vkmc> I only have one :)
15:24:12 <amito> are there *free* passes? not just discounted?
15:24:26 <vkmc> not sure if free... but certainly a discount
15:24:40 <xyang> vkmc, are you not going?
15:24:47 <vkmc> xyang, I'm attending ptg only
15:24:54 <amito> I got an email saying the price for past attendees is 20% from the original price. It was at least until the end of February (early bird)
15:29:30 <gouthamr> ..
15:29:40 <amito> *crickets*
15:29:50 * bswartz gets trout ready
15:30:02 <bswartz> tbarron must have lost connection or gone AFK suddenly
15:30:04 * gouthamr makes coffee, looks at tbarron
15:30:12 * amito unpacks trout shield
15:30:25 * ganso casts trout protection spell
15:30:30 * vkmc eats popcorn
15:30:31 <xyang> I was wondering where it everyone
15:31:21 <vkmc> maybe tbarron is having connection issues
15:31:29 <bswartz> What else is on the agenda?
15:31:30 <gouthamr> must be a network issue on tbarron's end.. let's move on
15:32:02 <bswartz> gouthamr: are you able to continue to run the meeting?
15:32:02 <gouthamr> #LINK https://etherpad.openstack.org/p/manila-denver-train-ptg-planning
15:32:19 <gouthamr> bswartz: nope, not chair, so can't set topic
15:32:29 <gouthamr> #topic PTG
15:32:32 <bswartz> Yeah but we can just continue on without bot powers
15:32:38 <gouthamr> fail :)
15:33:16 <gouthamr> yep, please look at the PTG Planning etherpad, and add topics, we'll prune, rearrange/organize closer to the event
15:33:56 <tbarron> I"ve been typing away
15:33:58 <tbarron> wondering why no one wanted to talk to me
15:34:00 <tbarron> Anything else on PTG?
15:34:02 <gouthamr> also, please indicate your attendance on there. we'll try to have (vkmc do the) online streaming for the PTG discussions as usual
15:34:04 <tbarron> #chair gouthamr
15:34:04 <openstack> Current chairs: gouthamr tbarron
15:34:05 <bswartz> tbarron: wb
15:34:14 <tbarron> #chair bswartz
15:34:15 <openstack> Current chairs: bswartz gouthamr tbarron
15:34:15 <bswartz> Did we netsplit?
15:34:25 * gouthamr gives up throne
15:34:38 <tbarron> gouthamr: keep going, it's all good
15:34:58 <gouthamr> tbarron: :P nothing else really, i think we covered PTG
15:35:18 <tbarron> #topic bugs
15:35:23 <jgrosso> woo hoo
15:35:48 <jgrosso> first bug :)
15:35:51 <jgrosso> https://bugs.launchpad.net/manila/+bug/1811336
15:35:52 <openstack> Launchpad bug 1811336 in Manila "Manila snapshot create method doesn't support "force" attribute" [Undecided,New]
15:36:03 <jgrosso> I was asked to revisit this with a wider audience !
15:36:33 <tbarron> yeah, I wanted people with more history than I have in manila so they could say
15:36:41 <tbarron> what "force" would add for this one
15:37:08 * bswartz waits for very slow web browser to open link...
15:37:19 <bswartz> I need more RAM in this VM
15:37:26 <tbarron> in cinder I can imagine that it would mean take a snapshot even if the volume is attached or some such
15:37:28 <gouthamr> https://github.com/openstack/manila/blame/f38b8d4efd1f68f4ea29747f7377e0936f61d89c/manila/share/api.py#L493
15:37:42 <gouthamr> we had that behavior, many releases ago...
15:37:43 <bswartz> What does force mean?
15:38:08 <tbarron> but in manila we have no knowledge of whether a share is actively being used
15:38:22 <bswartz> Correct
15:38:51 <tbarron> so why would we "force"?  we have reset-state to available, right?
15:39:00 <tbarron> user vs admin control?
15:39:10 <bswartz> So we never should have had a "force" flag, and it should be removed immediately, as long as that wouldn't cause back-compat issues
15:39:49 <tbarron> the bug reporter seems to just notice that the flag is there, not to give a use case for it
15:40:25 <gouthamr> actually, sorry, we still honor the force flag: https://github.com/openstack/manila/blob/master/manila/share/api.py#L1084
15:41:05 <tbarron> gouthamr: so the bug is invald?  (and the behavior isn't terribly useful ....?)
15:41:14 <tbarron> invalid
15:41:34 <gouthamr> tbarron: yes, i wonder if they want to send the flag down to the backend driver?
15:42:04 <tbarron> gouthamr: their complaint is that we don't "pass it on"
15:42:30 <tbarron> maybe this one should go to "incomplete" while we ask "pass to whom?"
15:42:52 <gouthamr> ack, will ask on the bug
15:43:02 <jgrosso> Ok will update bug
15:43:10 <gouthamr> jgrosso: thank you!
15:43:13 <jgrosso> welcome
15:43:14 <jgrosso> https://bugs.launchpad.net/manila/+bug/1816430
15:43:15 <openstack> Launchpad bug 1816430 in Manila "intermittent generic back end extend/shrink share failures" [Undecided,New]
15:43:16 <tbarron> gouthamr: ok, note though they are saing share_ap;i doesn't pass it
15:43:30 <tbarron> so they may think manager should do something with force?
15:43:51 <gouthamr> tbarron: ack
15:44:11 <tbarron> we are seeing this one quite frequently lately
15:44:12 <gouthamr> bswartz: you're in favor of removing it?
15:44:30 <carthaca> I understand it as: the share_api has it, but the api does not pass it
15:44:33 <bswartz> gouthamr yes
15:45:00 <tbarron> carthaca: but it doesn't need to pass it if it does the create even though the state wasn't available
15:45:22 <tbarron> which is the original intent of "force" given the code archaeology gouthamr showed us
15:45:33 <bswartz> Is there are cinder reattachment that occurs on shrink/extend in the generic driver?
15:45:39 <tbarron> carthaca: the state validation was earlier ...
15:45:56 <bswartz> I'm wondering if we have a timing problem and we're not waiting for the right thing
15:45:59 <gouthamr> bswartz: i can think of one case where it's helpful, but maybe this is a small topic for the PTG
15:46:09 <gouthamr> bswartz: i can research some more..
15:46:23 <tbarron> gouthamr: use the etherpad, luke
15:46:27 <tbarron> I know you will
15:46:42 <gouthamr> tbarron: :) done
15:47:01 <tbarron> bswartz: that seems like a good question (cinder reattachment)
15:48:08 * tbarron imagines a world in which Canonical pays people to work on the generic driver and make it great
15:48:30 <bswartz> https://github.com/openstack/manila/blob/master/manila/share/drivers/generic.py#L652
15:48:31 <gouthamr> s/people/ganso
15:48:42 <tbarron> u'fsck.ext2: No such file or directory while trying to open /dev/vdd\n
15:48:42 <bswartz> I see the reattach right there
15:49:02 <tbarron> nodePublishVolume isn't working
15:49:08 <tbarron> woops, wrong context
15:49:40 <ganso> tbarron:  :P
15:50:00 <ganso> #makeTheGenericDriverGreatAgain
15:50:09 <tbarron> switching from goland window to pycharm
15:50:26 <bswartz> Oh no the brazilians are stealing our memes
15:50:38 <ganso> bswartz: lol
15:50:44 <tbarron> they elected the meme-in-chief there
15:51:06 <lseki> rofl
15:51:09 <jgrosso> ok so is https://bugs.launchpad.net/manila/+bug/1816430  a PTG topic?
15:51:10 <openstack> Launchpad bug 1816430 in Manila "intermittent generic back end extend/shrink share failures" [Undecided,Triaged]
15:51:13 <tbarron> ok, everybody get back on topic, starting with you tbarron
15:51:37 <tbarron> jgrosso: we should have a list of important, recalcitrant bugs and that one can be on it
15:51:51 <jgrosso> ok great will add a new list
15:52:00 <bswartz> I don't see a need for PTG topic, someone with cinder/nova/generic driver experience just needs to dig in
15:52:18 <jgrosso> ok
15:52:22 <jgrosso> next
15:52:23 <tbarron> bswartz: yeah the topic would be - how do we get these attention, etc.
15:52:27 <bswartz> The generic driver is unloved since it's author moved on
15:52:30 <tbarron> not solving them there
15:52:51 <jgrosso> https://bugs.launchpad.net/manila/+bug/1819167
15:52:52 <openstack> Launchpad bug 1819167 in Manila "next share_links contains not supported marker field " [Undecided,New]
15:53:45 <bswartz> Seems like a straightforward API bug, but I'm not sure what the rules are for pagination
15:54:16 <gouthamr> ouch
15:54:29 <tbarron> will this one have churn given recent work with endpoints?
15:54:44 <gouthamr> we don't use markers in our API afaia, we allow "offset"
15:55:28 <gouthamr> tbarron: it's possible.. pagination needs a relook across the board, but i can take a look at this particular API for starters
15:55:37 <tbarron> gouthamr: thanks
15:56:06 <gouthamr> tbarron: i have been sharing with you/vkmc off-list, but our links are wrong, and it isn't just because of the changes we made to accommodate uwsgi/proxies
15:56:33 <gouthamr> jgrosso: please assign this to me
15:56:40 <vkmc> yeah, stuff started to pop up after we started tinkering urls
15:56:47 <tbarron> gouthamr: yeah, thanks for surfacing this discussion
15:57:23 <jgrosso> ok
15:57:25 <jgrosso> will do
15:57:45 <jgrosso> that is all I have for bugs
15:57:49 <jgrosso> thanks all!
15:57:55 <tbarron> #topic open-discussion
15:58:25 <tbarron> so I think our reference open source drivers should be more like zfs
15:58:33 <tbarron> with a clear separation between driver and back end
15:58:42 <tbarron> so the back end can run stable code
15:58:58 <tbarron> and the driver will be tested in gate on master
15:59:08 <tbarron> generic is the perfect example of violating this
15:59:20 <tbarron> so cinder or nova or neutron bugs in master break us
15:59:26 <tbarron> nuf said, I said it
15:59:44 <bswartz> I'm not sure how ZFS works different in regard to those issue
15:59:58 <tbarron> zfs back end is packaged, stable, right?
16:00:14 <tbarron> or could be at least
16:00:20 <bswartz> Might need to discuss this one later
16:00:24 <bswartz> I have another meeting to run to
16:00:24 <tbarron> we're trying to move cephs that wasy
16:00:26 <tbarron> yup
16:00:28 <bswartz> But it's an interesting topic
16:00:30 <tbarron> Thanks everyone!!
16:00:36 <tbarron> see you on #openstack-manila
16:00:40 <tbarron> #endmeeting