09:00:20 <jakeyip> #startmeeting magnum
09:00:20 <opendevmeet> Meeting started Wed Jan 10 09:00:20 2024 UTC and is due to finish in 60 minutes.  The chair is jakeyip. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:20 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:20 <opendevmeet> The meeting name has been set to 'magnum'
09:00:30 <jakeyip> Agenda:
09:00:31 <jakeyip> #link https://etherpad.opendev.org/p/magnum-weekly-meeting
09:00:35 <jakeyip> #topic Roll Call
09:00:51 <dalees> o/
09:01:01 <jakeyip> o/
09:01:14 <jakeyip> mnasiadka: ping :)
09:01:25 <mnasiadka> o/
09:02:32 <jakeyip> hi dalees mnasiadka, thanks for joining the meeting. hope you had a good holiday.
09:03:36 <mnasiadka> will be off for next two weeks for another vacation ;-)
09:03:47 <jakeyip> niceeee :)
09:04:09 <jakeyip> alright I think that's everyone, let's get on with it
09:04:54 <jakeyip> #topic Announcements
09:06:10 <jakeyip> I would like to change things up a bit this year. I realised I've been dropping the ball a bit last year on deadlines. Thanks to the others who reminded me.
09:06:49 <jakeyip> I would like to start meeting with a ping of deadlines we need to meet in near future so I can get on to things.
09:08:22 <jakeyip> one example is  feature freeze R-5 (Feb 26 - Mar 01, mnasiadka brought it up
09:08:38 <jakeyip> another is vPTG which should be in Apr
09:08:45 <jakeyip> anything else we need to take note of?
09:09:04 <dalees> Most deadlines will be on here, though I don't often look at it. Good to be reminded of upcoming ones - https://releases.openstack.org/caracal/schedule.html
09:09:52 <dalees> I'd like to ask if there is a deadline for spec additions for Caracal. I have a couple in draft I've not uploaded yet. I see only Cinder and Nova specify deadlines for these.
09:11:28 <jakeyip> dalees: for magnum? I am not aware of any, we can decide. follow nova for now?
09:12:18 <dalees> theirs is this week, so I'd prefer a little more. But yeah it can't be too close to R-5
09:12:35 <jakeyip> it doesn't have to be strict, still can upload after, it's just us
09:12:56 <jakeyip> bigger projects like cinder and nova have many projects downstream of them so they need to be stricter
09:13:03 <dalees> yep, ok.
09:14:06 <jakeyip> speaking of spec, capi spec needs +1 if nobody objects violently :P
09:14:38 <jakeyip> ok back to deadlines, anything we (I) need to take note of?
09:14:50 <dalees> I was just reading it again, I missed scrolling down to all of your updates in patchset 2. Yep I will +1
09:15:00 <jakeyip> thanks dalees
09:16:59 <jakeyip> close to the topic of deadlines, I also would like to get a feel for people who are interested in taking over as PTL
09:17:50 <dalees> keen to continue supporting you, jakeyip
09:18:09 <jakeyip> I was quite slammed last yaer due to team members in my company being away, which caused me to drop the ball on some things. this year should be better (fingers crossed)
09:19:02 <jakeyip> But if anybody wants to take over PTL do let me know. I am all for new leadership. feel free to DM me etc to talk about it.
09:19:36 <jakeyip> thanks dalees and mnasiadka for stepping up to help with release. :)
09:20:30 <mnasiadka> np
09:20:43 <jakeyip> dalees / mnasiadka: you keen on rotating for a cycle or so? or move to shared? hoppy to hear your opinions.
09:23:12 <mnasiadka> Well, from my perspective - if you're persistent on stepping down/rotating - I think dalees would be better candidate - but if he's not up for it, I can probably think about it.
09:23:57 <dalees> I'll have a think about that and discuss with you later.
09:24:55 <jakeyip> sure, I just want to put the idea out there, I don't want to be dictator for life. :P
09:24:57 <jakeyip> thanks al
09:25:04 <jakeyip> thanks all
09:25:23 <mnasiadka> benevolent dictator for life? ;-)
09:25:24 <jakeyip> #topic CAPI
09:25:54 <jakeyip> :P
09:26:11 <mnasiadka> Again?
09:26:14 <mnasiadka> :-)
09:26:25 <jakeyip> sticky topic :)
09:26:43 <mkjpryor> Hi all. Apologies for my late arrival - I had some issues connecting, not sure why...
09:26:55 <jakeyip> welcome mkjpryor :)
09:26:57 <mkjpryor> Did I miss anything critical?
09:27:03 <jakeyip> just in time for CAPI :P
09:27:07 <dalees> So, CAPI topic was prompted by elodilles's question about the currently empty capi-helm repo.
09:27:10 <mkjpryor> My favourite :D
09:27:56 <jakeyip> ok let's knock out the elodilles question first. dalees you were looking at this, any updates?
09:28:18 <mkjpryor> What was the question?
09:28:38 <dalees> well it's a bunch of helm charts that the driver uses; no point putting anything in there unless we're going to merge the driver (and thusly, fork the helm charts)?
09:28:59 <mkjpryor> So I think we are happy contributing the Helm charts to Magnum
09:29:09 <dalees> travisholton and I are contributing to the upstream sources currently, under github.com/stackhpc/
09:29:27 <mkjpryor> So no need to fork - we should just change the canonical place where changes happen
09:30:02 <dalees> mkjpryor: you mentioned last time becoming a core reviewer of this repo - you do have way more background and use cases than anyone.
09:30:21 <mkjpryor> I suppose if Magnum adopts the Helm charts then I would be happy to own those and be a core reviewer for them
09:30:44 <mnasiadka> Well, but if we don't have a driver - then there's no purpose for that repo
09:30:47 <mkjpryor> Probably for our driver too, if that gets adopted
09:30:52 <mnasiadka> and we'd need proper CI in that repo
09:31:00 <dalees> mnasiadka: indeed
09:31:43 <mnasiadka> So I think the way forward is either both driver and helm charts stay in GitHub, or we move them both to OpenDev under Magnum governance
09:31:48 <mkjpryor> mnasiadka: I don't actually agree with that statement. Even if we don't have the Magnum driver (yet) there is still value in the Magnum project owning the Helm charts as the best practice for deploying Kubernetes using CAPI on OpenStack
09:32:05 <mkjpryor> You don't have to use Magnum to do that
09:32:27 <mnasiadka> But then you can't expect Magnum core team to own this
09:32:56 <mkjpryor> I think we can if I join the core team, since that is basically how it works now
09:33:40 <mnasiadka> I'm not a fan of a single person repository that is completely not tied to anything in the project
09:33:45 <mkjpryor> It depends how we define the scope of Magnum I think. You can either say "Magnum is the API + drivers" or "Magnum provides mechanisms for deploying Kubernetes on OpenStack"
09:33:53 <mkjpryor> :shrugs:
09:34:07 <mkjpryor> I mean, selfishly, the way things are now means less work for me
09:34:44 <mkjpryor> jakeyip: Have you already discussed progress on the driver discovery? Did I miss it?
09:35:12 <mkjpryor> Because that needs to be sorted before we can think about merging our driver.
09:35:13 <jakeyip> best practice is a ... sensitive term...
09:35:17 <mkjpryor> Yes
09:35:20 <mkjpryor> Agreed
09:35:40 <jakeyip> I am not keen to bring in helm chart without driver, so let's concentrate on that for now
09:35:43 <mkjpryor> So maybe it is better to wait until a CAPI driver is merged and do it then
09:36:11 <jakeyip> yeap.
09:36:21 <mkjpryor> So I think the driver discovery is on the critical path to merging a CAPI driver. Where are we at with that?
09:36:33 <mkjpryor> *improved driver discovery
09:37:44 <jakeyip> conversely, we can merge capi driver without helm chart in currently release. just view it as an external dependency.
09:38:03 <jakeyip> is that agreeable?
09:38:33 <jakeyip> mkjpryor: I will get to the discovery in a bit
09:38:33 <mkjpryor> That would definitely work
09:39:02 <mkjpryor> I think it would be good to have a reference implementation of the Helm charts owned by Magnum, but that can happen after the driver is merged
09:39:09 <dalees> yes, Magnum could do without owning the charts repo for the short term, and while the driver remains beta.
09:39:12 <mkjpryor> I think that is probably the correct way round to do it
09:39:32 <mkjpryor> But I do think in the long term we are keen for the Magnum project to own the Helm chart
09:40:22 <mnasiadka> Basically, if we want to merge anything, we have around 6 weeks time
09:40:25 <opendevreview> Merged openstack/magnum-tempest-plugin master: Drop xena jobs after xena EOL  https://review.opendev.org/c/openstack/magnum-tempest-plugin/+/905190
09:40:35 <jakeyip> mkjpryor: yeap I think that is OK. glad we have it on record that StackHPC is OK with passing governace to OpenStack :P
09:40:49 <mkjpryor> We are open-first :D
09:40:58 <mnasiadka> Judging by the fact we haven't done anything in that direction since the start of the cycle, I feel a bit... concerned. ;-)
09:41:17 <jakeyip> alright, so we don't worry about helm repo in this cycle
09:41:23 <mkjpryor> Agreed
09:41:45 <jakeyip> mnasiadka, mkjpryor: so majority of the code works. there is one thing on critical path which is the code for improve driver discovery
09:42:10 <mkjpryor> The thing I would like to see merged in this cycle is the improved driver discovery, which then opens up the possibility of basically merging our driver as-is in the next cycle (as beta)
09:42:10 <mnasiadka> I am not convinced that the current patches in Gerrit are the same as the current code in github repo
09:42:26 <mkjpryor> mnasiadka: No - they probably are not
09:42:27 <dalees> that answers elodilles' question, even if we do progress the driver. We won't require the empty capi helm to be part of the Openstack Release in Caracal
09:42:28 <jakeyip> code part is with me, apologies I haven't progressed much yet but I'll make time the next couple of week
09:42:54 <jakeyip> I just have CKS on my plate, then I can knock this one out
09:43:06 <mnasiadka> And to be honest - I would prefer to get it all in one commit, since we're importing already working driver - it's not that the development of this driver is being done now and in the open.
09:43:12 <mkjpryor> :thumbsup: Thanks jakeyip
09:43:46 <dalees> mkjpryor: that seems like the achievable timeline - aim for the driver discovery improvements this cycle and the driver next.
09:44:00 <mkjpryor> mnasiadka - I would also propose that we abandon the current CAPI driver patches in Gerrit and start a new patchset that basically imports our driver
09:44:01 <jakeyip> I do need everyone's help to review the spec and +1. normally spec comes before code :P but I think we can do it in parallel
09:44:13 <mkjpryor> Since we know that it works
09:44:18 <jakeyip> I just don't want objections to come AFTER I wrote all that code
09:44:33 <mkjpryor> jakeyip: I can take a look at the spec after this meeting
09:44:39 <jakeyip> thanks mkjpryor
09:44:57 <dalees> Improve driver discovery spec link: https://review.opendev.org/c/openstack/magnum-specs/+/900410
09:45:14 <jakeyip> mnasiadka: got your point there, I think we can squash it, if we can make it basically noop with the combination of beta drivers, etc
09:45:55 <jakeyip> * I think we can squash CAPI into a massive commit if it works and is a noop to anyone installing Magnum
09:45:59 <mnasiadka> So - to get this simple - we improve driver discovery (and hopefully clean up old drivers) in 2024.1 - and aim for merging a CAPI driver in 2024.2?
09:46:29 <jakeyip> yeah sounds good to me.
09:46:36 <mkjpryor> +1
09:46:39 <jakeyip> stretch goal is 2024.1 CAPI :)
09:46:51 <jakeyip> depending on gofundme
09:47:14 <jakeyip> or buymeacoffee.com :D
09:48:22 <mnasiadka> Well, deployment projects already deliver a CAPI driver for Magnum in 2023.2 - so that's not a big hurry I guess
09:48:40 <mnasiadka> (and that driver is not the driver we're trying to get merged)
09:49:27 <jakeyip> just kidding, not asking for $$$. I DO like to push if I can. I don't think there's much left to do for CAPI, all work is in improve driver discovery
09:50:07 <mnasiadka> I'm going to say again - I don't think the CAPI driver tempest CI jobs are in any shape right now ;-)
09:50:09 <jakeyip> I've been running the current one in our dev cloud already
09:50:50 <jakeyip> oh yeah ok that may be work
09:51:44 <jakeyip> speaking of tests, how's the work you are doing coming along mnasiadka?
09:51:48 <dalees> plenty of work to do on the CAPI Helm driver, but it's viable as a driver, has reasonable unit tests and work continues in https://github.com/stackhpc/magnum-capi-helm/pulls ;)
09:52:09 <mnasiadka> jakeyip: I have some time this week, so I'll get them working before my vacation - will notify when it's ready to merge.
09:53:09 <jakeyip> in tempest IIRC there was a test to create a CT then a cluster, is that what CAPI tempest should do?
09:54:00 <mnasiadka> dalees: there's the other driver with also a community behind it (and already shipped with OSA and Kolla), and I have a feeling that forever there will be two drivers - we just need to allow for both to be coexisting ;-)
09:54:16 <mnasiadka> jakeyip: and deploy a CAPI mgmt cluster
09:54:28 <mnasiadka> without that it's not going to work ;)
09:54:46 <mnasiadka> I would say we could try to improve that aspect after we get the driver merged
09:54:54 <mnasiadka> (as in for users)
09:55:14 <jakeyip> yeah devstack does that
09:55:28 <mkjpryor> How do OSA and Kolla solve the CAPI mgmt cluster problem?
09:55:42 <mnasiadka> OSA uses vexxhost kubernetes collection for deploying CAPI mgmt cluster
09:55:44 <mkjpryor> If they are already shipping the other driver?
09:55:47 <mnasiadka> Kolla doesn't, you're on your own.
09:55:52 <mnasiadka> (at least for now)
09:55:54 <mkjpryor> I suppose it isn't really Kolla's problem
09:56:05 <mkjpryor> That is just the container builds right?
09:56:19 <mkjpryor> I wonder what OSA does
09:56:25 <jrosser> it depends if as a OSA deployment tool you want to give your users an out-of-the-box experience that just works
09:56:35 <jrosser> that is what i have aimed for with my OSA patches
09:56:41 <mnasiadka> jrosser: did they get merged?
09:56:50 <jrosser> not yet
09:57:01 <jrosser> the whole out-of-tree driver thing makes it tricky
09:57:07 <mnasiadka> ok, 2024.1 then
09:57:11 <jrosser> but i am working on the patches right now
09:57:22 <mkjpryor> jrosser: So how do you deploy the CAPI mgmt cluster in your current patches?
09:57:31 <jrosser> using the vexxhost ansible collection
09:57:40 <mnasiadka> Kolla for now ships vexxhost driver in the image and supports copying kubeconfig (and disables the CAPI driver at all if no kubeconfig given, because that fails miserably)
09:57:48 <jrosser> https://github.com/vexxhost/ansible-collection-kubernetes
09:58:27 <mkjpryor> OK - so you deploy a Kubernetes cluster on the OpenStack control plane nodes?
09:58:31 <jrosser> yes
09:58:32 <mkjpryor> Or other nodes?
09:58:37 <mkjpryor> :thumbsup:
09:59:06 <jrosser> i think that opinion varies about how/where the mgmt cluster should live
10:00:28 <mnasiadka> Yes, Kolla believes it should rather be an OpenStack instance
10:00:57 <jrosser> i think we are very strict about network isolation for the control plane
10:01:03 <mkjpryor> The approach we usually use is to use CAPI to deploy a cluster in an OpenStack project using a K3S bootstrap instance
10:01:03 <jrosser> which means you cant do that
10:01:12 <jakeyip> ok we are drifting. happy for this to continue, but I'd like to close meeting since we are at time
10:01:39 <mnasiadka> yup
10:01:44 <mnasiadka> I'd like reviews on the Swarm drop
10:01:51 <mnasiadka> So I could move to remove other drivers ;-)
10:01:57 <jakeyip> #agree target 2024.1 for improve-driver-discovery
10:02:07 <jakeyip> #agree target 2024.2 for CAPI Helm
10:02:14 <mnasiadka> #link https://review.opendev.org/c/openstack/magnum/+/894395
10:02:57 <jakeyip> mnasiadka: I've just spun my vagrant to test that... if only CI does that for me... :P
10:03:16 <jakeyip> alright, let's end
10:03:18 <jakeyip> #endmeeting