09:02:38 <jakeyip> #startmeeting magnum
09:02:38 <opendevmeet> Meeting started Wed Feb 22 09:02:38 2023 UTC and is due to finish in 60 minutes.  The chair is jakeyip. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:38 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:38 <opendevmeet> The meeting name has been set to 'magnum'
09:02:45 <jakeyip> #topic Roll Call
09:02:50 <jakeyip> o/
09:02:55 <dalees> o/
09:02:57 <travissoto> o/
09:03:07 <jakeyip> #link https://etherpad.opendev.org/p/magnum-weekly-meeting
09:03:40 <jakeyip> Thanks everyone for coming. Please feel free to populate the agenda.
09:04:02 <jakeyip> #topic Virtual PTG
09:04:30 <jakeyip> I've registered Magnum for Virtual PTG. We don't have a slot yet, will update when I get more info.
09:05:41 <jakeyip> If there's any days / slots we should avoid, please let me know.
09:06:00 <jakeyip> I will see if we can have it as close to this time as possible, hopefully we can accomodate everyone on opposite sides of the world :)
09:06:50 <jakeyip> any questions or comments?
09:06:57 <dalees> sounds good
09:07:27 <travissoto> wfm
09:07:31 <jakeyip> great! :)
09:07:39 <jakeyip> #topic Admin abilities on Dashboard
09:08:17 <jakeyip> who posted this? please continue
09:08:36 <dalees> this came up with mnaser 's patchset - I've always wondered why admins can see all clusters - it's caused issues for our admins in the past (thinking they were cleaning up a single project in preproduction :))
09:08:46 <dalees> i posted this
09:09:24 <dalees> should we propose to make the default more in line with Nova; only view the current projects' clusters in the dashboard?
09:09:53 <jakeyip> I see. But that will mean we need to change API behaviour then
09:10:07 <jakeyip> something like `--all-projects` ?
09:10:28 <dalees> right
09:10:45 <dalees> that's a larger change, indeed.
09:12:01 <jakeyip> we will have to think about how to change this, and minimise breaking old behaviour
09:12:06 <jakeyip> anyone good with microversions?
09:13:51 <dalees> shall i create a story, so we can track and discuss further the changes and impact? I wanted to get the community's view in this meeting - to see if it might have support.
09:13:51 <jakeyip> personally I am not against changing, I actually prefer similar behaviour to nova, etc
09:14:13 <jakeyip> dalees: sure please go ahead
09:15:41 <jakeyip> #action dalees to create story - propose making admin api actions work similar to other services like nova
09:16:23 <jakeyip> any other comments?
09:16:40 <dalees> thats fine on that topic for now. I will add more scope creep to the story ;)
09:16:52 <jakeyip> :)
09:17:17 <jakeyip> #topic Deprecation
09:18:22 <jakeyip> I had the chance to chat with mnasiadka briefly; he raised the topic about other things that can be deprecated
09:18:41 <mnasiadka> Oh, I nearly missed the meeting again :)
09:19:01 <jakeyip> hi mnasiadka, I will try to remember to ping you next week :)
09:19:22 <jakeyip> we talked about deprecating Swarm, CoreOS, fedora-ironic
09:20:16 <jakeyip> what does everyone think?
09:20:17 <mnasiadka> great, more the merrier :)
09:20:45 <dalees> no objections, they're not in use by us.
09:21:14 <jakeyip> I have also drafted a mail to the cores, I did not get an objection so I'll sent it out to the ML after this meeting
09:22:06 <jakeyip> of the three I'm most unsure about fedora-ironic; I've also emailed Feilong the previous PTL about this
09:22:20 <jakeyip> hopefully Feilong / ML will give us more info
09:22:26 <jakeyip> #action jakeyip to send deprecation email to ML - Swarm, CoreOS, fedora-ironic
09:22:42 <jakeyip> any other comments?
09:23:08 <jakeyip> good that we are all keen to remove dead code :)
09:23:30 <jakeyip> #topic Testing
09:23:41 <jakeyip> mnasiadka: how's it going :D
09:24:19 <jakeyip> background: mnasiadka is working on having a cluster test working in check / gate
09:24:35 <mnasiadka> I have some basic tests working on my local devstack env, so will update the patches and work on uploading some meaningful results from sonobuoy (and validate them in CI run)
09:25:40 <jakeyip> I'm curious if we can have a different test for different versions - maybe create different cluster template labels?
09:27:26 <jakeyip> e.g. zed will use a CT that we say is supported, antelope different CT with different labels
09:27:52 <jakeyip> we actually run the same tempest test in our cloud, so let me know if you need help.
09:29:29 <jakeyip> ok let's go on
09:29:50 <jakeyip> #topic Check / Gate health
09:29:58 <jakeyip> thanks dalees for helping fix up python-magnumclient
09:30:12 <dalees> welcome!
09:30:17 <jakeyip> unfortunately this week magnum decides to break :D
09:30:29 <jakeyip> I have just started looking at it
09:31:12 <jakeyip> if I can't fix it I'll call for help. watch for bat signal dalees :)
09:31:51 <jakeyip> that was everything in our agenda
09:31:57 <jakeyip> #topic Other matters
09:32:07 <dalees> np, send me a message and i can help look if you're stuck
09:32:16 <jakeyip> cool thanks!
09:32:39 <jakeyip> Any other matter, please feel free to post
09:35:34 <dalees> I've got one
09:36:38 <dalees> One feature we're looking at as a public cloud is the ability to launch clusters in service tenants and expose only the API for customers to use. Are any other community members aligned with this goal?
09:37:08 <jakeyip> expose only the k8s api?
09:37:09 <dalees> We're not looking to do this for Magnum Heat, but for Magnum CAPI it's a consideration.
09:37:53 <jakeyip> is that something like the trove model?
09:37:57 <dalees> Yes, though with k8s api admin breakouts will be trivial without a lot of changes; but isolating the Magnum cluster resources from the customer projects
09:38:08 <dalees> Yes, Trove and Octavia do this.
09:39:15 <jakeyip> what are your reasons for wanting this model?
09:41:40 <dalees> to turn the service from a templating system that boots clusters in an existing project into a managed service that delineates ownership of resources. Operations on the cluster control plane VMs should be done by a customer via Magnum API, not via Nova for example - either is currently possible.
09:43:13 <jakeyip> good point
09:44:05 <jakeyip> personally I like it that Magnum uses quota of the users' project.
09:44:24 <dalees> curious if Vexxhost is also interested in this, as a public cloud using Magnum.
09:45:15 <jakeyip> propose a story maybe? since I don't think mnaser is here
09:46:13 <dalees> jakeyip: yeah, it does make billing simpler too. I wonder if control plane is best suited for a managed service project and workers live in the customer project - then the bulk of workloads still uses quota (and can be changed as they see fit).
09:46:38 <dalees> ok, good idea.
09:47:39 <jakeyip> that may make tenant networking more complicated since you'll need to share network between the control plane project and tenant project
09:48:14 <dalees> i think you'd need to anyway, so workloads can be useful for the customer without requiring ingress for everything
09:48:57 <dalees> but yes, it would! :)
09:49:18 <jakeyip> the other thing that is great with the current model is that you can actually use some tricks - for example you can create an FIP using openstackclient then use that IP in an LB
09:49:52 <jakeyip> this makes it great for people who want to delete / recreate LB but keep the FIP, since dns points to that
09:52:23 <jakeyip> anyway, I think this is a big topic and I am aware that our meeting time is almost at an end
09:52:47 <jakeyip> #action dalees to create story about managed kubernetes model
09:52:54 <jakeyip> ^ coming up with titles are hard :)
09:53:10 <dalees> sounds good
09:53:16 <jakeyip> great
09:53:23 <jakeyip> anything else?
09:53:47 <jakeyip> #topic storyboard or launchpad
09:54:17 <jakeyip> let me know if you like storyboard or launchpad :D
09:54:38 <dalees> i've not used much of either; no preference.
09:55:14 <jakeyip> ha, ok I prefer launchpad, but not important :)
09:55:25 <jakeyip> alright I don't hear anyone else, let's close
09:55:45 <jakeyip> Thanks everyone for coming
09:55:47 <jakeyip> #endmeeting