14:04:12 <isviridov> #startmeeting magnetodb
14:04:13 <openstack> Meeting started Thu Jan 15 14:04:12 2015 UTC and is due to finish in 60 minutes.  The chair is isviridov. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:16 <openstack> The meeting name has been set to 'magnetodb'
14:04:20 <isviridov> achudnovets o/
14:04:34 <isviridov> Anybody else joined?
14:04:53 <ominakov> o/
14:05:04 <isviridov> Hey ominakov
14:05:18 <isviridov> Here we have an agenda for today https://wiki.openstack.org/wiki/MagnetoDB/WeeklyMeetingAgenda#Agenda
14:05:40 <isviridov> #topic Go through action items isviridov
14:05:49 <isviridov> sviridov announce mdb release in ML
14:06:24 <aostapenko> Hi, all
14:06:26 <isviridov> So, I'm done with it. I've send the announcement to openstack-dev and openstack mail lists
14:06:32 <isviridov> wlecome aostapenko
14:06:42 <isviridov> isviridov https://review.openstack.org/143458
14:07:04 <isviridov> We have merged it
14:07:21 <isviridov> Next action item is alos for me
14:07:22 <isviridov> isviridov https://review.openstack.org/#/c/145247/
14:07:44 <isviridov> achudnovets I did all my best here
14:07:47 <isviridov> :)
14:07:59 <achudnovets> I'm fixing docs for it. Thanks isviridov :)
14:08:27 <isviridov> achudnovets, cool
14:08:35 <isviridov> charlesw good morning
14:08:46 <isviridov> ptburke around?
14:08:48 <achudnovets> charlesw: o/
14:09:12 <isviridov> charlesw will you drive the topic from Paul?
14:09:16 <charlesw> Hi guys, Paul won't be able to join
14:10:02 <isviridov> charlesw will you substitute him?
14:10:25 <isviridov> I mean this topic 'refresh logo design ptburke'
14:10:34 <charlesw> I'll make sure his topic got covered
14:10:49 <isviridov> #topic refresh logo design ptburke
14:10:54 <isviridov> Please go ahead
14:10:57 <charlesw> Not sure what exactly he wanted though
14:11:50 <isviridov> I assume there is an idea to update mdb logo, what is great I think
14:12:14 <charlesw> He wans to see a new logo, and maybe get some small things like t-thirts, pens, etc
14:12:32 <isviridov> charlesw wow cool
14:12:37 <aostapenko> +2
14:12:58 <charlesw> I'll sure Symantec will sponsor it
14:13:12 <isviridov> aostapenko first we have to vote for new logo, then approve, then receive t-shirts
14:13:43 <isviridov> Hello ajayaa
14:13:46 <charlesw> Paul is a very artistic guy. He will send you a new design, and we can discuss and go from there
14:13:59 <isviridov> Great!
14:14:02 <charlesw> I haven't seen his design though
14:14:08 <ominakov> charlesw, sounds great
14:14:11 <isviridov> Let us wait for his income
14:14:18 <ajayaa> Hi isviridov
14:14:48 * isviridov we have TTL topic driver
14:15:02 <isviridov> ajayaa is here, let us move on
14:15:11 <isviridov> #topic ttl feature in mdb ajayaa
14:15:28 <ajayaa> do we want ttl on per row basis or column?
14:15:47 <ajayaa> cassandra provides column level ttl.
14:15:47 * isviridov looking for blueprint
14:16:10 <openstackgerrit> Illia Khudoshyn proposed stackforge/magnetodb: Add restore manager  https://review.openstack.org/146909
14:16:11 <ajayaa> if we want row level ttl then we might have to implement some login in mdb layer.
14:16:11 <isviridov> #link https://blueprints.launchpad.net/magnetodb/+spec/row-expiration
14:16:23 <ajayaa> logic*
14:16:32 <isviridov> ajayaa have you seen the bp?
14:16:39 <ajayaa> yes.
14:16:42 <ajayaa> it seems row level.
14:17:18 <ajayaa> The problem with row level is insert and update statements behave different in cassandra.
14:17:19 <isviridov> ajayaa yes, it is.
14:17:42 <ajayaa> and some inserts in mdb layer are insert and some are update.
14:18:03 <ajayaa> which creates inconsistency.
14:18:47 <ajayaa> has anyone here ever dealt with tll feature in cassandra?
14:19:18 <ajayaa> I would need to write a spec otherwise to explain inconsistencies.
14:19:27 <ajayaa> ttl*
14:19:48 <isviridov> What inconsistency do you mean?
14:19:57 <ikhudoshyn> in fact, spec would be great just to keep everybody on the same page
14:20:25 <isviridov> ikhudoshyn not sure spec is good for describing C* behaviour. I prefer mail list
14:20:51 <ajayaa> Mailing list is a good idea.
14:20:51 <ikhudoshyn> isviridov: ML is good for me as well
14:21:09 <ajayaa> I will write an email explaining this.
14:21:32 <isviridov> ajayaa great!
14:21:55 <isviridov> #action ajayaa start mail discussion about TTL implementation
14:22:40 <isviridov> Just for clarification
14:23:06 <isviridov> In API documentation we are declaring support of TTL for item (row)
14:23:08 <isviridov> #link https://magnetodb.readthedocs.org/en/latest/put_item.html#request-parameters
14:23:21 <isviridov> #link https://magnetodb.readthedocs.org/en/latest/update_item.html#request-parameters
14:23:30 <isviridov> ajayaa moving ahead?
14:23:40 <ajayaa> yes. please.
14:24:12 <isviridov> We have open discussion next
14:24:15 <isviridov> #topic Open discussion isviridov
14:24:53 <isviridov> achudnovets let us discuss the placing of service for export metrics to statsd
14:25:42 <achudnovets> isviridov: I think contrib is best place for it
14:26:24 <isviridov> We have two ways I se now, depends on how we handle this new feature. I mean if it is part of mdb core, or some extra functionality
14:26:29 <isviridov> dukhlov_ hey
14:26:37 <dukhlov_> hello
14:26:38 <achudnovets> dukhlov: o/
14:27:06 <isviridov> achudnovets I also thought about contrib. Will it be dependend on magentodb itself>
14:27:10 <isviridov> *?
14:27:39 <achudnovets> It will depend on MagnetoDB monitoring api
14:28:09 <achudnovets> and this service will use common openstack code
14:28:12 <charlesw> achudnovets can you expand on contrib idea?
14:28:13 <isviridov> I mean will you have magnetodb in requirements?
14:28:39 <isviridov> charlesw sorry
14:29:05 <achudnovets> isviridov: no, magnetodb code is not required for this service
14:29:10 <isviridov> Let me do it for everyone
14:29:39 <isviridov> We need a cluster level statistic in statsd for Symantec.
14:30:09 <isviridov> To achieve this we are introdusing one more service to pull data from mdb and put to statsd
14:30:59 <isviridov> it doesn't like as mdb part, so there is an idea to handle it as optional component and keep in contrib folder as HEAT team does
14:31:01 <isviridov> https://github.com/openstack/heat/tree/master/contrib
14:31:05 <isviridov> #link https://github.com/openstack/heat/tree/master/contrib
14:31:12 <charlesw> Is it push, or pull?
14:31:39 <isviridov> charlesw pull via Monitoring API
14:32:13 * isviridov looking for bp link
14:33:07 <isviridov> #link https://blueprints.launchpad.net/magnetodb/+spec/statsd-tables-metrics
14:33:57 <isviridov> #link https://review.openstack.org/#/c/143982/
14:34:46 <isviridov> Let us continue
14:36:08 <isviridov> achudnovets so it looks now as isolated component using python-magnetodbclient at most and no other connections with mdb
14:36:28 <achudnovets> isviridov: yep
14:36:31 <charlesw> StatsD is used and integrated in Swift, not contrib, and is part of core features. http://docs.openstack.org/developer/swift/admin_guide.html#reporting-metrics-to-statsd
14:38:58 <isviridov> achudnovets it looks exactly like collectd pluggin for me
14:40:02 <isviridov> charlesw it is ok, and we do it for request metrics. But for cluster level statistics we need additional execution entity
14:40:26 <isviridov> charlesw do you think we have to deliver it as part of mdb?
14:42:21 <charlesw> If the deployment is easy, we can make it part of contrib. But I'd think this is important feature and there's no other alternatives, leaving it in core but have a flag to enable/disable it, until we have a better alternative.
14:42:43 <isviridov> achudnovets another way is to intriduce one mere service what will use the storage, config, and all out code just send data to statsd periodically. In this we avoid credential management, API call so on. And still keep it optional.
14:43:08 <charlesw> Optional features, or alternative implementations, seem to be more appropriate for contrib
14:45:28 <isviridov> achudnovets what do you think?
14:45:44 <achudnovets> isviridov: it's the option.
14:46:05 <isviridov> achudnovets do you like it? :)\
14:47:01 <achudnovets> only if we are going to make statsd a part of our code
14:47:25 <isviridov> charlesw as far as we mostly have middleware already, it is better to have complete statsd integration and keep it as feature.
14:47:48 <isviridov> achudnovets yes, it looks like this now
14:48:15 <achudnovets> ok. Then I need to update spec
14:48:31 <isviridov> achudnovets charlesw do we have aggrement here?
14:48:59 <charlesw> sounds good to me :)
14:49:28 <isviridov> dukhlov_ ikhudoshyn aostapenko?
14:49:35 <achudnovets> lgtm
14:49:36 <aostapenko> +1
14:50:05 <isviridov> #agreed statsd inntegration is a part of mdb fuctionality
14:50:22 <isviridov> #agreed to place statds integration service at 'bin' folder
14:50:37 <isviridov> #action achudnovets update spec
14:51:04 * isviridov it was a quorum. Wasn't it?
14:51:19 <achudnovets> #link https://review.openstack.org/#/c/143982/
14:51:53 <achudnovets> just to specify what spec I need to update :)
14:51:54 <ikhudoshyn> it's funny that you ask it _after_ you posted 'agreed'
14:52:01 <isviridov> achudnovets yeap
14:52:39 <isviridov> achudnovets but it will be one more action. Will leave as is.
14:53:16 <isviridov> ikhudoshyn there were: isviridov aostapenko charlesw (3 of 5)
14:53:49 <isviridov> Anything else to discuss, anounce? 7 mins left
14:53:53 <ikhudoshyn> so it should have been 'It was a quorum. It was'
14:53:56 <ikhudoshyn> ))
14:56:02 <achudnovets> ikhudoshyn: democracy is an illusion...
14:56:18 <ikhudoshyn> achudnovets: you're so right)
14:57:38 <charlesw> achudnovets, did you learn that from you politics Masters degree training :)
14:57:39 <isviridov> If smb doesn't know OpenStack Community started accepting talks for summit in Vancouver.
14:58:30 <achudnovets> charlesw: I learned it because I'm from Ukraine :)
14:58:40 <isviridov> The deadline is 9 of February. I personally would love to see more talks about mdb
14:59:11 * isviridov thinks that democracy is the same everywhere
14:59:27 <isviridov> 1 min left
14:59:39 * ikhudoshyn thinks tat democracy just does not exists
14:59:40 <charlesw> isviridov, any suggestions of topics?
15:00:09 <openstackgerrit> Andrei V. Ostapenko proposed stackforge/magnetodb: Fixes log output  https://review.openstack.org/147546
15:00:25 <isviridov> charlesw not really, it can be any aspect of project, or field and mdb part in it
15:00:41 <isviridov> Just look at previous summit winners.
15:00:46 <isviridov> charlesw I'll send you link
15:00:59 <charlesw> great, thx
15:01:00 <isviridov> Thanks everyone for joinin
15:01:07 <isviridov> #endmeeting