13:06:15 <isviridov> #startmeeting magnetodb
13:06:17 <openstack> Meeting started Thu Oct 16 13:06:15 2014 UTC and is due to finish in 60 minutes.  The chair is isviridov. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:06:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:06:20 <openstack> The meeting name has been set to 'magnetodb'
13:06:31 <isviridov> Hi there
13:06:34 <isviridov> o/
13:06:45 <dukhlov> +1
13:07:41 <isviridov> So today agenda https://wiki.openstack.org/wiki/MagnetoDB/WeeklyMeetingAgenda
13:07:57 <isviridov> And let us go throgh action items from last time
13:08:10 <isviridov> #topic Go through action items
13:08:21 <isviridov> ajayaa review current list of metrics
13:08:52 <isviridov> He it not with us today, but I've updated the BP #link https://blueprints.launchpad.net/magnetodb/+spec/celiometer-integration
13:09:12 <isviridov> based on uscases we have now. Pls see whiteboard section
13:09:43 <isviridov> The metrics list in google spreadsheet is also updated with 'Data destination' column
13:09:56 <isviridov> I mean #link https://docs.google.com/a/mirantis.com/spreadsheets/d/1tYvgCSvkcOVED46MX8qSlUyrhNhHlyTrVkX7AXP-XR4/edit#gid=0
13:10:29 <isviridov> Any comments here?
13:11:16 <dukhlov> not from my side
13:11:31 <isviridov> Ok, move on?
13:11:36 <isviridov> isviridov start create spec repo like https://github.com/openstack/nova-specs
13:11:44 <isviridov> Here is a progress
13:12:02 <isviridov> So, here it is #link http://magnetodb-specs.readthedocs.org/en/latest/
13:12:05 <dukhlov> great news
13:12:48 <isviridov> I will update the docs a bit, but we can go with it already
13:12:55 <isviridov> #link https://github.com/stackforge/magnetodb-specs
13:13:48 <isviridov> Startinng from kilo we are following standard community BP approval process
13:14:17 <isviridov> I will move all current drafts from wiki to specs
13:14:46 <isviridov> #topic Juno release status update https://launchpad.net/magnetodb/+milestone/juno-rc1
13:15:25 <isviridov> I think we have done with juno and I'm going to prerare release today
13:15:53 <isviridov> The branch stable/juno will be created for critical and security fixes
13:16:11 <isviridov> Any objections, comments?
13:16:14 <isviridov> dukhlov, charlesw ?
13:16:45 <charlesw> fine with me
13:17:10 <dukhlov> ok for me
13:17:38 <isviridov> #topic Kilo roadmap overview and discussion https://launchpad.net/magnetodb/+milestone/kilo-1
13:17:50 <isviridov> I believe it is the biggest topic for today.
13:18:15 <isviridov> The Kilo milestone scope #link https://launchpad.net/magnetodb/+milestone/kilo-1
13:18:48 <isviridov> There are several really huge blueprints
13:19:06 <isviridov> Multidatacenter replication
13:19:10 <isviridov> Integration with Celiometer
13:19:15 <isviridov> Cassandra backend driver redesign
13:19:19 <isviridov> Export/Import data operations
13:19:23 <isviridov> Support of global indexes
13:20:36 <isviridov> I beleave we are slow with specs. We have only several designs approved.
13:20:47 <dukhlov> what about backups?
13:21:14 <isviridov> Do you mean 'Export/Import data operations'?
13:21:44 <isviridov> I believe it is what we have to do in scope of mdb
13:21:44 <dukhlov> no, I mean cassandra low level backups
13:21:48 <charlesw> Backup/recovery should be different
13:22:33 <dukhlov> Do we skip Backups for kilo?
13:23:09 <keith_newstadt> it feels like a lower priority to me
13:23:10 <isviridov> dukhlov, it should be eather job of administrators or database management layer -trove
13:23:19 <keith_newstadt> as it could be delivered as part of operations
13:23:28 <keith_newstadt> +1
13:23:42 <isviridov> dukhlov, what do you think?
13:23:43 <dukhlov> ok, clear
13:24:30 <dukhlov> that is right way for me, but in this case we need to create trove integration bp
13:24:57 <isviridov> dukhlov, not sure that we really need it in kilo
13:25:14 <dukhlov> ок
13:25:21 <isviridov> I suggest to wait for trove evolution :)
13:25:57 <keith_newstadt> +1
13:26:19 <isviridov> dukhlov, 'Cassandra backend driver redesign' should be specified well
13:26:48 <dukhlov> Agree
13:27:06 <dukhlov> I plan to write spec next week
13:27:16 <isviridov> dukhlov, as you know we have some simplifications in monitoring during waiting for this
13:27:21 <isviridov> dukhlov, cool
13:27:40 <isviridov> #action dukhlov write a spec for 'Cassandra backend driver redesign'
13:28:27 <isviridov> #action isviridov sync with ajayaa about 'Integration with Celiometer' status
13:28:40 * isviridov added remind for himself
13:29:20 <isviridov> keith_newstadt, what is the demand for 'Support of global indexes' from your point of view?
13:29:34 <isviridov> keith_newstadt, I
13:29:45 <isviridov> 've set it as Low prior
13:30:07 <keith_newstadt> we don't have anyone asking for it at the moment
13:30:26 <keith_newstadt> i think lower priority is fine.  better that we make what we have as solid and operable as possible.
13:30:48 <isviridov> keith_newstadt, agree
13:31:29 <charlesw> +1 to put more focus on operation side
13:31:37 <dukhlov> Cassandra has plans to implement GSI for version 3. I think it is reasonable to wait for that if we dont have any use case for now to implement it
13:31:41 * isviridov just realised that it would be great to send kilo roadmap to ML
13:31:58 <isviridov> #action isviridov share kilo scope with communnity via ML
13:32:15 <isviridov> dukhlov, +1
13:32:21 <isviridov> dukhlov, great to know
13:33:43 <isviridov> Looks like no other voices, let us move discussion to ML
13:34:07 <isviridov> dukhlov, keith_newstadt, charlesw?
13:34:21 <dukhlov> +1
13:34:22 <isviridov> Are we done with it for now?
13:34:36 <charlesw> dukhlov, what's the timeline for C* 3.0?
13:35:12 <dukhlov> charles: have no idea
13:35:26 <dukhlov> I will check
13:35:31 <isviridov> dukhlov, :)
13:35:37 <isviridov> dukhlov, no ideas, just hope
13:36:22 <isviridov> Ok, let us move on
13:36:27 <isviridov> #topic Open discussion
13:36:43 <isviridov> charlesw, will you attend summmit?
13:36:58 <charlesw> not going this time
13:37:12 <isviridov> charlesw, :(
13:37:23 <isviridov> We have a design session there. 90 mins !
13:37:47 <charlesw> good luck with that, keith will be there
13:38:05 <isviridov> Would be great to have cores there.
13:38:29 <keith_newstadt> we were limited on how many we could send
13:38:47 <keith_newstadt> it should be easier next time when the summit is in north america
13:39:28 <isviridov> keith_newstadt, here it is the same :( I know guy from Mirantis who pays for himself
13:39:35 <isviridov> keith_newstadt, yeap
13:40:14 <isviridov> Gentlemen we have some time left
13:40:18 <keith_newstadt> how about cores from mirantis?  who is coming?
13:40:33 <isviridov> keith_newstadt, it is only me
13:41:15 <keith_newstadt> we will need to promote the session, as it will be important to have community participation
13:41:42 <isviridov> sure thing. I have to clarify the schedule
13:41:59 <keith_newstadt> i know some folks around boston that i can reach out to
13:42:15 <keith_newstadt> having a link will help
13:42:19 <isviridov> #action isviridov clarify schedule of Ecosystem MagnetoDB design session
13:42:42 <isviridov> I have not found it in shed before
13:43:25 <isviridov> keith_newstadt, returning back to kilo are you interested in horizon integration for mdb?
13:44:11 <charlesw> Are we going to have some lab time for design session. Last time I attended a couple and felt very helpful.
13:44:11 <keith_newstadt> i think it is interesting, more from the community perspective than the symantec perspective
13:44:36 <keith_newstadt> only limited functionality - view tables, sizes, etc. but not manage data
13:44:46 <keith_newstadt> enough to give visibility to the community
13:45:13 <keith_newstadt> i think a clear and easy set up, perhaps some open hosting, and sample code would be good as well
13:45:42 <isviridov> keith_newstadt, yes. We have TechTalks for this also
13:45:43 <keith_newstadt> it is very compelling when you start to use it hands-on with real use cases
13:45:59 <keith_newstadt> :)
13:46:42 <isviridov> charlesw, what do you mean 'lab time'?
13:47:11 <charlesw> meaning hands-on lab exercises
13:47:55 <charlesw> Another topic, anybody interested in a Java client?
13:49:16 <dukhlov> Java Client to MagnetoDB?
13:49:21 <keith_newstadt> we have had requests for client libraries within symantec
13:49:28 <keith_newstadt> sdks
13:49:29 <isviridov> charlesw, it is a great idea, but there are workshops for this. We have to figure out what format is the best
13:49:44 <charlesw> A fluent style Java API can be more user friendly than REST API
13:49:46 <isviridov> charlesw, I'm very interested in blueprint for this :)
13:51:15 <isviridov> keith_newstadt, charlesw there are already existing implementations, would be great to look and probably contribute
13:51:51 <isviridov> here it is #link http://developer.openstack.org/#sdk
13:52:05 <isviridov> #link http://jclouds.apache.org/guides/openstack/
13:53:13 <charlesw> dukhlov, yes I meant Java client to MagnetoDB
13:53:36 <isviridov> #action isviridov do realease of mdb Juno
13:53:47 * isviridov one more remind :)
13:54:58 <isviridov> charlesw, does nuno uses IRC?
13:55:17 <isviridov> use*
13:55:18 <charlesw> I'll ask him
13:55:40 <isviridov> There is a patch from him, probably it will be easier to clarify details in chat
13:56:11 * isviridov 4 mins left
13:56:23 <isviridov> Are we done or 4 mins for coffe?
13:56:38 <keith_newstadt> +1 :)
13:56:55 <aostapenko> +1
13:57:05 <isviridov> aostapenko, wow. You were here
13:57:11 <isviridov> Thank you guys
13:57:23 <isviridov> #stopmeeting
13:57:30 <charlesw> thanks for organizing
13:57:33 <isviridov> #endmeeting