20:00:51 <rockyg> #startmeeting log_wg
20:00:52 <openstack> Meeting started Wed Mar 30 20:00:51 2016 UTC and is due to finish in 60 minutes.  The chair is rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:55 <openstack> The meeting name has been set to 'log_wg'
20:01:12 <rockyg> #topic summit planning
20:01:55 <rbradfor> are there any sessions scheduled?
20:02:03 <rockyg> So far, I've been pretty low key about log stuff for this summit.  The config stuff is critical and will go a long ways on lots of areas
20:02:20 <rockyg> But, what, if anything, do we want to get done at the summit?
20:02:56 <rockyg> Certainly, I'd like to recruit folks.  And meet rbradfor    jokke_  will not be there, so you can't meet him.
20:03:33 <rbradfor> logging in itself is not a standalone thing, how logging affects operators (so monday is ops day), and how logging may affect cross projects or oslo is where I'd expect to hear about it.
20:04:15 <rockyg> Yup.  So, what would be a good focus this round for the Ops summit?  I've gotta submit shortly
20:04:27 <rockyg> I will get it if I propose it.
20:05:04 <rbradfor> The Oslo planning is at https://etherpad.openstack.org/p/newton-oslo-summit-planning
20:05:27 <rbradfor> there is a proposal for mutable logging listed (but driver is not attending)
20:05:34 <rockyg> There is also a taxonomy of failures that is also happening in Ops.  Log issues will likely arise there, too.
20:06:15 <rockyg> The ops summit planning etherpad is:  https://etherpad.openstack.org/p/AUS-ops-meetup
20:06:32 <rockyg> #link https://etherpad.openstack.org/p/AUS-ops-meetup
20:06:45 <rockyg> #link https://etherpad.openstack.org/p/newton-oslo-summit-planning
20:07:55 <rbradfor> I am planning on attending the ops summit sessions
20:08:48 <rockyg> Cool.  And we should get an oslo session.  I'm thinking the right way to start on Error codes and even on the request id stuff is to get the fields added to oslo.log for them
20:09:12 <rockyg> So what would be a good log topic for the ops summit?
20:09:42 <rbradfor> for work I'm hoping to focus on, I either have a detailed etherpad (e.g. adoption), or have created specs that can be reviewed and commented on for discussion before austin.
20:10:29 <rockyg> Yup.  I'm hoping to create the oslo spec and have a few round with you and maybe others before the summit
20:10:49 <rockyg> For ops, it's usually more info gathering and dissemination
20:12:41 <rockyg> I'm thinking maybe a discussion of unhandled exceptions for Ops-logging?  Find out if we could clean up logging by handling some of the most common ones?
20:14:26 <rockyg> What would you like to learn from Ops?
20:15:30 <rbradfor> I'm interested in just hearing what are pain points across deployment and usage, and try to determine if these are Oslo related, and see I can provide input into how these things could move along
20:17:12 <rbradfor> I have yet been able to actually talk with a production operator.
20:17:18 <rockyg> We could do that. Logging pain points review then drill into top, or exceptions (that was a biggie last time.  It dumps sometimes multi-gig lines into log files)
20:17:45 <rbradfor> you are mentioned this, but I've never seen any actual examples.
20:17:53 <rockyg> I'll make sure that happens.  But just turning up, you'll meet a ton of them.
20:18:51 <rockyg> You should also present/moderate a session on config options.  I can help if you like, but I think once you get started, I'm not needed.  If ever needed.
20:19:16 <rockyg> I did a session on the nova effort at the midcycle
20:20:20 <rockyg> Oh, and I'm still confused about the syslog opts in oslo.log.  The descriptions seem to indicate it went away?????
20:20:27 <rockyg> Lots of ops use it.
20:20:59 <rockyg> I'll have an intern for the summer, so I can get lots of stuff done.
20:21:20 <rbradfor> I'm not familiar with the details, I need to experiement with syslog info. syslog is still an option, it was a specific syslog format that was deprecated and removed.
20:21:40 <rockyg> Which is why it would be good to get either oslo or cross project spec in decent shape for him/her
20:22:10 <rockyg> Ah.  The doc code needs to be clearer on that.
20:23:32 <rockyg> How about I throw an etherpad together with the oslo log format items I want and we iterate a bit on that before submission to gerrit?
20:23:55 <rbradfor> sure
20:24:12 <rockyg> And we can talk about that at an oslo summit session.
20:24:36 <rbradfor> feel free to add it to the Oslo etherpad quickly. I know Josh is scheduling now.
20:24:45 <rockyg> Now I've promissed something so I have to do it.
20:25:00 <rockyg> I'll add after this meeting
20:26:19 <rockyg> and add some comments.
20:26:50 <rockyg> on other proposed sessions, that is....
20:27:40 <rockyg> I think that covers it.  Anything else?  Can I add config options to ops summit with your name on it?
20:27:47 <rockyg> Or will you???
20:28:06 <rockyg> If you moderate, I'll take notes on the etherpad
20:29:32 <rbradfor> I see nobody has mentioned config options, so it's not my place to add this.
20:30:11 <rbradfor> should there be need to discuss I can be available to discuss
20:30:13 <rockyg> Anyone can add.  It's pretty much unconference style.  The person who wants it/wants to do it puts it up and others vote.
20:31:04 <rbradfor> my goal is to attend the ops summit, listen, learn and contribute when applicable
20:31:14 <rockyg> So, I put up the taxonomy discussion and all those +1s was to express interest.  Don't ask for permission, seek agreement :)
20:31:34 <rockyg> OK.  I'll put up a config session and make you attend and ask questions.
20:32:08 <rockyg> Sorry.  But, There is *lots* of interest in getting them fixed and debate about global config sections or not.
20:32:22 <rockyg> Especially when you have multi-cloud.
20:32:59 <rbradfor> ok, well as you say, if people express interest then we can talk more about it
20:33:07 <rockyg> Will do.
20:33:32 <rockyg> I think thats about it?  I have action items:
20:33:44 <rockyg> #action add logging to oslo planning etherpad
20:34:03 <rockyg> #action add config opts to Ops planning etherpad
20:34:28 <rockyg> #action start etherpad for logging format enhancements
20:34:28 <rbradfor> cool
20:34:51 <rockyg> Are we done for this meeting?
20:35:14 <rbradfor> I've nothing more to note. I'll await your etherpads
20:35:29 <rockyg> Thanks.  I'll get to it then:)
20:35:34 <rockyg> 3endmeeting
20:35:39 <rockyg> #endmeeting