20:01:39 <rockyg> #startmeeting log_wg
20:01:40 <openstack> Meeting started Wed Sep 23 20:01:39 2015 UTC and is due to finish in 60 minutes.  The chair is rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:44 <openstack> The meeting name has been set to 'log_wg'
20:02:26 <rockyg> ping jokke_ bknudson
20:02:33 <bknudson> rockyg: what's up?
20:02:44 <rockyg> And I know I'm forgetting someone.  Logg meeting
20:03:12 <bknudson> dhellmann maybe?
20:03:43 <rockyg> He's got a conflict.  He reads the logs, though.  That's another reason to move the meeting
20:04:19 <jokke_> o/
20:04:42 <rockyg> Hey!  I think we can start.
20:04:51 <rockyg> #topic updates
20:04:53 <jokke_> sorry for being bit late ... last glance things flying in for rc1
20:05:09 <bknudson> all the logging fixes are getting done
20:05:20 <rockyg> Kewl.  And glance is gonna be great by the time mitaka finishes....
20:05:40 <bknudson> ouch!
20:05:54 <rockyg> So, updates....Just got out of Ops monitoring meeting
20:05:57 <jokke_> rockyg: lets see about that, we do our best
20:06:41 <rockyg> jokke_,I think the community has finally woken up about the need for cross project comms, awareness, help, etc.
20:07:10 <jokke_> so to the topic, what's ops monitoring meeting?
20:07:18 <rockyg> There is a new OpenStack repository:  osops
20:08:21 <rockyg> A lot of the discussion was just getting things rolling, but, we have a place for ops bps now, and bugs that ops doesnt know which project to file under, and ops tools
20:09:27 <rockyg> for instance:
20:09:27 <rockyg> [12:03] *** now talking in #openstack-meeting-4
20:09:27 <rockyg> [12:03] *** topic is  (Meeting topic: operators_ops_tools_monitoring)
20:09:27 <rockyg> [12:03] *** set by openstack!~openstack@openstack/openstack on Wed Sep 23 11:59:36 2015
20:09:27 <rockyg> [12:03] *** channel #openstack-meeting-4 mode is +cnt
20:09:28 <rockyg> [12:03] *** channel created at Sun Nov 02 04:52:54 2014
20:09:28 <rockyg> [12:03] <j^2> nice, my goal is to get OSOps in the “big tent” around “N” or “O”s timeframe per the Operators meetus
20:09:29 <rockyg> [12:04] <j^2> Then Operators get ATC and all that jazz which is the goal of OSOps
20:09:29 <rockyg> [12:04] <rockyg> ++
20:09:30 <rockyg> [12:04] <j^2> so it looks like we need to just come together
20:09:30 <Behzad_> This is my first time attending the meeting.
20:09:40 <rockyg> sorry for that spam.
20:09:47 <rockyg> Welcome Behzad_!
20:09:59 <Behzad_> Thanks
20:10:02 <rockyg> my copy paste doesnt work so good...
20:10:33 <rockyg> https://github.com/openstack/osops-tools-logging
20:10:37 <Behzad_> I really liked that on ops tools have a place in the main openstack umbrelly
20:10:48 <Behzad_> umbrella
20:10:57 <rockyg> Yes.  I think it will make our life easier on Logging, too.
20:11:17 <Behzad_> What will be our guidelines for commiting changes to the osops-<> repo
20:11:32 <rockyg> The big ask was consistency on messages so things can get scripted
20:11:58 <rockyg> And to get multi-line traces out of the logs
20:12:42 <rockyg> But, converting etherpad info to BPs is a big win for tracking and discovery of ops issues and definition of tools and tool improvements
20:13:06 <jokke_> rockyg: the later will not happen before we get to the stage where _all_ projects can be ran in production without debugging
20:13:11 <rockyg> Anyway, that's the monitoring meeting
20:13:29 <rockyg> also, the requst-id spec got accepted
20:13:57 <jokke_> rockyg: the traces should be printed (on all projects using oslo_log at least) only when debug is enabled
20:14:10 <jokke_> yes it did
20:14:21 <rockyg> jokke_, ther is now also a TRACE level (I think) or it's proposed, that is above debug.  Or is it below?  I can never keep those straight
20:15:25 <rockyg> but whatever, you need to turn that debug won't provide TRACE if the patch gets in
20:15:51 <rockyg> man, I'm having problems typing today
20:15:53 <jokke_> that is just pointless :(
20:16:15 <jokke_> I think I might have overlooked that
20:16:23 <rockyg> Well, we need to get debug turnd off....maybe w focus on the worst tracee offenders first?
20:17:06 <rockyg> oh, my e key is not working great.  you will see dropouts
20:17:43 <Behzad_> what is the request-id spec?
20:17:45 <bknudson> keystone has request IDs in the logs now so if we can get the request ID out to the users then they can make the correlation
20:17:50 <Behzad_> can you send a link.
20:17:50 <rockyg> Lessee, more...cross project communications and coordination.  One of the themes for Mitaka
20:19:36 <rockyg> http://specs.openstack.org/openstack/openstack-specs/specs/return-request-id.html
20:20:14 <rockyg> I want to work with these guys on a spec on how to put them in the log messages
20:21:06 <rockyg> Also up is that the devs are now aware of the Product working group and want to use them for cross project communications
20:21:26 <Behzad_> thanks rockyg.
20:22:13 <rockyg> Any other updates?  I think I want our dev working session at Tokyo to focus on getting Error codes spec acceptable.
20:22:30 <jokke_> rockyg: they should be logged if a) context and b) oslo_log is used
20:22:37 <rockyg> What do you think?  One hour face to face with projects and ops to make it happen?
20:22:51 <jokke_> I would love that
20:24:24 <rockyg> I think we can convince devs that unique, memorable numbers can be used if we use interns, Prod_wg resources to roll them into the codebase and that they are - or a real error code
20:24:58 <bknudson> what's a unique memorable number? other than 3.14.
20:25:10 <bknudson> and 42 is an easy one to remember
20:26:12 <rockyg> So, spec has nnn-mmm-xxxx  with proj, module and number.  Some folks think thre are too many places where oslo.log is called to modify manually
20:26:39 <rockyg> oops.  only 2 m's
20:26:46 <bknudson> does this include debug logs?
20:27:04 <rockyg> Right now, only for ERROR
20:27:06 <bknudson> maybe you could leverage the translation files
20:27:30 <bknudson> since that has all the log messages, so if you could associate the # with the log message in the translation file that would get you a number
20:27:32 <jokke_> well everything ERROR+
20:27:35 <jokke_> at least
20:27:46 <jokke_> preferably WARNING+
20:28:01 <bknudson> I don't know if the message file format allows attaching extra metadata, but I think it does.
20:28:02 <rockyg> Yup.  Error code + summary   Summary can be translated, and will cue translators
20:28:14 <rockyg> jokke_, ++
20:28:30 <rockyg> But I'm willing to start with ERROR ;-)
20:28:56 <bknudson> if it's easy to add then no need to limit to error, just anything translatable
20:29:19 <jokke_> rockyg: I can be twisted to that, but IMHO it is way easier to do and allocate if it's done right at the first time ;)
20:29:21 <rockyg> I figure a grep of a project for oslo.log and we'll have the lists
20:29:27 <jokke_> bknudson: ++
20:30:14 <bknudson> we had a guy here work on a tool to generate message ids like this so we could use it in our product
20:30:37 <rockyg> jokke_, true.  If wee get the codes defined, we can convince the devs of warning and up.  Especially if we can get numbers of times the log fun ction is called in a project and show manual mods are doable
20:31:11 <rockyg> bknudson, so, just once and insert into code or at run time?
20:31:15 <bknudson> I don't think manual is going to be doable
20:31:38 <rockyg> bknudson, hah!  you don't know th powr of intrns and high schoolers.
20:32:09 <rockyg> I met 7 high schoolers at OSCon who were OS committers
20:32:31 <bknudson> I'm not sure how it works, but it uses the translation string to generate the message ID, or the message ID can be set manually in the po file
20:32:45 <rockyg> Once you get them started, they won't stop until a project is complete.  Can you say OCD?
20:33:01 <bknudson> I don't know how it works when the message ID is in the po file... it must be handled by the translation library where it returns the string with the message ID on it.
20:33:57 <bknudson> interns and high-schoolers are also going to review all these changes?
20:34:06 <bknudson> probably not if they're not core reviewers
20:34:10 <jokke_> bknudson: I think the translation files are exelent idea to pull the error messages and generate the codes
20:34:47 <rockyg> Yeah.  What we really need is a localization/translation person to describe how log translations are done in the commercial world
20:35:07 <rockyg> OS devs don't generally seem aware that this is a solved problem
20:35:17 <jokke_> :)
20:36:01 <rockyg> OK.  We are going to get Error Codes spec done at Tokyo.
20:36:25 <jokke_> I have no idea how those tools work either ... I just wrap the messages, some voodoo happens and those who wishes has their messages on some weird languages I cannot support ;)
20:36:29 <rockyg> #action Get cross project work session to get Error Codes spec into completable condition
20:37:40 <rockyg> jokke_, that's why a EC dictionary is really helpful.  YOu know what it was translated from;-)
20:38:36 <rockyg> ok.  any other topics to discuss?
20:39:03 <jokke_> was the doc sprint already?
20:39:21 <rockyg> Oslo docs sprint is tomorrow and Friday.  I want to get the log configs documented
20:39:30 <rockyg> #topic oslo docs sprint
20:39:34 <jokke_> ok, cool so it's now
20:40:04 <jokke_> so there is reviews coming to our direction?
20:40:11 <rockyg> Yup.  Wanna help?  We could do it on google docs or etherpad if there are multiple people
20:40:34 <jokke_> you'll be on irc?
20:40:53 <rockyg> There will be reviews if we get the docs written.  And, yes, I'll be on IRC and google...
20:41:04 <rockyg> The coordination is from IRC I believe.
20:41:09 <jokke_> if so I'll let you know how my time permits, but if there is reviews coming, those I promise to look through
20:41:32 <bknudson> I'll be participating in the sprint as much as I can.
20:41:36 <jokke_> cool ... I'll ping you tomorrow and/or Friday if it looks like I can help
20:42:00 <bknudson> #link http://lists.openstack.org/pipermail/openstack-dev/2015-September/074719.html
20:42:08 <rockyg> Excellent.  I think the first thing to do is to just cut and paste the config code into a doc or etherpad
20:42:46 <rockyg> In preparation for the sprint
20:43:23 <jokke_> gimme a sec I'll have a look if I have the repo cloned
20:43:31 <rockyg> Then we add documentation around and remove the code bits that don't need documentation
20:44:31 <jokke_> hmm-m no genconfig made for oslo.log
20:44:52 <rockyg> I'll see if I can put together an etherpad with links to pertinent places.
20:44:53 <jokke_> will have a look if it would be easy to do ... that would help pulling the current info out of the code
20:45:14 <rockyg> bknudson, posted the lines for log config in a meeting eithr last week or before
20:45:53 <rockyg> let's get the etherpad up now so folks can add to it.
20:46:02 <jokke_> I just generated configs for glance via tox -egenconfig which effectively pulls all config options, their help texts etc. into text file
20:46:18 <rockyg> oslo-log-config-doc?
20:46:25 <jokke_> sounds good to me
20:46:33 <rockyg> If so, I'll create and jokke_ cn dump
20:46:51 <jokke_> I'll see if I can get it easily working
20:46:59 <jokke_> would prevent tons of manual work
20:47:51 <rockyg> #link https://etherpad.openstack.org/p/oslo-log-conf-doc
20:48:32 <rockyg> I'll also put the request-id link in
20:50:18 <jokke_> good stuff
20:50:43 <jokke_> anything else?
20:50:49 <rockyg> Started.  I'll also add the dev ref pages in for reference.  That way if others get into the sprint before I do, they can start without me ;-)  7am is too eearly and I'll likely be up until 2 or 3 tonight
20:51:02 <rockyg> I think that's it from my side.
20:51:39 <rockyg> Behzad_, wanna help with the doc sprint?  If so, just turn up!
20:51:49 <jokke_> I don't have anything else either
20:51:54 <Behzad_> Thanks, will do
20:52:12 <rockyg> OK  Thanks everybody!
20:52:15 <rockyg> #endmeeting