20:00:32 <Rockyg> #startmeeting log_wg
20:00:33 <openstack> Meeting started Wed Sep 16 20:00:32 2015 UTC and is due to finish in 60 minutes.  The chair is Rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:38 <openstack> The meeting name has been set to 'log_wg'
20:01:21 <jokke_> o/
20:01:24 <Rockyg> anybody here for logging?  bknudson jokke_
20:01:32 <jokke_> I'm here yeah
20:01:42 <bknudson> hi
20:01:44 <Rockyg> Heh.
20:01:46 <jokke_> hi bknudson
20:02:15 <Rockyg> Hi.  Just an FYI.  the reason we haven't seen dhellmann is that he has a conflict at this time.
20:03:23 <Rockyg> Scheduling meetings going forward: anyone not ok with Friday around utc 1700 or 1800?
20:03:45 <jokke_> that sounds really stretching it
20:04:01 <jokke_> and I'd say for whole EMEA
20:04:09 <Rockyg> Yeah, I thought you might have an issue ;-)
20:05:06 <jokke_> well, I might be joining from my local over phone irc, but don't expect anything sane or quick coming from that interface ;)
20:07:09 <Rockyg> Yeah.  I was looking at the calendar and trying to figure out a reasonable day/time.  Hah.
20:07:34 <jokke_> is that only slot that does not overlap with anything else where people are tied in?
20:09:12 <Rockyg> Not sure.  Can't get the OS calendar on my laptop at the moment, or on my IPad, so can't check.  I'll get back to you guys on that.
20:09:27 <jokke_> k
20:09:31 <Rockyg> #topic logging docs
20:09:48 <Rockyg> #info oslo doc sprint scheduled for 9/24 and 9/25
20:11:05 <Rockyg> I started collecting doc info:  #link https://etherpad.openstack.org/p/oslo.log_config-documentation
20:11:28 <Rockyg> But it's actuall more than just config.  It's stuff to document.
20:12:10 <jokke_> yeii
20:12:27 <Rockyg> I've been going through some of the project docs to see what they have.
20:13:16 <Rockyg> The projects that have docs up on docs.openstack.org, when they have logging info, it is generally how to configure specific for a project, plus some in troubleshooting
20:13:34 <jokke_> yep
20:14:52 <Rockyg> The proj specific cong generally point to proj config files and location of proj logs:  /var/[proj]/[proj].og and /etc/[proj]/logging.conf and /etc/[proj]/[proj].conf
20:16:16 <Rockyg> But, we need to verify consistency and ensure that the "correct" locations/info are part of devref, I think.
20:16:34 <jokke_> hmm-m yeah I saw that ... is there a way to specify the config file for oslo log or is that something that is set?
20:17:49 <Rockyg> good question.  Some projects have sample files.  But what we *need* is where the global conf is, make that sane defaults and document in *that* file where to do proj specific changes
20:18:37 <jokke_> does oslo log actually honor any global log file?
20:19:09 <Rockyg> I need admin access to a running cloud, or someone who does to do this stuff.  And yes, oslo log has global config settings
20:19:53 <jokke_> ok, where that config file should be? I'll have a look tomorrow when I'm back in office
20:20:02 <Rockyg> so, Theorectically, all of the projects' long config should be empty
20:20:21 <Rockyg> s/long/log
20:20:45 <jokke_> yes that tends to be the normal situation
20:21:26 <Rockyg> I think the other thing we need is to differentiate between projects using oslo.log and pylog
20:21:49 <jokke_> or mixture of those
20:22:14 <Rockyg> Then figure out what the format for the pylog projects should be that most closely relates to the oslo.log default
20:22:40 <Rockyg> I also have the file with the config options open, but haven't really started digging in that too much yet.
20:23:57 <jokke_> ok ... well this sounds like big improvement if that all gets even documented to easily digested format
20:24:20 <Rockyg> OK.  I'll keep working on this and prep the etherpad for the docs sprint.  Questions, organization, etc.
20:24:54 <Rockyg> #topic Tokyo Summit
20:26:05 <Rockyg> We have a cross-project work session for the summit, and I just expanded some on the ops session.  Do we want a working session?  Could we actually get valuable work done on a/some specs if we had one?
20:27:24 <jokke_> are you referencing that wed noon sessions as x-project?
20:27:36 <Rockyg> yesa
20:27:56 <Rockyg> Actually, maybe.  I think so.
20:28:08 <Rockyg> Discussion on TC list.
20:28:26 <jokke_> I'd assume that and the ops side should be enough ... I have really difficult to believe anything useful getting done over 40min working session
20:28:57 <Rockyg> Yeah.  So far we haven't.
20:29:27 <jokke_> rather we could try to communicate around and trying to get folks together just to the lunch room for round table if people has overlapping off time
20:29:44 <Rockyg> But, one of Mitaka's themes seems to be shaping up as "interop"
20:29:55 <Rockyg> I think consistent logs fit that theme
20:30:33 <jokke_> ++
20:31:03 <Rockyg> It also looks like req-id is on the verge of merging.  I think once it does, we propose a log header field that takes three ids
20:32:08 <Rockyg> Originating id, prev id, current id
20:32:31 <Rockyg> That would allow full tracing.  The originating is going to be the hard one to get defined.
20:32:38 <jokke_> that sounds like mile long log line
20:33:12 <Rockyg> nope.  log message only as at most 3.  But we need to limit size of req-id to something reasonable
20:33:44 <jokke_> well I think the current proposal is uuid ... so 3 of those is pretty damn long header
20:33:56 <Rockyg> hmmm.
20:34:41 <Rockyg> we need that configurable.  uuid takes an integer to say how big it should be.  That should be a config option.  Need a RFE!
20:35:13 <jokke_> ;)
20:36:23 <Rockyg> I'll go back and reread the spec.  Maybe I can get them to include it, or maybe I can propose a bp for that spec that does it.
20:36:46 <Rockyg> Too much to do and not enough me.
20:37:12 <jokke_> even it's once again one extra config option I think some folks could appreciate that vs. standard uuid
20:37:20 <jokke_> I know the feeling
20:37:48 <bknudson> if you just want a short random string don't use uuid
20:38:05 <Rockyg> #action propose config option for req-id that allows size of id to be chosen
20:38:06 <bknudson> assuming you're fine with a chance of duplicate strings
20:38:58 <Rockyg> bknudson I think uuid() has a size option.  Also, for tracing, the id+time window will be unique
20:38:59 <jokke_> bknudson: well the req id was difficult enough to get agreed with uuid ... some people has fancy idea that they need to have id for each request that is unique over months time
20:39:17 <bknudson> uuid will be unique
20:39:48 <bknudson> https://docs.python.org/2/library/uuid.html#uuid.uuid4
20:39:51 <Rockyg> haha.  Actually, not with the size of some clouds...
20:39:52 <bknudson> doesn't have a size parameter
20:39:54 <jokke_> that's why I think it was selected at the first place
20:40:27 <bknudson> there's different uuid methods
20:40:30 <Rockyg> I think it's in keystone middleware.  A redefine maybe?
20:40:39 <jokke_> well yeah it's unique up to certain count
20:41:11 <Rockyg> But that middleware already has the id generator, it uses uuid, but it also takes an integer
20:41:23 <Rockyg> multiple of two, of course
20:42:44 <Rockyg> There is so much freaking cruft in the codebase that's not used, not known about, or used by one small thing.  It would be great to get some interns to clean it up.
20:43:11 <jokke_> you mean OpenStack in general or some specific part?
20:43:23 <Rockyg> In general.
20:43:30 <bknudson> hire some interns
20:43:40 <Rockyg> maybe less for some of the newer projects;-)
20:43:45 <jokke_> that Intern would retire and still we would be cursing the crud
20:43:46 <Rockyg> Or not.
20:44:40 <Rockyg> Yup.  Anything we are forgetting for summit?
20:45:19 <jokke_> do we want to have some more descriptive topic for that Wed noon session
20:45:26 <jokke_> into the schedule?
20:45:48 <Rockyg> do you have a link to that page?
20:45:55 <Rockyg> Let's look
20:46:26 <jokke_> the communications are on my work e-mail
20:47:00 <jokke_> and ofc I forgot to get my laptop ready for this
20:47:21 <Rockyg> Welcome to the club!
20:47:33 <Rockyg> We'll discuss next week, then.
20:47:42 <Rockyg> #topic Open Discussion
20:47:51 <Rockyg> Anything else?
20:48:15 <jokke_> http://sched.co/4A2Z
20:48:20 <jokke_> that should be the slot
20:48:47 <Rockyg> Oh, did anyone review that spec/patch I forwarded?
20:49:12 <jokke_> it's on my todo list still (open on a tab at office)
20:50:08 <Rockyg> Ah.  So, the work session.  Yeah. But let's put that on next week's agenda?
20:50:18 <jokke_> sure
20:50:20 <bknudson> we've got an attendee already!
20:50:25 <jokke_> so yes it's on work session title
20:50:43 <jokke_> bknudson: that is placeholder for all 10 parallel worksessions there ;)
20:50:52 <Rockyg> On the spec,, I'm pretty sure that they should be using oslo.log and not syslog, but....who am I to say?
20:52:35 <jokke_> I'd like to see that happening as well
20:52:52 <jokke_> (I did eyeball it but didn't dig in enough to comment anything
20:54:12 <Rockyg> I think it was this one? https://review.openstack.org/#/c/203509/
20:54:56 <jokke_> I think it was
20:55:09 <jokke_> looks vaguely familiar
20:56:24 <Rockyg> But, if it is, the rst file got lot smaller recently
20:58:32 <jokke_> this seems to have been growing ... was it some other logging api then than that security one?
20:58:36 <Rockyg> #link https://review.openstack.org/#/c/203509/
20:59:05 <Rockyg> https://review.openstack.org/#/c/203509/20/specs/liberty/logging-API-for-sg-and-fw-rules.rst
21:01:13 <jokke_> ok, till next week then ... or just ping me/send an e-mail if something iteresting pops up
21:01:53 <Rockyg> OK.  Sorry, I just hit something wierd.  The first time I posted the patch, I was looking at it, copied the url and posted.  The review I was seeing had three files - two json files - example and schema, and a 35 line rst file.  Now, it is what we currently see.
21:02:19 <jokke_> ah :)
21:02:29 <Rockyg> Freaky.
21:03:16 <Rockyg> plus, patch set showed like 8, but comments showed the 20.  Wow.
21:03:23 <jokke_> ;)
21:03:33 <jokke_> gerrit doing weird things
21:03:51 <jokke_> messing with yer mind
21:04:04 <Rockyg> Oops.  Ran over again.  Please review the spec.  I really think it needs comments from the log wg, but I don't want to jump in until a dev does.
21:04:12 <Rockyg> And it is time.
21:04:19 <Rockyg> #endmeeting