20:00:34 <jokke_> #startmeeting log_wg
20:00:34 <openstack> Meeting started Wed Jul 22 20:00:34 2015 UTC and is due to finish in 60 minutes.  The chair is jokke_. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:37 <openstack> The meeting name has been set to 'log_wg'
20:00:58 <jokke_> #topic attendance and courtecy calls
20:01:04 <bknudson> I'm here... I'm at the nova meetup
20:01:38 <jokke_> rockyg, dhellman, johnthetubaguy, nkrinner
20:01:44 <dhellmann> o/
20:01:51 <nkrinner> i'm here too. but only listening anyway and working on a unrelated bog currently too ;-(
20:01:53 <jokke_> hello everyone
20:02:13 <nkrinner> hi all though :-)
20:02:19 <jokke_> #topic action items
20:03:42 <jokke_> so I haven't had time to check the empty field markers yet and I haven't herd back from Rocky if she got the incubator using list looked in so those items stays still in the list
20:04:44 <jokke_> We have proposed talk around this working group to the Tokyo summit
20:05:06 <jokke_> I do not know about any other talks around logging yet so let's keep eye out for those
20:05:41 <jokke_> #topic Ongoing specs
20:06:38 <jokke_> has anyone been following up the talk around the request Ids and could give quick update what's going on there?
20:07:36 <dhellmann> I confess I'm confused about the current state. I thought an approach was settled on, but it seems there were some issues with it, and I missed a bunch of the last meeting so I don't know the details
20:07:57 <jokke_> I'm unfortunately on the smae state myself
20:08:00 <jokke_> same
20:08:42 <bknudson> there wasn't a meeting this week
20:08:53 <bknudson> so it'll be discussed on tuesday
20:09:07 <jokke_> bknudson: on X-project meeting?
20:09:10 <dhellmann> last discussion was http://eavesdrop.openstack.org/meetings/crossproject/2015/crossproject.2015-07-14-21.01.log.html
20:09:30 <bknudson> there was an approach that was easy to implement but then concerns were raised about it
20:09:42 <bknudson> so the current approach requires rewriting all the libraries
20:09:52 <dhellmann> there's an etherpad:
20:09:54 <dhellmann> #link https://etherpad.openstack.org/p/request-id
20:09:56 <bknudson> so don't expect it to be done any time soon
20:10:39 <jokke_> yeah that's what I was afraid as well
20:11:50 <jokke_> ok moving on
20:12:04 <jokke_> #topic ops midcycle planning
20:12:29 <bknudson> I'm not planning on being at the ops midcycle
20:12:41 <bknudson> would have been nice if the ops midcycle was before the keystone & nova midcycles
20:12:49 <jokke_> dhellmann: you were going to be there and I think Rocky said she will be there as well. Is there something we should act on beforehand?
20:13:08 <jokke_> I will not be able to attend either
20:13:29 <bknudson> where is it?
20:13:34 <dhellmann> I'm planning to participate, but let the ops folks drive it
20:13:37 <dhellmann> palo alto
20:13:49 <dhellmann> https://www.eventbrite.com/e/openstack-ops-mid-cycle-meetup-tickets-17703258924
20:14:00 <dhellmann> session planning: https://etherpad.openstack.org/p/PAO-ops-meetup
20:14:41 <jokke_> #link https://www.eventbrite.com/e/openstack-ops-mid-cycle-meetup-tickets-17703258924
20:14:42 <bknudson> if ops don't complain about logs then I guess we're done.
20:14:53 <jokke_> #link  https://etherpad.openstack.org/p/PAO-ops-meetup
20:14:56 <jokke_> bknudson: ++
20:15:13 <bknudson> "Matt Young <Matty@hp.com> - Monitoring and logging sessions"
20:15:22 <bknudson> so maybe there's some sessions for it
20:15:48 <jokke_> sounds good
20:16:01 <bknudson> the ops meetup is going to take over from the openstack summit.
20:16:25 <jokke_> bknudson: what do mean by that?
20:16:40 <bknudson> they've got their own lightning talks
20:16:47 <jokke_> aa
20:17:54 <jokke_> that's a good thing ... anything bringing the ops closer is improvement
20:18:31 <jokke_> anything else on this for now?
20:19:32 <dhellmann> I wish I knew if Rocky had anything planned
20:20:19 <jokke_> well we have well time to sync up still before
20:20:24 <dhellmann> true
20:20:55 <jokke_> so lets keep this topic in agenda for next week and see if we have some updates
20:21:33 <jokke_> #topic log_wg meeting time
20:21:46 <bknudson> this time works great for me.
20:21:49 <jokke_> is this time suitable for everyone currently here?
20:22:49 <dhellmann> yes, it works ok for me
20:22:59 <jokke_> there was request at some point to have earlier slot for EMEA/APJ ... I'm fine with this, would not like to have any later at least
20:25:03 <jokke_> I'll send e-mail out to the mailing list to check if there are still need for such, I think we can facilitate bi-weekly rotation if there is need for such. We rarely have anything burning that couldn't wait
20:25:20 <dhellmann> ++
20:25:24 <Nikolay_St> jokke_: I'm ok with this time :)
20:26:08 <jokke_> #action jokke_ will send e-mail to the mailing list probing if there is need for bi-weekly rotation of meeting time, otherwise we keep it as it is.
20:26:22 <jokke_> #topic open discussion
20:26:38 <jokke_> was there anything missing from agenda for this week?
20:26:52 * bknudson been busy with meetups
20:27:01 <dhellmann> yeah, I've been busy with release stuff
20:27:30 <bknudson> we're a long ways from L release.
20:27:30 <jokke_> I've been busy with the next Helion release
20:28:02 <dhellmann> bknudson: yeah, we have a bunch of tool work to get there, though, because of the changes we're making
20:28:06 <jokke_> bknudson: true, but not that far feature wise ... it's month and half to ff
20:29:41 <dhellmann> I would really like to see one specific initiative planned out for this group to push next cycle, and figure out a way to find some resources to actually work on the implementation. We should start talking about that now, so we have time to see if we can get summit session space (it will be more restricted than Vancouver) or at least start publicizing the plans so other teams can incorporate them in their planning.
20:30:09 <jokke_> dhellmann: I seriously like that
20:30:41 <bknudson> what's restricted? the # of sessions?
20:30:46 <bknudson> design summit sessions?
20:30:50 <dhellmann> bknudson: yeah, there won't be as much space is all
20:31:05 <dhellmann> at least that's my impression, we don't have a room count yet
20:31:54 <jokke_> that's the impression I got from the Vancouver wrap-up session as well
20:32:44 <bknudson> if we're depending on request ID then maybe we can help out with the impl
20:32:56 <bknudson> at least I could help out with keystoneclient
20:33:37 <dhellmann> that might be a good one
20:34:17 <bknudson> things probably haven't changed much since the last design summit session
20:34:55 <dhellmann> no, I don't think that has made any real progress
20:35:06 <jokke_> Is there anything we can do to help the spec work? For me it kind of feels like there's a deadlock between couple of opinions how that should be done?
20:35:18 <jokke_> exactly
20:35:37 <bknudson> I think the proposers are happy with rewriting all the clients.
20:35:44 <dhellmann> are we waiting for prototypes to be written?
20:35:54 <bknudson> a prototype would be nice
20:36:19 <dhellmann> well, yeah, but would it? I mean, what do the folks who are blocking it actually want?
20:36:28 <dhellmann> would a prototype help?
20:36:41 <jokke_> what I have understood is that the proposers are pretty much willing to start implementing any solution the community just agrees
20:36:49 <bknudson> the folk blocking it wants the rewrite of all the clients, and nobody has a problem with it
20:36:59 <dhellmann> is that just lifeless?
20:37:02 <bknudson> y
20:37:18 <bknudson> the proposers are fine with the amt of work.
20:37:42 <dhellmann> wow, ok
20:37:50 <dhellmann> so we just need the spec approved?
20:38:04 <bknudson> I haven't looked at the spec.
20:38:09 <bknudson> if it's been updated
20:38:16 <dhellmann> ok
20:39:01 <bknudson> the spec hasn't been updated yet
20:39:06 <bknudson> https://review.openstack.org/#/c/156508/16/specs/return-request-id.rst
20:39:16 <dhellmann> hmm
20:39:30 <jokke_> that does not help it moving forward :(
20:40:43 <jokke_> by the comment from lifeless it seems like POC has been agreed
20:40:59 <jokke_> so the prototype seems to be the way to go forward
20:41:51 <jokke_> that has been two weeks ago
20:44:17 <jokke_> anything else?
20:44:23 <dhellmann> that's all I have this wek
20:44:32 <bknudson> I don't have anything.
20:45:01 <Nikolay_St> nothing from me
20:45:07 <jokke_> ok, thanks everyone, lets spend this extra 15min well :)
20:45:16 <nkrinner> cu
20:45:22 <jokke_> #endmeeting