20:00:41 <Rockyg> #startmeeting log_wg
20:00:42 <openstack> Meeting started Wed Mar 25 20:00:41 2015 UTC and is due to finish in 60 minutes.  The chair is Rockyg. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:46 <openstack> The meeting name has been set to 'log_wg'
20:01:00 <Rockyg> Who's here for logging?
20:01:18 <nkrinner> o/ hi
20:02:39 <dhellmann> o/
20:02:56 <Rockyg> jokke_?
20:03:07 <Nikolay_St> \o/
20:04:09 <Rockyg> Good enough
20:05:08 <Rockyg> Didn't get an agenda out for this week.  But, let's follow the typical
20:05:19 <Rockyg> #topic action items
20:05:56 <Rockyg> rockyg: error code spec --
20:06:42 <Rockyg> I am within about half an hour of ready for checkin, but I haven't had time to get everything resetup on my laptop.  so, I would like to request some help.
20:07:22 <Rockyg> If I can't "just do it", can I forwad it to someone and have them do the git review and add me as a coauthor?
20:08:18 <Rockyg> any volunteers?
20:09:01 <dhellmann> normally I would, but I'm going to be out for about a week starting tonigh
20:09:04 <dhellmann> t
20:10:31 <Nikolay_St> Rockyg: may be I can help
20:10:40 <nkrinner> Rockyg: i'm willing to help, but i am not very experienced here and can only start in about 15 hours. but i can definitely take a look. not sure if that helps.
20:10:40 <Rockyg> OK.  My problem has been getting the repository clone.  I don't think I can submit without the infrastructure of that.
20:10:40 <Nikolay_St> Rockyg: but I'm not sure
20:11:01 <nkrinner> Nikolay_St: was faster
20:11:02 <Rockyg> Not a problem.  I will make it happen :-)
20:11:14 <Rockyg> I may reach out to you guys, though.
20:11:15 <nkrinner> Nikolay_St was faster...
20:11:30 <Rockyg> Next action item:
20:11:42 <Rockyg> Nikolay_St -- etherpad
20:11:58 <Nikolay_St> nkrinner: I see :) np, I can pass it to you
20:12:39 <Rockyg> Nikolay_St: do we have a link for the etherpad?
20:12:55 <nkrinner> Nikolay_St: we can look at it together, i am not sure if i can help anyway ;-)
20:13:12 <Rockyg> No fair, you guys in the same office?
20:13:15 <Nikolay_St> Rockyg: you mean that one? https://etherpad.openstack.org/p/Logging-Improvements
20:13:33 <Nikolay_St> nkrinner: same to me :D
20:13:38 <Rockyg> Oh, good.  I've gotta get that into the Wiki page
20:14:05 <Rockyg> and the last is a ping to jokke_
20:14:32 <Nikolay_St> Rockyg: I was a little bit surprised because we discussed it on previous meeting
20:14:36 <Rockyg> jokke_: time to start the ML thread on logging priorities
20:14:40 <Nikolay_St> about etherpad
20:15:11 <Rockyg> Yeah.  I didn't record it in the Wiki, also.  So I have the wiki up now and will put it in the actual wiki minutes
20:15:27 <Rockyg> Plus mark the AI done
20:15:57 <Rockyg> #topic Open discussion
20:16:09 <Rockyg> what else do we need to do/track/follow up on?
20:17:19 <Nikolay_St> uhm...
20:17:45 <Rockyg> One of the other hot topics is referrer IDs
20:18:03 <Nikolay_St> we have this patch in Sahara: https://review.openstack.org/#/c/164755/
20:18:52 <Nikolay_St> we don't want to merge it in Sahara, but we think we can discuss it somewhere because it should be useful to oslo.log
20:19:14 <Nikolay_St> is LWG right place?
20:19:43 <Rockyg> Yes.
20:20:21 <Rockyg> And, dhellmann is a good source to look at it, too.
20:20:27 <dhellmann> Nikolay_St: you shouldn't need to do that, the oslo logging library already has a keyword adapter to do it
20:20:38 <Nikolay_St> dhellmann: nice
20:20:47 <Nikolay_St> dhellmann: can you give me a link
20:20:57 <Nikolay_St> dhellmann: I think I miss it :(
20:21:01 <Rockyg> Looks like we need to document this feature in the DevRef...
20:21:39 <dhellmann> Nikolay_St: I'm not sure it's a public class. Just call oslo_log.getLogger(name) and then use it like LOG.level(format, foo=bar, blah=bletch)
20:21:41 <Rockyg> Unless it's already in oslo.log doc
20:22:21 <dhellmann> Nikolay_St: http://docs.openstack.org/developer/oslo.log/api/log.html#oslo_log.log.KeywordArgumentAdapter
20:22:25 <Nikolay_St> dhellmann: ok, thx. will check it later this week
20:23:50 <Rockyg> #info oslo.log  keyword adapter use example.  It can do what this patch does:  https://review.openstack.org/#/c/164755/
20:24:36 <Rockyg> Nikolay_St, can you write a paragraph and or code example for documenting how you get it working?
20:25:42 <Nikolay_St> Rockyg: you're talking about Adapter?
20:25:44 <Nikolay_St> sure
20:25:53 <Rockyg> dhellmann:  is there a possible rule of thumb we can publicize so that someone from oslo.log gets added to review list for any patch related to logging?
20:26:08 <Rockyg> Nikolay_St:  Thanks!
20:27:38 <dhellmann> Rockyg: there isn't a separate review team for oslo.log, so it wouldn't be easy. I'm not sure the team that manages the library is the best group to review the updates in the applications.
20:28:35 <dhellmann> Nikolay_St: if you want to add some examples to http://docs.openstack.org/developer/oslo.log/usage.html I can help with reviews there
20:28:58 <Rockyg> dhellmann:  give it some thought on how we might be able to get a person or group to publicize for inclusion on stuff like this.  Maybe the log-wg or some tag or something;-)
20:29:02 <Nikolay_St> dhellmann: ok, I'll contact you
20:29:13 <Rockyg> Yeah, I know.  Not that simple.
20:29:33 <dhellmann> Nikolay_St: ok. I'm going to be offline after this meeting until the middle of next week, but I'll catch up with email then
20:30:01 <Rockyg> #action Need to devise a way to include member of log_wg on log related project patches -- TBD maybe next meeting
20:30:01 <dhellmann> Rockyg: well, we need the people first. Tracking related changes won't be that hard once we have people to do the reviews
20:30:40 <Nikolay_St> dhellmann: ok, I'm not sure I can take a look until the beginning of next week.
20:30:40 <Rockyg> dhellmann, yeah we can discuss next meeting.
20:30:47 <dhellmann> Rockyg: ok
20:30:54 <dhellmann> Nikolay_St: ok, I just didn't want you to think I was ignoring you :-)
20:31:14 <Nikolay_St> dhellmann: nevermind :D
20:31:36 <Rockyg> Maybe we can use the liaisons if/when we get them
20:31:45 <Rockyg> Anyway, anything else to discuss?
20:33:00 <dhellmann> no news from me
20:33:16 <Nikolay_St> not from me
20:33:27 <Rockyg> Next week, we should have both jokke_ s email and the spec out, along with ML thread to advertise the spec, so might have some meat for the meeting.
20:33:48 <Rockyg> Let's call this one baked.
20:33:58 <Rockyg> Thanks everyone!
20:34:22 <Rockyg> oh, yeah, bknudson couldn't make it....
20:34:29 <Rockyg> #endmeeting