03:02:09 <VW_> #startmeeting Large Deployments Team
03:02:09 <openstack> Meeting started Fri Jul 24 03:02:09 2015 UTC and is due to finish in 60 minutes.  The chair is VW_. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:02:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:02:13 <openstack> The meeting name has been set to 'large_deployments_team'
03:02:38 <sorrison_> LDT meeting on now?
03:02:44 <VW_> yep sorrison_
03:02:52 <VW_> just started it while you were off briefly
03:03:20 <sorrison_> howdy, yeah was trying to change my nick
03:04:08 <VW_> sorry folks.  I've been traveling some and had a couple of larger issues at work, so I didn't get an agenda up on the wiki or anything
03:04:16 <VW_> but I thought we'd cover a few things
03:04:34 <VW_> 1.  Feedback from the Neutron mid-cycle ( mdorman and klindgren made it there)
03:04:47 <VW_> 2.  See if anyone has been with the Nova folks this week
03:05:17 <VW_> 3.  Discuss the upcomiing Ops-midcycle and anything we want to get out of an LDT session there
03:05:25 <VW_> Anyone have anything else?
03:05:36 <mdorman> sounds good to me.
03:05:43 <sorrison> sounds good
03:07:18 <VW_> cool then
03:07:35 <VW_> #topic Neutron mid-cycle
03:07:53 <mdorman> i can give an update on that.  i don’t think klindgren is here (not sure)
03:08:09 <VW_> cool - that would be great
03:08:23 <VW_> for refference some good conversation was had with devs in our last LDT Meeting
03:08:33 <VW_> as we were discussing the feedback we'd given at the summit
03:08:38 <VW_> or following it
03:08:39 <mdorman> so after our discussions in vancouver, kris, belmiro, and i and some others wrote up this RFE bug:  https://bugs.launchpad.net/neutron/+bug/1458890
03:08:40 <openstack> Launchpad bug 1458890 in neutron "Add segment support to Neutron" [Undecided,Triaged]
03:09:08 <mdorman> carl baldwin had kinda picked that up and thought it was somewhat a good fit for his routed networks spec:  https://review.openstack.org/#/c/196812/
03:09:27 <mdorman> so kris and i went to the neutron mid-cycle and spent an afternoon with those folks discussing the use case, and what our needs/requirements are
03:09:47 <mdorman> so i think we were pretty successful in getting on the same page as far as what the ‘ask’ was
03:10:07 <mdorman> generally it seemed like they were pretty open with moving in that directlion, and i think carl’s spec is a pretty good first step.
03:10:45 <sorrison_> It seems that it also requires some changes in what nova does too?
03:10:54 <klindgren> o/ - just got in
03:11:01 <mdorman> i am not sure if any neutron folks will be at the ops mid cycle, but hopefully we can do something there to try to keep some momentum on this.   the spec is pretty high level and doesn’t necessarily prescribe exactly what the changes would be to neutron.  so i think there’s a lot of follow on work necessary to make something happen.
03:11:17 <mdorman> sorrison:  yeah, the scheulding problem. we had talked about that as well.
03:11:35 <mdorman> somewhat rlated to that is the ip usages spec:  https://review.openstack.org/#/c/180803/   which we raised also
03:11:49 <mdorman> and i think got agreement that people were good with going forward with that, but since then there hasn’t really been any activity on the spec.
03:12:21 <mdorman> partially b/c we haven’t had time to give it attention, and partially because the only remaining decision points are specific to what the api looks like, and to some extent somebody just needs to make a decsion and go with it.
03:12:35 <mdorman> and for that i feel like we need a neutron core to kinda endorse it so it can get merged.
03:12:41 <mdorman> klindgren:  do you have anything to add?
03:12:49 <klindgren> They wanted to see/approve code - but we haven't gotten a review up that on master
03:13:24 <klindgren> pretty much the cores there were good with it - with decisions being made once the code was there - re: naming of the actual api's
03:13:26 <mdorman> yeah there was some sense that we may be able to just put a review up of the implementation and get it merged w/o a spec.
03:13:45 <VW_> I don't know of any Neutron folks at the mid-cycle, but I'll try and get updates from our two Neutron devs focused on upstream before then
03:13:50 <VW_> on both specs
03:13:53 <mdorman> so again i think that is somewhat on us to just get that out there.
03:13:57 <mdorman> cool
03:13:58 * VW_ is drafting a note to them now
03:14:09 <mdorman> klindgren:  do you remember the guys name from rax that was at the neutron meeting?
03:14:14 <klindgren> so we - as in Godaddy - just need to get code on gerrit
03:14:27 <klindgren> I do not - VW does :-)
03:14:39 <VW_> I believe it was Miguel
03:14:49 <klindgren> that sounds right
03:14:53 <VW_> he's also the Neutron Liason for cells v2
03:15:02 <VW_> which is fortuitous with your other comments?
03:15:04 <VW_> :)
03:15:27 <klindgren> yes - not sure if thats a segway
03:15:49 <klindgren> but I get the sense that most of LDT is running cells and most of us has patches for cells
03:16:07 <klindgren> I know mgange doesn, I know we are running most of the ones from NecTAR
03:16:15 <klindgren> I assume that rackspace has some as well
03:16:24 <sorrison> godaddy are you running Juno?
03:16:35 <klindgren> Thinking we should generate a list of what patches we are running to fix things, and try to get the common ones merged
03:16:44 <klindgren> Juno -> kilo in a week
03:16:51 <mdorman> anyway re #1 and neutron stuff, i think next steps are for GD to get a review out there for the ip usages api extension, and then all of us circle up at mid-cycle to talk about the routed networks spec and focus on getting more ops feedback on the spec itself, with hopes of it getting attention.
03:17:22 <VW_> Sounds good mdorman
03:17:54 <mdorman> #action go daddy staff to post neutron review with ip usages api extension
03:18:02 <sorrison> so sounds like only real thing we are missing is code?
03:18:15 <mdorman> for ip usages extension?  yeah i think so.
03:18:24 <sorrison> and segment support?
03:19:10 <klindgren> Segment support is the spec that is being lead by Carl Baldwin - but yes - bascially all we are missing upstream is everything :-)
03:19:18 <VW_> ha
03:19:47 <mdorman> i think teh segment support isgoing to involve some larger architectural changes/additions to neutron before it’s possible
03:20:22 <sorrison> yeah I think it is more than just code, it's architectural decisions etc. too which makes me think it's no short term thing here
03:20:38 <mdorman> agreed.  i do not get the sense it would be coming anytime soon.
03:20:44 <klindgren> yea - I got the sense that Liberty even M time frame is not happening
03:21:09 <sorrison> So none of the neutron cores have really started to think how we can achieve this?
03:21:41 <mdorman> i think carl baldwin is really the only one who is seriously thinking about it
03:21:51 <sorrison> it's a start :-)
03:21:54 <mdorman> yeah.
03:22:01 <mdorman> there may be others.  but he’s the only one i’ve seen championing it
03:22:21 * VW_ will attempt to help increase that number
03:22:56 <VW_> these minutes and the specs will all be in what I pass on to some of our Neutron folks
03:23:01 <mdorman> cool
03:23:06 <mdorman> anyways i think that probably wraps up topic #1
03:23:11 <VW_> I know their plates are full , but if they can help push
03:23:14 <VW_> yep
03:23:34 <VW_> and since you segway'ed nicely earlier, I'll modify my agenda
03:23:45 <VW_> #topic Cells v1 patches
03:23:47 <VW_> :)
03:23:53 <klindgren> sorry :-/
03:24:02 <VW_> not a problem at all
03:24:09 <VW_> I think it's useful stuff to chat about
03:24:19 <sorrison> We have a few patches I want to try get upstream somehow...
03:24:20 <sorrison> https://github.com/NeCTAR-RC/nova/commits/nectar/kilo
03:24:26 <sorrison> just rebased ours onto kilo
03:25:08 <sorrison> some don't make sense upstream, some won't be needed once neutron comes around but some are useful
03:25:10 <klindgren> So - repeat of the above - I think everyone who runs cells has patchs that they have been carrying.  Think it would be good to get a list going - between everyone and either get them upstream - or get them into a repo that other people can pull in
03:25:30 <sorrison> sounds great
03:25:38 <sorrison> anyone from CERN here?
03:25:51 <sorrison> they maybe sleeping
03:26:17 <VW_> yeah, I suspect they are
03:26:40 <VW_> and I'm not sure if any are coming to Palo Alto either
03:26:44 <VW_> sorrison are you?
03:27:01 <sorrison> no bit far for me and $$$
03:27:36 <VW_> yeah - figured so
03:27:51 <sorrison> One thing that we do which is a bit different is run our vncproxy and consoleauth at a per cell level as opposed at the API cell, what do others do here?
03:28:25 <mdorman> we do api cell
03:28:45 <sorrison> so does that mean your vnc can talk to all your hypervisors?
03:28:52 <klindgren> anyone have a feeling of how accepting upstream would be of a combined patchset from LDT, for cells v1?  I know in the past it seemed like anything re: cells was not well recieved
03:28:59 <mdorman> it’s spice for us, but yes it can.
03:29:15 <VW_> I like the patch set idea
03:29:25 <VW_> 1. to solve some of our problems and make them upstream
03:29:36 <sorrison> The AZ stuff I think multiple sites are using right?
03:29:45 <mdorman> yup
03:30:02 <sorrison> So that would be a good one to get upstreamed
03:30:04 <VW_> 2.  to push the concept of Ops inserting tangible work into the development cycle
03:30:48 <sorrison> Which dev do we send beers to?
03:30:50 <VW_> the challenge I see is most of folks on the Nova team that would pretty favorable to this are the RAX devs
03:30:56 <VW_> and most of them are very V2 focused
03:31:18 <sorrison> Do we just wait for V2?
03:31:35 <VW_> I don't know that that is the best answer eitehr
03:31:40 <VW_> either even
03:31:43 <klindgren> sounds like V2 is 1+ year out for multi cell deployment?
03:31:54 <VW_> yeah, that's what I'm hearing too
03:31:57 <VW_> it's not going to be M
03:32:18 <klindgren> M is one and only one  cell  for everyone afaik
03:32:21 <mdorman> i would assume the v1 is going to remain mostly static, since v2 is a rewrite
03:32:36 <mdorman> so it seems like we could probably make a decent case for merging in this stuff for v1
03:32:49 <VW_> yeah, klindgren, but that was origionally going to be L
03:33:03 <VW_> at least some of it
03:33:12 <klindgren> yea - thats why we moved to cells earlier :-)
03:33:15 <klindgren> ha!
03:33:26 <klindgren> its coming in 6 months!
03:33:28 <klindgren> and sigh
03:33:59 <mdorman> although since v2 is so far off, we will probably end up being large enough to need more than one cell by then anyway.  so maybe not as bad of a decision as it seems
03:34:15 <klindgren> indeed
03:34:20 <VW_> how about this.  Assuming we get and LDT slot at the mid-cycle, let's put a common cells v1 patch set on the agenda.
03:34:22 <mdorman> anyway, +1 to the patchset idea.   get review(s) out there as a starting point
03:34:30 <mdorman> agreed.
03:35:09 <VW_> we don't have to decide it all then, but we can chat about it more and between now and then, I can try to fish out some idea of how successful something like that might be from Garbutt and Laski
03:35:19 <VW_> report back at the meet-up
03:35:23 <mdorman> cool
03:35:42 <sorrison> Do we need to start with specs? Or one big spec?
03:36:02 <VW_> that's a good question
03:36:14 <VW_> probably a few specs - some may move faster than others
03:36:24 <VW_> but I'd like to get a feel for how much room there is try and push
03:37:03 <sorrison> Eg. as an example the "instance-name" attribute isn't correct when using cells so it could be classified as a bug
03:37:41 <VW_> Good point, sorrison
03:37:53 <VW_> perhaps we start an etherpad for cells v1 patches folks are running
03:37:58 <klindgren> AZ's doesn't work with cells, flavor create doesn't work wither - without patches
03:37:58 <VW_> then we can get LDT folks to add to it
03:38:06 <klindgren> vif plug stuff doesn't work - without patches
03:38:07 <sorrison> yeah that sounds good
03:38:19 <VW_> since we know sorrison (super helpful cells Ops dude) won't be there
03:38:27 <VW_> and I don't know about the CERN folks either
03:38:28 <sorrison> yeah I have that under review but needs a small change
03:38:51 <sorrison> lets action that
03:38:56 <klindgren> yea - I think we run all of sorrison's patches :-)
03:39:08 <VW_> #action VW create cells v1 patches etherpad
03:39:44 <sorrison> there will be a time when I will ask something of you :-)
03:40:09 <VW_> sounds ominous :P
03:40:22 <klindgren> #link https://etherpad.openstack.org/p/PAO-LDT-cells-patches
03:40:48 <VW_> sweet
03:41:28 <VW_> I'll get a note out on the mailing list about that
03:41:33 <VW_> thanks, klindgren
03:43:05 <VW_> alright that seems done for now
03:43:12 <VW_> #topic Nova mid-cylce
03:43:21 <klindgren> sorrison, thats fine :-) if we can ever return the favor
03:43:32 <klindgren> s/cylce/cycle
03:43:44 <VW_> blargh
03:43:51 * VW_ blames the lateness of the evening
03:44:11 <klindgren> I can't type normally anyway
03:44:53 <klindgren> So - Mike and I are going to mid-cycle
03:45:04 <klindgren> I think we are going to do a lightning talk - not sure what yet
03:45:09 <VW_> very cool
03:45:39 <VW_> anyone have close contacts at the Nova mid-cycle this week?
03:45:46 <VW_> We have several devs there
03:45:49 <klindgren> but not really sure whats going to happen in the general session
03:45:52 <klindgren> I do not
03:45:58 <VW_> but I haven't been able to catch up with them
03:46:54 <sorrison> I can always harass michael still
03:46:58 <VW_> I think most of us chimed in on the thread with Dave (who was there) about the v1/v2 DB behavior
03:47:26 <mdorman> med_ was at nova mid cycle, not sure if he’s here now though
03:47:36 <mdorman> ah, yup, what you jsut said.
03:48:03 <VW_> I'll see what I can find out from Garbutt and Laski
03:48:17 <VW_> at least John and I are in the same staff meeting on a weekly basis
03:48:39 <VW_> assuming there be some debrief from Nova mid-cycle there
03:49:21 <VW_> so, moving along
03:49:37 <VW_> #topic Ops - mid-cycle
03:50:02 <VW_> anything related to the OPs meetup besides what we've already discussed?
03:50:19 <VW_> I'm fairly interested in the CMDB chat
03:50:30 <mdorman> i feel like we have a pretty good LDT-specific agenda to work with there.
03:50:36 * klindgren hangs head in shame - I thought we were talking about the OPS midcycle
03:51:35 <VW_> I agree mdorman
03:51:40 <klindgren> I haven't been paying attention to the CMDB stuff - is that coming from RAX?
03:51:45 <VW_> it's not
03:52:01 <VW_> but based on email threads, I'm thinking that we've solved a lot of what people want
03:52:19 <VW_> so, my plan is to have most of my folks there listening intently
03:52:57 <klindgren> I do have a general ops question - does anyone find glance's option around images sharing missing features?
03:53:10 <VW_> hrm
03:53:26 <VW_> not necessarily, but I don't think we've gone too far down that road
03:53:31 <klindgren> Specifically - anyone can make an image public
03:53:40 <klindgren> that then shows up to everyone.
03:53:46 <sorrison> that's controlled by policy
03:53:58 <sorrison> it came in juno
03:54:19 <klindgren> policy as in restricting who can set image = public?
03:54:23 <sorrison> yes
03:54:45 <klindgren> like what I am getting is that typical enterprise setup here...
03:55:04 <klindgren> I want to have cloud blessed iamges - IE these come from some corprate things and everyone should have these
03:55:15 <klindgren> and hten have per department scoped images
03:55:18 <sorrison> "publicize_image": "role:admin",
03:55:32 <mdorman> ^^ nice
03:55:34 <klindgren> like a department may have 30-40 tenants
03:55:58 * VW_ afk for 2 minutes
03:56:02 <klindgren> and sharing between those tenants in cumberson as you have to share each time a tenant for that department is added
03:56:26 <klindgren> I guess I want heirarchical projects - implemented in glance
03:56:53 <mdorman> yeah i would be nice ot see glance (and other projects) embrace that
03:56:59 <klindgren> SO I can keep x departments specific image from being used by y department
03:57:47 * VW_ back
03:58:15 <klindgren> Specifically on our internal cloud where we have our hosting teams dev/test and they create the images to be used in the public cloud internally
03:58:35 <klindgren> I want to keep our internal guys from firing up CoreOS images in our corporate zones :-)
03:58:42 <VW_> so, in the larger picture, I think that as soon as we get traction on a comon LDT push with Nova, that Glance should be next in line
03:59:16 <mdorman> +1
03:59:34 <klindgren> kk - I am a huge +1 on that
03:59:44 <VW_> Let's keep it on the radar then and maybe as early as Tokyo we can make that a big agenda item
03:59:49 <VW_> when we have a bit more time and folks
04:00:30 <sorrison> sounds good
04:00:39 <VW_> cool - well we are out of meeting time
04:01:04 <VW_> but if you guys can stick around for as second after I end meeting I'd appreciate it
04:01:15 <mdorman> sure
04:01:26 <VW_> cool - anything else "official"
04:01:30 <mdorman> newp
04:01:38 <mdorman> thanks as always for organizing VW_
04:01:47 <VW_> my pleasure
04:01:49 <klindgren> nothing from me either
04:01:50 <sorrison> sure
04:01:54 <VW_> these last two have been really good meetings
04:02:01 <sorrison> yeah thanks VW_
04:02:07 <VW_> cool then
04:02:11 <VW_> #endmeeting