14:00:54 <dmellado> #startmeeting kuryr
14:00:55 <openstack> Meeting started Mon Dec 18 14:00:54 2017 UTC and is due to finish in 60 minutes.  The chair is dmellado. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:59 <openstack> The meeting name has been set to 'kuryr'
14:01:07 <dmellado> Hi folks, who's here today for the kuryr meeting? ;)
14:01:26 <leyal> Hi
14:01:26 <dulek> o/
14:01:38 <dmellado> #chair dulek leyal
14:01:39 <openstack> Current chairs: dmellado dulek leyal
14:02:22 <dmellado> ltomasbo: irenab ?
14:02:32 <ltomasbo> o/
14:02:53 <leyal> irenab in PTO
14:03:06 <dmellado> oh, true!
14:04:23 <dmellado> seems that some folks are having issues with freenode today, so let's start
14:04:29 <dmellado> #topic kuryr-libnetwork
14:04:47 <dmellado> anything to discuss on libnetwork? hongbin is not here either
14:06:42 <dmellado> going once
14:06:44 <dmellado> going twice...
14:06:50 <dmellado> #topic kuryr-kubernetes
14:06:57 <dmellado> dulek: anything to share? ;)
14:07:41 <dulek> I have an issue with https://review.openstack.org/#/c/527657/ - I was trying to fix occasional OpenShift download failures.
14:07:57 <dmellado> still having those 403 issues with openshift?
14:08:00 <dulek> But now downloading the binary takes ~7 minutes and gate times out.
14:08:16 <dulek> I wonder if we're able to extend the timeout?
14:08:35 <dmellado> hmmm I don't think so by default on infra, but I can bring the topic to the infra meeting
14:08:39 <ryuk_apuimedo> dmellado: here I am
14:08:47 <dmellado> maybe we could try some another mirror
14:08:53 <dmellado> chair ryuk_apuimedo
14:08:59 <dmellado> #chair ryuk_apuimedo
14:09:00 <openstack> Current chairs: dmellado dulek leyal ryuk_apuimedo
14:09:01 <ryuk_apuimedo> where are we at?
14:09:09 <dmellado> we were discussing kuryr-kubernetes
14:09:17 <dmellado> and the issues at the gates with the openshift binary download
14:09:45 <dulek> Do we have an alternative mirror? Currently it's downloaded from GitHub.
14:09:55 <dmellado> hmmm then it's bad!
14:10:14 <dmellado> dulek: did you get to check if it's a github issue?
14:10:19 <dmellado> or just an infra one
14:10:21 <ryuk_apuimedo> yes, I know it should ideally only depend on ost infra
14:10:29 <ryuk_apuimedo> but it was already the case with hyperkube
14:10:33 <dmellado> I mean, how long does it take to download from github from your laptop
14:10:37 <dmellado> +-7 minutes too?
14:10:49 <dulek> dmellado: Hm, good question.
14:10:51 <ryuk_apuimedo> can't be that bad
14:11:32 <ryuk_apuimedo> dmellado: it takes 100s
14:11:40 <ryuk_apuimedo> here on my granny's internet
14:11:44 <dmellado> dulek: let's give that a try and if it takes long too
14:11:55 <dmellado> maybe we can ask the ost infra folks to host an internal mirror
14:12:03 <dmellado> that'd solve the timeouts issues for sure
14:12:04 <ryuk_apuimedo> dmellado: that would be ideal
14:12:12 <ryuk_apuimedo> and speed up the testing!
14:12:15 <dulek> dmellado: ~100 seconds on my laptop as well.
14:12:30 <dmellado> dulek: then I'll ad an
14:12:44 <dmellado> #action dmellado to ask for openshift mirror on ost infra
14:12:46 <dmellado> add
14:13:08 <dulek> Okay, so I just wanted to raise that. Besides I have two patches waiting for merge for quite a long time.
14:13:16 <dulek> https://review.openstack.org/#/c/518024/ - daemon containerization.
14:13:28 <dulek> https://review.openstack.org/#/c/509380/ - CNI daemon docs.
14:13:43 <dmellado> dulek: ack, I'll try taking a look at them
14:13:56 <ryuk_apuimedo> dulek: that'll have to wait for irenab to come back from pto (I think she returns on wed)
14:13:57 <dmellado> ryuk_apuimedo: leave the death node and look at them too if you have the time
14:14:12 <dulek> ryuk_apuimedo: Sure thing. :)
14:14:20 <dulek> So that's it from my side. :)
14:14:25 <dmellado> dulek: thanks!
14:14:30 <dmellado> ryuk_apuimedo: how about you?
14:15:06 <ryuk_apuimedo> I've been working on openshift-ansible and other deployment questions
14:15:10 <ryuk_apuimedo> also
14:15:17 <dmellado> regarding to that
14:15:21 <dmellado> as soon as shade is released
14:15:22 <ryuk_apuimedo> I've been checking about keystone
14:15:31 <dmellado> you should be able to use the tag on os_stacks
14:15:37 <ryuk_apuimedo> and what we can do to improve the way we deploy
14:15:47 <ryuk_apuimedo> I want to limit the controller access to neutorn
14:15:49 <ryuk_apuimedo> *neutron
14:15:56 <ryuk_apuimedo> just like we do with our access to k8s
14:16:27 <ryuk_apuimedo> dmellado: how?!
14:16:43 <dmellado> I do have a pull request to ansible
14:16:48 <dmellado> waiting for shade to release
14:16:52 <ryuk_apuimedo> ah!
14:16:57 <ryuk_apuimedo> I was gonna do one now XD
14:16:58 <dmellado> it adds heat tag support
14:17:00 <dmellado> xD
14:17:03 <dmellado> no need xD
14:17:06 <ryuk_apuimedo> I have the file open
14:17:10 <ryuk_apuimedo> please, link to it
14:17:22 <dmellado> I have that local, just waiting for shade
14:17:27 <dmellado> but will put it online
14:17:28 <ryuk_apuimedo> and ping mordre, I think he's the author of the module
14:17:40 <dmellado> nope, but I know who is xD
14:17:47 <dmellado> matbu, a red hatter too
14:18:01 <dmellado> but we need first for shade to release
14:18:10 <dmellado> as the module depends on a shade version
14:18:34 <ryuk_apuimedo> true
14:18:58 <ryuk_apuimedo> btw, I plan on doing a Christmas release of kuryr-kubernetes
14:19:07 <ryuk_apuimedo> If we manage to get both dulek's patches merged
14:19:11 <dmellado> heh, what the codename's gonna be
14:19:13 <dmellado> santa?
14:19:15 <dmellado> xD
14:19:35 <dmellado> now seriously, ping me when you do that as I want to make sure rdo rpm goes smooth
14:19:47 <ryuk_apuimedo> Jack Skellington
14:20:02 <dmellado> and I'd link that to a kuryr-tempest-plugin release too
14:20:03 <ryuk_apuimedo> dmellado: will do!
14:20:31 <ryuk_apuimedo> what else do we have?
14:20:34 <dmellado> so from my side, we got gena and jon working on a few tests
14:20:38 <dmellado> pod to pod testing
14:20:49 <ryuk_apuimedo> did we find out why it works on openshift and not on k8s?
14:20:50 <dmellado> and ports_pool
14:20:56 <dmellado> not yet
14:21:02 <dmellado> but I'll try with a newer k8s version
14:21:16 <ryuk_apuimedo> wasn't 1.9 released this week?
14:21:31 <dmellado> perhaps, IIRC the testing was done with 1.6
14:21:32 <ryuk_apuimedo> or did I imagine it in the internet withdrawal syndrome I suffer?
14:21:35 <dmellado> wasn't it, dulek ?
14:21:47 <dulek> dmellado: Gate got updated to 1.8 recently.
14:21:56 <dmellado> hmmm then we need to check
14:22:13 <gcheresh> dulek: the gate that pass?
14:22:15 <dulek> dmellado: https://review.openstack.org/#/c/525502/
14:22:46 <ryuk_apuimedo> yboaron_: any update?
14:22:49 <dulek> gcheresh: No, gates with OpenShift are passing. I'm talking about K8s gates.
14:23:00 <yboaron_> Please review : https://review.openstack.org/#/c/523900/ - L7 router support and another one - minor documentation update : https://review.openstack.org/#/c/527697/
14:23:02 <ryuk_apuimedo> leyal: I have to review your specs, sorry I didn't get to it
14:23:10 <dulek> dmellado: You can raise the default in the dummy patch to let gate run 1.9.
14:23:21 <dmellado> dulek: yep, let's try that ;)
14:23:23 <leyal> ryuk_apuimedo , thanks :)
14:24:12 <ryuk_apuimedo> leyal: do you have anything else?
14:24:19 <leyal> I also added work items list to the blueprint - https://blueprints.launchpad.net/kuryr-kubernetes/+spec/k8s-network-policies
14:24:42 <leyal> and upload patch for the first one - https://review.openstack.org/#/c/526916/
14:24:42 <ryuk_apuimedo> yboaron_: have you tried octavia in HA?
14:24:54 <yboaron_> no
14:24:58 <ryuk_apuimedo> does the l7 routing work everytime or does it still drop packets?
14:25:17 <yboaron_> still dropping packets like crazy .. ,
14:25:39 <ryuk_apuimedo> yboaron_: do you have some hint of what could it be?
14:25:45 <yboaron_> I'm trying to check in neutron L7 policy in non-kuryr environment
14:25:50 <ryuk_apuimedo> ok
14:26:05 <ryuk_apuimedo> let us know what's the outcome asap
14:26:15 <ryuk_apuimedo> and we can bring it up with the octavia/neutron teams
14:26:17 <yboaron_> sure
14:26:22 <ryuk_apuimedo> thanks yboaron_
14:26:37 <yboaron_> and there's the issue of octavia + ova-firewall
14:26:58 <ryuk_apuimedo> did you bring that up with jlibosva?
14:27:19 * ryuk_apuimedo has a meeting that needs attendance in two minutes, so we'll have to cut short
14:27:26 <yboaron_> manage to reproduce it in octavia  local.conf , trying to debug it wit the help of good friends (jlisboa nd nmagenezi)
14:27:34 <ryuk_apuimedo> perfect
14:27:38 <ryuk_apuimedo> keep us updated!
14:27:43 <yboaron_> NP
14:27:45 <ryuk_apuimedo> Anything before we close the meeting?
14:28:40 <dmellado> ryuk_apuimedo: yep, merry christmas folks xD
14:29:28 <ryuk_apuimedo> thanks!
14:29:29 <leyal> dmellado, and happy Hanukkah :)
14:29:35 <ryuk_apuimedo> leyal: indeed!
14:29:38 <dmellado> leyal: for sure! ;)
14:29:43 <yboaron_> :-)
14:29:48 <ryuk_apuimedo> #endmeeting