14:03:27 <apuimedo> #startmeeting kuryr
14:03:28 <openstack> Meeting started Mon Oct 23 14:03:27 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:31 <openstack> The meeting name has been set to 'kuryr'
14:03:33 <apuimedo> Hello
14:03:39 <apuimedo> who's here today for the kuryr weekly?
14:03:43 <leyal> Hi
14:04:44 <apuimedo> Looks like there's not going to be quorum today
14:04:52 <apuimedo> lots of people in meetings
14:05:34 <leyal> dulek ask about the meeting in the channel..
14:05:43 <dulek> o/
14:06:12 <apuimedo> let's wait a couple minutes to see if anybody else shows up
14:06:30 <hongbin> o/
14:06:36 <apuimedo> dulek: please review https://review.openstack.org/#/c/513715/
14:07:01 <apuimedo> dmellado: ltomasbo: still in the meeting?
14:07:08 <dulek> apuimedo: Tab opened.
14:07:14 <apuimedo> thanks
14:08:30 <apuimedo> Ok, let's get started
14:08:35 <apuimedo> #topic kuryr
14:08:46 <ltomasbo> o/
14:09:09 <apuimedo> #info 0.7.0 release of kuryr-lib has been submitted and is awaiting its second +2 https://review.openstack.org/513069
14:09:14 <ltomasbo> sorry I was late
14:09:17 <apuimedo> hongbin: anything else on kuryr-lib?
14:09:19 <ltomasbo> still on the meeting
14:09:28 <hongbin> apuimedo: nothing else from me
14:09:40 <apuimedo> ok
14:09:45 <apuimedo> #topic kuryr-libnetwork
14:11:26 <apuimedo> hongbin: do you have anything?
14:12:00 <apuimedo> We're still waiting for limao's availability for the VTG session on it
14:12:00 <hongbin> apuimedo: just a comment that i will restart the sriov patch after the kurry-lib release
14:12:09 <apuimedo> hongbin: good
14:12:14 <apuimedo> looking forward to that
14:12:18 <apuimedo> anybody else?
14:12:26 <hongbin> this patch is under review: https://review.openstack.org/#/c/505443/
14:13:08 <apuimedo> nice one
14:13:18 <apuimedo> #action apuimedo to review https://review.openstack.org/#/c/505443/
14:13:48 <hongbin> nothing else from my side
14:13:55 <apuimedo> #topic kuryr-kubernetes
14:14:08 <apuimedo> dulek: update on daemon?
14:14:41 <dulek> Sure. I think I've fixed the problems irenab found.
14:15:16 <dulek> Those were related to usage of BaseHTTPServer with threading and unix socket.
14:15:35 <apuimedo> :/
14:15:51 <dulek> In a perfect world I'd just switch to oslo.service and oslo.service.wsgi and get over it, but turns out eventlet breaks pyroute2.
14:15:54 <apuimedo> we should check out if we can reproduce with a proper wsgi server
14:16:21 <dulek> apuimedo: Any preference on "proper server"?
14:17:27 <apuimedo> well, I was using uwsgi, but apache should work too
14:17:36 <apuimedo> we were using it with flask
14:17:54 <apuimedo> but still, the problem is that for the handlers we need something like oslo service
14:18:05 <apuimedo> dulek: did you try how it behaves with cotyledon?
14:18:11 <apuimedo> IIRC it uses normal thread
14:18:15 <apuimedo> *threads
14:18:45 <dulek> apuimedo: I haven't even looked at it, I've used my energy to try to make pyroute2 work with eventlet. And failed with that.
14:18:51 <dulek> BTW: https://github.com/svinota/pyroute2/issues/431
14:19:30 <dulek> Maybe this cotyledon thing is what we need, I'll look how Octavia uses it.
14:19:41 <apuimedo> dulek: svinota is quite sick of eventlet related breakage, if we don't fix it ourselves, I'm not sure he'll be willing to sink more hours into compat
14:19:49 <apuimedo> thanks dulek
14:19:59 <apuimedo> #action dulek to investigate cotyledon for the daemon
14:20:02 <dulek> My main problem with not using oslo.service is that whole signal handling needs to be written again.
14:20:12 <dulek> And rewriting stuff sucks.
14:20:19 <apuimedo> I thought cotyledon is compatible
14:20:25 <apuimedo> but I may misremember
14:20:39 * apuimedo wishes we could revert to python3 async
14:20:41 <apuimedo> :'()
14:20:43 <apuimedo> :'(
14:21:14 <dulek> apuimedo: It might be, I haven't looked hard at it yet. :)
14:21:52 <apuimedo> ok
14:21:59 <apuimedo> dulek: anything else from your side?
14:22:04 <dulek> Nope!
14:22:07 <apuimedo> okey
14:22:17 <apuimedo> leyal: IIRC you were looking at network policy
14:22:19 <apuimedo> is that right?
14:22:34 <leyal> apuimedo , yes
14:22:41 <apuimedo> leyal: any news?
14:22:52 <apuimedo> Did you check the ovn-kubernetes approach for ideas
14:22:58 <apuimedo> https://github.com/openvswitch/ovn-kubernetes/blob/74d6dfd9a540185d0a0c35a883ed6ee29b2c676d/go-controller/pkg/ovn/policy.go
14:24:01 <leyal> Currently it's i am in the research phase ..
14:24:38 <apuimedo> ok
14:24:52 <apuimedo> leyal: let us know how it goes
14:24:57 <apuimedo> and ping with questions ;-)
14:25:02 <Irena> We had few discussions with leyal, I think we can have some draft proposal by next week
14:25:10 <apuimedo> nice!
14:25:40 <apuimedo> ltomasbo: what about you? Still working on odl related kuryr deployment?
14:26:03 <ltomasbo> yep, I finally manage to install multinode odl, with nested kuryr
14:26:20 <ltomasbo> hit a couple of bug in my way, but not on the kuryr side
14:26:30 <ltomasbo> also, this is ready for reviews: https://review.openstack.org/#/c/510157/
14:26:45 <Irena> Do you deploy with de stack?
14:26:54 <Irena> Devstack
14:26:55 <apuimedo> ltomasbo: you have to walk me through that one
14:27:00 <apuimedo> when you have time
14:27:03 <ltomasbo> Irena, yep
14:27:18 <ltomasbo> apuimedo, the multinode devstack or the patch?
14:27:50 <apuimedo> the patche
14:27:52 <apuimedo> *patch
14:27:56 <Irena> Jenkins is complaining
14:27:59 <ltomasbo> sure!
14:28:09 <ltomasbo> dmellado said we don't care about jenkis
14:28:24 <ltomasbo> I did some rechecks
14:28:42 <ltomasbo> and it is failing randomly, even the pep8 pass in zuul but not in jenkins
14:28:45 <apuimedo> Irena: you can ignore jenkins
14:28:46 <Irena> Will check the patch then
14:28:48 <apuimedo> it's only zuul now
14:29:44 <ltomasbo> apuimedo, I'll ping you tomorrow and we can go through it
14:29:45 <Irena> Did I miss the update on testing?
14:29:55 <apuimedo> Irena: maybe :P
14:30:06 <apuimedo> I think we were' asking the same as you in #openstack-kuryr
14:30:21 <apuimedo> and dmellado said that jenkins does not matter anymore
14:30:37 <Irena> Ok
14:30:56 <Irena> I hope dmellado was not drunk
14:31:18 <ltomasbo> xD
14:31:19 <apuimedo> he had a cold
14:31:26 <apuimedo> no, some flu
14:31:32 <apuimedo> so maybe it's not 100% sure
14:31:34 <apuimedo> :-)
14:31:42 <Irena> :-)
14:31:44 <apuimedo> anything else on kuryr-k8s?
14:31:45 <dulek> Irena: I can find you an openstack-dev post that confirms that. ;)
14:31:52 <ltomasbo> he is here at the office, I'll double check with him later today
14:32:00 <Irena> Thanks
14:32:06 <ltomasbo> ahh, then dulek already knows!
14:33:28 <apuimedo> #info Please ignore jenkins on kuryr-k8s. Only zuul matters now
14:33:30 <apuimedo> there
14:33:32 <apuimedo> settled
14:33:34 <apuimedo> :-)
14:33:36 <apuimedo> #topic general
14:33:43 <apuimedo> Does anybody have anything else?
14:33:50 <Irena> What about kuryr tests? Any updates on this?
14:34:02 <apuimedo> Irena: not without dmellado on the meeting :(
14:34:36 <dulek> Irena: http://lists.openstack.org/pipermail/openstack-dev/2017-October/123643.html - found it! :)
14:34:54 <Irena> Ok, we can sync n the channel one dmellado is back
14:35:01 <dulek> "There is no Jenkins, only Zuul." - sounds serious. ;)
14:35:18 <Irena> dukes:thanks!
14:35:56 <Irena> Autocomplete kills me...
14:36:14 <apuimedo> dulek: that's a Ghostbuster's reference IIRC
14:36:38 <apuimedo> https://www.youtube.com/watch?v=lg7MAacSPNM
14:36:56 <dulek> apuimedo: Niiiice!
14:37:36 * janonymous got late
14:37:39 <apuimedo> :-)
14:37:54 <apuimedo> janonymous: anything to report before we close the meeting?
14:38:05 <janonymous> nopes :D
14:38:34 <apuimedo> alright
14:38:38 <apuimedo> THank you all for joining
14:38:40 <apuimedo> !
14:38:42 <apuimedo> #endmeeting