#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:01:47 UTC (full logs).

Meeting summary

  1. kuryr-lib (apuimedo, 14:04:01)
    1. Last week we released kuryr-lib 0.6.0. It is an independent release (apuimedo, 14:04:22)

  2. kuryr-libnetwork (apuimedo, 14:07:57)
    1. only requirements updates https://review.openstack.org/#/c/495184/3 (apuimedo, 14:09:09)
    2. ACTION: kuryr-libnetwork to be changed to cycle with intermediaries (apuimedo, 14:16:54)

  3. fuxi (apuimedo, 14:17:09)
    1. https://review.openstack.org/#/q/project:openstack/fuxi-kubernetes+and+status:open (hongbin, 14:17:59)

  4. kuryr-kubernetes (apuimedo, 14:19:56)
    1. ltomasbo got in a couple of port pool fixes that help with non ml2/ovs (apuimedo, 14:20:24)
    2. OpenDaylight LB is confirmed to work with kuryr-kubernetes (apuimedo, 14:21:11)
    3. Kuryr-kubernetes + legacy neutron-lbaasv2 works. Octavia lbaas will need layer2 support in kuryr-kubernetes. Native ODL lbaas needs more work as well (apuimedo, 14:23:33)
    4. I've started work on OpenShift support in devstack. The idea is to then gate with both k8s and devstack (apuimedo, 14:26:37)
    5. I've started work on OpenShift support in devstack. The idea is to then gate with both k8s and openshift (apuimedo, 14:27:02)
    6. yboaron posted a patch for loadbalancer service type support https://review.openstack.org/#/c/498253/ (apuimedo, 14:28:05)

  5. generalalright (apuimedo, 14:36:13)
  6. general (apuimedo, 14:36:21)


Meeting ended at 14:39:30 UTC (full logs).

Action items

  1. kuryr-libnetwork to be changed to cycle with intermediaries


People present (lines said)

  1. apuimedo (59)
  2. hongbin (12)
  3. dmellado (10)
  4. ltomasbo (8)
  5. janonymous (5)
  6. openstack (4)
  7. ivc (3)
  8. irenab (1)


Generated by MeetBot 0.1.4.