14:03:12 <apuimedo> #startmeeting kuryr
14:03:13 <openstack> Meeting started Mon Aug 21 14:03:12 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:17 <openstack> The meeting name has been set to 'kuryr'
14:03:44 <kzaitsev_ws> o/
14:03:52 <dmellado> Hi everyone ;)
14:04:06 <apuimedo> Hi all
14:04:13 <apuimedo> #topic kuryr-libnetwork
14:04:14 <zengchen> hi, apuimedo
14:04:24 <irenab> hi
14:05:02 <apuimedo> I think we have all that's needed to send a release patch for kuryr-libnetwork
14:05:29 <apuimedo> the gate is working again
14:05:51 <apuimedo> #action apuimedo to send kuryr-libnetwork release patch
14:06:02 <apuimedo> anything else on kuryr-libnetwork?
14:07:23 <apuimedo> and it seems we should also do for kuryr-lib
14:07:32 <apuimedo> to bump the keystoneauth requirements
14:07:45 <apuimedo> #action apuimedo to make a new kuryr-lib release
14:07:55 <janonymous> o/
14:08:08 <apuimedo> #topic fuxi
14:08:22 <apuimedo> #chair zengchen
14:08:22 <openstack> Current chairs: apuimedo zengchen
14:08:29 <apuimedo> go ahead zengchen
14:09:57 <zengchen> i have updae the patches about flex volume driver
14:10:20 <zengchen> apuimedo:could you please merge them?
14:11:12 <zengchen> https://review.openstack.org/#/c/476839/
14:11:19 <zengchen> https://review.openstack.org/#/c/476863
14:11:26 <zengchen> https://review.openstack.org/#/c/476312
14:11:58 <apuimedo> zengchen: checking
14:12:16 <zengchen> i also update the design and implementation of watch framework. please take a look at it. thanks.
14:12:32 <zengchen> apuimedo:thanks
14:12:56 <irenab> apuimedo, I can take a look tomorrow too
14:13:09 <zengchen> i will continue to work on the implementation of provisioner
14:13:21 <zengchen> irenab:thanks
14:13:36 <apuimedo> irenab: I'll give my +2 if it looks okay, feel free to merge them
14:13:44 <irenab> ok
14:13:50 <zengchen> great
14:14:47 <zengchen> apuimedo:that's all from my side.
14:15:01 <apuimedo> thanks zengchen!
14:15:05 <apuimedo> #topic kuryr-kubernetes
14:15:23 <apuimedo> #info kuryr-kubernetes 0.2.0 was just released
14:15:37 <apuimedo> and there's a stable/pike branch for it
14:16:00 <dmellado> RDO branches should be ok as well
14:16:05 <apuimedo> unfortunately, I had missed the global requirements bump on kuryr-lib that brought the new kuryr-lib
14:16:12 <dmellado> now rdo master follows queens-queens-uc
14:16:12 <apuimedo> sorry
14:16:16 <apuimedo> the new keystonauth
14:16:28 <apuimedo> so it seems I'll have to cut a release for kuryr-lib,
14:16:34 <apuimedo> then wait for the proposal bot
14:16:47 <apuimedo> and backport the darned patch
14:16:55 <apuimedo> and cut 0.2.1
14:17:00 <dmellado> heh
14:20:17 <irenab> apuimedo, something else if on agenda?
14:20:23 <irenab> s/if/is
14:20:26 <apuimedo> mmm
14:20:59 <apuimedo> well, now that the release is past, I want to get the containerized devstack support so that we can merge vikasc related patches
14:21:10 <apuimedo> that will probably mean a 0.3.0
14:21:19 <apuimedo> the multi-vif will mean a 1.0.0
14:21:35 <apuimedo> and cni split should be there before 1.0.0
14:21:38 <apuimedo> no time to stop
14:21:41 <dmellado> apuimedo: is there a roadmap with the releases/features?
14:22:01 <apuimedo> dmellado: yes, but you need to do me a CT
14:22:15 <dmellado> CT?
14:22:26 <irenab> MRI?
14:22:40 <apuimedo> dmellado: tomografia axial computerizada
14:22:46 <apuimedo> irenab: something similar
14:22:48 <apuimedo> xD
14:22:50 <dmellado> lol
14:23:16 <irenab> apuimedo, safer to ask you to put it on kuryr wiki
14:23:30 <apuimedo> yes, less radioactive too
14:24:17 <apuimedo> irenab: dmellado: the queens slide on irenab's presentation in boston is a good guide
14:24:31 <apuimedo> we want to do both policy and ingress controllers
14:24:43 <apuimedo> and multi networks
14:24:46 <apuimedo> it is a tall order
14:24:48 <apuimedo> a lot of work
14:24:56 <apuimedo> and it needs scenario testing asap
14:25:01 <irenab> we probably need to add LoadBalancer service type support too
14:25:24 <irenab> + external service IP for clusterIP type
14:25:41 <apuimedo> irenab: oh, yes
14:25:55 <apuimedo> I consider that a given since yboaron has it more or less working
14:26:02 <apuimedo> I expect him to push a wip patch today
14:26:23 <irenab> nice, didn't know
14:26:24 <apuimedo> after that, externalIP should also be supported
14:26:37 <apuimedo> dmellado: oh, and IPv6 scenario gates
14:26:43 <dmellado> heh
14:26:59 <dmellado> irenab: apuimedo wouldn't you have a link handy for irenab 's presentation?
14:27:09 <irenab> let me check
14:27:09 <dmellado> otherwise I'll look for it, so no worries
14:27:43 <irenab> https://www.openstack.org/videos/boston-2017/project-update-kuryr
14:27:49 <irenab> will have to check for slides
14:27:52 <dmellado> awesome, thanks irenab
14:27:57 <apuimedo> dmellado: https://docs.google.com/presentation/d/19mlrlzYk3n_pUsL8WOXpYLNzJ0IqBAA2OmqsNakvrcY/edit?usp=sharing
14:28:02 <dmellado> ack
14:28:07 <apuimedo> in case you prefer not to hear my voice
14:28:15 <dmellado> lol
14:28:19 <dmellado> much appreciated
14:28:24 <irenab> https://www.slideshare.net/celebdor/openstack-boston-summit-kuryr-project-updates
14:28:25 <apuimedo> Octavia support made it into Pike surprisignly
14:28:48 <dmellado> btw, octavia gate should be operational as soon as a few patches land
14:28:56 <irenab> I am checking if deployment with DF + Octavia works properly
14:29:11 <apuimedo> IPv6 was not on the roadmap but I felt like adding it anyway :P
14:29:17 <dmellado> irenab: apuimedo
14:29:19 <dmellado> https://review.openstack.org/#/c/487928/
14:29:26 <apuimedo> #link https://review.openstack.org/#/c/487928/
14:29:26 <dmellado> https://review.openstack.org/#/c/495744/
14:29:27 <irenab> dmellado, we probably need to enable tests for different gates
14:29:36 <apuimedo> #link https://review.openstack.org/#/c/495744/
14:30:03 <dmellado> yep,  I do plan to engage into that at the PTG alongside infra and qa guys
14:30:14 <irenab> cool
14:30:26 <irenab> dmellado, good job
14:30:36 <dmellado> \o/
14:30:55 <apuimedo> but I repeat. Top priority for tempest test writing
14:31:09 <dmellado> +1. that's my idea at the PTG
14:31:11 <apuimedo> I know it is a chore. But we should all write one
14:31:26 <dmellado> apuimedo: do you know when are we having our 'new folks' starting?
14:31:32 <apuimedo> dmellado: could you maybe describe the easiest flow to develop that?
14:31:39 <apuimedo> dmellado: september
14:31:47 <dmellado> I'll put up a section on the wiki for kuryr
14:31:58 <apuimedo> thanks dmellado
14:32:24 <apuimedo> #action dmellado to put tempest test writing section for kuryr in the wiki
14:33:46 <apuimedo> anything else anybody?
14:34:41 <dmellado> let's call it a day so I can go to the beach, it's hot here today so I started waaay early xD
14:35:37 <irenab> dmellado, beach in Madrid?
14:35:58 <apuimedo> irenab: all of Spain's coast belongs to Madrid
14:36:00 <dmellado> irenab: I'm off Madrid for a while
14:36:02 <dmellado> xD
14:36:05 <apuimedo> now he's in the north-west one
14:36:17 <irenab> :-)
14:36:50 <apuimedo> alright then
14:36:57 <apuimedo> thank you all for joining
14:36:59 <apuimedo> #endmeeting