14:01:53 <apuimedo> #startmeeting kuryr
14:01:54 <openstack> Meeting started Mon Apr 17 14:01:53 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:57 <openstack> The meeting name has been set to 'kuryr'
14:02:20 <apuimedo> Hello Kuryrs! Welcome to the weekly irc meeting
14:02:23 <dmellado> o/ apuimedo I thought you'd cancel today xD
14:02:25 <apuimedo> who's here today?
14:02:33 <limao> o/
14:02:35 <apuimedo> dmellado: I just finished stuffing myself
14:02:39 <alraddarla> o/
14:02:50 <apuimedo> taking the meeting before the traditional chocolate cakes
14:02:51 <yedongcan> o/
14:02:54 <apuimedo> :-)
14:03:00 <dmellado> how was easter (well, technically still is)
14:03:08 <dmellado> oh, chocolate cake! I forgot to buy this year
14:03:15 <dmellado> not as much as a tradition here in Mordor
14:04:11 <apuimedo> :-)
14:04:21 <apuimedo> Easter is good
14:04:23 <ivc-> o/
14:04:24 <apuimedo> but too stuffing
14:04:27 <apuimedo> Alright. Let's get started
14:04:34 <apuimedo> thank you all for joining
14:04:40 <apuimedo> #topic kuryr-libnetwork
14:04:49 <apuimedo> kzaitsev_ws: are you here?
14:05:27 <hongbin> o/
14:06:10 <apuimedo> limao: how is the fix on the rally tests?
14:06:37 <limao> apuimedo: https://review.openstack.org/#/c/457070/
14:07:15 <apuimedo> cool
14:07:16 <limao> This need to be merged first in project-config, I see some error log related nova, which we did not enable it in rally test.
14:07:21 * dmellado adding that to his review queue
14:07:27 <apuimedo> this one went completely under my radar
14:08:12 <apuimedo> limao: looks good to me
14:08:21 <limao> for plugin v2, https://review.openstack.org/#/c/449038/ and https://review.openstack.org/#/c/451479/ is ready for review, please feel free to add your comments
14:08:33 <apuimedo> IIUC, with the change you did, now we get all the default ones PLUS the kuryr-libnetwork related ones
14:08:43 <apuimedo> limao: let's take a look
14:08:52 <dmellado> limao: LGTM
14:09:18 <apuimedo> limao: right. I forgot to ask you on IRC last time
14:09:19 <limao> and kuryr/kuryr-libnetwork-v2plugin has not been created yet in docker hub, if you want to have a try, you can use limao/kuryr-libnetwork-v2plugin for test. I uploaded one test v2plugin with latest master kuryr code.
14:09:27 <apuimedo> what is this rootfs requirement
14:09:29 <apuimedo> ?
14:10:13 <limao> apuimedo: rootfs is needed by pluginv2, if you want to build a pluginv2, you must build rootfs first
14:10:18 <dmellado> yeah, read that too about limao/kuryr-libnetwork-v2plugin
14:10:29 <apuimedo> limao: right
14:10:36 <dmellado> who can create the 'official' one in dockerhub? (maybe you, apuimedo ?)
14:10:40 <apuimedo> limao: did you check with infra about pushing the image?
14:10:44 <apuimedo> I can create it
14:10:54 <apuimedo> but we need something that pushes to it
14:11:03 <apuimedo> either infra
14:11:07 <apuimedo> job
14:11:27 <dmellado> heh, I see
14:11:35 <limao> apuimedo : this is a doc about plugin v2 :https://docs.docker.com/engine/extend/
14:12:00 <limao> apuimedo: for the job, I'm checking the kolla job in project-config
14:12:11 <apuimedo> I see
14:12:13 <apuimedo> thanks
14:12:14 <dmellado> limao: you meant docker build -t rootfsimage .
14:12:18 <dmellado> for rootfs, I guess
14:12:39 <apuimedo> limao: kolla use docker build, push a tarball and then it is used by the other jobs
14:12:45 <apuimedo> that is an option
14:12:58 <limao> dmellado: Yeah, in the doc has detail info ;-)
14:13:01 <apuimedo> I would hope to be able to push to dockerhub as well when we publish tags though
14:13:22 <dmellado> does kolla publish to dockerhub as well?
14:13:55 <apuimedo> dmellado: they do. But I don't remember how
14:14:01 <apuimedo> if they have it external or internal
14:14:14 <apuimedo> they went back and forth on the approach and I do not remember how it settled
14:14:39 <limao> apuimedo : when I check the code, I thought kolla use this kind of job to upload the imange name: 'kolla-dsvm-build-{distro}-{type}-{node}{suffix}'
14:14:50 <limao> (I'm not sure if my understanding is right)
14:15:20 <apuimedo> AFAIR these build jobs are for the tarballs
14:15:29 <apuimedo> that are then used for the other jobs
14:15:50 <limao> publishers:
14:15:51 <limao> - devstack-logs
14:15:51 <limao> - scp:
14:15:52 <limao> site: 'tarballs.openstack.org'
14:15:54 <limao> files:
14:15:56 <limao> - source: 'images/*.tar.gz'
14:15:58 <limao> target: 'tarballs/kolla/images/'
14:16:00 <limao> - console-log
14:16:11 <dmellado> yep, looks like a tarball thingy
14:16:15 <apuimedo> right
14:17:07 <apuimedo> limao: I'll ask the kolla folks tomorrow
14:17:17 <limao> apuimedo: Thanks for help
14:17:20 <dmellado> grepping doesn't sort out any hint on project.config
14:17:24 <apuimedo> #action apuimedo to get info about the publishing
14:17:34 <apuimedo> #action apuimedo to create the dockerhub kuryr-libnetwork project
14:17:48 <apuimedo> dmellado: It's likely external
14:17:52 <apuimedo> like I used to have
14:17:54 <limao> apuimedo: another thing is about docker swarm mode
14:17:55 <dmellado> "action apuimedo to share chocolate cake with dmellado"
14:18:03 <dmellado> xD
14:18:07 <limao> The process of create network in swarm mode is different with non-swarm mode. Network UUID lenth of Swarm mode is 26, it was 64 in non-swarm mode. Swarm network are lazily created on the node once the first task/container is started there. At swarm network creation, the pool allocation, from the IPAM driver's default global address space will be done by the swarm allocator.(NetworkAllocate) When the network will be created on the nod
14:18:07 <limao> e, the pool allocation will be requested on the node from the IPAM driver's default local address space. (For detail : https://github.com/docker/docker/issues/32604)
14:18:09 <apuimedo> dmellado: take the train
14:18:09 <dmellado> apuimedo: it'll probably be
14:18:24 <dmellado> apuimedo: I might do that shortly, I'll let you know
14:18:33 <hongbin> apuimedo: would appreciate if you can create the dockerhub for fuxi as well :)
14:18:38 <apuimedo> limao: how are they lazily created?
14:18:57 <apuimedo> by the daemon checking in the store?
14:19:37 <limao> apuimedo: when the docker container schedule to the host, it call libnetwork api
14:19:59 <dmellado> #action apuimedo to create the dockerhub fuxi project
14:20:03 <dmellado> hongbin: ^^ ;)
14:20:05 <limao> There is a sample in https://github.com/docker/docker/issues/32604
14:21:27 <apuimedo> dmellado: so kuryr/fuxi you mean?
14:21:31 <apuimedo> fine with me
14:21:34 <hongbin> +1
14:21:36 <apuimedo> :-)
14:22:06 <dmellado> apuimedo: yep, I was lazy too so I assumed that you'd bash-complete that
14:22:08 <dmellado> xD
14:22:12 <apuimedo> limao: will it be called for each node?
14:22:54 <limao> When the container be scheduled to a host, it will call IpamDriver.RequestAddress and IpamDriver.RequestPool
14:23:35 <limao> In our currently code, IpamDriver.RequestPool can't be called twice
14:23:41 <apuimedo> so request pool will be called per node
14:23:53 <apuimedo> limao: do we have a bug reported?
14:24:07 <apuimedo> sorry if I missed it. PTO has kept me afk
14:24:20 <limao> https://launchpad.net/bugs/1668486
14:24:21 <openstack> Launchpad bug 1668486 in kuryr-libnetwork "We can only create kuryr local network in docker swarm 1.13" [High,In progress] - Assigned to Liping Mao (limao)
14:24:27 <limao> I added comments in this bug
14:24:27 <apuimedo> thanks
14:24:35 <limao> if we need a seperate bug, I can do it
14:24:45 <apuimedo> I leave it open to check it first thing in the morning tomorrow
14:24:49 <apuimedo> thanks limao
14:24:54 <apuimedo> anythin else on kuryr-libnetwork?
14:25:10 <limao> thanks, apuimedo, nothing from me about kuryr-libentwork
14:25:21 <apuimedo> thanks a lot for all the v2 work limao!
14:25:30 <apuimedo> #topic fuxi
14:25:35 <apuimedo> #chair hongbin
14:25:35 <openstack> Current chairs: apuimedo hongbin
14:25:38 <apuimedo> go ahead hongbin
14:25:41 <hongbin> hi
14:25:57 <hongbin> last week, a spec for fuxi kubernetes was submitted
14:26:05 <hongbin> #link https://review.openstack.org/#/c/452554/
14:26:11 <apuimedo> OH!
14:26:17 <hongbin> i think it is ready for review at this version
14:26:32 <apuimedo> I see irenab has been reviewing it already
14:26:33 <apuimedo> good!
14:26:43 <dmellado> I'll review it too, another one for the queue
14:26:44 <hongbin> yes
14:27:05 <hongbin> besides that, there is another patch for optimizing the performance of fuxi
14:27:11 <hongbin> #link https://review.openstack.org/#/c/454656/
14:27:26 <hongbin> two patches are both in wip, so would appreciate feedback from reviewers :)
14:27:29 <apuimedo> hongbin: is there a bp for the spec?
14:27:48 <hongbin> apuimedo: https://blueprints.launchpad.net/kuryr-kubernetes/+spec/fuxi-kubernetes
14:27:51 <dmellado> https://blueprints.launchpad.net/openstack/?searchtext=fuxi-kubernetes
14:27:52 <apuimedo> it would be good to have it, and reference it on the spec and subsequent patches
14:27:58 <dmellado> apuimedo: it's mentioned in the review
14:28:01 <apuimedo> so that we can track it better
14:28:11 <hongbin> agree
14:28:11 <apuimedo> ah right
14:28:17 <apuimedo> irenab never misses that
14:28:19 <apuimedo> :-)
14:28:27 <hongbin> apuimedo: that is all from my side
14:29:00 <apuimedo> hongbin: I see it failed for dragonflow, somebody should reach to oanson about that
14:29:01 <apuimedo> :-)
14:29:12 <apuimedo> or likely irenab
14:29:28 <hongbin> couldn't imagine a doc change fail the gate :)
14:29:50 <hongbin> apuimedo: sure, i will fix that
14:29:51 <apuimedo> limao: please, take a look at https://review.openstack.org/#/c/454656/ too
14:30:06 <apuimedo> anything else on fuxi?
14:30:23 <apuimedo> #action apuimedo to review the fuxi-k8s spec
14:30:55 <hongbin> apuimedo: it seems nothing else
14:31:37 * dmellado thinking about recheck
14:31:47 <dmellado> documentation changes breaking the gate is odd
14:32:02 <hongbin> dmellado: done
14:32:24 <apuimedo> very well
14:32:40 <apuimedo> dmellado: this gate can be broken at the dragonflow master side
14:32:42 <apuimedo> :-)
14:32:55 <apuimedo> it's fragile that way
14:33:00 <apuimedo> #topic kuryr-kubernetes
14:33:58 <apuimedo> #info merging https://review.openstack.org/#/c/376045/23
14:34:16 <apuimedo> So we finally have k8s cluster type service support!
14:34:37 <apuimedo> thanks to all for the reviews and specially to ivc- for the hard work
14:34:42 <ivc-> apuimedo finally
14:34:51 <ivc-> XD
14:35:17 <apuimedo> ivc-: brought by the easter bunny
14:35:22 <dmellado> heh
14:35:26 <dmellado> congrats! xD
14:35:42 <ivc-> heh ty
14:36:37 <apuimedo> #info guru reports being added too https://review.openstack.org/#/c/447942/5
14:36:40 <apuimedo> thanks janonymous!
14:37:24 <apuimedo> ivc-: I suppose easter kept you busy in other endeavors, but just in case? Any actor related update?
14:38:04 <janonymous> o/ sry got late
14:38:30 <apuimedo> :-)
14:39:35 <ivc-> apuimedo actors might be too big of a bite for now. but maybe we can do the driver/handler loading part with few changes to the current architecture
14:40:39 <apuimedo> ivc-: looking forward to discussing that
14:40:41 <apuimedo> :-)
14:40:48 <apuimedo> I'll ping you tomorrow
14:40:59 <dmellado> apuimedo: you're making me recall akka and some scary folks
14:41:05 <ivc-> we need a videoconf brainstorm imo
14:41:09 <dmellado> +1 on that
14:41:11 <apuimedo> dmellado: right
14:41:27 <apuimedo> ivc-: I propose this wednesday then
14:41:31 <apuimedo> does that work?
14:41:40 <ivc-> dmellado what i had in mind was pretty much like akka :)
14:41:53 <dmellado> ivc-: :D
14:41:55 <dmellado> wed what time?
14:42:29 <apuimedo> same time as this meeting
14:42:34 <apuimedo> was what I wanted to propose
14:42:45 <dmellado> can we make it 1 hour earlier or 1 after?
14:42:57 <ivc-> apuimedo i have a conflicting meeting. 1 hour earlier would work for me
14:43:00 <dmellado> it might collide with another upstream meeting where I'm supposed to be
14:43:18 <dmellado> +1 earlier works for me too
14:43:43 <apuimedo> 1 earlier
14:43:45 <apuimedo> ?
14:43:48 <apuimedo> alright
14:43:57 <ivc-> irenab kzaitsev_ws ok with that?
14:44:09 <apuimedo> #action apuimedo to send meeting invite for 13utc this wednesday
14:44:21 <apuimedo> ivc-: I'll ping them both in the morning to check with them
14:44:29 <apuimedo> anything else on kuryr-kubernetes?
14:47:09 <apuimedo> alright then.
14:47:13 <apuimedo> #topic general
14:47:33 <apuimedo> We've been ask about joining storyboard (moving from launchpad)
14:47:39 <apuimedo> I'm in favor of such move
14:47:47 <apuimedo> I'd like to hear what others think about it
14:47:56 <apuimedo> since it is a big change that affects everybody
14:48:07 <apuimedo> I'll post to the mailing list too
14:48:12 <dmellado> I haven't really used storyboard, any summary on your arguments in favor from launchpad?
14:49:31 <apuimedo> dmellado: I'll try to bring that sort of info to the mailing list post
14:49:36 <apuimedo> I'm not ready to sell it yet
14:49:38 <apuimedo> :-)
14:49:39 <dmellado> lol
14:49:42 <dmellado> I'll wait for it then
14:51:10 <apuimedo> :-)
14:51:20 <apuimedo> anything else before we close?
14:52:46 <apuimedo> very well
14:52:49 <apuimedo> #endmeeting