14:03:53 <apuimedo> #startmeeting kuryr
14:03:53 <openstack> Meeting started Mon Apr  3 14:03:53 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:57 <openstack> The meeting name has been set to 'kuryr'
14:03:58 <apuimedo> Hello Kuryrs!
14:04:02 <apuimedo> Welcome to the weekly meeting
14:04:05 <ltomasbo> o/
14:04:06 <apuimedo> who's here for the show?
14:04:07 <vikasc> o/
14:04:08 <mchiappero> o/
14:04:08 <ivc_> o/
14:04:11 <alraddarla> o/
14:04:32 <hongbin> o/
14:05:11 <limao> 0/
14:05:29 <apuimedo> Hi all
14:05:35 <apuimedo> let's get this started
14:05:42 <apuimedo> #topic fuxi
14:05:48 <apuimedo> #chair hongbin
14:05:48 <openstack> Current chairs: apuimedo hongbin
14:05:54 <hongbin> hi
14:06:06 <garyloug> o/
14:06:10 <hongbin> last week, i uploaded a draft for the fuxi-kubernetes spec
14:06:17 <hongbin> #link https://review.openstack.org/#/c/452554/
14:06:28 <hongbin> will continue to work on that and reviews are welcome
14:06:54 <hongbin> that is for k8s, for the fuxi server side, these patches need reviews
14:07:10 <hongbin> https://review.openstack.org/#/c/449833/ https://review.openstack.org/#/c/450547/
14:07:17 <apuimedo> hongbin: would you mind to have a placeholder bp linked to the spec?
14:07:56 <hongbin> apuimedo: this one? https://blueprints.launchpad.net/kuryr-kubernetes/+spec/fuxi-kubernetes
14:08:17 <apuimedo> right, put a link to it in the commit message
14:08:22 <hongbin> sure
14:08:30 <dmellado> hi o/
14:08:32 <hongbin> will do that in the next revision
14:08:33 <apuimedo> #action limao vikasc apuimedo to review https://review.openstack.org/#/c/449833/ https://review.openstack.org/#/c/450547/
14:08:33 <dmellado> sorry I'm late
14:08:35 <dmellado> xD
14:08:49 <apuimedo> #action apuimedo vikasc ivc_ to review https://review.openstack.org/#/c/452554/
14:08:54 <apuimedo> thanks hongbin
14:08:55 <hongbin> this one as well: https://review.openstack.org/#/c/447823/
14:09:00 <hongbin> welcome
14:09:19 <ivc_> vikasc i've answered your -1 comment
14:09:33 <apuimedo> ivc_: you're skipping section!
14:09:34 <apuimedo> :P
14:09:34 <ivc_> oh, wrong topic
14:09:47 <apuimedo> no worries
14:10:01 <hongbin> i think this topic is finished :)
14:10:02 <vikasc> ivc_, thanks Ilya, will take a look. and i am in mid of preparing local setup to try this patch as well.
14:10:42 <apuimedo> #topic kuryr
14:10:57 <apuimedo> We should merge this https://review.openstack.org/#/c/451019/1
14:11:21 <apuimedo> anybody's got anything else on kuryr-lib?
14:11:41 <dmellado> +1 on the global-reqs
14:12:08 <apuimedo> thanks vikasc and limao_
14:12:13 <apuimedo> #topic kuryr-libnetwork
14:12:36 <vikasc> apuimedo, yw!
14:13:40 <apuimedo> Same thing for https://review.openstack.org/#/c/451020/
14:13:45 <dmellado> apuimedo: so you don't thank me, heh
14:13:47 <dmellado> I'll get sad
14:13:49 <dmellado> xD
14:13:55 <apuimedo> limao_: vikasc ^^
14:14:05 <apuimedo> dmellado: thank you :-)
14:14:13 <dmellado> now it's too late
14:14:14 <apuimedo> I was only looking at the +2 :P
14:14:15 <dmellado> xD
14:14:19 <hongbin> btw, fuxi has the same thing: https://review.openstack.org/#/c/431085/
14:14:29 <apuimedo> let's merge that then as well
14:14:44 <dmellado> we should make a bot for auto +2+A those patches xD
14:14:56 <apuimedo> dmellado: we hold them before release
14:15:16 <apuimedo> hongbin: btw, did the fuxi subteam consider when it wants to cut a release?
14:15:27 <apuimedo> Probably once manila is working and with fullstack?
14:15:48 <hongbin> apuimedo: sure, i have no problem for that
14:15:58 * dmellado recalls that would need to check what's going on with manila and its tempest plugin...
14:16:28 <apuimedo> :-)
14:16:35 <apuimedo> alright, back to the patches
14:17:05 <apuimedo> limao_: what does https://review.openstack.org/#/c/451479/ need to get out of WIP, should we review already?
14:18:26 <limao_> apuimedo: I just want to discuss it in this meeting, when I write doc, I think we'd better to have an official v2plugin docker hub
14:18:35 <dmellado> limao_: there's a nit typo
14:18:37 <dmellado> just -1'ed it
14:18:39 <dmellado> ;)
14:18:53 <apuimedo> limao_: I agree
14:18:53 <limao_> dmellado: sure, thanks
14:19:05 <apuimedo> IIRC I own the dockerhub kuryr project name
14:19:17 <apuimedo> the question is about building
14:19:29 <apuimedo> either we do it ad-hoc like we used to
14:19:44 <apuimedo> or we get a job in infra to push it
14:19:53 <apuimedo> I think kolla already push containers
14:19:56 <dmellado> a job in infra would be nice and cleaner
14:19:58 <apuimedo> we should check how they do it
14:20:04 <apuimedo> dmellado: it didn't use to be possible
14:20:13 <apuimedo> hopefully it will have changed
14:20:17 <apuimedo> have you checked, limao_ ?
14:20:45 <limao_> apuimedo: I have not checked how kolla do it right now, let me check it this week
14:21:07 <apuimedo> thanks limao_
14:21:28 <limao_> apuimedo: https://review.openstack.org/#/c/449038/
14:21:28 <apuimedo> #action limao_ to check how kolla publish the containers to see if we can do it for the v2 plugin support
14:21:53 <limao_> This is used to build the rootfs for v2plugin
14:22:17 <limao_> I think it is ready for review
14:23:11 <apuimedo> very well
14:23:15 <apuimedo> I'll review today
14:23:28 <limao_> to support swarm mode, we need also support AllocateNetwork and FreeNetwork  (  https://review.openstack.org/#/c/451475/ ), these two api is missed in libnetwork document (https://github.com/docker/libnetwork/issues/1699)
14:23:37 <apuimedo> I suppose it needs https://review.openstack.org/#/c/451475/
14:23:47 <apuimedo> ah, right, I was searching for the same
14:23:54 <apuimedo> vikasc: please review as well
14:24:16 <vikasc> apuimedo, sure, adding myself as reviewer
14:24:26 <apuimedo> thanks
14:24:28 <limao_> Another problem is v2plugin can't work right now, because in swarm mode, when ipam driver request ip for gateway , it will not pass options (https://github.com/docker/libnetwork/issues/1702)
14:24:52 <limao_> It looks like  just fixed in master code, but has not released in swarmkit
14:25:46 <apuimedo> limao_: which options are we dependant on?
14:26:05 <limao_> apuimedo: {"RequestAddressType": "com.docker.network.gateway"}
14:26:23 <apuimedo> aha
14:26:23 <limao_> we have logic in request address to check if it is gateway ip address
14:26:27 <apuimedo> so it really is a bug
14:26:31 <apuimedo> yes, I remember now
14:26:43 <apuimedo> limao_: I think we should probably ask them for a backport
14:26:56 <limao_> apuimedo: Yes, I create a issue in libnetwork
14:27:15 <apuimedo> thanks
14:27:28 <limao_> apuimedo: they fixed it 4 days ago, let me update the issue to see if they can backport it
14:27:54 <hongbin> i wonder if it is feasible to setup the gate for testing the swarm mode (as long as all the problems are fixed in docker side)
14:28:23 <apuimedo> very well. thanks limao_
14:28:45 <apuimedo> hongbin: it should. with zuul v2 you can get two nodes for a gate
14:28:48 <limao_> hongbin: Yes, we should have gate to test it, after v2plugin can works ;-)
14:28:53 <apuimedo> dmellado: for v3 you can get even more, right?
14:29:12 <hongbin> the problem can only be re-produced in two nodes?
14:29:19 <dmellado> apuimedo: you mean zuul?
14:29:48 <apuimedo> yeah
14:29:58 <dmellado> IIRC yeah, but I'll double check
14:30:09 <hongbin> limao_: ack
14:30:13 <apuimedo> hongbin: well, swarm mode is better tested in two nodes, I'd say
14:30:15 <dmellado> limao_: I can sync w/you if you'll be taking a look too
14:30:22 <limao_> hongbin: I did not tried in one node, I use two for test right now. let me double check, but if we are using swarm mode, we'd better to have two nodes.
14:30:36 <hongbin> i see
14:30:47 <limao_> dmellado: sure thanks
14:31:28 <apuimedo> limao_: what is the rootfs part of https://review.openstack.org/#/c/451475/ for?
14:31:33 <limao_> nothing else about v2plugin from me
14:31:45 <limao_> apuimedo: this is for v2plugin
14:32:00 <apuimedo> I don't see it being used
14:32:04 <apuimedo> is it some convention?
14:32:05 <limao_> apuimedo: when you build v2plugin you need to build a rootfs
14:32:21 <limao_> apuimedo: let me find the link
14:32:43 <apuimedo> ok, thanks!
14:33:07 <apuimedo> anything else on kuryr-libnetwork?
14:34:16 <limao_> apuimedo : some background https://docs.docker.com/engine/extend
14:35:07 <limao_> apuimedo: nothing from me about libnetwork, thanks
14:35:07 <apuimedo> thanks limao_ !
14:35:48 <apuimedo> #topic kuryr-kubernetes
14:37:19 <apuimedo> the biggest item is of course https://review.openstack.org/#/c/376045/
14:37:32 <apuimedo> which is the last thing before we release 0.1.0
14:38:12 <mchiappero> when is the release going to happen?
14:38:17 <apuimedo> vikasc: I think ivc_ is right on his answer to the comment
14:38:18 <ltomasbo> apuimedo, this is the last patch for the lbaas support, right?
14:38:26 <apuimedo> ltomasbo: that's right
14:38:28 <vikasc> apuimedo, ok..
14:38:41 <ltomasbo> I'll try it as soon as I have the environment running...
14:38:47 <apuimedo> mchiappero: as soon as this is merged and I get through the bureacracy
14:38:51 <apuimedo> ltomasbo: good!
14:38:53 <apuimedo> thanks
14:38:55 <vikasc> apuimedo, i am also working on preparing env to test it
14:39:11 <ivc_> apuimedo vikasc i'd even say that that '_driver' option is different from the one vikasc is referring to and it does belong in config.py
14:39:36 <mchiappero> apuimedo: ok... I think macvlan should be mergeable by then
14:40:13 <ivc_> apuimedo also we need to refactor some stuff (this patch included), but not before 0.1.0
14:40:26 <apuimedo> ivc_: vikasc: let's merge https://review.openstack.org/#/c/407179/2
14:40:51 <apuimedo> ivc_: agreed
14:41:20 <vikasc> apuimedo, sure
14:42:24 <apuimedo> vikasc: ivc_: please, review https://review.openstack.org/#/c/451650/
14:42:29 <apuimedo> it will help vagrant users
14:43:15 <apuimedo> ivc_: do you have some draft (not necessarily the code) of the proposed ref-actor
14:43:19 <apuimedo> (pun intended)
14:43:24 <ivc_> hehe
14:43:31 <vikasc> :)
14:43:58 <ivc_> nope not yet. not even sure if its for 1.0 or post-1.0
14:44:20 <ivc_> i'd prefer 1.0 ofc, but the thing is pretty huge
14:45:13 <apuimedo> well, we can better estimate the time when we have a clearer picture
14:45:19 <ivc_> sure
14:45:40 <apuimedo> but I think that if we get split daemon and other stuff for 1.0 and do actors for 2.0, it's not a bad thing
14:46:01 <apuimedo> of course, the problem will be with config option changes
14:46:10 <apuimedo> people will get bothered most likely
14:46:28 <ivc_> that and also updating every part of driver/handler we have now
14:46:57 <apuimedo> that's dev facing, the 1 vs 2 discussion is user facing :-)
14:47:06 <apuimedo> (as well, not only)
14:47:49 <apuimedo> ivc_: did you see https://review.openstack.org/#/c/450113/ ?
14:48:05 <ivc_> i'd like us to have some brainstorming videoconf session for ref-actors, but need to draft it first
14:48:16 <ivc_> yup
14:48:39 <ivc_> its about the same thing as that -1 vikasc comment :)
14:49:20 <apuimedo> ivc_: looking forward to that videoconf
14:49:24 <apuimedo> let me know when you are ready
14:49:29 <apuimedo> and we'll set a date
14:50:12 <apuimedo> anything else on kuryr-k8s?
14:50:14 <ivc_> sure. around next week most likely
14:50:16 <ltomasbo> yes
14:50:23 <apuimedo> alraddarla: mchiappero: how's the effort coming along
14:50:32 <ltomasbo> can we have a brief discussion about the ports pool
14:50:41 <apuimedo> ivc_: next week is easter, my availability will be limited, but we can see
14:50:44 <ltomasbo> I wsa not able to join the IRC meeting for the last couple of weeks
14:51:00 <apuimedo> ltomasbo: do you think we can do it in 5 min?
14:51:02 <ltomasbo> did we decide to go for a modification of the current ones
14:51:11 <apuimedo> Otherwise better to move it to the channel
14:51:26 <ltomasbo> to follow what apuimedo proposed in https://review.openstack.org/#/c/446462/
14:51:29 <ltomasbo> sure
14:51:31 <ltomasbo> either works
14:51:33 <mchiappero> real quick: unfortunately I've been busy on internal deliveries and KubeCon for a couple of weeks, I'm currently finishing up the UT for MACVLAN, we should be able to push tomorrow
14:52:16 <apuimedo> ltomasbo: very well, let's move it there, then
14:52:20 <mchiappero> I also started another patch for better reutilizing some common code with VLAN and MACVLAN, but it's still WIP
14:52:23 <ltomasbo> apuimedo, ok!
14:52:25 <apuimedo> great!
14:52:32 <apuimedo> looking forward to that one mchiappero
14:52:34 <apuimedo> :-)
14:52:50 <alraddarla> apuimedo, still working on getting our enviornment set up but once that is up i will test my code and hopefully psuh it up
14:52:56 <mchiappero> apuimedo: that's all from me
14:53:02 <apuimedo> cool
14:53:09 <apuimedo> #topic general
14:53:19 <ivc_> ltomasbo i'm leaning towards apuimedo approach, but i'm also addressing the problem in ref-actor update :)
14:53:39 <hongbin> i want to bring up a discussion about consolidating docker installation scrilpt if there is a chance :)
14:53:43 <apuimedo> ivc_: timing is a factor
14:53:50 <apuimedo> what will come first?
14:53:52 <apuimedo> we'll see
14:54:01 <apuimedo> Last week there was kube con and we had a couple of community members there
14:54:04 <ivc_> apuimedo time is our worst enemy yes
14:54:05 <apuimedo> mchiappero: any news?
14:54:19 <apuimedo> irenab is on pto, she was also there
14:54:45 <mchiappero> uhm it was mainly about data center
14:54:58 <mchiappero> which means little open stack related talks
14:55:49 <apuimedo> I can imagine :_0
14:55:51 <apuimedo> :-)
14:55:57 <apuimedo> anything else before we close?
14:55:58 <mchiappero> I still need to rework notes, recap... nothing special comes to mind right now, but I'll let you guys know otherwise
14:57:21 <hongbin> apuimedo: hey, could i bring up the docker installation topic?
14:57:23 <apuimedo> very well
14:57:27 <apuimedo> hongbin: please do!
14:57:32 <hongbin> #link https://review.openstack.org/#/c/452575/
14:58:05 <hongbin> right now, fuxi, kuryr-libnetwork has duplicated script in devstack plugin to install docker, i am proposing to consolidate them into one place
14:58:21 <hongbin> it will be either in devstack tree or a docker devstack plugin
14:58:37 <apuimedo> right
14:58:50 <hongbin> i want to know if that is the thing we would like to do? (offload docker scrilpt out-of-tree)
14:59:13 <apuimedo> hongbin: I agree with sean dague
14:59:22 <apuimedo> a plugin under qa sounds like the best option
14:59:34 <hongbin> apuimedo: ok
15:00:10 <hongbin> if everyone would like to have a docekr devstack plugin, i will go ahead and create it
15:00:19 <apuimedo> alright, the bells are tolling
15:00:23 <apuimedo> time to end the meeting
15:00:29 <apuimedo> thank you all for joining
15:00:36 <apuimedo> for further discussiong, let's go to the channel
15:00:38 <apuimedo> #endmeeting