14:01:04 <apuimedo> #startmeeting kuryr
14:01:05 <openstack> Meeting started Mon Mar 20 14:01:04 2017 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:08 <openstack> The meeting name has been set to 'kuryr'
14:01:23 <apuimedo> Hello everybody and welcome to the weekly IRC meeting
14:01:33 <apuimedo> who's here today?
14:01:37 <alraddarla> o/
14:01:43 <yedongcan> o/
14:01:45 <limao> o/
14:02:29 <apuimedo> irenab: hongbin: ltomasbo|away:
14:02:37 <hongbin> o/
14:02:46 <irenab_> hi
14:03:10 <apuimedo> #topic kuryr-libnetwork
14:04:07 <apuimedo> I think we are practically at the point of being able to cut a release
14:04:56 <hongbin> +1
14:05:16 <yedongcan> yes
14:05:20 <limao> +1
14:05:25 <irenab_> +1
14:05:30 <apuimedo> very well
14:05:34 <apuimedo> I'm merging https://review.openstack.org/#/c/444661/6
14:05:42 <apuimedo> Cause having more fullstack tests is always good
14:06:35 <apuimedo> Also https://review.openstack.org/#/c/446891/3
14:06:46 <apuimedo> so people can make easily vagrant machines of the release
14:07:32 <hongbin> i will submit another revision for this one soon: https://review.openstack.org/#/c/445683/ , i think it would be good to have this fix in the release as well
14:07:59 <yedongcan> Thanks, hongbin.
14:08:28 <apuimedo> hongbin: I'd like to merge https://review.openstack.org/#/c/446706/3 too. But it needs to reference the blueprint for IPv6 as janonymous said
14:08:51 <hongbin> apuimedo: ack
14:08:52 <apuimedo> hongbin: agreed on https://review.openstack.org/#/c/445683/
14:09:05 <apuimedo> Do we all agree to cut the release when https://review.openstack.org/#/c/445683/ gets merged?
14:09:21 <irenab_> yes
14:09:30 <yedongcan> +1
14:09:53 <limao> +1
14:09:56 <apuimedo> +1
14:10:07 <apuimedo> hongbin:
14:10:25 <hongbin> apuimedo: +1
14:10:30 <apuimedo> very well then
14:10:51 <apuimedo> #info Kuryr-libnetwork will cut a release when https://review.openstack.org/#/c/445683/ is merged
14:11:09 <apuimedo> alright. Final part of this topic
14:11:23 <apuimedo> Do we want to set up some goals for making a Pike release?
14:13:13 <irenab_> Can we add this topic for next weekly to think till then?
14:13:14 <apuimedo> #action apuimedo bring up to the mailing list the question of having a Pike release for kuryr-libnetwork
14:13:24 <apuimedo> irenab_: oops. we wrote at the same time
14:13:26 <apuimedo> :P
14:13:35 <apuimedo> let's take it to the ML
14:13:37 <irenab_> +1 on email
14:13:44 <apuimedo> and vote next week
14:13:54 <irenab_> agreed
14:14:04 <apuimedo> #info Next weekly meeting will see a vote on kuryr-libnetwork pike release
14:14:36 <apuimedo> It's between keeping fully async releases only or having async releases + some OSt joint releases
14:14:43 <apuimedo> #topic kuryr-lib
14:15:51 <apuimedo> I would like to propose to cut a 0.3.1 release for kuryr-lib
14:16:24 <apuimedo> so that it includes the nested vlan shuffling and device_owner fixes
14:16:45 <irenab_> +1
14:16:56 <yedongcan> +1
14:17:00 <irenab_> apuimedo: what is still pending review ?
14:17:02 <apuimedo> limao: hongbin
14:17:10 <apuimedo> irenab_: afaik only requirements
14:17:16 <apuimedo> which I don't want to touch
14:17:18 <apuimedo> before a release
14:17:19 <limao> +1
14:17:36 <apuimedo> very well
14:17:55 <apuimedo> #action apuimedo to send patch for 0.3.1 kuryr-lib release
14:18:35 <apuimedo> #info I've been working on rpm packages for kuryr-kubernetes. I'll be adding kuryr-lib as well (package name python-kuryr)
14:18:47 <apuimedo> anything else on kuryr-lib?
14:20:01 <apuimedo> very well, moving on
14:20:05 <apuimedo> #topic fuxi
14:20:14 <hongbin> hi
14:20:15 <apuimedo> #chair hongbin
14:20:16 <openstack> Current chairs: apuimedo hongbin
14:20:40 <hongbin> last week, this patch got merged https://review.openstack.org/#/c/438292/ , which is the first step for setting up the ci for manila provider
14:21:13 <hongbin> besides that, there are other fixed proposed: https://review.openstack.org/#/c/445788/ https://review.openstack.org/#/c/447305/ https://review.openstack.org/#/c/429484/
14:21:37 <hongbin> that is for fuxi, i didn't receive a update from fuxi-kubernetes side this week
14:21:51 <hongbin> i will try to give an update next week on that
14:21:58 <apuimedo> thanks hongbin
14:21:59 <hongbin> apuimedo: that is all from my side
14:22:44 <apuimedo> very well
14:22:47 <apuimedo> I'm merging those changes
14:22:54 <apuimedo> #topic kuryr-kubernetes
14:22:58 <hongbin> apuimedo: thx
14:23:03 <apuimedo> We have a few blueprints to vote on
14:23:42 <apuimedo> https://blueprints.launchpad.net/kuryr-kubernetes/+spec/kuryr-k8s-contrail-integration
14:23:57 <alraddarla> +1 ;)
14:24:00 <apuimedo> +1
14:24:17 <apuimedo> ivc delegated a +1 vote on me
14:24:25 <irenab_> +1
14:25:12 <apuimedo> very well then. I'll merge the spec and approve the blueprint
14:25:36 <apuimedo> #info Kuryr-kubernetes contrail integration bp https://blueprints.launchpad.net/kuryr-kubernetes/+spec/kuryr-k8s-contrail-integration approved
14:25:48 <alraddarla> Thanks all
14:26:38 <apuimedo> second
14:26:54 <apuimedo> I submitted this blueprint https://blueprints.launchpad.net/kuryr-kubernetes/+spec/use-ovsdbapp
14:27:33 <apuimedo> much like we use pyroute2 instead of "ip link", it would make us use ovsdbapp instead of "ovs-vsctl
14:27:35 <apuimedo> "
14:28:05 <apuimedo> The code is the same production ready code that used to live in openstack/neutron
14:28:34 <apuimedo> I helped Neutron's otherwiseguy split it in the Atlanta PTG
14:28:43 <apuimedo> and the idea is that os-vif will end up using it as well
14:29:03 <irenab_> apuimedo: just use lib instead of wrapping commands on kuryr side?
14:29:10 <apuimedo> exactly
14:29:12 <apuimedo> it's native
14:29:19 <irenab_> +1
14:29:29 <apuimedo> yedongcan: limao: hongbin: maybe it would be a good idea to implement this for a Pike release in kuryr-libnetwork too
14:29:36 <yedongcan> +1
14:29:40 <limao> +1
14:29:41 <janonymous> o/
14:29:41 <hongbin> +1
14:29:45 <apuimedo> Very well then
14:30:12 <apuimedo> #info ovsdbapp usage is approved. It will wait merging for the first release of ovsdbapp
14:31:04 <apuimedo> I would also like to bring for discussion https://blueprints.launchpad.net/kuryr-kubernetes/+spec/driver-handler-opt-loading
14:32:27 <apuimedo> irenab_: do you think we need a spec for this one?
14:32:34 <irenab_> apuimedo: similar to the neutron ml2/services drivers?
14:32:41 <apuimedo> right
14:33:06 <irenab_> apuimedo: I donot think we need spec, can be later added into devref to guide on adding new driver
14:33:12 <apuimedo> janonymous: could you update https://blueprints.launchpad.net/kuryr-kubernetes/+spec/client-migration to reflect the discussion in the VTG ?
14:33:23 <apuimedo> so we can approve it soon and start using it
14:33:29 <janonymous> apuimdeo: yes , sure i will
14:33:35 <apuimedo> irenab_: very well. Thanks
14:33:38 <apuimedo> janonymous: thanks!
14:33:51 <apuimedo> irenab_: Let's vote on that one over ml
14:34:11 <apuimedo> #action apuimedo to bring https://blueprints.launchpad.net/kuryr-kubernetes/+spec/driver-handler-opt-loading for ml voting
14:34:40 <apuimedo> janonymous: I saw you submitted another one https://blueprints.launchpad.net/kuryr-kubernetes/+spec/oslo-gmr
14:34:45 <irenab_> apuimedo: I think it makes sense, not sure needs ml to confirm, but up to you
14:34:57 <apuimedo> irenab_: to be on the safe side
14:34:59 <apuimedo> :-)
14:35:09 <janonymous> apuimedo: yes i will complete it this week
14:35:14 <apuimedo> janonymous: very well
14:35:36 <apuimedo> #action janonymous to complete https://blueprints.launchpad.net/kuryr-kubernetes/+spec/oslo-gmr and ping cores about it so we can vote next weekly IRC meeting
14:37:17 <apuimedo> yedongcan: thanks for https://review.openstack.org/#/c/447385/
14:37:19 <apuimedo> merging it
14:37:21 <apuimedo> :-)
14:37:29 <apuimedo> and thanks janonymous for the report that led to the fix
14:38:03 <apuimedo> Please, all of you, rebase your patches after this one
14:38:17 <apuimedo> so that we don't get false -1s
14:38:53 <apuimedo> Sorry. I got to go. Please ping me on #openstack-kuryr for more discussion. Thank you all for joining
14:38:55 <apuimedo> #endmeeting