#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:01:00 UTC (full logs).

Meeting summary

  1. kuryr-lib (apuimedo, 14:03:12)
    1. We should to cut a new kuryr release due to https://review.openstack.org/#/c/414766/ which is needed by https://review.openstack.org/#/c/410403/ (apuimedo, 14:04:27)
    2. ACTION: apuimedo to send a request for a new kuryr-lib release so fuxi can re-use kuryr-lib's keystonauth code (apuimedo, 14:05:46)
    3. apuimedo sent an email to svinota about cutting a new release of pyroute2 (apuimedo, 14:07:29)
    4. ACTION: apuimedo to raise pyroute2 upper-constraints once pyroute2 has a new release (apuimedo, 14:07:50)
    5. https://github.com/svinota/pyroute2/issues/317 (apuimedo, 14:08:29)

  2. kuryr-libnetwork (apuimedo, 14:11:02)
    1. mostly cleanups and fixes these past two weeks on kuryr-libnetwork (apuimedo, 14:12:15)
    2. ACTION: apuimedo to review https://review.openstack.org/#/c/414659/ and https://review.openstack.org/#/c/415363/ (apuimedo, 14:12:53)
    3. ACTION: ltomasbo to rebase and rework https://review.openstack.org/#/c/402462/ (apuimedo, 14:13:29)
    4. ACTION: ltomasbo to add documentation about simple deployment and exercising the container-in-vm code in kuryr-libnetwork (apuimedo, 14:16:12)

  3. kuryr-kubernetes (apuimedo, 14:16:28)
    1. ACTION: vikasc to add documentation about simple deployment and exercising the container-in-vm code in kuryr-kubernetes patch https://review.openstack.org/#/c/410578/ (apuimedo, 14:17:14)
    2. we added a voting devstack installation gate (apuimedo, 14:18:50)
    3. https://review.openstack.org/#/c/404191/ (apuimedo, 14:23:28)
    4. https://review.openstack.org/#/c/413715/ (apuimedo, 14:23:36)
    5. vikasc submitted a patch for container-in-vm! (apuimedo, 14:24:06)
    6. https://wiki.openstack.org/wiki/StoryBoard (apuimedo, 14:31:13)
    7. https://storyboard.openstack.org/#!/page/about (apuimedo, 14:32:59)

  4. open discussion (apuimedo, 14:33:07)


Meeting ended at 14:34:38 UTC (full logs).

Action items

  1. apuimedo to send a request for a new kuryr-lib release so fuxi can re-use kuryr-lib's keystonauth code
  2. apuimedo to raise pyroute2 upper-constraints once pyroute2 has a new release
  3. apuimedo to review https://review.openstack.org/#/c/414659/ and https://review.openstack.org/#/c/415363/
  4. ltomasbo to rebase and rework https://review.openstack.org/#/c/402462/
  5. ltomasbo to add documentation about simple deployment and exercising the container-in-vm code in kuryr-libnetwork
  6. vikasc to add documentation about simple deployment and exercising the container-in-vm code in kuryr-kubernetes patch https://review.openstack.org/#/c/410578/


Action items, by person

  1. apuimedo
    1. apuimedo to send a request for a new kuryr-lib release so fuxi can re-use kuryr-lib's keystonauth code
    2. apuimedo to raise pyroute2 upper-constraints once pyroute2 has a new release
    3. apuimedo to review https://review.openstack.org/#/c/414659/ and https://review.openstack.org/#/c/415363/
  2. openstack
    1. apuimedo to review https://review.openstack.org/#/c/414659/ and https://review.openstack.org/#/c/415363/
    2. ltomasbo to rebase and rework https://review.openstack.org/#/c/402462/
    3. vikasc to add documentation about simple deployment and exercising the container-in-vm code in kuryr-kubernetes patch https://review.openstack.org/#/c/410578/


People present (lines said)

  1. apuimedo (88)
  2. irenab (38)
  3. vikas_ (19)
  4. openstack (3)


Generated by MeetBot 0.1.4.