#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:03:48 UTC (full logs).

Meeting summary

  1. kuryr-libnetwork (apuimedo, 14:05:05)
    1. https://review.openstack.org/404591 (apuimedo, 14:07:16)
    2. https://review.openstack.org/404591 (apuimedo, 14:07:19)
    3. https://review.openstack.org/#/c/401874/5 (apuimedo, 14:09:03)
    4. https://review.openstack.org/#/c/400365/ (apuimedo, 14:10:26)
    5. https://bugs.launchpad.net/kuryr-libnetwork/+bug/1651015 (apuimedo, 14:14:20)

  2. kuryr-kubernetes (apuimedo, 14:22:57)
    1. ivc_ made a very nice demo of the services patch https://asciinema.org/a/51qn06lgz78gcbzascpl2du4w (apuimedo, 14:23:25)
    2. irenab posted a WIP patch for adding OVS native support https://review.openstack.org/#/c/412215/ (apuimedo, 14:25:05)
    3. irenab reports ovs native ~ 2x pod creation burst speed performance improvement when using ovs-native binding with Dragonflow (apuimedo, 14:26:09)
    4. ACTION: irenab to add local.conf.df and local.conf.ovsnative to the ovs native WIP patch (apuimedo, 14:27:27)
    5. ACTION: put README.md and doc fixes for kuryr-kubernetes 1.0.0 milestone (apuimedo, 14:29:18)
    6. ACTION: apuimedo to add the wait for dependencies in devstack container start (apuimedo, 14:32:01)
    7. vikasc posted a patch for bringing nested vlan vifs to kuryr-kubernets (apuimedo, 14:33:44)
    8. https://review.openstack.org/#/c/410578/ (apuimedo, 14:33:50)

  3. fuxi (apuimedo, 14:49:14)
    1. The fuxi is switching to keystone v3 (hongbin, 14:52:19)
    2. https://review.openstack.org/#/c/410403/ (hongbin, 14:52:37)
    3. https://review.openstack.org/#/c/409982/ (hongbin, 14:52:42)
    4. ACTION: hongbin look into how to resue keystone v3 code in kuryr lib (hongbin, 14:52:56)
    5. https://review.openstack.org/#/c/403931/ (hongbin, 14:54:14)
    6. https://review.openstack.org/#/c/403941/ (hongbin, 14:54:19)
    7. https://review.openstack.org/#/c/373745/ (hongbin, 14:54:36)
    8. https://review.openstack.org/#/c/408845/ (hongbin, 14:55:19)
    9. https://review.openstack.org/#/c/409968/ (hongbin, 14:55:24)
    10. https://github.com/docker/docker/pull/29468 (hongbin, 14:55:52)

  4. general (apuimedo, 14:56:06)
    1. https://review.openstack.org/#/c/405203/ could use one more +2 :) (alraddarla_, 14:56:21)


Meeting ended at 14:59:01 UTC (full logs).

Action items

  1. irenab to add local.conf.df and local.conf.ovsnative to the ovs native WIP patch
  2. put README.md and doc fixes for kuryr-kubernetes 1.0.0 milestone
  3. apuimedo to add the wait for dependencies in devstack container start
  4. hongbin look into how to resue keystone v3 code in kuryr lib


Action items, by person

  1. apuimedo
    1. apuimedo to add the wait for dependencies in devstack container start
  2. hongbin
    1. hongbin look into how to resue keystone v3 code in kuryr lib
  3. irenab
    1. irenab to add local.conf.df and local.conf.ovsnative to the ovs native WIP patch


People present (lines said)

  1. apuimedo (145)
  2. hongbin (29)
  3. ivc_ (23)
  4. mchiappero (17)
  5. irenab (14)
  6. janonymous (9)
  7. yedongcan (6)
  8. vikasc (6)
  9. openstack (5)
  10. alraddarla_ (4)
  11. garyloug (1)
  12. limao (1)
  13. limao_ (1)
  14. mattmceuen (1)
  15. diga (1)


Generated by MeetBot 0.1.4.