#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:02:08 UTC (full logs).

Meeting summary

  1. kuryr-libnetwork (apuimedo, 14:03:48)
  2. kuryr-lib (apuimedo, 14:03:57)
    1. before release we must have CNI driver (apuimedo) and one vlan binding mode (vikasc + ltomasbo) (apuimedo, 14:11:48)
    2. ACTION: apuimedo to move CNI patch to kuryr-kubernetes and make it work with the pod handler and have a devstack test (apuimedo, 14:15:00)
    3. kuryr-lib release drops CNI driver (apuimedo, 14:15:18)

  3. kuryr-libnetwork (apuimedo, 14:18:48)
    1. The refactoring of where the devices are created and deleted to better comply with libnetwork and also to make nested flow work is pending kuryr-lib release (apuimedo, 14:23:39)

  4. kuryr-kubernetes (apuimedo, 14:30:42)
    1. we move CNI and os-vif binding to kuryr-kubernetes first. From here it will bubble up to kuryr-lib (apuimedo, 14:31:11)
    2. https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing (apuimedo, 14:35:09)
    3. ACTION: get https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing in sync with the code and post it as devref (apuimedo, 14:37:03)

  5. fuxi (apuimedo, 14:51:50)
    1. hongbin is our new fuxi contact (apuimedo, 14:52:02)
    2. ACTION: apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi (apuimedo, 14:57:04)


Meeting ended at 14:59:42 UTC (full logs).

Action items

  1. apuimedo to move CNI patch to kuryr-kubernetes and make it work with the pod handler and have a devstack test
  2. get https://docs.google.com/document/d/1hExm0TNp_OMWY_XMVRYpSvg5G8kFrL5hcrT9M_NDCwo/edit?usp=sharing in sync with the code and post it as devref
  3. apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi


Action items, by person

  1. apuimedo
    1. apuimedo to move CNI patch to kuryr-kubernetes and make it work with the pod handler and have a devstack test
    2. apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi
  2. irenab
    1. apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi
  3. openstack
    1. apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi
  4. vikasc
    1. apuimedo, vikasc irenab to review https://review.openstack.org/#/q/project:openstack/fuxi


People present (lines said)

  1. apuimedo (141)
  2. ivc_ (51)
  3. mchiappero (21)
  4. irenab (21)
  5. hongbin (19)
  6. vikasc (14)
  7. ltomasbo (7)
  8. alraddarla_ (7)
  9. openstack (5)
  10. lmdaly (2)
  11. garyloug (1)
  12. yedongcan (1)
  13. limao_ (1)
  14. janonymous (1)


Generated by MeetBot 0.1.4.