#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:02:11 UTC (full logs).

Meeting summary

  1. kuryr-lib (apuimedo, 14:03:52)
  2. kuryr-libnetwork (apuimedo, 14:06:37)
    1. mchiappero and lmdaly reported a bug in how we handle the creation and deletion of interfaces in libnetwork that impacts us specially when working in container-in-vm mode (apuimedo, 14:07:12)
    2. https://github.com/docker/libnetwork/issues/1520 (mchiappero, 14:09:42)
    3. https://bugs.launchpad.net/neutron/+bug/1639186 (limao_, 14:09:45)
    4. ACTION: mchiappero lmdaly to push the libnetwork fix for container device deletion ordering (apuimedo, 14:13:03)
    5. https://bugs.launchpad.net/neutron/+bug/1639186 (apuimedo, 14:13:43)
    6. ltomasbo has been checking the vlan-aware-vms neutron reference implementation for completeness (apuimedo, 14:14:12)
    7. ltomasbo has found out that Neutron QoS does not get applied to the container subports (apuimedo, 14:14:36)
    8. https://review.openstack.org/#/c/361993/ (vikasc, 14:25:55)
    9. ACTION: vikasc to work with ltomasbo to put the vlan management in sync with the two ways ltomasbo is experimenting with (apuimedo, 14:27:41)
    10. limao has been working on revamping the rally tests, to test the cost we incur on container creation going to neutron (apuimedo, 14:32:33)

  3. kuryr-kubernetes (apuimedo, 14:35:33)
    1. https://trello.com/b/1Ij919E8/networking (apuimedo, 14:39:25)
    2. https://review.openstack.org/#/c/391329/ (apuimedo, 14:40:12)
    3. https://review.openstack.org/#/c/376045/ (ivc_, 14:46:13)

  4. open discussion (apuimedo, 14:52:11)
    1. ACTION: apuimedo to update the trello board (apuimedo, 14:53:57)


Meeting ended at 14:54:05 UTC (full logs).

Action items

  1. mchiappero lmdaly to push the libnetwork fix for container device deletion ordering
  2. vikasc to work with ltomasbo to put the vlan management in sync with the two ways ltomasbo is experimenting with
  3. apuimedo to update the trello board


Action items, by person

  1. apuimedo
    1. apuimedo to update the trello board
  2. lmdaly
    1. mchiappero lmdaly to push the libnetwork fix for container device deletion ordering
  3. ltomasbo
    1. vikasc to work with ltomasbo to put the vlan management in sync with the two ways ltomasbo is experimenting with
  4. mchiappero
    1. mchiappero lmdaly to push the libnetwork fix for container device deletion ordering
  5. vikasc
    1. vikasc to work with ltomasbo to put the vlan management in sync with the two ways ltomasbo is experimenting with


People present (lines said)

  1. apuimedo (135)
  2. irenab (30)
  3. ltomasbo (21)
  4. ivc_ (16)
  5. vikasc (13)
  6. mchiappero (10)
  7. openstack (5)
  8. limao_ (4)
  9. janonymous (2)
  10. garyloug (1)
  11. yedongcan (1)
  12. pc_m (1)
  13. Drago1 (1)
  14. lmdaly (1)


Generated by MeetBot 0.1.4.