14:01:51 <apuimedo> #startmeeting kuryr
14:01:51 <openstack> Meeting started Mon Oct 17 14:01:51 2016 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:54 <openstack> The meeting name has been set to 'kuryr'
14:02:06 <apuimedo> Welcome to Kuryr's weekly IRC meeting
14:02:17 <apuimedo> Who's here to attend?
14:02:19 <vikasc> o/
14:02:22 <limao_> o/
14:02:22 <lmdaly> o/
14:02:23 <garyloug> o/
14:02:27 <tango> o/
14:02:27 <yedongcan1> o/
14:03:00 <mchiappe> o/
14:03:33 <ltomasbo> o/
14:03:40 <apuimedo> #info vikasc limao_ lmdaly garyloug tango yedongcan1 mchiappe ltomasbo and apuimedo present
14:04:00 <apuimedo> #topic Ocata summit
14:04:21 <apuimedo> As you all know, next week there will be Ocata's summit in Barcelona
14:04:55 <apuimedo> #info Kuryr's working sessions are already scheduled and with descriptions filled https://www.openstack.org/summit/barcelona-2016/summit-schedule/global-search?t=kuryr:
14:05:49 <apuimedo> Please, if anybody has something to add to the descriptions or feels like there is some topic we need to discuss that is not part of any session, bring it up now or reach out to me later
14:06:06 <apuimedo> who is attending from you?
14:06:22 <lmdaly> o/
14:06:37 <tango> I will join
14:07:00 <limao_> o/
14:07:08 <diga_> o/
14:07:21 <ltomasbo> o/
14:07:32 <apuimedo> vikasc: you are joining too, right?
14:07:54 <vikasc> apuimedo, unfortunately,  nope :(
14:07:59 <apuimedo> :O
14:08:58 <apuimedo> oh, I forgot to say. If there is a work session any of you cares a lot about but are not able to attend, I guess we could swap topics
14:09:20 <apuimedo> #action apuimedo to figure out a way to have tele presence in the meetings
14:09:53 <vikasc> apuimedo, that woud be awesome to have
14:10:00 <apuimedo> #info next week there won't be weekly IRC meeting. We'll see each other enough :P
14:10:06 <mchiappe> yes, at least audio
14:10:16 <limao_> If you need, we can webex meeting so that remote can access
14:10:58 <apuimedo> limao_: if the connexion allows. I'll try to bring some microphone/speakers if there are none available in the room
14:11:18 <apuimedo> #action apuimedo to contact the organization about remote presence to work sessions
14:11:35 <mchiappe> even offline could be acceptable
14:11:59 <mchiappe> or get some free tickets :P
14:12:33 <apuimedo> #info there will be work session notes. We'll update the work session etherpads
14:12:47 <apuimedo> #action apuimedo to set up the work session and fishbowl etherpads
14:13:00 <apuimedo> aynthing else about next week's summit?
14:14:18 <apuimedo> alright. Moving on
14:14:37 <ivc_> o/
14:15:14 <apuimedo> ivc_: hi
14:15:27 <apuimedo> #topic kuryr-lib
14:16:49 <apuimedo> #info limao_ got CI fixes merged last week https://review.openstack.org/384262
14:17:12 <apuimedo> limao_: are all of the CI fixes merged or is there any other that requires reviewing attention?
14:18:20 <limao_> apuimedo: all CI related fixed
14:18:27 <apuimedo> great
14:18:59 <apuimedo> vikasc: limao_ also sent this bug fix for a dumb bug I introduced https://review.openstack.org/#/c/384249/2
14:19:11 <apuimedo> vikasc: please, merge
14:19:20 <vikasc> apuimedo, sure
14:20:08 <apuimedo> vikasc: this one should also get merged https://review.openstack.org/#/c/384248/2
14:20:18 <apuimedo> limao_: thanks for all the bug reports and fixes
14:20:38 <limao_> apuimedo: :)
14:21:02 <apuimedo> anything else on kuryr-lib?
14:21:15 <apuimedo> oh, yes
14:21:21 <apuimedo> vikasc: https://review.openstack.org/#/c/378485/ also requires your attention
14:21:31 <apuimedo> thanks for that one yedongcan1
14:21:45 <vikasc> apuimedo, sure.
14:23:29 <apuimedo> there is one more thing
14:24:20 <apuimedo> I was wondering if kuryr-lib shouldn't have a non-voting gate that checks that the change doesn't break kuryr-libnetwork (and eventually kuryr-kubernetes) fullstack tests
14:24:24 <apuimedo> limao_: what do you thinkg?
14:24:30 <apuimedo> *think
14:25:49 <apuimedo> it should only be the kuryr-lib + kuryr-libnetwork master fullstack test for now (if we decide to do it)
14:26:01 <apuimedo> #topic kuryr-libnetwork
14:26:56 <limao_> apuimedo: kuryr-lib and kuryr-ibnetwork master has been tested in kuryr-libnetwork
14:27:21 <limao_> do you mean kuryr-lib master and kuryr-libnetowrk master in Kuryr-lib CI?
14:27:30 <apuimedo> limao_: I mean in both places
14:27:49 <apuimedo> so new kuryr-lib changes don't introduce breakage on lib consumers
14:27:51 <ivc_> limao_, but having an indication in kuryr-lib that it breaks kuryr-libnetwork/k8s would be nice
14:28:12 <limao_> apuimedo: ivc_: yes
14:28:20 <apuimedo> btw. I'm very happy that the new kuryr-libnetwork CI tests you introduced already caught important stuff, as in https://review.openstack.org/#/c/382878/
14:28:22 <apuimedo> :-)
14:28:31 <limao_> better have that in Kuryr-lib CI, let me double check it
14:28:54 <apuimedo> I think our amount of consumers is reduced enough that having a test for each of them in kuryr-lib is reasonable
14:29:02 <apuimedo> (hope we don't get shouted at by infra :P )
14:29:47 <limao_> apuimedo: :) try to push it in infra
14:29:56 <apuimedo> vikasc: janonymous patch https://review.openstack.org/#/c/380925/ requires your attention
14:30:12 <vikasc> apuimedo, ack
14:30:21 <apuimedo> also https://review.openstack.org/#/c/384359/1
14:30:26 <apuimedo> vikasc: ^^
14:30:39 <apuimedo> otherwise 'cover/' stays there bothering when doing git status :P
14:30:39 <vikasc> apuimedo, ack
14:31:18 <apuimedo> yedongcan1's https://review.openstack.org/#/c/378485/ should also get merged
14:31:58 <vikasc> apuimedo, will go through it soon.
14:32:10 <apuimedo> #action apuimedo to check properly https://bugs.launchpad.net/kuryr-libnetwork/+bug/1633435
14:32:12 <openstack> Launchpad bug 1633435 in kuryr-libnetwork "Make fullstack test stable" [Undecided,In progress] - Assigned to Dongcan Ye (hellochosen)
14:32:41 <apuimedo> I saw yedongcan1's bug, but as limao_ says, it seems like docker pull is synchronous
14:33:36 <apuimedo> vikasc: I agree with https://review.openstack.org/#/c/382878/ . Check it too ;-)
14:33:43 <yedongcan1> apuimedo: Got it
14:33:47 <vikasc> apuimedo, sure :)
14:34:23 <apuimedo> #info last Friday we had a meeting with mchiappe lmdaly about the kuryr-libnetwork drivers for neutron usage
14:35:36 <apuimedo> #info the idea is to have a kuryr-libnetwork driver that does the ipvlan/macvlan necessary actions, another one for vlan-aware-vms and one for the current bare-metal approach
14:36:26 <apuimedo> mchiappe: lmdaly: if there is any update, question, request on that, let us know now or at any time on IRC :-)
14:36:54 <lmdaly> Thanks apuimedo will do :)
14:36:58 <apuimedo> cool
14:37:04 <apuimedo> anything else on kuryr-libnetwork?
14:37:52 <apuimedo> alright! Moving on
14:38:02 <apuimedo> #topic kuryr-kubernetes
14:39:31 <apuimedo> vikasc: I'll try to get ahold of another core reviewer so that we can merge https://review.openstack.org/#/c/381488/
14:39:59 <vikasc> apuimedo, thanks
14:40:16 <apuimedo> #action apuimedo vikas to review ivc_ 's https://review.openstack.org/#/c/386192/ and https://review.openstack.org/#/c/376043/
14:40:34 <apuimedo> ivc_: any updates/requests on your side?
14:41:06 <ivc_> apuimedo, i was about to say that we could probably merge 2 other patches
14:41:10 <apuimedo> I'm close to finishing the kuryr presentation's slides
14:41:22 <ivc_> but you merged them already :P
14:41:46 <apuimedo> so this week, after I prepare the work sessions, I should be able to finish kuryr-lib's CNI patch. Much longer than it should have taken
14:42:20 <apuimedo> ivc_: monday meetings serve to cap the max time of such merges to a single week
14:42:21 <apuimedo> :P
14:42:33 <apuimedo> which is longer than I want as well
14:42:49 <apuimedo> I have to finish the bot that notifies me of such things
14:42:55 <apuimedo> and updates the trello board
14:42:57 <apuimedo> :P
14:43:21 <ivc_> apuimedo, that would be neat :)
14:44:07 <apuimedo> I seem to recall that lmdaly and mchiappe wanted to join in the kubernetes handler fun
14:44:33 <apuimedo> ivc_: I remember that you showed me that you significantly expanded the patches' docstrings
14:45:05 <apuimedo> so I suppose that soon we will be able to get other people up to speed enough to join in
14:45:44 <apuimedo> I have to check the patches properly to make a diagram for the presentation and I'll probably make a small patch to devref to add the diagram too
14:46:05 <apuimedo> alright. Anything else on kuryr-kubernetes?
14:46:28 <ivc_> apuimedo, the next 3 patches will introduce the NamespaceHandler and PortPodHandler, so we are getting close to the CNI patch
14:46:34 <mchiappe> apuimedo: yes, right, I'm afraid some more time is needed
14:47:33 <apuimedo> ivc_: right. I need to finish that asap. I am already tired of drawing presentations and doing organizational stuff. The summit can't be over soon enough
14:48:07 <apuimedo> looking forward a lot to work with those of you that will come
14:48:14 <apuimedo> in the same room
14:48:26 <apuimedo> #topic open discussion
14:49:01 <mchiappe> apuimedo: regarding kuryr-libnetwor and the interface deletion, using a file in /var/run/ to store the namespace file and interface index poses the question of how to manage cleanups
14:49:32 <apuimedo> mchiappe: /run is automatically cleaned on reboot by contract
14:49:35 <mchiappe> any preference?
14:49:44 <apuimedo> so those that we fail to clean, can be left there, imho
14:49:45 <mchiappe> ok
14:50:10 <mchiappe> fine with me :)
14:50:16 <ivc_> apuimedo, what about servers with high uptime?
14:50:19 <apuimedo> mchiappe: darn. I had forgotten to mention about the bug in the kuryr-libnetwork part :/
14:50:34 <apuimedo> ivc_: I don't think we'll saturate /run
14:50:55 <apuimedo> if we see it becomes a problem we can cleanup /run/kuryr on kuryr startup
14:51:36 <mchiappe> apuimedo: my concern is also about potential crashes
14:51:46 <apuimedo> that's my only concern
14:51:56 <mchiappe> but I would say doing no clean up is fine
14:52:04 <mchiappe> yes right :)
14:52:49 <apuimedo> I want you all to note that I am a local to the next summit. So if anybody needs help or has any questions, feel free to reach out on IRC or email
14:53:16 <tango> +1
14:53:28 <apuimedo> the best warning I can give you is
14:53:33 <apuimedo> if you take the city bus
14:54:23 <apuimedo> it does not stop at every place. You have to request the stop in advance. And often there is no display to show which is the next stop. So be careful with that or you'll have a nice long walk
14:54:24 <apuimedo> :D
14:54:40 <vikasc> :D
14:54:58 <tango> Is there metro?
14:55:04 <apuimedo> there is a metro
14:55:22 <apuimedo> metro and tram are easier to manage
14:55:38 <apuimedo> for taxi there is an uber-like application called Hailo
14:55:53 <apuimedo> there was another one the name of which I don't remember
14:56:05 <apuimedo> also, please avoid tourist traps
14:56:08 <tango> How's the traffic if going by taxi or Hailo?
14:56:21 <apuimedo> it's okay except rush hour
14:56:39 <apuimedo> a good rule of thumb is to avoid restaurants/cafes within 100m of major landmarks :-)
14:56:49 <apuimedo> (in almost every country)
14:57:54 <apuimedo> if you are bored and want to go to the movies, there's a cinema by the sea, not too far from the sumit without dubbing called Icaria
14:58:01 <apuimedo> and it's discount week next week
14:58:09 <apuimedo> I think I covered the basics :P
14:58:29 <lmdaly> +1 :D
14:58:32 <mchiappe> you missed where to get drunk :P
14:58:46 <apuimedo> mchiappe: that's because I'm like a taliban and don't drink anything but water
14:58:48 <apuimedo> :P
14:59:03 <apuimedo> so I wouldn't know what to recommend
14:59:19 <mchiappe> good for you!
14:59:21 <apuimedo> just if you see yourself paying for wine like in your home countries, you are getting scammed
14:59:31 <apuimedo> cause good wine here is much cheaper
14:59:45 <apuimedo> 7€ a bottle should get you high quality
14:59:45 <mchiappe> I know, the same in Italy
14:59:49 <apuimedo> ;-)
15:00:00 <apuimedo> anyway, back to our channel
15:00:00 <mchiappe> here is at least 3 times as much
15:00:07 <apuimedo> alright. looking forward to see you lot next week!
15:00:10 <apuimedo> #endmeeting