#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:02:50 UTC (full logs).

Meeting summary

    1. devvesa limao icoughla garyloug lmdaly ivc_ and apuimedo present (apuimedo, 14:05:05)
    2. https://wiki.openstack.org/wiki/Meetings/Kuryr#Meeting_September_12th.2C_2016 (apuimedo, 14:06:05)

  1. kuryr: new config options (apuimedo, 14:06:36)
    1. Today the patch that marks the first openstack/kuryr release got merged https://review.openstack.org/316320 (apuimedo, 14:07:19)
    2. Now all the authentication options for talking to Neutron reside in the [neutron] config group (apuimedo, 14:08:16)
    3. kuryr-libnetwork and kuryr-kubernetes can now use the new kuryr.lib.utils code to support keystone v3 (apuimedo, 14:08:41)
    4. the options for authentication now are loaded and registered by openstack/keystoneauth (apuimedo, 14:09:23)

  2. kuryr: release (apuimedo, 14:12:02)
    1. We are changing the name of the openstack/kuryr repository to match the pypi package it produces https://review.openstack.org/368864 (apuimedo, 14:12:42)
    2. a patch for cutting the first kuryr-lib release has been sent https://review.openstack.org/368622 (apuimedo, 14:13:10)

  3. kuryr-libnetwork: keystone v3 support (apuimedo, 14:16:00)
    1. a patch has been sent to use the new kuryr-lib config facilities. It has been successfully manually tested to work with devstack and keystone v3 https://review.openstack.org/367033 (apuimedo, 14:17:04)
    2. after the v3 patch gets merged, those of you that have kuryr.conf tuned should update to the new keystoneauth standard options (apuimedo, 14:17:47)
    3. https://paste.fedoraproject.org/427103/47367050/ (apuimedo, 14:18:27)
    4. it will support v2password v3password v2token and v3token (apuimedo, 14:19:08)

  4. kuryr-libnetwork testing fixes (apuimedo, 14:23:23)
    1. kuryr-lib's keystone v3 patch requires kuryr-libnetwork's keystone v3 patch to be merged to be working again (apuimedo, 14:23:58)
    2. ACTION: apuimedo, banix, vikas, irenab to get kuryr-libnetwork's v3 patch merged (apuimedo, 14:24:54)
    3. ACTION: apuimedo to get gates working again (apuimedo, 14:25:10)
    4. ACTION: janonymous banix and limao to work on gates and testing fixes too (apuimedo, 14:26:50)
    5. limao already sent a patch for fixing rally tests this week, so it is a continued focus https://review.openstack.org/#/c/365851/ (apuimedo, 14:27:54)
    6. janonymous sent a fix for devstack that is important for ubuntu based tests https://review.openstack.org/#/c/367753/ (apuimedo, 14:29:11)
    7. ACTION: banix to review and hopefully merge https://review.openstack.org/#/c/367753/ (apuimedo, 14:29:33)
    8. : limao verified that before the keystone v3 kuryr-lib patch, only the fullstack gate was failing https://review.openstack.org/#/c/365683/ (apuimedo, 14:32:05)

  5. kuryr-libnetwork: container-in-vm (apuimedo, 14:32:43)
    1. ACTION: vikas to update the mailing list about the container-in-vm kuryr-libnetwork patches (apuimedo, 14:33:33)

  6. kuryr-kubernetes: asyncio style upstreaming (apuimedo, 14:40:09)
    1. devvesa got the first translator layer patch merged https://review.openstack.org/#/c/363758/ (apuimedo, 14:40:45)
    2. ACTION: apuimedo to address vikas' comments to https://review.openstack.org/#/c/365600/ (apuimedo, 14:42:11)
    3. ACTION: apuimedo to upstream a first version of the CNI driver (apuimedo, 14:44:12)

  7. kuryr-kubernetes: py2/py3 eventlet style PoC (apuimedo, 14:44:40)
    1. https://review.openstack.org/#/c/320545/ (devvesa, 14:46:03)

  8. ipvlan address pairs proposal (apuimedo, 14:53:24)
    1. http://lists.openstack.org/pipermail/openstack-dev/2016-September/103461.html (apuimedo, 14:54:40)
    2. icoughla and his team have an IPVLAN, address pairs working PoC for kuryr-libnetwork container-in-vm (apuimedo, 14:59:09)


Meeting ended at 15:03:05 UTC (full logs).

Action items

  1. apuimedo, banix, vikas, irenab to get kuryr-libnetwork's v3 patch merged
  2. apuimedo to get gates working again
  3. janonymous banix and limao to work on gates and testing fixes too
  4. banix to review and hopefully merge https://review.openstack.org/#/c/367753/
  5. vikas to update the mailing list about the container-in-vm kuryr-libnetwork patches
  6. apuimedo to address vikas' comments to https://review.openstack.org/#/c/365600/
  7. apuimedo to upstream a first version of the CNI driver


Action items, by person

  1. apuimedo
    1. apuimedo, banix, vikas, irenab to get kuryr-libnetwork's v3 patch merged
    2. apuimedo to get gates working again
    3. apuimedo to address vikas' comments to https://review.openstack.org/#/c/365600/
    4. apuimedo to upstream a first version of the CNI driver
  2. banix
    1. apuimedo, banix, vikas, irenab to get kuryr-libnetwork's v3 patch merged
    2. janonymous banix and limao to work on gates and testing fixes too
    3. banix to review and hopefully merge https://review.openstack.org/#/c/367753/
  3. irenab
    1. apuimedo, banix, vikas, irenab to get kuryr-libnetwork's v3 patch merged
  4. janonymous
    1. janonymous banix and limao to work on gates and testing fixes too
  5. limao
    1. janonymous banix and limao to work on gates and testing fixes too
  6. openstack
    1. banix to review and hopefully merge https://review.openstack.org/#/c/367753/
    2. apuimedo to address vikas' comments to https://review.openstack.org/#/c/365600/


People present (lines said)

  1. apuimedo (121)
  2. ivc_ (12)
  3. icoughla (9)
  4. devvesa (9)
  5. hongbin (6)
  6. limao (5)
  7. openstack (5)
  8. tonanhngo (4)
  9. banix (4)
  10. irenab (2)
  11. janonymous (2)
  12. sigmavirus (2)
  13. garyloug (1)
  14. pablochacin (1)
  15. lmdaly (1)
  16. jimbaker (1)


Generated by MeetBot 0.1.4.