#openstack-meeting-4: kuryr

Meeting started by apuimedo at 14:00:55 UTC (full logs).

Meeting summary

    1. ivc_, tonanhngo, limao, vikasc, devvesa, janonymous and apuimedo in attendance (apuimedo, 14:04:04)

  1. kuryr-lib (apuimedo, 14:04:14)
    1. all the necessary cleanups for kuryr-lib got merged (apuimedo, 14:04:58)
    2. https://review.openstack.org/361972 (apuimedo, 14:05:05)
    3. https://review.openstack.org/361937 (apuimedo, 14:05:12)
    4. https://review.openstack.org/361937 (apuimedo, 14:05:20)
    5. https://review.openstack.org/362070 (apuimedo, 14:05:54)
    6. we are missing the keystonev3 support that I've been working on (apuimedo, 14:06:31)
    7. ACTION: apuimedo, vikas to work out the auth remotedriver-> rpc driver (apuimedo, 14:23:32)
    8. https://github.com/kubernetes/kubernetes/blob/master/pkg/cloudprovider/providers/openstack/openstack.go#L219 (apuimedo, 14:23:54)

  2. kuryr-libnetwork (apuimedo, 14:24:01)
    1. the contents of the 'common' package have been moved to the base package as agreed, thanks to vikas' patch https://review.openstack.org/361567 (apuimedo, 14:24:51)
    2. https://review.openstack.org/362857 (apuimedo, 14:25:15)
    3. sample config file generation is now generated by a script that prevents common mistakes when using oslo-config-generator (apuimedo, 14:26:01)
    4. https://review.openstack.org/364240 (apuimedo, 14:26:06)
    5. limao fixed the MTU bug that meant that MTU was not being retrieved from Neutron (apuimedo, 14:27:07)
    6. https://review.openstack.org/#/c/355714/ (apuimedo, 14:27:22)
    7. Docker 1.9 compat patch was merged as well https://review.openstack.org/352768 (apuimedo, 14:27:54)
    8. devstack should now be back into a working state (apuimedo, 14:28:18)
    9. ACTION: limao and janonymous to check the rally jobs (apuimedo, 14:30:14)
    10. ACTION: vikasc apuimedo to review https://review.openstack.org/#/c/363414/1 (apuimedo, 14:31:47)

  3. kuryr-kubernetes (apuimedo, 14:33:48)
    1. last Thursday a kuryr-kubernetes videoconf meeting was held (apuimedo, 14:34:13)
    2. More information about it can be found on the mailing list (apuimedo, 14:34:29)
    3. devvesa is working on the python3 upstreaming (apuimedo, 14:37:29)
    4. ivc_ is working on a py2/py3 eventlet PoC that matches its features (apuimedo, 14:37:55)
    5. There is a new spec proposal for the watcher/translator interaction for kuryr-kubernetes (apuimedo, 14:38:44)
    6. https://review.openstack.org/365600 (apuimedo, 14:38:55)
    7. ACTION: apuimedo, vikas to review https://review.openstack.org/363758 (apuimedo, 14:40:45)
    8. ACTION: apuimedo, devvesa, ivc to come up with a functional testing approach for the gates (apuimedo, 14:41:27)
    9. https://review.openstack.org/#/c/363758/ (devvesa, 14:41:27)
    10. https://review.openstack.org/#/c/363758/ (apuimedo, 14:41:46)
    11. https://github.com/kubernetes/kubernetes/blob/master/hack/local-up-cluster.sh (devvesa, 14:44:22)
    12. ACTION: apuimedo to check hyperkube for signs of life (apuimedo, 14:45:55)
    13. ACTION: apuimedo ask to Kubernetes-dev on Slack :) (devvesa, 14:46:13)
    14. ACTION: devvesa to ask about hyperkube on kubernetes-dev slack (apuimedo, 14:46:53)
    15. next meeting to discuss and decide the testing approach and tools (apuimedo, 14:47:57)
    16. Usage docs should go on kuryr-kubernetes / kuryr-libnetwork (apuimedo, 14:48:58)
    17. specs on openstack/kuryr (apuimedo, 14:49:08)
    18. ACTION: gsagie to get fuxi people on the weekly meetings so that they also participate :-) (apuimedo, 14:55:09)

  4. open discussion (apuimedo, 14:57:41)
    1. ACTION: apuimedo to post the agenda by Thursday and ML reminder so people have time to add items (apuimedo, 14:59:57)


Meeting ended at 15:02:30 UTC (full logs).

Action items

  1. apuimedo, vikas to work out the auth remotedriver-> rpc driver
  2. limao and janonymous to check the rally jobs
  3. vikasc apuimedo to review https://review.openstack.org/#/c/363414/1
  4. apuimedo, vikas to review https://review.openstack.org/363758
  5. apuimedo, devvesa, ivc to come up with a functional testing approach for the gates
  6. apuimedo to check hyperkube for signs of life
  7. apuimedo ask to Kubernetes-dev on Slack :)
  8. devvesa to ask about hyperkube on kubernetes-dev slack
  9. gsagie to get fuxi people on the weekly meetings so that they also participate :-)
  10. apuimedo to post the agenda by Thursday and ML reminder so people have time to add items


Action items, by person

  1. apuimedo
    1. apuimedo, vikas to work out the auth remotedriver-> rpc driver
    2. vikasc apuimedo to review https://review.openstack.org/#/c/363414/1
    3. apuimedo, vikas to review https://review.openstack.org/363758
    4. apuimedo, devvesa, ivc to come up with a functional testing approach for the gates
    5. apuimedo to check hyperkube for signs of life
    6. apuimedo ask to Kubernetes-dev on Slack :)
    7. apuimedo to post the agenda by Thursday and ML reminder so people have time to add items
  2. devvesa
    1. apuimedo, devvesa, ivc to come up with a functional testing approach for the gates
    2. devvesa to ask about hyperkube on kubernetes-dev slack
  3. janonymous
    1. limao and janonymous to check the rally jobs
  4. limao
    1. limao and janonymous to check the rally jobs
  5. openstack
    1. vikasc apuimedo to review https://review.openstack.org/#/c/363414/1
    2. apuimedo, vikas to review https://review.openstack.org/363758
  6. vikasc
    1. vikasc apuimedo to review https://review.openstack.org/#/c/363414/1


People present (lines said)

  1. apuimedo (174)
  2. devvesa (28)
  3. tonanhngo (19)
  4. irenab (16)
  5. vikasc (8)
  6. ivc_ (7)
  7. limao (5)
  8. janonymous (5)
  9. openstack (3)
  10. flaper87 (1)
  11. pablochacin (1)


Generated by MeetBot 0.1.4.