#openstack-meeting-4: kuryr

Meeting started by apuimedo at 15:01:07 UTC (full logs).

Meeting summary

    1. banix, gsagie, fawadkhaliq, salv-orlando, irenab and apuimedo in the meeting (apuimedo, 15:02:48)

  1. design summit logistics (apuimedo, 15:03:46)
    1. https://etherpad.openstack.org/p/kuryr-design-summit (apuimedo, 15:03:54)
    2. fishbowl and work session slots are 40 minute (apuimedo, 15:07:06)
    3. ACTION: gsagie to prepare a proposal/email to the ops list detailing what we'd like to show and try to get some feedback (apuimedo, 15:09:35)
    4. ACTION: gsagie to send the rooms request. Last chance today for people to add stuff to the etherpad :-) (apuimedo, 15:15:00)

  2. Kubernetes integration (apuimedo, 15:15:30)
    1. https://review.openstack.org/#/c/281132/ (apuimedo, 15:16:01)
    2. ACTION: apuimedo to send API watcher as devref (apuimedo, 15:21:51)
    3. ACTION: devvesa to send CNI driver as devref (apuimedo, 15:22:02)
    4. ACTION: all to review the current spec (apuimedo, 15:22:13)

  3. VM-nested containers (apuimedo, 15:23:01)
    1. https://review.openstack.org/#/c/269039/9/doc/source/specs/mitaka/nested_containers.rst (apuimedo, 15:24:27)
    2. ACTION: apuimedo and all to review the spec! (apuimedo, 15:25:35)
    3. https://blueprints.launchpad.net/kuryr/+spec/kuryr-agent (fawadkhaliq, 15:26:02)
    4. ACTION: fawadkhaliq report on vlan aware VMs progress to the ML (apuimedo, 15:29:51)
    5. OVN binding profile mechanism http://docs.openstack.org/developer/networking-ovn/containers.html (fawadkhaliq, 15:31:27)
    6. https://review.openstack.org/273954 (apuimedo, 15:31:52)
    7. https://review.openstack.org/279253 (apuimedo, 15:32:10)

  4. Existing network reuse (apuimedo, 15:32:56)
    1. https://wiki.openstack.org/wiki/Meetings/Kuryr#Meeting_February_29.2C_2016 (apuimedo, 15:34:06)
    2. ACTION: : banix to work on using name to have it working like right now (apuimedo, 15:44:42)
    3. ACTION: : banix to continue investigation of replacing it with description/tags/kv for release time (apuimedo, 15:45:24)

  5. Packaging (apuimedo, 15:46:34)
    1. https://github.com/celebdor/rdo-kuryr (apuimedo, 15:47:14)
    2. https://github.com/openstack-packages/kuryr (apuimedo, 15:47:45)
    3. https://review.openstack.org/#/c/279320/ (apuimedo, 15:49:56)
    4. https://blueprints.launchpad.net/kolla/+spec/kuryr-docker-plugin (Hui, 15:52:36)
    5. https://blueprints.launchpad.net/kolla/+spec/kuryr-docker-plugin (apuimedo, 15:52:46)

  6. Rally and fullstack integration (apuimedo, 15:52:59)
    1. https://review.openstack.org/#/c/265105/ (gsagie, 15:53:29)
    2. https://review.openstack.org/#/c/265105/ (apuimedo, 15:53:38)
    3. ACTION: apuimedo review https://review.openstack.org/#/c/265105/ (apuimedo, 15:53:48)
    4. ACTION: gsagie to check the patch to try to dig out the issues (apuimedo, 15:54:11)
    5. : as we start implementing specs (like re-using neutron nets) please, add integration tests (apuimedo, 15:55:02)

  7. community and other topics (apuimedo, 15:55:21)
    1. http://ons2016.sched.org/event/67nA/container-based-dynamic-service-chain-using-distributed-sdn-pipeline-injection-openstack-dragonflow-kuryr-eshed-gal-or-huawei?iframe=yes&w=&sidebar=yes&bg=no#?iframe=yes&w=i:100;&sidebar=yes&bg=no (gsagie, 15:55:50)
    2. http://ons2016.sched.org/event/67nA/container-based-dynamic-service-chain-using-distributed-sdn-pipeline-injection-openstack-dragonflow-kuryr-eshed-gal-or-huawei?iframe=yes&w=&sidebar=yes&bg=no#?iframe=yes&w=i:100;&sidebar=yes&bg=no (apuimedo, 15:55:55)
    3. ACTION: gsagie apuimedo to add to the next meeting agenda bug scrubbing (apuimedo, 15:58:32)


Meeting ended at 16:01:05 UTC (full logs).

Action items

  1. gsagie to prepare a proposal/email to the ops list detailing what we'd like to show and try to get some feedback
  2. gsagie to send the rooms request. Last chance today for people to add stuff to the etherpad :-)
  3. apuimedo to send API watcher as devref
  4. devvesa to send CNI driver as devref
  5. all to review the current spec
  6. apuimedo and all to review the spec!
  7. fawadkhaliq report on vlan aware VMs progress to the ML
  8. : banix to work on using name to have it working like right now
  9. : banix to continue investigation of replacing it with description/tags/kv for release time
  10. apuimedo review https://review.openstack.org/#/c/265105/
  11. gsagie to check the patch to try to dig out the issues
  12. gsagie apuimedo to add to the next meeting agenda bug scrubbing


Action items, by person

  1. apuimedo
    1. apuimedo to send API watcher as devref
    2. apuimedo and all to review the spec!
    3. apuimedo review https://review.openstack.org/#/c/265105/
    4. gsagie apuimedo to add to the next meeting agenda bug scrubbing
  2. banix
    1. : banix to work on using name to have it working like right now
    2. : banix to continue investigation of replacing it with description/tags/kv for release time
  3. fawadkhaliq
    1. fawadkhaliq report on vlan aware VMs progress to the ML
  4. gsagie
    1. gsagie to prepare a proposal/email to the ops list detailing what we'd like to show and try to get some feedback
    2. gsagie to send the rooms request. Last chance today for people to add stuff to the etherpad :-)
    3. gsagie to check the patch to try to dig out the issues
    4. gsagie apuimedo to add to the next meeting agenda bug scrubbing
  5. openstack
    1. apuimedo review https://review.openstack.org/#/c/265105/
  6. UNASSIGNED
    1. devvesa to send CNI driver as devref
    2. all to review the current spec


People present (lines said)

  1. apuimedo (164)
  2. gsagie (65)
  3. irenab (40)
  4. banix (36)
  5. fawadkhaliq (24)
  6. Hui (10)
  7. salv-orlando (10)
  8. russellb (9)
  9. openstack (3)
  10. Sukhdev (1)


Generated by MeetBot 0.1.4.