03:01:01 <tfukushima> #startmeeting kuryr
03:01:01 <openstack> Meeting started Tue Dec 29 03:01:01 2015 UTC and is due to finish in 60 minutes.  The chair is tfukushima. Information about MeetBot at http://wiki.debian.org/MeetBot.
03:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
03:01:04 <vikasc> meeting is just about to start?
03:01:05 <openstack> The meeting name has been set to 'kuryr'
03:01:05 <vikasc> o
03:01:09 <vikasc> got it
03:01:11 <vikasc> :)
03:01:14 <baohua> :)
03:01:16 <fawadkhaliq> hello
03:01:21 <gsagie_> Hello all :)
03:01:21 <vikasc> hi
03:01:38 <tfukushima> Who's up for Kuryr IRC meeting?
03:01:56 <gsagie_> o/
03:02:16 <fawadkhaliq> o/
03:02:30 <vikasc> o/
03:02:33 <baohua> o/
03:03:16 <tfukushima> #info gsagie_, fawadkhaliq, vikas, baohua and tfukushima present
03:03:49 <tfukushima> I'm on vacation and it seems we don't have the agenda today.
03:04:09 <tfukushima> Let me see the topics presented in the last meeting.
03:04:25 <tfukushima> #topic IPAM
03:04:56 <gsagie_> tfukushima: IPAM has been merged i believe, anyone managed to test it out instead of visas?
03:05:02 <gsagie_> vikasc
03:05:10 <gsagie_> beside vikasc that is :)
03:05:46 <vikasc> I have address Banix comments on one patch, https://review.openstack.org/#/c/256211/
03:06:01 <vikasc> rest of the patches have been reviewd and w+1
03:06:41 <gsagie_> ok cool, we will want to add some full stack tests to it once the basic is merged
03:06:50 <gsagie_> so we can test it in the gate
03:06:53 <vikasc> gsagie_,  makes sense
03:07:11 <gsagie_> its not directly related to this, but:
03:07:11 <vikasc> gsagie_,  i will be working on that
03:07:12 <gsagie_> #info OVS unbind patch got merged - https://review.openstack.org/#/c/259888/
03:07:46 <gsagie_> banix: ping?
03:08:40 <tfukushima> I can't see him online.
03:09:11 <gsagie_> tfukushima: you have a patch describing IPAM for debrief https://review.openstack.org/#/c/248010/
03:09:34 <gsagie_> devref
03:09:42 <gsagie_> its still WIP
03:10:02 <tfukushima> Yes, but it should be reviewed and updated by vikasc.
03:10:27 <tfukushima> Because it's not based on the implementation of vikasc.
03:10:32 <vikasc> tfukushima, gsagie_  Will be doing shortly.
03:10:44 <gsagie_> okie great :)
03:11:50 <tfukushima> #action vikasc review and update IPAM devref patch by tfukushima
03:11:54 <gsagie_> Think we can move to testing
03:12:08 <tfukushima> #topic Testing
03:12:24 <tfukushima> gsagie_: How's it going?
03:13:04 <gsagie_> there is one patche that is somehow "hacky" that is needed for the gate tests, https://review.openstack.org/#/c/259744/
03:13:29 <gsagie_> basically we need to retrieve the Neutron client credentials for the gate as they aren't populated, i have added a bug for me to work on that part
03:13:51 <gsagie_> but i think its best we get this merged and keep iterating it on parallel so people can start adding full stack tests
03:14:18 <vikasc> +1 gsagie_
03:14:23 <gsagie_> once this is merged, this https://review.openstack.org/#/c/259751/  adds some basic tests for networks
03:14:38 <gsagie_> and we can continue testing actual containers deployment after, pinging each other
03:14:58 <gsagie_> I do also plan to present a Rally plugin/context for docker, maybe put an action on me for that
03:15:27 <gsagie_> baohua: banix told me you are also looking at CI/gate/testing, can you elaborate what are your efforts?
03:15:39 <gsagie_> maybe we can sync up :)
03:15:43 <baohua> yes,+1
03:16:03 <baohua> i'm looking at the tempest and rally these days, we can work together on it
03:17:09 <gsagie_> baohua: have you seen my patches? i think the Neutron client and docke client are enough for our first stage of full stack testing
03:17:42 <baohua> just assgined myself as the reviewer, i will check your patch today :)
03:17:50 <gsagie_> We do need to make sure that we can access the container using the Docker client and issue commands, what seems to be possible
03:17:53 <gsagie_> ok great :)
03:18:20 <baohua> think it should work
03:19:08 <tfukushima> #action gsagie_ and baohua have the syncup for the testing
03:19:41 <gsagie_> maybe also for me to present Rally plugin for Docker
03:20:16 <tfukushima> #action gsagie_ has the Rally plugin for Docker
03:20:33 <gsagie_> tfukushima: did apuimedo update you regarding his capabilities research?
03:20:36 <gsagie_> :)
03:20:52 <tfukushima> #topic Capabilities
03:21:17 <tfukushima> No, not yet. I was on vacation and so he is now, I guess.
03:21:47 <tfukushima> #action apuimedo updates about the capability  research
03:22:11 <tfukushima> #topic Kubernetes integration
03:22:41 <gsagie_> irenab started an etherpad, you have the link Taku ? (as i am not at the office)
03:23:03 <tfukushima> gsagie_: Actually not yet.
03:23:21 <gsagie_> ok, i will post it to the mailing list
03:23:33 <vikasc> gsagie_,  that will be great. Thanks
03:23:48 <tfukushima> #action gsagie_ posts the link of the Kubernetes networking on the mailing list
03:23:49 <gsagie_> tfukushima: any progress on how to model k8 networking to Neutron?
03:24:23 <tfukushima> I and she started looking at the Kubernetes networking model and how we possibly could leverage Kuryr for that.
03:25:30 <tfukushima> I think we can create some random networks, subnets and ports associated with the pod container but the networking model of Kubernetes differs from the Neutron model and we need to think about it well.
03:26:32 <gsagie_> tfukushima: what if we create local networks for each compute node and connect them all using a router?
03:26:39 <gsagie_> local network
03:27:08 <gsagie_> This is of course a temporary solution, until and if Kubernetes support libnetwork
03:27:21 <tfukushima> That's what we would try but we started by the single Kuberntes node where a master and a minion reside.
03:28:25 <tfukushima> I tried the cluster with the multiple nodes on GCP but the default configuration allowed me only to launch Debian VM instances and I needed the Ubuntu ones.
03:28:27 <gsagie_> ok, maybe we should also get banix opinion on that as  believe he has some experience with that integration
03:29:18 <tfukushima> #action tfukushima asks banix about the Kubernetes integration.
03:29:46 <gsagie_> fawadkhaliq: have you guys thought about Kubernetes integration with IOVisor?
03:29:59 <gsagie_> or vikasc
03:30:25 <fawadkhaliq> there has been some discussions but nothing concrete yet
03:30:33 <fawadkhaliq> I will share once there is more
03:30:52 <vikasc_> gsagie_,  I have not tried k8 or swarm with kuryr yet.
03:30:55 <gsagie_> okie
03:31:06 <gsagie_> Swarm is suppose to work according to banix last update
03:31:15 <gsagie_> he promised a demo:)
03:31:16 <vikasc_> gsagie_, yes
03:31:21 <vikasc_> :)
03:31:22 <vikasc_> yes
03:31:44 <vikasc_> gsagie_, I also wanted to try once myself
03:32:03 <gsagie_> ok cool, important you also do that
03:32:10 <gsagie_> i will try to find time myself
03:32:15 <gsagie_> aswell
03:32:21 <tfukushima> #link Kubernets networking model http://kubernetes.io/v1.1/docs/admin/networking.html
03:32:22 <vikasc_> gsagie_, that will be great
03:32:38 <vikasc_> thanks for the link tfukushima
03:32:41 <gsagie_> thanks tfukushima!
03:32:54 <tfukushima> It doesn't say much though.
03:32:59 <vikasc_> :)
03:33:00 <gsagie_> maybe also add the one that describe the binary pluggable script
03:33:29 <tfukushima> #link Kubernetes networking plugin "spec" https://godoc.org/github.com/kubernetes/kubernetes/pkg/kubelet/network/exec
03:33:40 <baohua> seems k8s is flexible in underly networking. only have to consider its service ip
03:33:41 <vikasc_> i think exploring k8 integration should have priority over swarm
03:34:23 <baohua> agree, k8s is more complicated than swarm
03:34:32 <gsagie_> vikasc_ : Swarm is already working (supposedly) Kubernetes is our next priority
03:34:38 <vikasc_> magnum also focussing more on k8s
03:34:43 <vikasc_> gsagie_, true
03:35:50 <gsagie_> ok think we can move to Kolla and packaging
03:35:52 <vikasc_> gsagie_,  we  should focus on k8 integration then and wait for banix demo :)
03:36:17 <gsagie_> but i think apuimedo and devvesa need to update on that
03:37:23 <tfukushima> #topic Kolla  and packaging
03:38:01 <gsagie_> Anyone that is here has anything to add on this?
03:39:45 <tfukushima> I don't think so and let's move to the next topic.
03:39:54 <tfukushima> #topic Magnum
03:40:30 <tfukushima> Who's working on Magnum now?
03:41:03 <gsagie_> no one currently, we decided to work on Kubernetes integration first, but you can put an action on me to write a design about this integration and what is needed
03:41:35 <gsagie_> i have to go :) see you all
03:41:41 <kexiaodong> Magnum can only deploy k8s on virtualMachine.
03:42:28 <tfukushima> #action gsagie_ investigates about Magnum integration possibilities and writes the design
03:42:28 <gsagie_> kexiaodong: yes, we are now focusing on Kubernetes bare meta deployments, we will need to integrate with nested containers and Magnum as a driver which is a design i will start writing
03:44:03 <kexiaodong> ok
03:44:29 <tfukushima> Let's see what we can do after seeing the networking plugin for K8s maybe.
03:45:19 <tfukushima> Ok, let's wrap up earlier because we're going to have the year end and the new year.
03:45:24 <tfukushima> #topic Open Discussion
03:45:44 <tfukushima> Does anyone have any topics to be shared?
03:47:48 <tfukushima> Kuryr was born this year and it's still like four - five months since then. We have contributors, meeting and the code working.
03:48:26 <tfukushima> Great job everyone and hope Kuryr would have more advances in the next year.
03:48:45 <kexiaodong> Nice summary.
03:49:00 <tfukushima> I'm trying :-p
03:49:04 <baohua> great project and contributors :)
03:49:52 <tfukushima> I wish everyone has the nice year end and the new year.
03:50:44 <tfukushima> The next meeting is scheduled Jan 4th next week,
03:51:20 <tfukushima> so see you there and have nice year end again.
03:51:50 <tfukushima> That's it. Anyone wants to add more?
03:52:03 <baohua> just +1 :)
03:52:33 <tfukushima> Alright, I'm closing the meeting.
03:52:40 <tfukushima> #endmeeting