15:00:44 <apuimedo> #startmeeting kuryr
15:00:45 <openstack> Meeting started Mon Dec  7 15:00:44 2015 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:49 <openstack> The meeting name has been set to 'kuryr'
15:00:56 <apuimedo> Hello kuryrs!
15:00:57 <gsagie> Hello
15:00:59 <fawadkhaliq> o/
15:01:07 <apuimedo> welcome to another weekly meeting
15:01:13 <apuimedo> who's here for the show?
15:01:24 <gsagie> hi carl_baldwin :)
15:02:02 <carl_baldwin_> gsagie: hi
15:02:28 <banix> hi
15:03:20 <banix> I unfortunately have to leave in 10-15 minutes but will catch up from the log
15:04:10 <apuimedo> #info gsagie fawadkhaliq, banix and apuimedo present
15:04:18 <apuimedo> thanks all for joining
15:04:27 <apuimedo> we've seen quite a bit of cleanups this week
15:04:33 <apuimedo> and some new committers
15:04:36 <apuimedo> :-)
15:04:41 <apuimedo> #topic binding
15:04:51 <apuimedo> banix: since you have to go early
15:05:00 <apuimedo> you have the floor
15:05:19 <banix> apuimedo: thanks. I think the basic OVS is there and working; should get merged soon.
15:05:34 <gsagie> Hello raofei! :)
15:05:41 <banix> we may need some rework in particular wrt use of vif_type
15:06:09 <irenab> hi! sorry for being late
15:06:20 <banix> I believe the vif_type can be the same for different plugs, for example ovs and hybrid_ovs
15:06:28 <gsagie> hi irenab
15:06:37 <banix> but I will double check and see how we can deal with that
15:06:41 <fawadkhaliq> banix: absolutely
15:06:52 <apuimedo> agreed banix . Looks good to me
15:07:21 <banix> that’s all on binding (well, plug/unplug :) )
15:07:24 <apuimedo> I just did +2
15:07:43 <apuimedo> #info https://review.openstack.org/#/c/253285/ is ready for a final round of reviews and merging
15:07:45 <apuimedo> :-)
15:07:55 <apuimedo> #topic configuration
15:08:01 <banix> i think jenkins may fail on pep8 i am afraid
15:08:12 <banix> keep your +2s coming if i respin. thanks
15:08:22 <banix> configuration also seems ready
15:08:38 <banix> had to do a couple of rebase; hopefully can get it merged today
15:08:41 <apuimedo> banix: https://review.openstack.org/#/c/251532/ already has the change for pep8?
15:09:01 <banix> yes
15:09:30 <apuimedo> good
15:09:32 <banix> but i see one of my two patches failing on pep8 i think it is the OVS one but I will chase that in couple of hours
15:09:42 <apuimedo> very well
15:09:45 <gsagie> yeah configuration should be good to merge, just small pep8 error
15:10:16 <banix> gsagie: yes, already fixed that in the latest patch
15:10:16 <apuimedo> #info https://review.openstack.org/#/c/251532/ is ready for a final round & merging
15:10:42 <apuimedo> #action get configuration management merged today
15:11:11 <apuimedo> #topic existing networks reuse
15:11:27 <apuimedo> tfukushima pushed the spec today
15:11:35 <apuimedo> did anybody have the chance to review it already?
15:11:50 <apuimedo> I see irena did
15:11:53 <apuimedo> #link https://review.openstack.org/#/c/254005/
15:12:08 <gsagie> #link https://blueprints.launchpad.net/kuryr/+spec/existing-neutron-network
15:12:14 <apuimedo> #action all to review https://review.openstack.org/#/c/254005/
15:12:29 <banix> I think both of my patches are ok. the pep8 error was from a different patch.
15:12:32 <apuimedo> #link https://gist.github.com/tfukushima/e7a481b71ef817ec11a1
15:12:35 <gsagie> yeah we need to review some patches from Vikas as well
15:12:38 <irenab> apuimedo: few chapters are more discussion than spec.
15:12:39 <apuimedo> banix: good to know
15:12:59 <gsagie> they are starting to pile up
15:13:04 <apuimedo> gsagie: agreed
15:13:05 <gsagie> i will spend tommorow doing reviews
15:13:15 <apuimedo> #topic ipam
15:13:39 <apuimedo> gsagie: irenab: how closely have you followed it? I couldn't check ipam since last wednesday
15:13:56 <apuimedo> I understand now they are split into more consumable pieces
15:14:16 <gsagie> apuimedo: havent looked at it close enough, but plan to review it all tommorow
15:14:20 <irenab> apuimedo: will have to review it again, did some cycles before
15:14:44 <apuimedo> #action all to review the IPAM patches
15:14:55 <apuimedo> #link https://review.openstack.org/#/c/252848/
15:15:02 <apuimedo> #link https://review.openstack.org/#/c/252835/
15:15:07 <apuimedo> #link https://review.openstack.org/#/c/252835/
15:15:26 <fawadkhaliq> apuimedo: ack
15:15:28 <apuimedo> anything more about ipam?
15:15:34 <gsagie> btw, i do see that OVS plug/unplug has no unbinding implemented
15:15:43 <apuimedo> although we are all missing an up to date view on the state :P
15:16:22 <apuimedo> heh, that's true gsagie
15:16:24 <apuimedo> :O
15:16:26 <apuimedo> :O
15:16:28 <apuimedo> :O
15:16:30 <apuimedo> How did I miss it
15:16:35 <gsagie> lets merge it and i will add another patch to fix it
15:16:37 <apuimedo> must be how much I really want this in
15:16:43 <apuimedo> agreed
15:16:48 <apuimedo> gsagie: please, do the honors
15:17:07 <gsagie> done
15:17:07 <apuimedo> #topic testing
15:17:16 <apuimedo> gsagie: you have the floor
15:17:55 <gsagie> I have started playing with docker-py which seems to have most of what we need, i still need to check how exacly to run pings from the container to test connectivity but from the look it should support it
15:18:05 <gsagie> i do have some strange problem with docker but hopefully a restart will fix it
15:19:07 <gsagie> I am trying to figure out if we can at first stage add these functional tests to the gate, and in a next step add them to Rally. i have some understanding how Rally works. dont think there will be any problem adding Kuryr stuff to it
15:19:45 <apuimedo> gsagie: I'm okay with a multi stage appraoch
15:19:50 <gsagie> so at this point i am mostly going to start creating functional tests that uses Neutron client and the docker client (like creating networks, creating containers and checking everything is added in Neutron correctly)
15:19:56 <apuimedo> #info gsagie proposes adding functional tests to the gate
15:20:29 <apuimedo> #info gsagie proposes to work in parallel in adding tests to rally
15:20:29 <gsagie> then we might also want to run these tests with multiple Neutron plugins
15:20:39 <gsagie> apuimedo: #action..
15:20:52 <fawadkhaliq> gsagie: are we adding Kuryr to Rally or Rally plugin to Kuryr?
15:20:53 <gsagie> ohhh yeah its info :)
15:20:54 <apuimedo> gsagie: action after discussion :P
15:20:54 <gsagie> sorry
15:21:13 <apuimedo> fawadkhaliq: we should try for a plugin approach if it is feasible
15:21:19 <apuimedo> do you have experience with it, fawadkhaliq ?
15:21:23 <fawadkhaliq> +1
15:21:23 <gsagie> fawadkhaliq : we can do both
15:21:38 <irenab> gsagie: what is multiple plugins?
15:21:43 <gsagie> i think it will be better to manage it inside Kuryr, as long as its ok with the Rally people
15:21:51 <gsagie> irenab: Neutron backends..
15:21:54 <fawadkhaliq> we can do both. both should work. Plugin would be better.
15:21:59 <irenab> gsagie: ml2?
15:22:08 <gsagie> irenab: like midonet, OVS ...
15:22:15 <fawadkhaliq> perhaps we should check with Rally team what's recommended? I can take that up?
15:22:18 <apuimedo> I agree that plugin should be better
15:22:23 <irenab> two neutrons or one neutron with multiple backends?
15:22:45 <gsagie> irenab: just few jobs, one for each backend, but its just a proposal to look in the future..
15:22:48 <apuimedo> #action gsagie to go to the ml so we can discuss the topic with rally people
15:23:09 <irenab> gsagie: any bug/bp you track the work for testing?
15:23:12 <gsagie> okie, will present the question
15:23:21 <gsagie> irenab: not yet, will add
15:23:46 <apuimedo> cool
15:23:52 <apuimedo> thanks gsagie
15:24:05 <gsagie> I think we can manage it with bugs, or do you prefer a bp?
15:24:05 <irenab> gsagie: I woud suggest to add basic infra for tests, so more tests can be pushed in parallel
15:24:20 <fawadkhaliq> irenab: +1
15:24:21 <gsagie> irenab: thanks, thats the goal
15:24:31 <apuimedo> gsagie: bugs for requesting and defining tests, bp for the
15:24:34 <gsagie> building the base class
15:24:42 <apuimedo> rally plugin proposal
15:24:48 <irenab> gsagie: no preference, just need some place to raise general comments, not patch specific
15:24:59 <gsagie> apuimedo, irenab: ok
15:25:24 <irenab> apuimedo: +1
15:26:16 <apuimedo> #info test case requests on lp bugs
15:26:36 <apuimedo> #acion gsagie to make a bp about testing
15:26:48 <apuimedo> (not about specific tests)
15:26:56 <apuimedo> anything else about testing?
15:27:00 <gsagie> not from me
15:27:06 <fawadkhaliq> nope
15:27:50 <apuimedo> cool
15:27:57 <apuimedo> #topic capabilities
15:28:54 <gsagie> ajo was checking that?
15:28:59 <gsagie> he is not here
15:29:10 <apuimedo> #action apuimedo to create a proposal for the launcher and capabilities solution
15:29:16 <irenab> apuimedo: can you please explain what it is about?
15:29:19 <apuimedo> gsagie: ajo is only checking it for neutron
15:29:27 <apuimedo> with the launcher I passed him
15:29:36 <apuimedo> neutron agents, sorry
15:29:39 <apuimedo> basically
15:29:48 <apuimedo> the thing is
15:29:54 <apuimedo> there is a launcher coded in C
15:30:03 <apuimedo> that we set with CAP_NET_ADMIN
15:30:23 <apuimedo> so that all our operations that require CAP_NET_ADMIN can be performed
15:30:37 <apuimedo> without us needing to run as root, nor sudo, nor rootwraps
15:30:57 <apuimedo> and not a privileged daemon
15:31:00 <irenab> by us you mean kuryr inoked command?
15:31:06 <apuimedo> yes
15:31:34 <apuimedo> the problem with that is that when we do execve (or rather Python does)
15:32:06 <apuimedo> it may present some problems with the capabilities that arrive to the binding shell scripts
15:32:09 <apuimedo> gotta check
15:32:57 <apuimedo> #action apuimedo to check what happens with binding scripts
15:33:03 <apuimedo> shell is particularly problematic
15:33:41 <apuimedo> any other question?
15:33:44 <irenab> I was trying to see if there is any progress on os vif, but seems no code for review yet.
15:34:25 <irenab> I think we can consider this for later phase and probably see if the approach we choose will work for os vif
15:34:46 <apuimedo> yup
15:35:11 <apuimedo> #topic open discussion
15:35:18 <apuimedo> anybody else with another topic?
15:35:22 <gsagie> not me
15:35:46 <fawadkhaliq> mope
15:35:50 <fawadkhaliq> nope nothing
15:36:08 <irenab> no
15:36:11 <apuimedo> okay then
15:36:15 <gsagie> thanks everyone! and Happy Hannukah irenab ;)
15:36:27 <irenab> gsagie: same same :-)
15:36:30 <fawadkhaliq> Happy Hannukah!
15:36:41 <apuimedo> happy hannukah
15:36:47 <irenab> thanks guys
15:36:51 <apuimedo> and thanks all for joining
15:36:53 <apuimedo> #endmeeting