15:00:43 <apuimedo> #startmeeting kuryr
15:00:44 <openstack> Meeting started Mon Oct  5 15:00:43 2015 UTC and is due to finish in 60 minutes.  The chair is apuimedo. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:48 <openstack> The meeting name has been set to 'kuryr'
15:00:56 <diga> o/
15:01:08 <apuimedo> Welcome to the Kuryr weekly meeting
15:01:15 <apuimedo> I hope you all had a nice weekend
15:01:18 <apuimedo> :-)
15:01:28 <apuimedo> Who's here? I see diga and gsagie
15:01:32 <banix> o/
15:01:39 <tfukushima> o/
15:01:45 <dane_leblanc> o/
15:02:02 <feisky> o/
15:02:32 <feisky> first time to join, thanks to gsagie
15:02:47 <diga> apuimedo: gsagie : today my company officially granted me to put 50% of my time to Kuryr & Openstack
15:03:00 <gsagie> diga: thats great
15:03:11 <diga> gsagie: Thanks
15:03:23 <apuimedo> #info gsagie diga banix tfukushima dane_leblanc feisky present
15:03:35 <apuimedo> diga: cool ;-)
15:03:45 <diga> apuimedo: gsagie :Now I can work dedicately on kuryr :)
15:03:59 <apuimedo> glad to read that
15:04:13 <diga> :)
15:04:22 <apuimedo> #topic demo
15:04:34 <apuimedo> hi VikasC, joining the meeting?
15:05:07 <apuimedo> tfukushima: please, update us on the progress with the demo on Kilo (and the ever going changes in IPAM in docker experimental)
15:05:12 <gsagie> VikasC: saw the vagrant patch, looks very interesting, will review it tommorow
15:05:38 <apuimedo> still needs some work on enabling kuryr IIRC
15:05:53 <VikasC> gsagie:  Thanks
15:06:11 <VikasC> apuimedo:  Hi
15:06:25 <tfukushima> I tried my code run against Kilo + Docker 1.9.0 and I confirmed it worked appropriately after some modifications.
15:06:56 <gsagie> apuimedo: feisty would like to start working on the OVS VIF binding starting tomorrow, will provide some help and hopefully we can start working on it basted on Taku's patch
15:06:57 <apuimedo> tfukushima: so I guess we pin to Kilo and Docker 1.9.0 for the demo
15:06:59 <tfukushima> With subnetpool supports.
15:07:07 <banix> tfukushima: can you explain what you plan to demo please
15:07:11 <apuimedo> nice to hear
15:07:29 <apuimedo> banix: the demo is having kuryr on two hosts
15:07:33 <gsagie> feisky
15:07:40 <apuimedo> and having the containers communicate
15:07:47 <apuimedo> being on the same neutron network
15:08:19 <tfukushima> It's going to be very simple first. Create the default subnetpool in advance, create a network, launch two Docker containers and attach them to the tow services.
15:08:38 <tfukushima> They can talk each other because they're in the same subnet.
15:08:47 <VikasC> tfukushima:  tow services?
15:09:15 <tfukushima> Two endpoints in CNM term. But they're "services" in the Docker CLI.
15:09:18 <apuimedo> VikasC: it's a docker network construct
15:09:23 <banix> how do you create the network? on one of the nodes?
15:09:38 <VikasC> apuimedo:  ok..
15:09:59 <feisky> tfukushima: will the demo show multiple networks?
15:10:57 <apuimedo> banix: both hosts should start the docker daemon pointing to the same kv store
15:11:08 <tfukushima> We'll have the multiple subnets to show the connectivity separation but I'm not planning to show the multiple networks so far.
15:11:10 <apuimedo> I guess that with Taku we'll try it with zookeeper
15:11:29 <tfukushima> I really want to show the quick demo here but my env is suffered from the networking issue.
15:11:32 <apuimedo> so that the networks created on one host are visible on the others
15:11:49 <feisky> tfukushima: ok
15:11:56 <apuimedo> tfukushima: we can do it later this week, sending an invite
15:12:04 <banix> apuimedo: ok, so that part is not in tree as of now. correct?
15:12:21 <apuimedo> banix: that's just a matter of how you start the docker daemon
15:12:27 <apuimedo> but it is not documented in the repo
15:12:55 <apuimedo> #info for the multinode demo, the docker hosts use the same kv-store when starting the docker daemon
15:12:59 <banix> you mean by specifying the kvstore?
15:13:22 <apuimedo> banix: yes
15:13:59 <apuimedo> #action apuimedo tfukushima to test kvstore with zookeeper
15:14:12 <banix> apuimedo: I thought the driver needs to explicitly use the store but it seems, that is not hte case and libnetwork takes care of that. Is this correct?
15:14:25 <gsagie> apuimedo: zookeeper is because midonet already uses zookeeper? because it seems etcd might be simpler
15:14:43 <apuimedo> gsagie: it's because we already have it running in the demo image :P
15:14:51 <gsagie> ok :)
15:15:04 <apuimedo> banix: exactly. the driver is not interacting with it, libnetwork does
15:15:14 <apuimedo> at least, that's my understanding of it
15:15:29 <banix> apuimedo: ok thanks; tfukushima you agree?
15:16:29 <tfukushima> Yes.
15:17:12 <apuimedo> tfukushima: any other demo update?
15:17:22 <apuimedo> feisky: what's your tz?
15:17:56 <gsagie> she is from china i believe
15:18:03 <apuimedo> ok
15:18:21 <gsagie> i will assist her with the OVS VIF binding if she will need help
15:18:31 <tfukushima> Not so much. The big new is subnetpool worked nicely.
15:18:34 <apuimedo> feisky: so please, be in #openstack-neutron so we can all work on the demo ;-)
15:18:55 <tfukushima> Regarding the IPAM, there was the big change in libnetwork API but let's talk that later.
15:18:56 <feisky> apuimedo: CST
15:18:56 <apuimedo> #info subnetpool usage works. Thanks Taku!
15:19:19 <feisky> apuimedo: I have join #openstack-neutron
15:19:33 <apuimedo> #topic milestone 1B (Connect to existing networks)
15:20:10 <apuimedo> I remind the newcomers that this sub-milestone depends on us getting the mapping from either docker labels or storing it in tags in Neutron
15:20:30 <banix> apuimedo: is there a place where milestones are kept? can you provide the link please
15:21:06 <apuimedo> banix: heh... Good point. I keep them in my laptop. I'll put them on the wiki tonight.
15:21:06 <gsagie> apuimedo: the tags spec is still up there, i hope there will be an agreement for Mitaka but it will probably take time to get it merged into Neutron anyway
15:21:07 <feisky> gsagie: not she please
15:21:21 <gsagie> feisky: ohh sorry
15:21:23 <apuimedo> feisky: gsagie: we don't judge :P
15:21:35 <gsagie> :)
15:21:38 <apuimedo> #action apuimedo to update milestone information in the wiki
15:21:53 <banix> and the labels now I doubt that will get in 1.9
15:22:12 <apuimedo> banix: most likely not
15:22:22 <gsagie> apuimedo : feisky also had a good point, do we want to have a TODO list for new contributors that want to take on tasks, or is that something that is managed only using the blue prints?
15:22:26 <tfukushima> :-(
15:22:48 <apuimedo> gsagie: we do
15:22:57 <apuimedo> we need a low hanging fruit section
15:23:08 <apuimedo> for smaller things that do not require blueprints
15:23:10 <gsagie> you can put an action on me, i will update it
15:23:18 <apuimedo> gsagie: thanks
15:23:31 <banix> we need to triage bugs, assign bueprints priority, owner, etc
15:23:35 <apuimedo> #action gsagie to create a low hanging fruit section in the wiki
15:23:47 <apuimedo> banix: perfectly agreed
15:24:06 <gsagie> banix: yeah, there are also two related specs in Neutron that are "part of" Kuryr, the tags to resources and port forwarding which i am trying to propose
15:24:12 <feisky> I see https://blueprints.launchpad.net/kuryr has no been updated for a long time
15:24:19 <apuimedo> banix: tfukushima: gsagie: what are your thoughts on taking the current patch for the network labels
15:24:24 <apuimedo> and test against that
15:24:30 <banix> and we can have low hanging features/fixes tracked on launchpad.. wikis go out od date more quickly
15:24:32 <apuimedo> (after the summit)
15:24:47 <apuimedo> I don't foresee the network labels interface to change
15:24:55 <gsagie> apuimedo: if we want to support pre-allocation of ports, we can use binding_profile
15:25:09 <gsagie> currently in Neutron
15:25:21 <apuimedo> gsagie: aka the ovn trick?
15:25:25 <banix> apuimedo: I am going to see if I can get an updated version of the patch; i think we should try to port it
15:25:26 <gsagie> apuimedo: yep
15:25:56 <apuimedo> my preference is to try to use the updated version of the patch that banix will try to get
15:25:56 <gsagie> at least as a place holder until either tags or labels are merged
15:26:07 <gsagie> k
15:26:15 <apuimedo> and use labels/binding profile as a second/third option
15:26:37 <apuimedo> #aciton banix to try to get a docker x86_64 build with the network labels patch
15:26:49 <apuimedo> #action banix to try to get a docker x86_64 build with the network labels patch
15:27:08 <apuimedo> feisky: you are right on that
15:27:27 <apuimedo> we all need to be more consistent in our usage of launchpad
15:27:35 <apuimedo> (specially me)
15:28:01 <gsagie> armax: ping
15:28:15 <apuimedo> salv-orl_: I summon you
15:28:20 <feisky> some one should update it's status as consistent with code
15:28:23 <armax> gsagie: pong
15:28:30 <apuimedo> let's see if he is here for the testing quiestions
15:28:31 <salv-orl_> hi
15:28:37 <apuimedo> feisky: I'll do that
15:28:42 <gsagie> armax: wanted to know if there is going to be a design session time for Kuryr in Neutron
15:29:03 <salv-orl_> gsagie: how much are you willing to pay ;)
15:29:10 <apuimedo> salv-orl_: did you have some time in the last week to do "salv-orlando to chat with the infra people about running func tests
15:29:12 <apuimedo> there"
15:29:14 <salv-orl_> armax should put slots to auction
15:29:24 <salv-orl_> yes. Basically the bottom line is
15:29:29 <apuimedo> salv-orl_: I can pay in salmiakki
15:29:39 <gsagie> salv-orl_ : are you going to run the auction? ;) i might just pay you
15:29:39 <apuimedo> oh great
15:29:40 <salv-orl_> if we have a devstack way to do that, we can do it
15:29:43 <apuimedo> #topic testing
15:29:44 <armax> gsagie: I am working on the summit session but I doubt the project gets an entire slot
15:29:49 <salv-orl_> but it better be through a devstack plugin
15:30:01 <salv-orl_> otherwise we need to talk and it's a long process as we need modified images
15:30:16 <armax> I will send an update on a draft of the schedule later this week
15:30:18 <apuimedo> #info we need a devstack plugin for the testing infrastructure
15:30:24 <gsagie> armax: ok thanks
15:30:33 <apuimedo> thanks salv-orl_ ;-)
15:30:50 <salv-orl_> Looking at my kuryr dev env, I think with some work we can setup devstack to make it work, even if it's a bit weird as we use devstack to setup software which is not part of the openstack deployment
15:31:11 <salv-orl_> I won't have time to make progress during this week, but the next one I can see where I can get with devstack
15:31:16 <apuimedo> salv-orl_: agreed. It is a bit weird :P
15:31:28 <apuimedo> very well, thanks salv-orl_ ;-)
15:31:34 <gsagie> I am not too familiar with that, but can we somehow use Rally?
15:31:48 <apuimedo> #action salv-orl_ to try next week to work on devstack integration
15:32:01 <salv-orl_> once you have a VM with docker, kury, neutron, and keystone at least
15:32:06 <salv-orl_> you can use whatever you want
15:32:18 <apuimedo> cool
15:32:37 <apuimedo> gsagie: the sessions you and armax are talking about are Friday's?
15:33:01 <armax> I am not
15:33:33 <gsagie> apuimedo : no, there is a design session which has Neutron slots in it, i was hoping we could get an hour for Kuryr, but i guess its more crowded right now
15:33:51 <gsagie> its starting from the second, or third day of the summit and is happening in parallel i believe
15:33:52 <salv-orl_> fwiw my 2p is that kuryr contributors should probably look for a slot, table, or whatever at the contributor meetup
15:33:54 <apuimedo> sure, but if it were to happen, it's Friday, right?
15:33:55 <armax> if I recall correctly Friday’s sessions are self-organized…
15:33:58 <banix> All Friday sessions are held at the Pokemon Center
15:34:09 <apuimedo> ah, ok
15:34:12 <salv-orl_> it's hard to get a fishbowl session. acceptance rate is very low ;)
15:34:13 <gsagie> Friday is free talks
15:34:22 <apuimedo> ah yes, sorry
15:34:28 <apuimedo> I confused them both :P
15:34:39 <apuimedo> I was to the fishbowl of Nova last time, right
15:34:44 <apuimedo> that was not Friday
15:35:02 <apuimedo> ok. salv-orl_ good point on that
15:35:30 <apuimedo> gsagie: can you look into the contributor meetup option
15:35:44 <apuimedo> otherwise we'll meet as well on Friday in the Neutron and Magnum rooms
15:35:47 <apuimedo> for a while
15:35:57 <apuimedo> #topic Summit
15:36:23 <gsagie> k, np
15:36:23 <apuimedo> I finally have the flight tickets, so Japan, here we go!
15:36:33 <apuimedo> tfukushima: you will be our host ;-)
15:36:58 <gsagie> :)
15:37:15 <apuimedo> #action gsagie to try to scoop up some mini design session / contributor meetup spot
15:37:44 <banix> tfukushima: what is your tz? I thought you were in Cali. No?
15:37:53 <gsagie> Tokyo..
15:37:57 <apuimedo> banix: he lives in Tokyo!
15:38:08 <apuimedo> but he works around the clock lately :P
15:38:13 <tfukushima> I'm in Tokyo.
15:38:23 <tfukushima> Sorry I was recording the quick demo.
15:38:28 <banix> and was visiting you the other time? when we had a hangout? ok makes sense
15:38:39 <apuimedo> tfukushima: you finally got good enough latency?
15:38:49 <tfukushima> Looks so.
15:38:53 <apuimedo> banix: yes, tfukushima was visiting Barcelona back then
15:39:16 <banix> so you are in Barcelona apuimedo ?
15:39:33 <apuimedo> banix: a town nearby, I don't go to Barcelona too often
15:39:45 <apuimedo> Does anybody else have some proposal thought about the summit?
15:40:02 <banix> cool
15:40:27 <apuimedo> we are missing somebody in Austin to contribute to Kuryr to have the next summits covered
15:40:36 <apuimedo> in hosts ;-)
15:40:47 <gsagie> apuimedo: we should probably schedule to all meet sometime either during the summit or after
15:40:59 <gsagie> after "summit working hours"
15:41:20 <apuimedo> gsagie: agreed
15:41:31 <banix> +1
15:41:38 <apuimedo> I don't know Tokyo at all, so I'll defer to tfukushima to suggest some spot ;-)
15:42:10 <tfukushima> Today is not my good networking day. I'm having a trouble to upload my video to Google Drive.
15:42:21 <apuimedo> otherwise I'll propose a Gyudon joint like Yoshinoya
15:42:25 <apuimedo> xD
15:42:35 <tfukushima> #link Kuryr demo public repo https://drive.google.com/open?id=0BwURaz1ic-5tS2RMeV9tQUhrTUE
15:42:49 <apuimedo> so it uploaded finally tfukushima ?
15:43:16 <apuimedo> #topic open floor
15:43:25 <apuimedo> anybody else have anything to bring up?
15:43:34 <tfukushima> #link kuryr demo with the default subnetpool https://drive.google.com/file/d/0BwURaz1ic-5tcnFxSndEVVh3dXc/view?usp=sharing
15:43:49 <banix> We will have a presentation on Monday at the summit
15:43:51 <tfukushima> It takes some time the video is encoded.
15:43:52 <gsagie> i got an email from someone proposing to do alternate IRC meetings, as the meeting time in US is problematic
15:44:22 <apuimedo> banix: Monday?!
15:44:26 <gsagie> thought i will bring it up here
15:44:35 <banix> apuimedo: Tuesday :)
15:44:38 <apuimedo> Didn't it start Tuesday this time
15:44:43 <apuimedo> ah, ok ;-)
15:44:55 <banix> The one on Monday will by at the joint you were mentioning I supose :)
15:44:56 <apuimedo> gsagie: that's a good point
15:45:16 <apuimedo> heh, that wouldn't be bad
15:45:51 <apuimedo> gsagie: did they propose some time?
15:46:08 <apuimedo> I could see a 21:00 utc
15:46:10 <gsagie> Nope, just said that is when he drive the kids to school
15:46:16 <gsagie> Someone from Wallmart
15:46:21 <apuimedo> aha
15:47:18 <apuimedo> who, eghobo?
15:47:29 <apuimedo> gsagie: ^^
15:47:41 <gsagie> Egor Guz
15:48:04 <apuimedo> yup, that's eghobo I think
15:48:08 <gsagie> I think we can do an experiment and have two meetings for some week and see whats the interest we get
15:48:14 <banix> tfukushima: can you post the commend you use to start docker daemon here as well
15:48:16 <apuimedo> agreed
15:48:31 <gsagie> and if there is, we can consider an alternate meetings
15:48:45 <apuimedo> ok
15:48:47 <tfukushima> banix: Actually I didn't do anything special. sudo service docker start.
15:49:06 <apuimedo> banix: it will be special when we use the kv-store flag
15:49:12 <tfukushima> diga: The error we got was due to the daemon was not working correctly.
15:49:17 <banix> tfukushima: ok so you are not using it yet
15:49:20 <gsagie> apuimedo: i will try to find a time slot for next week that fits US time zone
15:49:21 <apuimedo> #action gsagie apuimedo to bring up alternate meetings to the mailing list
15:49:29 <gsagie> okie great :)
15:49:56 <tfukushima> banix: I don't think so.
15:49:56 <apuimedo> anything else?
15:50:17 <tfukushima> libnetwork had the significant change on its IPAM interface for the API.
15:50:28 <tfukushima> #link IPAM change of libnetwork https://github.com/docker/libnetwork/commit/763709cbbdd300e7d7000a2c05942fe529d4627a#diff-a1e90ab5bba3aeb1ec3a46addf5b99ca
15:50:44 <irenab> apuimedo: any news for second phase: containers in VM?
15:50:50 <banix> and the UI is changing as well
15:51:12 <apuimedo> irenab: embargoed until we get the demo. I expect to kickstart it with strength in Tokyo
15:51:12 <tfukushima> banix: Which UI do you mean?
15:51:28 <banix> docker for networking (libnetwork)
15:52:04 <feisky> #tfukushima has this been merged?
15:52:17 <apuimedo> tfukushima: banix: feisky take it to #openstack-neutron!
15:52:19 <apuimedo> ;-)
15:52:24 <apuimedo> #endmeeting