15:15:49 <banix> #startmeeting kuryr
15:15:50 <openstack> Meeting started Mon Sep 14 15:15:49 2015 UTC and is due to finish in 60 minutes.  The chair is banix. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:15:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:15:54 <openstack> The meeting name has been set to 'kuryr'
15:16:07 <banix> Here we fo
15:16:09 <tfukushima> Thanks, banix.
15:16:44 <banix> Gal and Toni don’t seem to be around and I do not see an agenda posted
15:17:22 <banix> Gal is off today. Happy Rosh Hashanah :)
15:17:38 <banix> Anyway let’s have a quick open discussion
15:17:51 <banix> #topic Open Discussion
15:18:11 <tfukushima> We usually discuss our updates e.g., VIF binding and IPAM these days.
15:18:26 <diga> Guys, I am submitting VIF patch with tests & exception tomorrow
15:19:04 <banix> @diga I also left a comment regarding the vif binding
15:19:13 <diga> yes, I saw those
15:19:28 <banix> Is it settled that we want vif binding as binaries?
15:19:40 <diga> yes
15:20:37 <diga> banix : my dad is hospitalized, can I leave early today ?
15:20:50 <banix> diga: yes of course
15:21:00 <diga> Thanks :)
15:21:12 <tfukushima> For IPAM, I updated my patches and now it reuses the existing subnets if it's necessary.
15:21:16 <diga> will ping you tomorrow
15:21:18 <banix> diga: I am sorry to hear that. Hope everything will be alright soon
15:21:31 <banix> salv-orlando: are you still around?
15:21:38 <tfukushima> #link IPAM(CreateEndpoint) https://review.openstack.org/#/c/210052/
15:21:39 <diga> yes, he is getting discharge today
15:21:52 <diga> so I need to take him to the home
15:22:08 <banix> diga: great. yes of course.
15:22:25 <diga> thanks, see you tomorrow
15:22:50 <banix> tfukushima: do you have anything you want to discuss, any reviews?
15:22:57 <banix> I see the link above
15:23:32 <tfukushima> Yeah, I'd appreciate if salv-orlando could take a look at it.
15:23:39 <banix> @tfukushima I will review it today
15:23:42 <tfukushima> Deleting the Docker endpoint also takes care of that model now.
15:23:46 <tfukushima> Thanks, banix.
15:23:57 <tfukushima> #link IPAM(DeleteEndpoint) https://review.openstack.org/#/c/210053/
15:25:03 <banix> I will review all the patches out there today.
15:25:27 <tfukushima> In this model, Kuryr tries to delete the subnets which IDs are contained in the port to be deleted. But if the subnet is still referred from other ports, python-neutronclient would get the exception.
15:26:08 <tfukushima> Kuryr records that and keeps going on.
15:26:18 <banix> @tfukushima I see
15:26:30 <banix> what about when the last port is deleted?
15:26:52 <banix> Wouldn’t a dhcp port prevent the deletion?
15:27:41 <tfukushima> banix: Oh, I might miss that possibility. Could you give me the pointer to DHCP port?
15:28:58 <banix> @tfukushima if we have dhcp enabled (which is what we want in most cases), then a port is created for the dnsmaq to provide dhcp services
15:29:09 <tfukushima> I want to examine if a subnet has any port but it seems there's any good way to achieve that. So I took this nasty approach, try to delete and catch exceptions if it was failed.
15:30:06 <tfukushima> Ok, that sounds my code is flawed.
15:30:08 <banix> you can know if the port is a dhcp port; will leave comment on your patch
15:30:50 <banix> tfukushima: not flawed, may need to be modified a bit
15:32:05 <banix> anything else to discuss now? if not let’s call it a day :)
15:33:24 <apuimedo> tfukushima: sorry for the delay
15:33:37 <banix> #chair apuimedo
15:33:39 <openstack> Current chairs: apuimedo banix
15:33:39 <tfukushima> NP. banix is generously organising the meeting now.
15:33:47 <apuimedo> :-)
15:33:51 <apuimedo> thanks banix
15:33:59 <banix> np
15:34:18 <apuimedo> We're on open discussion already, right?
15:34:29 <banix> apuimedo: we started there :)
15:34:34 <apuimedo> oh, good
15:34:37 <banix> Didn’t see an agenda
15:34:56 <apuimedo> banix: well, it was just reviewing the state after the virtual sprint
15:35:19 <apuimedo> but I propose to go over that tomorrow in #openstack-neutron
15:35:21 <banix> apuimedo: please go ahead with the discussion
15:35:30 <banix> ok
15:35:33 <apuimedo> who's here for the meeting?
15:35:43 <apuimedo> if we are enough we might as well do it now
15:36:02 <banix> i think some may have left
15:36:06 <apuimedo> but I think we don't have much of a quorum
15:36:12 <banix> yeah
15:36:35 <apuimedo> banix: tfukushima: do you have some update that is not yet on the logs of this meeting?
15:36:42 <banix> I will review all the patches
15:36:48 <apuimedo> banix: thanks
15:36:59 <banix> no, i submitted a patch for config, diga can see if useful
15:37:30 <apuimedo> tfukushima: did you submit the delete subnet with the try except approach?
15:37:41 <tfukushima> Yes, I did.
15:38:09 <apuimedo> great
15:38:14 <tfukushima> But banix pointed out that could have some problems when we have DHCP ports.
15:38:35 <apuimedo> IIRC it is configurable whether those prevent subnet deletion
15:38:43 <banix> tfukushima: now i am wondering iof the delete subnet logic has that
15:38:57 <apuimedo> #action apuimedo to review remaining tfukushima patches by 15th
15:39:04 <banix> yes apuimedo that may be the case
15:39:15 <apuimedo> banix: I read that code some time ago
15:39:28 <apuimedo> but I'm almost sure it is now possible
15:39:39 <banix> apuimedo: and I did probably before then :)
15:39:51 <apuimedo> #action tfukushima apuimedo: to check about special ports and subnet/net deletion
15:40:08 <apuimedo> any other topic?
15:40:21 <apuimedo> banix: did you put me as a reviewer to your patch?
15:40:39 <banix> banix: will do if not there
15:41:23 <apuimedo> thanks
15:41:45 <tfukushima> I found new patches as well although I was not added to their reviewers.
15:42:03 <tfukushima> So we need to check out the following link periodically.
15:42:10 <apuimedo> which?
15:42:12 <tfukushima> #link Kuryr patches https://review.openstack.org/#/q/status:open+project:openstack/kuryr,n,z
15:42:56 <apuimedo> tfukushima: right. But people should be proactive in adding reviewers
15:43:05 <apuimedo> I'll keep an eye out though
15:43:09 <apuimedo> since there are no more topics, Thank you all for joining, specially banix for covering for my emergency absense
15:43:18 <apuimedo> #endmeeting