14:59:01 <gsagie_> #startmeeting kuryr
14:59:02 <openstack> Meeting started Mon Aug 31 14:59:01 2015 UTC and is due to finish in 60 minutes.  The chair is gsagie_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:05 <openstack> The meeting name has been set to 'kuryr'
14:59:29 <apuimedo> o/
14:59:34 <tfukushima> o/
14:59:39 <irenab> hi, meanwhile here
14:59:43 <apuimedo> tfukushima: long time no see
14:59:51 <diga> o/
14:59:52 <tfukushima> I had good time.
14:59:54 <gsagie_> tfukushima: wb :)
15:00:23 <daneyon> o/
15:00:31 <gsagie_> hi daneyon
15:00:34 <gsagie_> #topic vif-binding-unbinding
15:00:38 <daneyon> :-)
15:00:45 <tfukushima> gsaigie: Thanks.
15:01:02 <gsagie_> i will press the commands because apuimedo might need to leave in the middle
15:01:15 <apuimedo> thanks for that gsagie_ ;-)
15:01:16 <diga> apuimedo: gsagie_ : irenab : I was on long holiday from last 4 days, will join office tomorrow
15:01:19 <gsagie_> diga, do you have any update where things are standing? do you think we might have something working for the virtual sprint?
15:01:24 <diga> forgot to update you guys
15:01:59 <gsagie_> np diga, hope you had fun.
15:02:20 <diga> I have almost done all the suggested changes, will send that patch for review tomorrow
15:02:37 <gsagie_> next week is the virtual sprint, i think the VIF binding is critical point and we will have to start from where you finish at that point and work on that
15:02:38 <apuimedo> diga: thanks diga
15:02:42 <gsagie_> ok cool
15:03:01 <diga> apuimedo: gsagie_ : welcome
15:03:02 <apuimedo> #action diga to send the vif binding patch with the correnctions on September 1st
15:03:12 <diga> +1
15:03:14 <gsagie_> is there any open issues there?
15:03:21 <banix> hi
15:03:21 <gsagie_> or something that needs help?
15:03:23 <daneyon> can someone add a link to the vif binding review?
15:03:26 <gsagie_> hi banix !
15:03:29 <banix> sorry for being late ….
15:03:41 <diga> not yet, but If I need help, will let know for sure
15:03:58 <gsagie_> #link https://review.openstack.org/#/c/214002/ - vif binding unbinding
15:04:09 <banix> I noticed the reference to executables there
15:04:33 <gsagie_> #action diga, gsagie keep track on the generic VIF binding in Nova
15:04:34 <banix> wasn’t a second approach being advocated by nova people? have we considered that. just raising the question
15:04:38 <daneyon> gsagie_ thanks
15:04:52 <diga> gsagie_: +1
15:05:04 <gsagie_> banix: yeah we are trying to keep track with the work Nova has done on that and we will try to combine or leverage that here
15:05:29 <banix> gsagie_: great
15:05:41 <gsagie_> banix: i will look at that code this week so we will have some inputs
15:05:58 <gsagie_> anything else on that?
15:06:16 <diga> nothing from my side
15:06:27 <gsagie_> #topic ipam
15:06:51 <gsagie_> Taku, i guess you didn't have chance to look at that yet
15:07:06 <tfukushima> No, I didn't.
15:07:16 <tfukushima> Could you give me a bit of its context?
15:07:17 <gsagie_> #link ipam https://blueprints.launchpad.net/kuryr/+spec/ipam
15:07:22 <irenab> We discussed this approach with apuimedo, it looks right direction
15:07:34 <gsagie_> basically from what i understood we want to save on creating subnets
15:07:42 <irenab> thanks for banix for mentioning it at some review
15:08:09 <gsagie_> for every EndPoint added, but i think that we need to figure what is the common configuration of addresses for containers
15:08:35 <gsagie_> daneyon: maybe you can help with this, i assume its common that addresses on the same network are from the same CIDR
15:08:38 <diga> tfukushima: if you want, I can contribute to this tomorrow onwards
15:08:42 <apuimedo> gsagie_: what do you mean?
15:08:54 <apuimedo> that depends on the COE
15:09:03 <diga> lets finish this before our sprint
15:09:15 <apuimedo> the COE can pass cidr when creating endpoints
15:09:38 <gsagie_> apuimedo: ahh ok, i thought we will try to deduct that ourselfs
15:10:01 <gsagie_> because we can also try to do this if no CIDR is supplied
15:10:04 <apuimedo> gsagie_: we can be configured to use some specific pool too
15:10:04 <daneyon> gsagie_ I'm at capacity until I get the Magnum container networking model implemented... ~ 4 weeks. I will help review though.
15:10:11 <apuimedo> if no cidr is supplied
15:10:16 <irenab> gsagie_: in case cidr is not provies, it should grab from the pool
15:10:52 <gsagie_> ok make sense
15:11:19 <gsagie_> #action taku sync up on ipam plan and update create endpoint
15:11:34 <gsagie_> anything else needed there?
15:12:09 <daneyon> Endpoint within a coe such as k8s is implemented differently than endpoint within libnetwork
15:12:57 <apuimedo> gotta go, I'll check the updates later
15:13:07 <gsagie_> bye apuimedo!
15:13:24 <gsagie_> daneyon : can you explain more?
15:13:26 <apuimedo> daneyon: I assume a k8s driver could pass CIDRs to libnetwork when creating pods
15:13:33 <apuimedo> but I gotta go
15:13:40 <apuimedo> talk to you all later
15:13:44 <apuimedo> thanks for joining
15:14:17 <tfukushima> diga: I'm catching up with it and let me see how I can work on it. I'm not sure if it's efficient to share the same task with others, especially you have your own now.
15:14:26 <gsagie_> daneyon: ?
15:14:41 <daneyon> gsagie_ 1 sec
15:15:08 <daneyon> well, k8s uses pods ( a single net ns for multiple containers)
15:15:34 <daneyon> when you look at the endpoint code in k8s and libnetwork, they are simply different
15:15:57 <daneyon> have you looked at how ipam is implemented in weave's libnetwork driver?
15:16:08 <gsagie_> on another note, i will just update that i have a spec proposed to Neutron to allow adding tags to resources, this will help us map Docker Id's to Neutron Id's and everything that we needed at that end
15:16:13 <gsagie_> please review if you have time
15:16:24 <gsagie_> #link add tags to resources - https://review.openstack.org/#/c/216021/
15:17:05 * irenab need to go, will catch up later
15:17:16 <daneyon> apuimedo we will need to track if and how k8s will integrate with libnet. As I mentioned in the reviews of the magnum net spec, k8s and libnetwork are not on the same path. That does not mean they can;t be, but it's up to the k8s community
15:17:23 <banix> gsagie_: note that this will need a counterpart on openstack client side but that can come later
15:17:24 <tfukushima> #link https://github.com/weaveworks/weave/blob/master/docs/ipam.md
15:18:04 <gsagie_> also updated Kuryr spec in Neutron repo, please also review if you have time, daneyon, dane_leblanc, irena  , thanks for the review, please also forward it to more people so we can more comments
15:18:19 <daneyon> thx tfukushima for providing a link. I think that's a good reference model for a libnetwork remote driver ipam.
15:18:22 <gsagie_> #link Kuryr Neutron spec https://review.openstack.org/#/c/213490/
15:19:12 <tfukushima> daneyon: I haven't read through it though.
15:19:58 <gsagie__> sorry everyone, got disconnected
15:20:03 <gsagie__> saw my links to the specs?
15:20:10 <banix> y
15:20:13 <gsagie__> okie
15:20:15 <daneyon> tfukushima let me provide another link. The link you provided is good for how weave does ipam. I will provide a link on how weave's remote libnetwork driver implements ipam.
15:20:34 <daneyon> #link https://github.com/weaveworks/docker-plugin/blob/master/plugin/driver/ipam.go
15:21:01 <gsagie__> thanks for the link
15:21:29 <daneyon> at the surface, I think kuryr could follow a similar pattern. Instead of Weave's IPAM, we would leverage the Neutron dhcp-agent
15:22:00 <daneyon> gsagie__ yw
15:22:01 <banix> and note that we now have a plugable ipam in neutron ….
15:22:21 <gsagie__> yeah thats good point banix
15:22:46 <gsagie__> so now with Kuryr you could also have pluggable IPAM to your containers
15:23:45 <gsagie__> anything else on that topic? lets check that link and edit the IPAM blue print if needed
15:24:35 <gsagie__> #action look at weave IPAM and see if we can leverage this approach
15:24:43 <banix> sounds good
15:24:55 <gsagie__> #topic configuration management
15:25:04 <gsagie__> banix, irenab: any update on that?
15:25:18 <gsagie__> i saw irenab added a blue print for that
15:25:36 <banix> banix:  nothing on my side; just got back from a week off. will focus on it this week
15:25:36 <gsagie__> #link configuration management blue print https://blueprints.launchpad.net/kuryr/+spec/kuryr-config
15:25:54 <banix> will be in touch with irenab
15:25:57 <gsagie__> #action banix configuration management blue print
15:26:14 <gsagie__> ok great, thanks band and welcome back :)
15:26:17 <gsagie__> banix
15:26:32 <banix> thanks :)
15:26:51 <gsagie__> anyone have anything to add for configuration management?
15:27:13 <gsagie__> not a crowded meeting today :)
15:27:24 <tfukushima> The configuration management could be a dependency of the IPAM as it's described in the bp of it.
15:27:38 <tfukushima> Meanwhile I can just mock the configuration though.
15:28:57 <gsagie__> tfukushima: yeah its a good point, if you have time please keep an eye on that work to see that it also fits everything needed in IPAM
15:29:13 <diga> sorry guys, getting disconnected due to travelling
15:29:28 <tfukushima> gsagie__: Ok.
15:29:30 <gsagie__> #topic magnum-kuryr integration
15:29:36 <gsagie__> diga: np
15:29:54 <gsagie__> i think the bot is gone as well..
15:30:19 <daneyon> #link https://etherpad.openstack.org/p/magnum-kuryr
15:30:38 <gsagie__> daneyon: we are trying to keep updated with the ether pad, i saw you made some good comments on the spec and i sent an updated version today with responses
15:31:15 <daneyon> gsagie__ great
15:31:22 <daneyon> please continue to keep an eye on the ep
15:31:32 <gsagie__> We are also simultaneously keeping track of some important specs and work in Neutron that are needed for Kuryr and Magnum use cases, like the trunk ports and tags to resources
15:31:44 <daneyon> I have an action to start cleaning up the ep over the next week
15:32:22 <gsagie__> daneyon: is there any urgent open issue that you see is not being addressed right now? (or any other use case for that matter)
15:32:35 <daneyon> gsagie__ maybe you and i can sync offline in the next week to create a formalized integration plan.
15:32:51 <daneyon> gsagie__ no, not atm
15:33:03 <gsagie__> daneyon: sure that would be great, this needs it time.  ping me when you have a preferred dat/time
15:33:06 <gsagie__> day
15:33:16 <daneyon> gsagie__ will do
15:33:46 <gsagie__> #action gsagie meet with daneyon to discuss integration plan and open issues with kuryr-magnum integration
15:34:20 <gsagie__> #action daneyon will clean the magnum-kuryr etherpad
15:34:39 <gsagie__> #topic virtual sprint
15:35:12 <gsagie__> so, next week we are going to have a virtual sprint 8,9/9   who is planning to attend?
15:35:22 <gsagie__> even if partially
15:35:42 <tfukushima> I definitely will.
15:36:10 <diga> o/
15:36:14 <tfukushima> Oh, but which timezone?
15:36:18 <gsagie__> tfukushima: ok great :) we will talk about the time zone
15:36:29 <daneyon> gsagie__ can you provide some background on a virtual sprint?
15:37:10 <banix> i plan to attend
15:37:22 <gsagie__> daneyon: its simply very close process to the mid-cycle sprints, we meet for 2-3 days and iterate on agenda of tasks to finish some work together
15:37:42 <gsagie__> so we can talk online here and move things faster
15:38:15 <diga> gsagie__:  just a question - what is our milestone last date for Liberty release
15:38:31 <daneyon> gsagie__ where is the meeting at?
15:38:51 <gsagie__> daneyon: we will meet at #openstack-neutron and maybe choose a different channel
15:39:24 <daneyon> gsagie__ Oh... I thought maybe it was in person
15:39:28 <daneyon> got it, thx
15:39:36 <gsagie__> for the timezone, we will probably need to do it in two time zones in parallel and sync together around this time or some time earlier for Taku
15:39:46 <banix> gsagie__: hangout or anything like that? or simply conference call
15:39:53 <gsagie__> daneyon: it would be ideal if we could do it in person, but everyone are in different places :)
15:40:08 <banix> i can set a conference call
15:40:23 <banix> set up that is
15:40:43 <gsagie__> banix: please do :) we can decide how its going
15:40:48 <daneyon> gsagie__ when you have the logistics finalized for the sprint, can you send them out on the ML?
15:40:54 <banix> gsagie__: sounds good. sure
15:42:02 <gsagie__> daneyon: sure will, just need to set the agenda and decide with everyone how to do it with different time zones
15:42:52 <gsagie__> but i think we can do it in two time zones and sync in the middle
15:43:05 <gsagie__> anyone have any special request/idea for the agenda?
15:44:01 <diga> gsagie__: Taku & my zone difference is just 3 hrs so I request to arrange meetup accordingly
15:44:10 <diga> I am fine with EU zone also
15:44:45 <gsagie__> diga: sure, you are also close to me and apuimedo and ire nab, so we work something that will be good for everyone
15:44:46 <daneyon> gsagie__ maybe take an action for everyone to think of agenda items for next week. Maybe create an ep that people can add their agenda ideas too?
15:45:04 <gsagie__> daneyon: yeah good idea, will do that and send to the ML
15:45:05 <diga> yes
15:45:46 <daneyon> gsagie__ I have some ideas for agenda, I would just rather add them to an ep.
15:46:06 <gsagie__> we will close the agenda items ending this week when we see the progress, probably going to be around closing any gaps to the VIF binding and starting containerising plugins
15:46:21 <gsagie__> daneyon: will send an update today
15:46:29 <daneyon> gsagie__ thx
15:47:35 <gsagie__> #action gsagie start etherpad for virtual sprint agenda, send details to ML , finalise timezones and sync up meetings time with all the participates
15:47:48 <gsagie__> #action banix update conference call for virtual sprint
15:47:57 <gsagie__> ok, everyone
15:48:01 <gsagie__> #topic open discussion
15:48:28 <gsagie__> thanks all for joining !! :)
15:48:39 <banix> thanks all
15:48:51 <tfukushima> Thank you.
15:49:26 <VikasC> Thanks all
15:49:51 <gsagie__> and daneyon, please email me when you want to do the offline integration plan
15:50:05 <gsagie__> good day/night everyone!
15:50:14 <daneyon> gsagie__ will do. I'll touch base with you at the end of the week.
15:50:22 <gsagie__> k, thanks
15:50:27 <daneyon> bye
15:50:44 <diga_> thank you all ! Good Night!
15:56:19 <diga> gsagie__: I think we are running our of time
15:56:39 <gsagie__> diga: meeting has ended :)
15:56:44 <diga> okk
15:56:53 <gsagie__> the bot is just not working, so i can't do end meeting
15:56:56 <gsagie__> #end meeting
15:57:01 <diga> okk
15:57:06 <gsagie__> #endmeeting
16:00:42 <jroll> ohai
16:01:01 <Sukhdev> hello
16:01:03 <yushiro> hi
16:01:08 <cragusa> hi
16:01:09 <Sukhdev> time for meeting
16:01:26 <openstack> Sukhdev: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:01:41 <banix> Sukhdev: the bot not working
16:02:03 <Sukhdev> banix: oh really? any work arounds?
16:02:08 <banix> so the previous endmeeting has not been done
16:02:19 <Sukhdev> #endmeeting