#openstack-meeting-4: kuryr

Meeting started by apuimedo at 15:01:50 UTC (full logs).

Meeting summary

    1. gsagie, tfukushima, diga, banix, daneyon and apuimedo present (apuimedo, 15:03:23)
    2. topic: vif-binding-unbinding (apuimedo, 15:04:27)
    3. https://blueprints.launchpad.net/kuryr/+spec/vif-binding-and-unbinding-mechanism (diga, 15:05:08)

  1. vif-binding-unbinding (apuimedo, 15:05:29)
    1. https://blueprints.launchpad.net/kuryr/+spec/vif-binding-and-unbinding-mechanism (apuimedo, 15:06:05)
    2. https://etherpad.openstack.org/p/Kuryr_vif_binding_unbinding (tfukushima, 15:06:12)
    3. https://github.com/midonet/midonet/blob/master/tools/docker/mm-docker.sh#L28-L39 (tfukushima, 15:08:59)
    4. https://github.com/openstack/kuryr/blob/master/doc/source/design.rst#user-workflow (tfukushima, 15:10:44)
    5. : NetworkDriver.Join gives Kuryr the Network Namespace location to put the veth (apuimedo, 15:11:49)
    6. ACTION: diga to update on the executable calling via gerrit ;-) (apuimedo, 15:12:51)

  2. libnetwork <-> docker network mapping (apuimedo, 15:15:03)
    1. https://github.com/docker/libnetwork/issues/139 (apuimedo, 15:16:52)
    2. https://github.com/docker/libnetwork/issues/414 (tfukushima, 15:17:19)
    3. https://github.com/docker/libnetwork/issues/414 (apuimedo, 15:19:19)
    4. ACTION: tfukushima to find out about the label persistence or libnetwork abuse (apuimedo, 15:26:32)
    5. ACTION: gsagie to look at putting hte network resource info in neutron as a last resort option (apuimedo, 15:28:59)

  3. feature mapping (apuimedo, 15:29:19)
    1. https://review.openstack.org/#/c/213490/ (gsagie, 15:30:16)
    2. ACTION: all to review the spec (apuimedo, 15:32:03)
    3. we'll be adding cluster/orchestration engines sections in the kuryr spec (apuimedo, 15:36:04)
    4. it is important to discuss about the expectations/assumptions those engines have and how they are affected by Kuryr (apuimedo, 15:36:51)

  4. configuration management (apuimedo, 15:38:40)
    1. https://wiki.openstack.org/wiki/Meetings/Containers#Container_Networking_Subteam_Meeting (daneyon, 15:38:54)
    2. ACTION: banix to update on configuration management for the next meeting (apuimedo, 15:42:59)

  5. sprint proposal (apuimedo, 15:43:16)
    1. irenab proposed a virtual/semi-virtual sprint (apuimedo, 15:43:52)
    2. ACTION: irenab gsagie to propose dates and format (apuimedo, 15:44:15)

  6. VM container networking (apuimedo, 15:44:52)
    1. kuryr drivers will have a brainstorming session about VM container networking for Milestone 2 on Wednesday (apuimedo, 15:45:45)
    2. ACTION: apuimedo to bring diagrams of two proposals to spark discussion (apuimedo, 15:46:17)
    3. https://plus.google.com/hangouts/_/midokura.com/kuryr (apuimedo, 15:47:58)
    4. the goal of the meeting is to come out of it with an agreement of a plan A and B for the VM container use case (apuimedo, 15:49:07)
    5. August 19th 15UTC (apuimedo, 15:50:05)

  7. Open floor (apuimedo, 15:50:36)
    1. https://review.openstack.org/#/q/status:open+project:openstack/kuryr,n,z (tfukushima, 15:52:04)
    2. ACTION: apuimedo to finally review and W+1 the patches that have reviews (apuimedo, 15:53:15)


Meeting ended at 15:54:50 UTC (full logs).

Action items

  1. diga to update on the executable calling via gerrit ;-)
  2. tfukushima to find out about the label persistence or libnetwork abuse
  3. gsagie to look at putting hte network resource info in neutron as a last resort option
  4. all to review the spec
  5. banix to update on configuration management for the next meeting
  6. irenab gsagie to propose dates and format
  7. apuimedo to bring diagrams of two proposals to spark discussion
  8. apuimedo to finally review and W+1 the patches that have reviews


Action items, by person

  1. apuimedo
    1. apuimedo to bring diagrams of two proposals to spark discussion
    2. apuimedo to finally review and W+1 the patches that have reviews
  2. banix
    1. banix to update on configuration management for the next meeting
  3. diga
    1. diga to update on the executable calling via gerrit ;-)
  4. gsagie
    1. gsagie to look at putting hte network resource info in neutron as a last resort option
    2. irenab gsagie to propose dates and format
  5. tfukushima
    1. tfukushima to find out about the label persistence or libnetwork abuse


People present (lines said)

  1. apuimedo (106)
  2. gsagie (50)
  3. tfukushima (21)
  4. daneyon (19)
  5. banix (18)
  6. diga (14)
  7. openstack (3)
  8. dane_leblanc_ (2)


Generated by MeetBot 0.1.4.