14:00:28 <mnasiadka> #startmeeting kolla
14:00:28 <opendevmeet> Meeting started Wed Jul 27 14:00:28 2022 UTC and is due to finish in 60 minutes.  The chair is mnasiadka. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:28 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:28 <opendevmeet> The meeting name has been set to 'kolla'
14:00:38 <mnasiadka> #topic rollcall
14:00:39 <mnasiadka> o/
14:00:41 <RamonaRautenberg[m]> o/
14:00:59 <yoctozepto> o/
14:01:09 <hrw> o\
14:03:16 <opendevreview> Marcin Juszkiewicz proposed openstack/kolla master: Move to CentOS Stream 9  https://review.opendev.org/c/openstack/kolla/+/836664
14:03:22 <mnasiadka> #topic agenda
14:03:22 <mnasiadka> * CI status
14:03:22 <mnasiadka> * Release tasks
14:03:22 <mnasiadka> * Regular stable releases (first meeting in a month)
14:03:22 <mnasiadka> * Current cycle planning
14:03:24 <mnasiadka> * Additional agenda (from whiteboard)
14:03:24 <mnasiadka> * Open discussion
14:03:30 <mnasiadka> (no actions from last week)
14:03:34 <mnasiadka> #topic CI Status
14:03:41 <yoctozepto> (bbezak, mnasiadka: same error on debian so it's new ironic: https://99863b9db4f0aa324d57-99bfed502b9130cc4d1d06a7b48bd458.ssl.cf1.rackcdn.com/839585/37/experimental/kolla-ansible-debian-source-ironic/74bb93c/primary/logs/ansible/test-ironic )
14:03:46 <yoctozepto> the CI is green
14:03:47 <mnasiadka> apart the cinder-backup s3 breakage we're fine I guess
14:03:53 <yoctozepto> (and I was not that much offtopic :D )
14:03:57 <mnasiadka> I mean that was reverted
14:04:01 <yoctozepto> yup
14:04:06 <mnasiadka> yoctozepto: are you going to follow up on #openstack-ironic? ;-)
14:04:24 <yoctozepto> mnasiadka: can do
14:04:28 <mnasiadka> thanks
14:04:32 <mnasiadka> #topic Release tasks
14:05:11 <mnasiadka> R-14 - nothing on Kolla schedule in that timeframe
14:05:21 <mnasiadka> #topic Current cycle planning
14:05:31 <mnasiadka> So, we're close to getting Jammy merged in Kolla
14:05:37 <mnasiadka> Kolla-Ansible got merged some days ago
14:05:48 <mnasiadka> bbezak is working on Kayobe part
14:05:57 <mnasiadka> hrw: how is CS9?
14:08:35 <mnasiadka> I noticed some rabbitmq issues, we replaced xinetd with socat
14:08:40 <mnasiadka> so I guess we're on a good path
14:08:46 <mnasiadka> any other features we should be discussing?
14:09:25 <hrw> CS9 is only rmq now I think
14:09:32 <mnasiadka> nice
14:09:37 <hrw> but that's only all-in-one testing
14:09:48 <hrw> needs multinode tests
14:10:26 <mnasiadka> So we need to add the cephadm job back but on CS9
14:11:02 <mnasiadka> but I think without resolving the rmq memory issue - it might be hard to go further
14:11:06 <hrw> multinode CI is something I am not familiar with
14:11:14 <mnasiadka> I can help
14:11:30 <hrw> I will discuss it with rmq upstream
14:11:34 <mnasiadka> thanks
14:11:43 <mnasiadka> Ok then, let's move to additional agenda
14:11:44 <mnasiadka> #topic Additional agenda (from whiteboard)
14:11:54 <mnasiadka> (yoctozepto) No bare rechecks
14:12:01 <mnasiadka> (I wanted to touch that one as well today)
14:12:25 <yoctozepto> remember to always add some comment to an issued recheck! it's ok to forget from time to time I guess but let's try our best to avoid bare ones
14:12:31 <mnasiadka> I guess we should stop doing "recheck" and start doing "recheck (something failed)" or even "recheck(bug:[number])"
14:12:52 <mnasiadka> yoctozepto: should we add that to kolla contributor docs with examples?
14:12:52 * hrw out
14:12:52 <yoctozepto> recheck + whatever you think makes sense at the time
14:13:19 <yoctozepto> mnasiadka: I don't know if we discuss rechecks; also, this should be in the main openstack contributor docs anyhow
14:13:27 <mnasiadka> ok
14:13:34 <yoctozepto> as cores we need to set an example
14:13:37 <yoctozepto> and remind others
14:13:45 <yoctozepto> let's move on :-)
14:13:47 <mnasiadka> yes, that's what I wanted to write
14:13:48 <mnasiadka> :)
14:13:57 <mnasiadka> (yoctozepto) Removal of the Keystone admin endpoint
14:13:57 <mnasiadka> https://review.opendev.org/c/openstack/kolla/+/843751
14:13:57 <mnasiadka> https://review.opendev.org/c/openstack/kolla-ansible/+/843730
14:14:08 <yoctozepto> should we progress with this?
14:14:23 <yoctozepto> we can remove it from kolla with no pain as kolla-ansible still creates it
14:14:31 <yoctozepto> and then decide what to do with k-a one
14:14:35 <mnasiadka> I'm fine with that, are there any services that are failing?
14:14:40 <yoctozepto> we can have it be re-enabled via a flag
14:14:48 <yoctozepto> mnasiadka: none in our CI
14:14:54 <yoctozepto> but we don't have 100% coverage
14:14:59 <mnasiadka> I think keystone client stopped defaulting to admin
14:15:02 <mnasiadka> so we should be fine
14:15:03 <yoctozepto> thus, it would make sense to have a fallback just in case
14:15:09 <yoctozepto> ah, so maybe none
14:15:23 <yoctozepto> if no other voices, I will repropose as non-WIP
14:15:26 <mnasiadka> so, what's the plan? remove in Kolla and make optional in Kolla-Ansible?
14:16:29 <yoctozepto> ah, so you prefer my optional path?
14:16:34 <yoctozepto> good, can be done
14:17:52 <mnasiadka> thanks
14:18:32 <mnasiadka> (yoctozepto) Deprecate collectd and telegraf
14:18:32 <mnasiadka> not available in jammy https://review.opendev.org/c/openstack/kolla/+/839585
14:18:51 <yoctozepto> this is not our main stack
14:18:59 <mnasiadka> basically not
14:19:01 <yoctozepto> no idea if it's functional
14:19:11 <mnasiadka> it builds for Debian today though
14:19:25 <yoctozepto> it brings no benefits over the other stack afaik
14:19:46 <mnasiadka> anyone on the meeting that cares for collectd and telegraf?
14:20:07 <TimBeermann[m]> we do not care
14:20:29 <yoctozepto> so the usual: ask on the mailing list, wait a few weeks and deprecate then drop?
14:21:05 <mnasiadka> yes
14:21:12 <mnasiadka> yoctozepto: willing to do that?
14:21:42 <yoctozepto> btw, https://bugs.launchpad.net/ubuntu/+source/collectd/+bug/1971093
14:21:51 <yoctozepto> mnasiadka: ok, can do
14:22:28 <mnasiadka> #action yoctozepto send a mail around dropping collectd and telegraf
14:23:36 <mnasiadka> (yoctozepto) Restoring periodics
14:23:44 <mnasiadka> We stopped running periodics? :)
14:24:03 <priteau> I think Flint was using collectd?
14:24:04 <yoctozepto> yup, due to dockerhub
14:24:17 <yoctozepto> sorry, I forgot to mention I meant kolla-ansible :-)
14:24:26 <yoctozepto> we don't have periodic jobs there
14:24:32 <yoctozepto> except for the ones from templates
14:24:48 <yoctozepto> priteau: hmm, that would be a blocker indeed
14:25:00 <yoctozepto> wondering if he's on ubuntu ;d
14:25:14 <mnasiadka> rather not
14:25:34 <mnasiadka> collectd seems to have some traction on Ubuntu side
14:25:40 <mnasiadka> let's see if anybody replies to your mail
14:25:49 <yoctozepto> ok, it does not hurt
14:26:03 <mnasiadka> yoctozepto: kolla-ansible periodics - we should run something - but would be good to check if those are failing :)
14:27:12 <yoctozepto> I mean, I think we should run all the jobs at least weekly, not sure if daily makes much sense
14:27:24 <yoctozepto> maybe for some
14:27:45 <yoctozepto> +/- week failure windows are still better than no-idea-how-long failure windows
14:28:31 <mnasiadka> true
14:28:52 <mnasiadka> but notifications are only sent to openstack-stable-maint for stable
14:28:56 <mnasiadka> and nowhere for master, right?
14:29:00 <yoctozepto> right
14:29:04 <yoctozepto> need to check during the meetings
14:29:13 <yoctozepto> we used to do that when we had periodics
14:29:32 <mnasiadka> I guess that's what we can do
14:29:39 <yoctozepto> in the CI status
14:29:40 <yoctozepto> basically
14:30:00 <yoctozepto> thanks to priteau for mentioning periodics today
14:30:04 <mnasiadka> ok, I'll make a change in the kolla docs to include (check for periodics)
14:30:08 <yoctozepto> when asked about the blazar testing in ci
14:31:31 <priteau> If we have links in the wiki to the zuul build reports, it could be quick to check in the meetings
14:31:47 <priteau> wiki or docs
14:32:05 <yoctozepto> whiteboard
14:32:09 <yoctozepto> we have it there
14:32:13 <yoctozepto> just nothing to see
14:32:16 <priteau> ok
14:32:46 <mnasiadka> yoctozepto: couldn't we add periodics to the Grafana dashboard?
14:33:01 <yoctozepto> mnasiadka: probably, but it's not something I am interested in
14:33:26 <yoctozepto> btw, we are going jammy as we speaaak
14:33:38 <yoctozepto> and ironic's issue is with new werkzeug
14:33:44 <yoctozepto> so far so good
14:33:57 <yoctozepto> let's move on
14:34:59 <mnasiadka> yoctozepto: not saying you should be interested, I can look into adding this - as it would be easy to check during the meeting.
14:35:43 <mnasiadka> (yoctozepto) How do we want to handle linuxbridge being experimental?
14:35:43 <mnasiadka> i.e. should we hide it as experimental as well? (and cede testing it?)
14:36:06 <mnasiadka> I think we should delete the CI and mark it in support matrix as experimental
14:36:16 <yoctozepto> mnasiadka: re grafana if you wish, I don't mind
14:36:45 <yoctozepto> mnasiadka: ok, I agree; 2 questions: what matrix you mean and what about letting users use it?
14:36:46 <yoctozepto> ;p
14:37:34 <mnasiadka> yoctozepto: we have that Kolla support matrix (I don't know if anything is in Kolla-Ansible) - we could add a statement about Linuxbridge in there
14:37:45 <yoctozepto> ah, ok, can do
14:38:03 <mnasiadka> I think we should let users use it, just write a statement we don't test it and it's marked experimental by Neutron
14:38:24 <yoctozepto> mnasiadka: but how to let/teach users to re-enable it?
14:38:28 <yoctozepto> as now it will simply fail
14:38:53 <yoctozepto> docs or do it for the users?
14:38:55 <yoctozepto> I would say docs
14:39:01 <yoctozepto> more pain, more gain
14:39:02 <mnasiadka> docs should be enough
14:39:05 <yoctozepto> or something like that
14:39:06 <yoctozepto> ok
14:39:13 <mnasiadka> let's not make it easy for them
14:39:20 <yoctozepto> you speak my mind
14:39:23 <mnasiadka> I don't think LB driver will live long in the Neutron repo
14:39:45 <yoctozepto> me neither
14:40:53 <mnasiadka> (yoctozepto) Let me introduce you to the altcomp scenario
14:40:53 <mnasiadka> https://review.opendev.org/c/openstack/kolla-ansible/+/851204
14:41:20 <yoctozepto> please welcome the long-awaited altcomp scenario where we test others ways to do compute
14:41:32 <yoctozepto> altcomp = alternative compute
14:41:49 <yoctozepto> the commit messages gives the background and summary
14:42:02 <yoctozepto> if no objections, please consider merging right away ;d
14:42:22 <yoctozepto> this is also a nice scenario to test blazar etc.
14:42:28 <yoctozepto> cloudkitty
14:42:54 <yoctozepto> whatever comes to ours mind that makes sense to test because it's good enough (TM) on our side and we want to keep it that way
14:43:07 <mnasiadka> Ok, I'll look in the patch later this week
14:43:14 <yoctozepto> ok, thanks
14:43:36 <yoctozepto> it scraps FUBAR zun and leaves the rest
14:43:42 <mnasiadka> nice
14:43:42 <yoctozepto> while renaming the scenario to altcomp
14:44:02 <mnasiadka> ok, frickler is on pto, so no discussion about vptg
14:44:16 <mnasiadka> headphoneJames is reminding us to review lets encrypt patch
14:44:23 <yoctozepto> frickler is seemingly waiting for me to go on pto...
14:44:40 <mnasiadka> and systemd and podman are also on the list to get reviewed
14:46:02 <mnasiadka> #topic Open discussion
14:46:56 <yoctozepto> I had everything discussed
14:47:55 <mnasiadka> me too
14:47:58 <mnasiadka> ok, thanks for attending
14:48:02 <mnasiadka> see you next week!
14:48:05 <mnasiadka> #endmeeting