15:00:20 <mgoddard> #startmeeting kolla
15:00:26 <openstack> Meeting started Wed Mar 17 15:00:20 2021 UTC and is due to finish in 60 minutes.  The chair is mgoddard. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:29 <openstack> The meeting name has been set to 'kolla'
15:00:31 <mgoddard> #topic rollcall
15:00:34 <mgoddard> \o
15:00:43 <headphoneJames> o/
15:00:47 <priteau> o/
15:02:48 <wuchunyang> o/
15:03:10 <yoctozepto> o//
15:03:56 <mnasiadka> o/
15:03:58 <mgoddard> #topic agenda
15:04:04 <mgoddard> * Roll-call
15:04:06 <mgoddard> * Announcements
15:04:08 <mgoddard> ** PTG 19th - 23rd April, registration open | https://april2021-ptg.eventbrite.com | https://www.openstack.org/ptg/
15:04:10 <mgoddard> * Review action items from the last meeting
15:04:12 <mgoddard> * CI status
15:04:14 <mgoddard> * Review requests
15:04:16 <mgoddard> * PTG team signup http://lists.openstack.org/pipermail/openstack-discuss/2021-March/020915.html
15:04:18 <mgoddard> * PoC: image build & test pipeline (https://review.opendev.org/c/openstack/kolla/+/777796 and https://review.opendev.org/c/openstack/kolla-ansible/+/777946)
15:04:19 <openstackgerrit> Merged openstack/kolla-ansible master: Upgrade service configuration for ELK 7  https://review.opendev.org/c/openstack/kolla-ansible/+/740986
15:04:20 <mgoddard> * Wallaby release planning
15:04:22 <mgoddard> #topic announcements
15:04:24 <mgoddard> #info PTG 19th - 23rd April, registration open
15:04:26 <mgoddard> #link https://april2021-ptg.eventbrite.com
15:04:46 <mgoddard> Please remmeber to register if you would like to attend the PTG
15:04:53 <mgoddard> Any other announcements
15:04:55 <mgoddard> ?
15:05:49 <yoctozepto> guess not
15:06:08 <mgoddard> #topic Review action items from the last meeting
15:06:20 <mgoddard> mgoddard send an email to openstack-discuss to gauge interest in the 'early' PTG slot
15:06:22 <mgoddard> I did it
15:06:47 <mgoddard> http://lists.openstack.org/pipermail/openstack-discuss/2021-March/021119.html
15:07:37 <mgoddard> Please respond if you are interested in attending a time slot outide of the normal 13:00-17:00 UTC window
15:08:21 <mgoddard> #topic CI status
15:09:08 <mgoddard> Kolla train *still* broken
15:09:17 <mgoddard> I just rechecked https://review.opendev.org/c/openstack/kolla/+/774602
15:11:12 <mgoddard> Looks like the NFV job is still busted
15:11:45 <mgoddard> is there anything else broken in CI?
15:11:59 <yoctozepto> I have not noticed
15:12:12 <yoctozepto> the decrease in logs is nice
15:12:12 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: [DNM] Set environment for testing  https://review.opendev.org/c/openstack/kayobe/+/773411
15:12:19 <mgoddard> #topic Review requests
15:12:26 <mgoddard> here we go
15:12:47 <mgoddard> 2 weeks until feature freeze
15:12:51 <yoctozepto> https://review.opendev.org/c/openstack/kolla/+/752512
15:13:00 <mgoddard> now is your chance to request a review
15:13:21 <headphoneJames> https://review.opendev.org/c/openstack/kolla-ansible/+/741340/
15:13:24 <mgoddard> +1
15:13:38 <headphoneJames> finishing off the LE test case
15:14:07 <kevko> https://review.opendev.org/c/openstack/kolla-ansible/+/780811
15:14:49 <mgoddard> kevko: I'd suggest starting nearer the bottom of the chain...
15:15:01 <kevko> yes :D
15:15:15 <priteau> headphoneJames: Shouldn't you be a co-author?
15:15:20 <kevko> i've reworked mariadb role
15:16:22 <headphoneJames> priteau: sure, what needs updating
15:16:43 <priteau> you can put a Co-Authored-By line
15:17:21 <priteau> Or I can see with Jason if you should be main author
15:17:37 <bbezak> https://review.opendev.org/c/openstack/kolla-ansible/+/768228 second core review needed ;)
15:18:45 <bbezak> this as well - https://review.opendev.org/c/openstack/kolla-ansible/+/777595
15:18:53 <openstackgerrit> Merged openstack/kolla-ansible master: Set changed_when to false for group_by tasks  https://review.opendev.org/c/openstack/kolla-ansible/+/779836
15:18:59 <mgoddard> here's my request: https://review.opendev.org/c/openstack/kolla-ansible/+/689870/18
15:19:17 <headphoneJames> priteau: I think Jason would be ok if I'm main author, since almost none of his original code exists. I'm ok either way.
15:19:40 <mgoddard> time's up for review requests!
15:19:49 <mgoddard> #topic PTG team signup
15:20:29 <mgoddard> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-March/020915.html
15:20:38 <mgoddard> We need to pick some slots
15:21:04 <mgoddard> Let's wait until the end of the week to allow people to respond to the ML
15:21:22 <mgoddard> Please add discussion topics here: https://etherpad.opendev.org/p/kolla-xena-ptg
15:21:29 <mgoddard> Anything else we should discuss re PTG?
15:22:31 <mgoddard> #topic PoC: image build & test pipeline
15:22:55 <mgoddard> We started this last time but didn't really have time to discuss
15:22:59 <mgoddard> #link https://etherpad.opendev.org/p/docker-pull-limits
15:23:19 <yoctozepto> I did not have time to inspect it, sorry :-(
15:23:19 <mgoddard> I added 3a and 3b
15:25:05 <yoctozepto> I like 3a
15:27:23 <kevko> 3a +1
15:28:50 <mgoddard> they aren't necessarily mutually exclusive, but 3a is definitely simpler
15:30:55 <openstackgerrit> Sven Kieske proposed openstack/kolla-ansible master: fix missing lang env in curator crontab  https://review.opendev.org/c/openstack/kolla-ansible/+/781114
15:31:59 <yoctozepto> they  are not
15:32:00 <mnasiadka> mgoddard: my problem is with wording "Infra could" - I think it requires a volunteer from our side to work with infra
15:32:14 <yoctozepto> but we need a solution right now
15:32:21 <yoctozepto> 3b sounds too worky ;/
15:32:42 <mgoddard> well, we need to come up with a proposal, then work with infra
15:32:48 <mnasiadka> well, question how much traffic would flow between nodepool providers and when somebody will shoot us in the head
15:33:02 <mgoddard> it shouldn't be a lot if there is a cache
15:33:12 <mnasiadka> if we build weekly - then yes
15:33:13 <mgoddard> and setting up a cache shouldn't be hard
15:33:21 <openstackgerrit> Michal Arbet proposed openstack/kolla-ansible master: Add mariadb arbitrator to mariadb role  https://review.opendev.org/c/openstack/kolla-ansible/+/780811
15:33:21 <openstackgerrit> Michal Arbet proposed openstack/kolla-ansible master: [CI] Test Mariadb-Arbitrator with shards in the nova cells scenario  https://review.opendev.org/c/openstack/kolla-ansible/+/780970
15:33:37 <yoctozepto> I would prefer we restored the daily build then
15:33:59 <mgoddard> one step at a time :)
15:34:17 <yoctozepto> obviously! :-)
15:34:49 <openstackgerrit> Pierre Riteau proposed openstack/kayobe-config-dev master: DNM: Test multiple environments  https://review.opendev.org/c/openstack/kayobe-config-dev/+/752469
15:35:21 <kevko> just curious, why  can't there be some nexus somewhere?
15:35:56 <mgoddard> infra does maintain a registry
15:36:09 <mgoddard> but it's not really intended to be used in this way
15:36:14 <openstackgerrit> Pierre Riteau proposed openstack/kayobe master: [DNM] Set environment for testing  https://review.opendev.org/c/openstack/kayobe/+/773411
15:36:19 <mgoddard> and we have a lot more images than other projects
15:37:01 <kevko> maybe someone can sponsor and give one server for "our" registry ..
15:37:58 <yoctozepto> one server would not necessarily be enough
15:38:02 <yoctozepto> what about quay, mgoddard?
15:38:15 <yoctozepto> did not we establish it's good enough?
15:38:24 <yoctozepto> y not use it?
15:38:48 <mgoddard> it could work, it just might leave us in a similar position
15:40:03 <yoctozepto> but it should be a no brainer to change it immediately
15:40:05 <yoctozepto> and give it a try
15:40:39 <mgoddard> it would involve some effort - account setup, secrets, etc
15:41:06 <mnasiadka> yeah, but still we could use it just for master for the next cycle and see how it behaves
15:41:18 <mnasiadka> going back to docker hub is a no brainer
15:41:18 <yoctozepto> I can go and try to set us up
15:41:33 <yoctozepto> just give me your blessing
15:41:43 <mgoddard> blessed
15:41:56 <yoctozepto> thank you, oh ptl
15:42:25 <mgoddard> #action yoctozepto try out quay.io
15:42:29 <mgoddard> #topic Wallaby release planning
15:42:50 <yoctozepto> uhm
15:42:50 <yoctozepto> https://quay.io/plans/
15:42:59 <yoctozepto> 30-day free trial
15:43:05 <yoctozepto> did we miss something? :D
15:43:19 <yoctozepto> Can I use Quay for free?
15:43:19 <yoctozepto> Yes! We offer unlimited storage and serving of public repositories. We strongly believe in the open source community and will do what we can to help!
15:43:22 <yoctozepto> ah :D
15:43:34 <mgoddard> #undo
15:43:35 <openstack> Removing item from minutes: #link https://quay.io/plans/
15:43:40 <mgoddard> #undo
15:43:41 <openstack> Removing item from minutes: #topic Wallaby release planning
15:43:44 <mgoddard> #topic Wallaby release planning
15:44:15 <mgoddard> We're pretty close to release now
15:44:19 <mgoddard> What do we need to focus on?
15:44:34 <mgoddard> Or rather, we're close to feature freeze
15:44:40 * yoctozepto is going to focus on masakari
15:44:46 <yoctozepto> and hacluster
15:45:06 <mgoddard> ok
15:45:21 <mgoddard> K-A CentOS stream needs work
15:45:29 <mgoddard> hrw was looking at it
15:46:44 <mgoddard> We need this one
15:46:46 <mgoddard> https://review.opendev.org/c/openstack/kolla-ansible/+/779455
15:49:08 <mgoddard> I've added DEFERRED to a bunch of the priorities
15:49:25 <mgoddard> It's not set in stone, just what seems likely right now
15:49:46 <mgoddard> (on the whiteboard)
15:49:48 <mgoddard> https://etherpad.opendev.org/p/KollaWhiteBoard
15:50:50 <yoctozepto> ok
15:51:11 <mgoddard> #topic Open Discussion
15:51:18 <mgoddard> Anything else to discuss today?
15:55:34 <yoctozepto> not really
15:56:56 <mgoddard> Thanks all
15:56:58 <mgoddard> #endmeeting