16:00:03 <inc0> #startmeeting Kolla
16:00:08 <openstack> Meeting started Wed May 17 16:00:03 2017 UTC and is due to finish in 60 minutes.  The chair is inc0. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:13 <openstack> The meeting name has been set to 'kolla'
16:00:18 <hrw> o/
16:00:23 <inc0> #topic rollcall
16:00:25 <inc0> w00t!
16:00:25 <spsurya_> o/
16:00:26 <duonghq> o/
16:00:32 <duonghq> wo0t
16:00:41 <egonzalez> w00t \o/
16:00:44 <rwellum> o/
16:00:45 <vhosakot> o/
16:00:48 <mandre> o/
16:00:57 <kfox1111> o/
16:01:32 <sdake> o/
16:01:47 <krtaylor> o/
16:02:36 <inc0> lets give it few more minutes for slackers
16:02:53 <gema> thanks x)
16:02:55 <gema> o/
16:03:01 <inc0> :D
16:03:17 <inc0> #topic Announcements
16:03:37 <inc0> We're back! Summit was interesting and it was awesome to meet lots of you there
16:03:45 <krtaylor> +1
16:03:47 <vhosakot> +1
16:03:50 <gema> +1
16:03:54 <inc0> that's it from me, any community announcements?:)
16:03:54 <rwellum> +1
16:03:57 <Serlex> :) +1
16:03:58 <spsurya_> +1
16:04:07 <gema> thanks for everybody's help in getting the multi arch main change in
16:04:15 <gema> \o/
16:04:18 <hrw> +1
16:04:48 <inc0> that's a good change, thank you for doing the heavy lifting
16:05:02 <inc0> ok let's move on to agenda
16:05:12 <inc0> #topic Image sharing on docker hub (inc0)
16:05:37 <inc0> sooo...if you follow ML, that's topic of the day yesterday
16:06:28 <duonghq> ya, hot topic
16:06:39 <inc0> if you haven't, don't read it now as it's...long
16:07:07 <daidv> o/
16:07:14 <inc0> bottom line, depends how TC will move from there, that will affect this topic
16:07:32 <krtaylor> #link http://lists.openstack.org/pipermail/openstack-dev/2017-May/116677.html
16:07:58 <inc0> I think it's premature to discuss technical details of how we want to do it until this concludes, so for now I encourage everyone to follow this thread and chime in
16:08:31 <Jeffrey4l_> o/
16:08:32 <inc0> anything anyone want to add to this?
16:08:38 <gema> i'd like to add something
16:08:41 <britthouser> 0/ sorry i'm alte
16:08:42 <inc0> go ahead
16:08:53 <gema> we will need, for ARM64 to publish the containers regardless of the resolution
16:09:11 <gema> what I mean is, if the community decides to go against it we will have to do it somehow under linaro's umbrella
16:09:17 <inc0> well nobody can, or want, to stop you
16:09:18 <krtaylor> yep, same for ppc64le
16:09:20 <gema> not sure if power is in the same boat or not
16:09:42 <inc0> I think issue is "openstack publishing"
16:09:48 <inc0> linaro can do what linaro wants
16:09:54 <gema> so we are pretty much in favor of doing this upstream so that we can just be consumers (and fix any issues we find)
16:10:02 <krtaylor> but that is just pushing to a different docker hub namespace, right?
16:10:08 <gema> krtaylor: right
16:10:10 <hrw> I was thinking about kolla-aarch64 user or sth like that
16:10:10 <kfox1111> yeah.
16:10:14 <inc0> not sure how we'll handle that
16:10:21 <inc0> depends a lot on resolution
16:10:28 <gema> hrw: that'll depend on the resolution
16:10:29 <kfox1111> docker hub suposidly supports multiarch tags.
16:10:36 <hrw> inc0: sure
16:10:41 <hrw> kfox1111: it does? nice
16:10:44 <kfox1111> where different arch versions can be uploaded with the same tag,
16:10:46 <inc0> like, if we won't push to kolla, I'd be reluctant to push to kolla-aarch64
16:10:50 <kfox1111> and depending on the arch of docker, will pull the right image.
16:10:58 <gema> kfox1111: wasn't aware of that, that is useful indeed
16:11:06 <kfox1111> I read a blog on it somewhere...
16:11:09 <hrw> kfox1111: docker 17.xx needed or 0.12 is fine?
16:11:11 <kfox1111> I'll try and dig it back up.
16:11:15 <hrw> thx kfox1111
16:11:16 <gema> kfox1111: thanks!
16:11:21 <krtaylor> yes, but few populate the metadata from what I understand
16:11:30 <gema> krtaylor: so we'll do it
16:11:43 <gema> at least for kolla iamges
16:11:45 <gema> images
16:11:52 <inc0> well there will be more challenges
16:12:07 <inc0> like, infra can't build arch
16:12:16 <hrw> inc0: we work on 3rdparty CI
16:12:16 <inc0> so it's up to you guys
16:12:27 <gema> yep, we will fix that
16:12:29 <inc0> I know, not sure how this is going to fit with infra workflow
16:12:34 <inc0> but that's logistics
16:12:37 <inc0> we'll figure sth out
16:12:50 <hrw> inc0: our goal is to follow upstream afaik
16:12:56 <gema> krtaylor: you will probably be the guinea pic as your 3rd party CI is already there
16:12:57 <inc0> right now, we need to wait for TC resolution and provide feedback for them
16:13:00 <gema> pig x)
16:13:14 <gema> (guinea pig, gosh it came across wrong)
16:13:14 <kfox1111> gema: https://integratedcode.us/2016/04/22/a-step-towards-multi-platform-docker-images/ I think.
16:13:20 <krtaylor> hehheh
16:14:04 <gema> kfox1111: thanks, bookmarked for reading later
16:14:09 <hrw> #link https://integratedcode.us/2016/04/22/a-step-towards-multi-platform-docker-images/
16:14:31 <krtaylor> for 3rd party CI, that would only apply is multi arch was tested upstream, else its on our systems - or am I missing something
16:14:47 <inc0> ok, so anything else on that topic?:) we'll be coming back to this one as things unroll
16:15:29 <inc0> ok moving on
16:15:36 <inc0> #topic Forum feedback https://etherpad.openstack.org/p/kolla-boston-feedback (inc0)
16:15:58 <inc0> let's drop all the random thoughts we have after summit
16:16:03 <inc0> until they disapear;)
16:16:09 <krtaylor> btw, excellent onboarding session, one of the best I went to
16:16:17 <inc0> wow thank you
16:16:23 <sdake> inc0 was the onboarding recorded?
16:16:28 <inc0> no:(
16:16:31 <gema> :(
16:16:34 <sdake> bummer
16:16:34 <inc0> but that was one of feedback for forum
16:16:41 <inc0> so next one probably will be
16:16:51 <inc0> and I can do that any day;)
16:16:57 <sdake> ought to have that onboarding at the ptg as well imo :)
16:16:59 <krtaylor> and bring a hdmi->vga adapter  :)
16:17:04 <gema> sdake: +1
16:17:05 <inc0> and that
16:17:24 <gema> ODS felt like not a good fit for me, I have decided to attend only PTG going forward
16:17:50 <rwellum> onboarding was good. Project update too - but 5pm on Thursday was tough time.
16:18:02 <gema> I did head home Wed night
16:18:10 <spsurya_> inc0: may i also provide the feedback ?
16:18:15 <inc0> spsurya_: ofc
16:18:55 <spsurya_> inc0: i only watched the summit videos
16:19:01 <spsurya_> :)
16:19:22 <krtaylor> gema, it certainly was a bit less technical than in the past - I was hoping for more of an all-in-one midcycle
16:19:32 <gema> yup
16:19:42 <Serlex> Agreed!
16:19:56 <hrw> I hope that my 2 weeks trip for PTG pass ;D
16:20:22 <hrw> s/2/3/
16:21:04 <rwellum> Huge containers feel to this summit. 43 presentations. Several of them conflicted in content.
16:21:52 <Serlex> Several? you are been nice :)
16:21:57 <rwellum> containers/kubernetes
16:22:00 <rwellum> Yeah..
16:22:31 <vhosakot> yeah, many sessions had repeated content
16:22:56 <Serlex> As with anything in life, Summit is up for constructive criticism, some sort coordination would go a long way
16:23:14 <vhosakot> many of the sessions in Forum were not recorded.
16:23:32 <duonghq> gema, summit/ptg splitting make summit lease technical stuff :(
16:23:53 <gema> duonghq: fair enough, I am good with less travel overall
16:23:53 <Serlex> I have etherpad links, should include it in the this meeting etherpad?
16:24:05 <duonghq> ya
16:24:23 <vhosakot> of the speakers in the kuryr session said kolla-kubernetes, openstack-helm and loci all do the same.
16:24:31 <vhosakot> one* of the speakers
16:24:39 <inc0> hmm I think I've lost operator feedback etherpad link, anyone have it handy?
16:24:53 <Serlex> yep inc0
16:25:11 <Serlex> done
16:25:17 <inc0> thanks
16:25:30 <rwellum> vhosakot: +1 lots of confusion about this. And the keynote demo - which was dreadful..
16:25:38 <vhosakot> inc0: https://etherpad.openstack.org/p/boston-deploying-openstack-on-k8s ?
16:26:01 <inc0> yeah, it's already linked in feedback etherpad
16:26:15 <vhosakot> yep
16:29:03 <inc0> thank you all for kind words:)
16:29:39 <vhosakot> inc0: somebody asked me if you used Digital Ocean to create 5 VMs for each attendee.  I said I don't know as I did not know at that point how you created those many VMs for everyone for the workshop.
16:29:54 <inc0> I had my own cloud
16:30:03 <vhosakot> right, you told me.  cool
16:30:06 <inc0> deployed in very similar way that these on workshops:)
16:32:13 <sdake> openstack on openstack ftw :)
16:32:26 <sdake> openstack on openstack on openstack on openstack :)
16:32:30 <vhosakot> lol
16:32:31 <sdake> where doth it end
16:32:36 <spsurya_> :D
16:32:41 <inc0> turtles
16:32:42 <vhosakot> k8s-on-openstack-in-a-loop ;)
16:32:43 <britthouser> turtles all the way down
16:32:49 <hrw> sdake: we need to go deeper
16:32:58 <sdake> britthouser that is the phrase of doom :)
16:32:58 <duonghq> I also saw k8s on k8s ....
16:33:08 <gema> sdake: OOM, killing a random openstack
16:33:21 <inc0> k8s itself is kinda k8s on k8s as k8s runs k8s control services
16:33:23 <hrw> or how it we would say at linaro: we need to crystalize that idea
16:33:25 <hrw> ":D
16:33:28 <spsurya_> while(1){openstack on openstack}
16:33:57 <inc0> ok I think we've exhausted our summit feedbacks;)
16:34:11 <inc0> I encourage everyone to take long look at ops feedback
16:34:16 <inc0> it was very good session
16:34:23 <sdake> inc0 you should thread them together
16:34:24 <inc0> let's make sure to address issues there
16:34:37 <inc0> what do you mena?
16:34:43 <sdake> inc0 our ops feedback sessions are impressive, however, we have not done alot of action on them - alot of stuff in the history of the etherpads is low hanging fruit
16:34:54 <sdake> as in make one master page for the ops sessions and link from that
16:34:55 <vhosakot> many ops told the docs are not the best and do not work OTB without asking help in IRC.  sounded like some ops want kolla to work OTB without spending time in IRC.
16:34:59 <inc0> good idea!
16:35:19 <inc0> #action inc0 to gather past ops feedback sessions and organize them
16:35:44 <inc0> vhosakot: technically that's how it's supposed to be right?
16:36:38 <vhosakot> inc0: I like going to IRC for help, no doubt :)
16:37:24 <inc0> well, what I'm saying is, every time we help someone with basic deploy means we didn't make our docs clear enough
16:37:42 <sdake> inc0 or the person didn't read the docs :)
16:37:47 <inc0> :D
16:37:49 <inc0> that too
16:37:53 <inc0> anyway, moving on
16:37:57 <inc0> #topic open discussion
16:38:04 <daidv> Can I?
16:38:08 <inc0> daidv: ofc
16:38:16 <hrw> https://venturebeat.com/2017/05/16/hp-enterprise-unveils-single-memory-160-terabyte-computer-the-machine/ - 160TB ram.  aarch64
16:38:38 <sdake> wow that must cost a  fortune
16:38:47 <hrw> daidv: go
16:38:51 <hrw> sorry for interrupting
16:38:55 <rwellum> I just ordered 2 of those. :/
16:38:55 <daidv> I have two things.
16:39:00 <daidv> The first one that I want to re-raise "Mixing binary and source image during deployment" blueprint
16:39:03 <daidv> with some poc code
16:39:08 <daidv> https://review.openstack.org/#/c/460436/4/ansible/roles/glance/defaults/main.yml
16:39:22 <daidv> that we will have a new variable for each project
16:39:31 <inc0> daidv: looks good, let's do it!
16:39:40 <daidv> Thanks.
16:40:05 <inc0> I'd do one more thing
16:40:06 <daidv> The second one, I want to ask something about external database for Kolla?
16:40:15 <inc0> we have glance-api-tag: openstack-releae
16:40:26 <inc0> how about doing glance-api-tag: glance-tag
16:40:37 <inc0> and glance-tag: openstack-release
16:40:43 <inc0> so you can specify per-service tags
16:40:47 <inc0> for CI build scenerio
16:41:08 <inc0> daidv: it's possible:)
16:41:12 <daidv> I know, but for special case
16:41:19 <daidv> we can use this : "glance_api_image_full"
16:41:59 <inc0> yeah, but it's inconvenient
16:43:38 <daidv> Ok, agreed. I will make it ASAP and waiting for blueprint is accepted.
16:43:56 <daidv> can we come back with external database,
16:44:13 <daidv> Actually, I have make it by passing boostrap.yml
16:44:24 <daidv> and replace boostrap.yml with boostrap_service.yml during deployment
16:45:08 <inc0> so external database has nova db but not nova schema?
16:45:23 <daidv> (I have created database, set privilege by shell script before deployment)
16:45:35 <daidv> inc0, yep.
16:46:18 <daidv> Can we have some way for config this and setting a new task for
16:46:27 <daidv> creating database ...
16:46:36 <inc0> well, deploy should just work
16:46:36 <daidv> without db_sync?
16:46:50 <inc0> as it won't recreate db if db exists
16:47:51 <daidv> inc0, sure, and operators can manage database by himself.
16:48:23 <egonzalez> having the database_user/passwd with privs, bootstrap.yml will create dbs and users, then db sync
16:48:51 <egonzalez> just override database_address with your db cluster IP
16:48:54 <Jeffrey4l_> egonzalez, +1
16:50:07 <egonzalez> other case is when user/dbs are already created, some changes are needed into bootstrap.yml to allow db sync in external_db
16:51:41 <hrw> bye
16:51:43 <daidv> egonzalez, +1 , for this other case, I alway got failure when I have not clean database
16:52:08 <inc0> ok, let's wrap it up:)
16:52:12 <inc0> thank you all for coming!
16:52:18 <inc0> or rather
16:52:21 <inc0> anyone else?
16:52:26 <inc0> want to add anything?
16:52:53 <inc0> guess not:) thank you all! let's move to our regular work:)
16:52:54 <daidv> thank you for all suggestions.
16:52:58 <inc0> #endmeeting kolla