16:01:33 <sdake> #startmeeting kolla
16:01:34 <openstack> Meeting started Wed Aug 19 16:01:33 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:38 <openstack> The meeting name has been set to 'kolla'
16:01:40 <sdake> #topic rollcall
16:01:41 <SamYaple> first
16:01:53 <bmace> hi
16:02:02 <sdake> o/ - kolla rockin!
16:02:20 <rhallisey> hey
16:02:22 <jmccarthy> o/
16:02:23 <jpeeler> hey
16:02:37 <inc0> afternoon/evening guys
16:02:40 <sdake> waiting 2 more mins for folks
16:03:04 <pbourke> hi
16:03:37 <SamYaple> lets make all the important decisions now
16:03:43 <sdake> #topic Announcements
16:04:16 <sdake> 1. There is an operator midcycle this week - lots of good news on kolla front - will get to that later in agenda
16:05:00 <sdake> 2. I kicked all "Not started" blueprints to rc1 which has a deadline of September 25th (HARD DEADLINE) - more on this in the meeting
16:05:12 <sdake> anyone else have announcements?
16:05:19 <inc0> meeting time?
16:05:30 <sdake> inc0 yup we are in the meeting now
16:05:42 <inc0> I meant to remind that we're moving 30mins forward
16:05:52 <sdake> oh right
16:06:12 <inc0> and remove GMT-night one
16:06:26 <sdake> 3. i am posting an email aftr this meeting to propose we move all meetings to 16;30 including our 22:00 meeting
16:06:35 <sdake> would appreciate fast feedback on that
16:06:53 <sdake> on the mailing list
16:06:59 <sdake> #topic gate status
16:07:16 <sdake> jpeeler has done a fantastic job of integrating build.py with the gate
16:07:30 <sdake> i've done some work to start building all combos of templates + docker + ubuntu + source + binary
16:07:34 <sdake> this is 8 gates total
16:07:40 <sdake> we can't do ubuntu binary
16:07:44 <sdake> so it is  actually 6 gates
16:07:57 <pbourke> good job guys
16:08:06 <rhallisey> nice job jpeeler
16:08:08 <sdake> we only have 2 gates operatoinal at this time
16:08:15 <pbourke> really looking forward to having gates that actually... gate :)
16:08:17 <sdake> but the rest are coming shortly
16:08:33 <sdake> on the gates that actually gate front, we need a --retry because the mirrors re flakey
16:08:46 <inc0> whats plan of CI-checking that services actually run and work well?
16:08:46 <sdake> once the gate works reliably we can possibly make the gates voting
16:09:06 <sdake> but delorean has no mirros so if delorean repo goes down, our voting gate would block
16:09:22 <jpeeler> inc0: that's after image building gets sorted
16:09:22 <sdake> so mirrors of delorean will be the trigger point for voting gating (pus retry)
16:09:44 <sdake> ya after image building is working reliably we can tackle functional ci
16:10:03 <inc0> can we make sources builds block at least?
16:10:11 <sdake> i'd like to start off simple with an AIO deploy on centos binary/source that nova boots and checks the nova instance enters active state
16:10:25 <sdake> inc0 we pull openvswitch from delorean repos
16:10:33 <sdake> the only one we can make voting is ubuntu-source
16:10:36 <sdake> but i'd be game for that
16:11:03 <inc0> well centos-binary is our main distro still, so that wouldnt block too much
16:11:17 <SamYaple> sdake: ubuntu-source isnt ready
16:11:26 <SamYaple> you mean centos-source?
16:11:32 <sdake> yup its a problem that centos-binary is our main distro
16:11:43 <inc0> SamYaple, centos-source still uses delorean openvswitch
16:11:44 <sdake> centos-source also pulls from delorean repos for openvswitch
16:12:07 <inc0> question tho - won't this work without delorean up? openvswitch is in other repos too
16:12:12 <sdake> my action is to ride the delorean people to get them to ssetup mirrors
16:12:17 <SamYaple> ubuntu-source isn't ready though
16:12:30 <sdake> yes we wont make the gates voting untit he code works samyaple ;)
16:12:42 <SamYaple> ok just making sure everyone knows
16:12:46 <SamYaple> ubuntu isnt ready like at all
16:12:57 <SamYaple> im going through it now
16:13:31 <sdake> one thing i need sooner rather then later for gating is for setup_gate.sh to setup an ubuntu environment gate
16:14:10 <sdake> once the gating patches are complete in project-config, we are removing f21-functional gate job (build.sh gating)
16:14:27 <sdake> we also need --retry on the gates if someone wants to tackle that
16:14:51 <sdake> #topic Operator Midcycle
16:15:11 <sdake> #link #link https://etherpad.openstack.org/p/PAO-ops-meetup
16:15:16 <inc0> anyone from kolla is there?
16:15:20 <sdake> #link #link https://etherpad.openstack.org/p/PAO-ops-meetup
16:15:24 <sdake> #link https://etherpad.openstack.org/p/PAO-ops-meetup
16:15:28 <sdake> #undo
16:15:28 <sdake> #undo
16:15:28 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa4c2690>
16:15:29 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa4c25d0>
16:15:30 <sdake> #undo
16:15:31 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa4c2390>
16:15:33 <sdake> #link https://etherpad.openstack.org/p/PAO-ops-meetup
16:15:51 <sdake> #link https://etherpad.openstack.org/p/PAO-ops-containers-for-deployment
16:16:11 <sdake> #link https://etherpad.openstack.org/p/PAO-ops-upgrades
16:16:23 <sdake> inc0 operators are keen to use Kolla
16:16:37 <sdake> I wasn't there but got a report back
16:16:47 <inc0> I know...I pitched kolla a lot;)
16:16:57 <sdake> there was some discussion on osad vs kolla
16:17:18 <sdake> apparently immutability is huge with the operators and this was a big point on the osad vs kolla discussion in the midcycle
16:17:33 <inc0> we had good discussion about kolla in Vancouver ops summit
16:17:35 <sdake> kolla was well represented, people seemed super interested in what we havet o offer
16:17:36 <inc0> upgrades session
16:18:16 <sdake> since it takes us about a week to implement a new container + ansible code for it assuming there is no keystone domain work erequired, we scale extremely quickly
16:18:26 <sdake> the links above (for your later viewiing pleasure)
16:18:28 <sdake> key requirements
16:18:39 <sdake> need upgrade from one version to the next
16:18:59 <sdake> operators want to be able to run rabbitmq/galera on their own vms
16:19:07 <sdake> in some cases rather then in containers
16:19:21 <sdake> there was alot of quesitons about whether docker was production ready
16:19:28 <inc0> it's not a problem with a bit of tinkering of inventory file
16:19:36 <sdake> my answer to that is "for kolla use cases it absolutely is"
16:19:46 <sdake> for more advanced use casewss it is not
16:20:05 <SamYaple> inc0: no that isnt inventory file tinkering, that is enable_rabbitmq: no
16:20:18 <sdake> yup
16:20:24 <SamYaple> but we _can_ is the point
16:20:28 <sdake> I think we can support that use case easily
16:20:36 <SamYaple> if thats a major concern i can write some docs around it
16:20:46 <SamYaple> I wrote the playboosk to support just that
16:20:49 <inc0> tools being used are tripleo and ansible
16:20:57 <sdake> there wasn't alot of discussion about haproxy+keepalived being abstracted out into bare metal like rabbitmq/galera
16:20:57 <inc0> and we'll have both
16:21:11 <sdake> docs will help samyaple
16:21:34 <sdake> any questions?
16:21:39 <sdake> waiting for 30 seconds for irc lag :)
16:21:48 <harmw> hi guys!
16:21:53 <SamYaple> hey harmw
16:22:01 <inc0> now, that's a irc lag harmw :D
16:22:01 <SamYaple> we already discussed moving the time for next week
16:22:11 <SamYaple> so hopefully you wont get cut off anymore
16:22:18 <sdake> hey harmw
16:22:21 <harmw> please excuse me for beeing not as active past weeks
16:22:22 <sdake> harmw check the logs plz :)
16:22:26 <harmw> will do sdake
16:23:07 <sdake> #action all developres to review last two ops midcycle etherpads for ideas
16:23:15 <inc0> I'll talk with Will Auld (moderator of upgrades session) and ask if there is more to be done than things in etherpad
16:23:25 <SamYaple> namedropper
16:23:27 <SamYaple> boo
16:23:33 <sdake> #topic Liberty-3 planning
16:23:34 <SamYaple> :)
16:23:47 <inc0> we
16:24:00 <inc0> we're in middle of l3...is this a good time to plan stuff?;)
16:24:04 <sdake> #link https://launchpad.net/kolla/+milestone/liberty-3
16:24:12 <sdake> please everyone open that page up
16:24:20 <rhallisey> inc0, we're doing status
16:24:22 <sdake> i know clicking is hard ;0
16:24:33 <harmw> ok
16:25:10 <sdake> anything good progress, implemented, needs code review i'm going to skip
16:25:25 <sdake> we have a logging section in the agenda so skipping that one
16:25:49 <sdake> the goal of this session is to identify any bluepritns that wont make aug 31
16:25:56 <sdake> so they can be kicked to rc1
16:25:58 <SamYaple> ok sdake give me a second to update some blueprints
16:26:05 <SamYaple> go over other peoples first
16:26:09 <rhallisey> sdake, kick anything that isn't ceph for me
16:26:20 <sdake> rhallisey kicking
16:26:25 <sdake> 2 mins for people to update their status
16:26:31 <sdake> starting again at 9:29
16:26:36 <harmw> sad, thats easy for me
16:26:39 <harmw> :p
16:26:51 <inc0> any chance to bump ironic priority up?
16:27:21 <inc0> if we land this, we might actually impact tripleo heavily with a bit of luck
16:27:25 <jpeeler> inc0: i know you've pinged me a few times about ironic. i'm on it starting today
16:27:44 <jpeeler> already starting converting my old work to config-external
16:27:46 <inc0> jpeeler, anything we can help you with?
16:28:01 <inc0> I hate tripleo devtest, let's make it better
16:28:10 <SamYaple> sdake: was the core/contrib structure kciked?
16:28:18 <sdake> samyaple yes
16:28:25 <jpeeler> inc0: not yet, learning exercise for me for now since i've not done a new container in a while. but it's being worked on, so i'll let you know more later
16:28:27 <SamYaple> to Mitaka?
16:28:27 <sdake> we will get to rc1 next promise :)
16:28:32 <sdake> i think to rc1
16:28:39 <sdake> keep in mind we can make whatever changes we like
16:28:45 <inc0> appreciate that jpeeler
16:28:50 <sdake> lets focus on l3 for now plz :)
16:29:01 <pbourke> a quick question on the ansible swift bp
16:29:03 <sdake> rhallisey I am going to leave your bugs in liberty-3 ok?
16:29:17 <pbourke> how do people feel about us leaving it up to the op to provide the rings
16:29:18 <sdake> pbourke let me go through them in ordern ow
16:29:18 <rhallisey> sure
16:29:23 <pbourke> sdake: ah
16:29:31 <pbourke> sure
16:29:48 <sdake> ok 3 mins is up
16:29:57 <sdake> hopefully you have had a chance to udate all your blueprints
16:30:18 <sdake> if something is in good progress but it wont land until rc1 in compelted state lets keep it in l3
16:30:20 <sdake> and we can kick it at the end of the cycle
16:30:39 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/kolla-ansible-script
16:30:57 <sdake> diga is responsible for reporting status on this one
16:31:06 <sdake> since he isnt around i'll do that
16:31:18 <sdake> i'm not sure what else is needed here
16:31:22 <sdake> kolla-ansible deploy works ok
16:31:36 <SamYaple> sdake: it needs to be written in python
16:31:38 <sdake> I would appreciate moe discussion on the blueprint so we know hat people want out of it
16:31:42 <SamYaple> we talked about this in L2
16:31:47 <sdake> right
16:31:56 <sdake> can you add discussion to the blueprint on that point
16:32:00 <SamYaple> sure
16:32:03 <harmw> SamYaple: could you add the wy to it?
16:32:06 <sdake> what we wnt here i really undefined
16:32:24 <sdake> https://blueprints.launchpad.net/kolla/+spec/ansible-mongodb
16:32:29 <sdake> coolsvap|away is responsible for this one
16:32:37 <sdake> its a dependency of ceilometer
16:32:40 <sdake> it is not started
16:32:49 <sdake> he said he would knock it out this weekend along with ceilometer
16:32:51 <harmw> is the original even in a working state?
16:32:56 <sdake> harmw no idea
16:33:09 <harmw> (else he's in for more hard labor to get it even up and running)
16:33:35 <harmw> horizon feels like something that needs prio
16:34:18 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/ansible-horizon
16:34:28 <sdake> i just took this over from rhalllisey since he requested it be kicked
16:34:32 <sdake> there is a review up
16:34:44 <pbourke> is it still in wip?
16:34:48 <sdake> rhallisey mind giving an update on your WIP ansible code?
16:35:13 <rhallisey> I haven't looked at horizon since I thought you were going to take it
16:35:18 <sdake> pbourke yes I haven't touched it
16:35:27 <sdake> what state was it in then rhallisey ?
16:35:34 <SamYaple> hey guys im sorry I have to drop off here
16:35:34 <rhallisey> oh
16:35:46 <sdake> SamYaple understood
16:35:47 <rhallisey> basic infrastructure setup
16:35:48 <SamYaple> sdake was there anything else I was needed for?
16:35:49 <rhallisey> that's all
16:35:54 <SamYaple> ive got like 3 min
16:35:58 <sdake> the logging discussion and rc1 discussion :)
16:36:04 <SamYaple> :/
16:36:06 <sdake> but we can tackle that next wek
16:36:13 <SamYaple> ok will ill read logs
16:36:16 <SamYaple> inc0 is leading that
16:36:18 <sdake> or the mailing lit
16:36:21 <sdake> ok
16:36:32 <inc0> we can discuss that tomorrow
16:36:36 <SamYaple> inc0 hit me up later if you haev questions
16:36:37 <harmw> regarding horizon, perhaps I can put in some effort there
16:36:39 <SamYaple> thanks guys im out
16:36:39 <sdake> so before weeks end i plan to have a horizon ansible code up and running
16:36:41 <sdake> or die trying
16:36:49 <rhallisey> SamYaple, see ya
16:36:56 <sdake> harmw if you want to take the wip blueprint that would rock - I am really overloaded
16:37:06 <sdake> but it absolutely needs to finish before the 31st
16:37:18 <sdake> all essential/high need to finish before the 31st plz :)
16:37:30 <harmw> it'd be realy sad if my contribution for L3 would be 0,0
16:37:37 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/replace-config-external
16:37:41 <sdake> harmw sometimes it happens
16:37:48 <harmw> lets not, ok :p
16:37:50 <sdake> harmw you are doing reviews, that is a contirbution
16:38:22 <harmw> sdake: I can't assign myself to it
16:38:43 <sdake> this blueprint is not started
16:38:52 <harmw> (horizon)
16:38:56 <sdake> the idea here is to use a json file to load into the container and remove config-eternal
16:39:02 <sdake> harmw i'll do after meeting ok?
16:39:05 <harmw> sure thing
16:39:18 <sdake> SamYaple if your still around any chance this woudl make liberty3?
16:39:43 <pbourke> does it need to?
16:39:45 <harmw> feels like a no, imho
16:39:56 <sdake> since this is in the not started state, I will speak to sam about it tomorrow when he returns
16:40:03 <harmw> it's a great feature, but I think there's higher prio work still to do
16:40:03 <sdake> and we may kick it to rc1
16:40:07 <harmw> ok
16:40:08 <pbourke> harmw: +1
16:40:09 <harmw> wfm
16:40:18 <sdake> i want the containers to be locked down after liberty
16:40:22 <sdake> as in the structure and config
16:40:28 <sdake> so we have an easy migration path
16:40:50 <sdake> so it is fairly high on my priority list
16:40:58 <sdake> but overall medium given our list of other work
16:41:04 <pbourke> fair point
16:41:07 <harmw> I'd say kickoff the last sprint with this one
16:41:11 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/run-data-container
16:41:18 <sdake> this is unowned
16:41:46 <sdake> harmw wfm since need sam's expertise lets make sure hes on board with that
16:41:55 <harmw> ofcourse :)
16:41:56 <sdake> the idea of this blueprint is to use a data container for /run
16:42:05 <sdake> for things like neutron and haproxy
16:42:10 <sdake> i dont think it can be done for nova
16:42:18 <sdake> this woudl be a breaking change to our containers
16:42:26 <sdake> so again another thing that needs to be locked down before t he release
16:42:35 <sdake> which is september 25th (rc1) deadline
16:42:50 <sdake> anyone interested in giving  this a spin?
16:43:26 <sdake> ok moving to rc1
16:43:32 <harmw> sounds like it needs some more investigation, so perhaps settle in having someone do that and do the works in the next sprint
16:44:23 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/neutron-third-party-plugins
16:44:29 <sdake> note rc1 is not really a sprint
16:44:39 <sdake> its supposed to be bug fixes only :)
16:44:41 <harmw> true true
16:44:48 <sdake> and mandatory features we missed in l3
16:44:54 <sdake> pbourke mind giving an update on this one
16:45:07 <sdake> in other words, will it make aug 31st
16:45:22 <harmw> pbourke: you've got requests for specific plugins here (from ppl)?
16:45:22 <pbourke> i haven't looked at it for a little while, but afaik it just needs a restructure, should not be a big deal
16:45:27 <pbourke> harmw: yes
16:45:30 <harmw> cool
16:45:37 <harmw> $work, perhaps?
16:45:37 <pbourke> sdake: so yes should not be a problem for l3
16:45:49 <sdake> pbourke if you could get a reworked patch in the queue for debate that woudl help
16:45:58 <sdake> the last patch hasn't been touched since the beginning of l3 :)
16:46:07 <sdake> #link https://blueprints.launchpad.net/kolla/+spec/ironic-container
16:46:09 <pbourke> well, I said a while :p
16:46:29 <sdake> jpeeler mind giving us an update on ironic in container and ansibilizing the work
16:46:32 <sdake> it says started
16:46:54 <jpeeler> well it was started from june and then i had to put it down
16:47:12 <jpeeler> so as i was saying earlier, i have started porting my work over to current practices
16:47:42 <jpeeler> and i'll be focused on it now that the gate is running the new build job
16:47:51 <sdake> cool
16:47:59 <sdake> well when it gets to good progress pleae update the tracker
16:48:06 <jpeeler> will do
16:48:18 <sdake> i'm going to start pushing starteds next week
16:48:25 <inc0> jpeeler, if you need any help with ansible, ping me
16:48:27 <sdake> so we can focus on the blueprints we can finish
16:48:43 <jpeeler> inc0: alrighty!
16:48:48 <sdake> #topic liberty rc1 planning
16:48:50 <sdake> we are running short on time
16:48:59 <sdake> so I just want to point out a link
16:49:18 <sdake> #link #link https://launchpad.net/kolla/+milestone/liberty-rc1
16:49:18 <sdake> #undo
16:49:19 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0xa5f8510>
16:49:20 <sdake> #link https://launchpad.net/kolla/+milestone/liberty-rc1
16:49:46 <sdake> you will notice all blueprints here are in not started state
16:49:51 <sdake> they were originally in liberty3
16:50:08 <sdake> if you think something should be pushed to mitaka, be prepared next meeting to make the case :)
16:50:15 <harmw> I'm seeing two already started
16:50:18 <sdake> #topic templating
16:50:30 <sdake> #link #link https://etherpad.openstack.org/p/kolla-dockerfile-template
16:50:35 <sdake> harmw those i just pushed this meeting
16:50:42 <harmw> k
16:50:42 <sdake> ok so good news everyone :)
16:51:03 <sdake> the templating is complete - everything needed is in the review queue
16:51:18 <sdake> please prioritize these reviews today
16:51:26 <harmw> cool
16:51:32 <sdake> i think just nova is left for an ack
16:51:34 <sdake> but not certain
16:51:45 <inc0> how about I make logging stuff in template-only containers?
16:51:46 <sdake> so we have complete parity with docker and docker_templates
16:52:02 <sdake> inc0 logging is next up on agenda
16:52:05 <sdake> we will hae 5 minutes
16:52:07 <sdake> so for templating
16:52:12 <sdake> we need to nuke the docker directory
16:52:21 <inc0> I mean, do we accept new stuff in templating from start?
16:52:27 <sdake> inc0 yes
16:52:28 <inc0> without "normal" Dockerfiles?
16:52:30 <sdake> docker is deprecated
16:52:34 <inc0> ok
16:52:39 <sdake> the docker directory is deprecated now
16:52:42 <sdake> as of today
16:52:55 <inc0> that's what I wanted to hear (read)
16:53:00 <pbourke> +1
16:53:04 <harmw> sdake: is that in the docs already?
16:53:05 <sdake> i am going to make a blueprint for removal of the docker directory
16:53:18 <sdake> harmw no - needs docs changes
16:53:20 <sdake> harmw it is in some of the docs actually
16:53:22 <sdake> the README.md
16:53:26 <rhallisey> uh hold on..
16:53:27 <sdake> iirc
16:53:34 <harmw> I mentioned doing that in some of the changes made in docs recently
16:53:42 <harmw> ok sdake
16:53:44 <inc0> what's up Ryan?
16:54:11 <harmw> building up suspense..
16:54:27 <jpeeler> ha
16:54:31 <harmw> *drumroll*
16:54:46 <rhallisey> I just want to make sure we can consume these
16:54:47 <sdake> rhallisey speak or i'll move on :)
16:54:59 <sdake> rhallisey i will put a blueprint up in the discussion phase
16:55:00 <sdake> for rc1
16:55:03 <inc0> rhallisey, you mean tripleo? this shouldn't affect tripleo
16:55:11 <rhallisey> ya I haven't looked that them at all
16:55:14 <inc0> since its about building dockers
16:55:19 <inc0> not deployment
16:55:22 <sdake> rhallisey we hae cmplete parity with docker so tripleo is unaffecte
16:55:23 <jpeeler> right
16:55:23 <sdake> d
16:55:26 <rhallisey> I just want to be sure since we're using docker dir atm
16:55:56 <inc0> rhallisey, do you build images docker images in tripleo?
16:56:24 <rhallisey> we aren't, but we might
16:56:32 <sdake> #action sdake to make blueprint to remove docker directory
16:56:39 <inc0> I don't think we should tho
16:56:40 <sdake> if you aren't then you can use the docker templates directory and build.py
16:56:45 <rhallisey> kk
16:57:02 <sdake> i dont want to maintain two docker build systems or sets of files
16:57:08 <rhallisey> oh ya agreed
16:57:11 <inc0> let's just teach tripleo to consume registry images, and let build.py do its templating magic
16:57:25 <sdake> ok logging - unfortunately we are out of time
16:57:26 <rhallisey> inc0, I think that's likely the case
16:57:34 <sdake> #topic open discussion
16:57:37 <rhallisey> just was bringing it up
16:57:40 <rhallisey> that's all
16:57:40 <sdake> 3 minutes - sorry for short amount of time
16:57:50 <inc0> sdake, I'll just prepare prototype of loggin and we'll discuss it next week
16:58:19 <inc0> rsyslog container is inprog
16:58:22 <harmw> regarding logging, I know putting logs in a datacontainer makes us able to cater to everyones needs
16:58:23 <sdake> inc0 sounds good
16:58:38 <sdake> yes i'd like one data container for logs if possible per node
16:58:39 <harmw> but docker can log using fluentd, which talks logstash native
16:58:48 <harmw> perhaps nice to look into, some day
16:59:11 <sdake> and to put the log files in /var/log
16:59:14 <inc0> let's discuss it next week, I have few ideas I want to try out
16:59:18 <sdake> cool
16:59:20 <harmw> sounds like a plan
16:59:25 <sdake> have discussion on the logging blueprint pls
16:59:33 <sdake> that way there is a referencable recor
16:59:39 <sdake> if you want, create an etherpad for discussion
16:59:42 <sdake> and link it to the blueprint
16:59:48 <sdake> or link blueprint to it i mean
16:59:55 <sdake> ok we are outof time, we can overflow in #kolla
16:59:58 <sdake> #endmeeting