20:06:06 <sdake> #startmeeting kolla
20:06:07 <openstack> Meeting started Mon Apr 20 20:06:06 2015 UTC and is due to finish in 60 minutes.  The chair is sdake. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:06:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:06:10 <openstack> The meeting name has been set to 'kolla'
20:06:18 <sdake> #topic rollcall
20:06:22 <sdake> o/ hey
20:06:26 <rhallisey> hello
20:06:48 <sdake> daneyon make it?
20:07:09 <sdake> jpeeler shadower?
20:07:23 <jpeeler> hey!
20:07:25 <daneyon_> here
20:07:27 <sdake> hey jpeeler
20:07:32 <sdake> hey daneyon
20:07:39 <sdake> #topic miletone #4 bug beating
20:07:52 <sdake> we have quite a few bugs in milestone #4
20:08:11 <sdake> what I would like to do is cut a stable/kilo release and fix those milestone 34 bugs that dont make it by friday
20:08:16 <sdake> and backport them
20:08:42 <sdake> then we will enter rc releases on stable/kilo branch
20:09:03 <sdake> any objections?
20:09:13 <rhallisey> nope
20:09:26 <daneyon_> i thought we are using rdo juno pkgs
20:09:34 <sdake> we are
20:09:42 <sdake> but we are releasing in the kilo branch
20:09:43 <daneyon_> so would it be stable/juno?
20:09:51 <sdake> i think that would be confusing
20:10:31 <daneyon_> so when we use rdo kilo, then will that be a different stable branch?
20:10:54 <sdake> theoretically that would be stable/liberty
20:11:32 <daneyon_> ok
20:11:36 <sdake> its confusing either way
20:12:01 <daneyon_> i think it's confusing calling it stable/kilo when the code we are basing our work is juno.
20:12:14 <sdake> maybe we can cover that in documentation?
20:12:21 <sdake> we are releasing at the stable/kio release cycle
20:12:30 <daneyon_> people are going to think we are using openstack kilo if it's stable/kilo
20:12:32 <sdake> and some day we may have release from source
20:12:39 <daneyon_> ok
20:12:44 <sdake> i htink we can document that
20:12:53 <sdake> but as is it remains undocumented
20:13:11 <sdake> so settled then -doc fix to the problem?
20:13:12 <daneyon_> ok
20:13:18 <daneyon_> yes
20:13:22 <sdake> cool
20:13:31 <sdake> #topic milestone #4
20:14:36 <sdake> #link https://blueprints.launchpad.net/kolla/milestone-4
20:15:09 <sdake> well I've beendebuggingneutron for the last 7 days
20:15:14 <sdake> so no luck on working on ceilometer :(
20:15:21 <sdake> I'll finish teh job on multios tho
20:15:32 <sdake> I think ceiloemter will have to fit after kilo is branched
20:15:42 <sdake> rhallisey any updates on cinder?
20:15:48 <daneyon_> i have yet to start the ha spec due to #link https://bugs.launchpad.net/kolla/+bug/1444219
20:15:50 <openstack> Launchpad bug 1444219 in kolla milestone-4 "nova booted with neutron fails to obtain dhcp lease" [Critical,Triaged] - Assigned to Steven Dake (sdake)
20:16:03 <sdake> ya i think that spec are going into l1
20:16:07 <sdake> i'll move it now
20:16:18 <rhallisey> not much
20:16:32 <rhallisey> sdake, did you get a chance to try it at all?
20:16:57 <sdake> rhallisey no the code wasn't merged last I checked
20:17:06 <rhallisey> ya I need another +2
20:17:07 <sdake> and I've been debugging neutron for 7 days groan
20:17:57 <daneyon_> rhallisey what review needs another +2?
20:18:12 <rhallisey> https://review.openstack.org/#/c/170965/
20:18:58 <sdake> if someone wants to review that I'd super love them :)
20:19:10 <sdake> it looked good, the compose file looked less good :(
20:19:37 <rhallisey> sdake, ya I'll add a volume once this is merged
20:19:45 <rhallisey> to fix the compose file
20:19:49 <sdake> do you need a volume mount
20:19:54 <sdake> or can't you just mount that stuff locally?
20:20:02 <sdake> i.e. does it need to persist?
20:20:18 <rhallisey> that's a good question..
20:20:20 <sdake> by mount locally i mean use the container filesystem
20:20:29 <rhallisey> I don't this it needs to persist
20:20:40 <sdake> then just remove all the bind mounts and your good to go :)
20:20:41 <rhallisey> s/this/think
20:20:43 <sdake> with testing of course :)
20:21:21 <rhallisey> sdake, right I'll get rid of what I can
20:21:38 <sdake> cool deadline is friday - i'd like to test it out before then
20:21:43 <sdake> so hopefullly it hits the repo soon :)
20:22:21 <daneyon_> I don't see a compose file in #link https://review.openstack.org/#/c/170965/
20:22:29 <sdake> it is a different eview
20:22:30 <daneyon_> is that in a different review?
20:22:38 <daneyon_> ok
20:22:41 <rhallisey> ya I separated them
20:23:24 <sdake> #topic open discussion
20:23:44 <jpeeler> one +2 for reviews?
20:24:01 <sdake> right
20:24:07 <sdake> jpeeler had brought up the idea of requriing 1 +2 for reviews
20:24:17 <sdake> now that our core team is smaller and our velocity is higher
20:24:22 <sdake> thoughts?
20:24:59 <rhallisey> sdake, do you feel like we're moving too slow with reviews?
20:25:00 <daneyon_> anyone see if we can call an ENV var in compose yml volumes?
20:25:34 <sdake> ya reviews are too slow
20:26:11 <sdake> it really takes 6 core team size to support 2 +2 reviewerss
20:26:17 <sdake> although it can be done with 5
20:27:30 <rhallisey> sdake, we can certainly go for it until we get a few more cores
20:27:33 <jpeeler> i admit i haven't helped the speed much lately
20:27:52 <sdake> jpeeler shit happens
20:27:53 <rhallisey> ya I haven't been reviewing at full speed either
20:28:11 <daneyon_> i feel like there has been a few times the second core review helped from merging a bug, etc..
20:28:36 <rhallisey> daneyon_, that's what I was thinking too
20:28:37 <daneyon_> With tat said, I am fine with a single +2, we may just need to troubleshoot more bugs on the backend
20:28:42 <jpeeler> there's always value in additional review
20:28:46 <sdake> there are 2 solutions to this problem - increase capacity - reduce requirements
20:28:49 <rhallisey> that's what I liked about it
20:29:33 <sdake> i'm personally willing to wait for the 2 core reviewers
20:29:47 <sdake> i can harass ppl on irc if need ;)
20:30:07 <sdake> I am hopeful after the dog & pony show at summit we will have more contribs :)
20:30:16 <rhallisey> indeed
20:30:25 <daneyon_> sdake: your harassment technique works well
20:30:28 <sdake> should we revisit this after summit?
20:30:33 <daneyon_> ya
20:30:52 <rhallisey> ya sure
20:31:05 <sdake> #action revisit dropping to 1 core revewier post summit
20:31:10 <daneyon_> anyone see if we can call an ENV var in compose yml volumes?
20:31:44 <sdake> daneyon_ you could really throw me a bone if you pasted a sample :)
20:31:44 <rhallisey> don't know
20:31:55 <daneyon_> OK, i'll continue to look into it
20:32:20 <rhallisey> sdake, Slow and I have been able to successfully show integration with tripleo
20:32:30 <sdake> rhallisey nice!
20:32:40 * sdake would like to be a fly on th wall in that meeting ;)
20:32:58 <rhallisey> we made a video.  I just need to narrate it and and I'll post it somewhere the public can see
20:33:02 <sdake> using compose or something else?
20:33:05 <rhallisey> atomic
20:33:18 <rhallisey> but again could be with compose
20:33:21 <rhallisey> not much changes
20:33:25 <rhallisey> like only a few lines
20:33:40 <sdake> i don't have a strong preference to how poeple use kolla
20:33:59 <rhallisey> we'll at least it can go either way
20:34:02 <sdake> obey the license, and i'm good :)
20:34:52 <sdake> anything else folks?
20:35:03 <daneyon_> nada
20:35:10 <sdake> enjoy :)
20:35:13 <sdake> #endmeeting