#openstack-keystone: keystone

Meeting started by d34dh0r53 at 15:02:17 UTC (full logs).

Meeting summary

  1. roll call (d34dh0r53, 15:02:39)
  2. review past meeting work items (d34dh0r53, 15:04:26)
    1. https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-03-20-15.00.html (d34dh0r53, 15:05:05)
    2. ACTION: d34dh0r53 Look into adding/restoring a known issues section to our documentation (d34dh0r53, 15:05:27)
    3. ACTION: d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation (d34dh0r53, 15:05:34)

  3. liaison updates (d34dh0r53, 15:05:45)
  4. specification OAuth 2.0 (hiromu) (d34dh0r53, 15:07:20)
    1. https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext (d34dh0r53, 15:07:29)
    2. https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability (d34dh0r53, 15:07:31)
    3. https://review.opendev.org/c/openstack/keystone-specs/+/861554 (d34dh0r53, 15:07:35)
    4. https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls (d34dh0r53, 15:07:39)
    5. https://review.opendev.org/c/openstack/keystone/+/838108 (d34dh0r53, 15:07:43)
    6. https://review.opendev.org/c/openstack/keystoneauth/+/838104 (d34dh0r53, 15:07:45)

  5. specification Secure RBAC (dmendiza[m]) (d34dh0r53, 15:09:37)
    1. https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_ (d34dh0r53, 15:09:49)
    2. https://review.opendev.org/c/openstack/keystone/+/902730 (Merged) (d34dh0r53, 15:09:57)
    3. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713 (Merged) (d34dh0r53, 15:09:59)
    4. https://review.opendev.org/c/openstack/keystone/+/913999 (dmendiza[m], 15:12:02)
    5. https://review.opendev.org/c/openstack/devstack/+/914115 (dmendiza[m], 15:13:45)
    6. https://review.opendev.org/c/openstack/keystone/+/914520 (dmendiza[m], 15:14:36)
    7. https://review.opendev.org/c/openstack/keystone/+/909238 (dmendiza[m], 15:16:00)
    8. https://review.opendev.org/c/openstack/tempest/+/912489 (dmendiza[m], 15:18:00)
    9. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/913593 (dmendiza[m], 15:19:33)
    10. https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/914089 (dmendiza[m], 15:20:54)

  6. specification Improve federated users management (gtema) (d34dh0r53, 15:27:23)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews (d34dh0r53, 15:27:27)

  7. specification OpenAPI support (gtema) (d34dh0r53, 15:33:28)
    1. https://review.opendev.org/c/openstack/keystone-specs/+/910584 (d34dh0r53, 15:33:33)

  8. open discussion (d34dh0r53, 15:35:28)
    1. https://foss.heptapod.net/python-libs/passlib/-/issues/190 (d34dh0r53, 15:35:40)

  9. bug review (d34dh0r53, 15:39:33)
    1. https://bugs.launchpad.net/keystone/?orderby=-id&start=0 (d34dh0r53, 15:39:40)
    2. https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0 (d34dh0r53, 15:39:59)
    3. https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0 (d34dh0r53, 15:40:32)
    4. https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0 (d34dh0r53, 15:40:55)
    5. https://bugs.launchpad.net/keystonemiddleware/+bug/1940770 (d34dh0r53, 15:42:10)
    6. https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0 (d34dh0r53, 15:43:16)
    7. https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0 (d34dh0r53, 15:43:34)

  10. conclusion (d34dh0r53, 15:43:49)
    1. https://etherpad.opendev.org/p/dalmation-ptg-keystone (d34dh0r53, 15:44:15)


Meeting ended at 15:44:25 UTC (full logs).

Action items

  1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
  2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


Action items, by person

  1. d34dh0r53
    1. d34dh0r53 Look into adding/restoring a known issues section to our documentation
    2. d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation


People present (lines said)

  1. d34dh0r53 (66)
  2. dmendiza[m] (30)
  3. opendevmeet (3)


Generated by MeetBot 0.1.4.