15:02:41 <d34dh0r53> #startmeeting keystone
15:02:41 <opendevmeet> Meeting started Wed Feb 14 15:02:41 2024 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:41 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:41 <opendevmeet> The meeting name has been set to 'keystone'
15:03:00 <d34dh0r53> #topic roll call
15:03:07 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m], mharley, jph, gtema
15:03:08 <bbobrov> hello
15:03:09 <d34dh0r53> o/
15:04:48 <xek> o/
15:07:41 <dmendiza[m]> 🙋‍♂️
15:09:58 <d34dh0r53> #topic review past meeting work items
15:10:25 <d34dh0r53> no updates on either of mine :/
15:10:37 <d34dh0r53> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:10:45 <d34dh0r53> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:10:59 <d34dh0r53> oops, forgot the link
15:11:05 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2024/keystone.2024-02-07-15.02.html
15:11:11 <d34dh0r53> next up
15:11:16 <d34dh0r53> #topic liaison updates
15:12:29 <opendevreview> Boris Bobrov proposed openstack/keystone master: Test listing app creds with deleted role  https://review.opendev.org/c/openstack/keystone/+/908998
15:13:31 <opendevreview> Boris Bobrov proposed openstack/keystone master: Test listing app creds with deleted role  https://review.opendev.org/c/openstack/keystone/+/908998
15:13:32 <d34dh0r53> one note from releases, we've transitioned stable/yoga to unmaintained/yoga as part of the new TC resolution 2023-07-24 Unmaintained status replaces Extended Maintenance
15:13:46 <d34dh0r53> #link https://governance.openstack.org/tc/resolutions/20230724-unmaintained-branches.html
15:14:02 <d34dh0r53> and I don't have any VMT updates
15:15:02 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:15:11 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:15:13 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:15:15 <d34dh0r53> External OAuth 2.0 Specification
15:15:17 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:15:19 <d34dh0r53> OAuth 2.0 Implementation
15:15:21 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls
15:15:23 <d34dh0r53> OAuth 2.0 Documentation
15:15:25 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108
15:15:27 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:17:46 <d34dh0r53> doesn't look like hiromu is around
15:18:00 <d34dh0r53> so we'll move on
15:18:14 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:18:23 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:18:25 <d34dh0r53> 2024.1 Release Timeline
15:18:27 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:18:29 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:18:31 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/902730 (Merged)
15:18:33 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/903713
15:21:20 <dmendiza[m]> Yeah, I finally updated all the tempest tests
15:21:26 <dmendiza[m]> Just looking for reviews now
15:22:01 <d34dh0r53> sweet! thanks dmendiza[m]
15:22:16 <d34dh0r53> I think I've reviewed everything, but please let me know if not
15:22:39 <dmendiza[m]> I think there's one more backport I need. I'll ping you once I get the patch up for review.
15:22:51 <d34dh0r53> thanks dmendiza[m]
15:23:23 <d34dh0r53> next up
15:23:35 <d34dh0r53> #topic specification Improve federated users management (previously: Add schema version and support to "domain" attribute in mapping rules) (gtema)
15:23:41 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/748748 - waiting for reviews
15:23:54 <gtema> still waiting for reviews;-)
15:25:23 <d34dh0r53> ack, I'll try to get to it this week
15:25:38 <gtema> would be awesome, thanks
15:26:18 <d34dh0r53> np
15:26:27 <d34dh0r53> #topic open discussion
15:26:41 <d34dh0r53> nothing is on the agenda but I'll leave the floor open for a few minutes
15:30:24 <d34dh0r53> cool, moving on
15:30:34 <d34dh0r53> #topic bug review
15:30:40 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:30:46 <d34dh0r53> two new bugs for keystone
15:31:00 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2052916
15:31:44 <d34dh0r53> looks like someone is working on that, thank you!
15:31:57 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2053137
15:32:20 <bbobrov> this is mine
15:32:24 <d34dh0r53> ack
15:32:31 <bbobrov> i have discovered a bit more after i posted it
15:32:37 <d34dh0r53> thank you for looking into it
15:33:37 <d34dh0r53> hmm, I wonder if that notification is ever being processed
15:34:07 <bbobrov> the problem is in listing role assignments with the role
15:34:37 <bbobrov> https://opendev.org/openstack/keystone/src/commit/7dc175a41f92e3f01cf26912431d0f2c98a03b32/keystone/assignment/core.py#L103 returns an empty list
15:35:14 <bbobrov> and i think i understand why
15:35:32 <bbobrov> https://opendev.org/openstack/keystone/src/commit/7dc175a41f92e3f01cf26912431d0f2c98a03b32/keystone/assignment/core.py#L1342 because the role assignments are first deleted
15:35:43 <bbobrov> and of course listing them then returns an empty list
15:35:52 <d34dh0r53> I was just going to say, probably because the role_id no longer exists
15:36:18 <d34dh0r53> I think #1342 needs to move below the notification
15:36:24 <bbobrov> right, i switched the lines and my test passes
15:36:37 <bbobrov> i will post the fix after my tox run finishes
15:36:54 <bbobrov> https://review.opendev.org/c/openstack/keystone/+/908998 - the test to demo the issue btw
15:38:03 <d34dh0r53> cool, thank you
15:38:15 <d34dh0r53> ping when you're ready for reviews
15:39:02 <d34dh0r53> next up
15:39:18 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:39:37 <d34dh0r53> no new bugs for python-keystoneclient
15:39:47 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:40:05 <d34dh0r53> keystoneauth is also good to go
15:40:11 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:40:25 <d34dh0r53> as is keystonemiddleware
15:40:29 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:40:50 <d34dh0r53> pycadf has no new bugs
15:41:35 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:41:47 <d34dh0r53> nor does ldappool
15:41:51 <d34dh0r53> #topic conclusion
15:42:31 <d34dh0r53> It looks like Registration is open for the PTG
15:42:33 <d34dh0r53> #link https://openinfra.dev/ptg/
15:44:22 <d34dh0r53> And here's a link to the etherpad we'll be using
15:44:35 <d34dh0r53> #link https://etherpad.opendev.org/p/dalmation-ptg-keystone
15:44:48 <d34dh0r53> I just started it so expect more soon
15:44:55 <bbobrov> i am not sure that my company will pay that price for the ticket
15:45:52 <gtema> too many zeroes in the price?
15:46:34 <d34dh0r53> lol
15:46:52 <d34dh0r53> free ninety free!
15:47:52 <d34dh0r53> Thanks everyone!
15:47:54 <d34dh0r53> #endmeeting