15:00:00 <d34dh0r53> #startmeeting keystone
15:00:00 <opendevmeet> Meeting started Wed Oct 11 15:00:00 2023 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'keystone'
15:00:10 <d34dh0r53> #topic roll call
15:00:12 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m]
15:00:14 <d34dh0r53> o/
15:00:50 <dmendiza[m]> 🙋‍♂️
15:02:23 <d34dh0r53> #topic review past meeting work items
15:02:49 <d34dh0r53> no updates unfortunately
15:02:52 <d34dh0r53> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:03:01 <d34dh0r53> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:03:13 <d34dh0r53> forgot the link
15:03:16 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-10-04-15.00.html
15:03:25 <d34dh0r53> #topic liaison updates
15:04:29 <d34dh0r53> release: the 2024.1 Caracal cycle has started, release information here:
15:04:45 <d34dh0r53> #link https://releases.openstack.org/caracal/schedule.html
15:04:53 <d34dh0r53> nothing from VMT
15:06:12 <d34dh0r53> next up
15:06:22 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:06:31 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:06:33 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fenhance-oauth2-interoperability
15:06:35 <d34dh0r53> External OAuth 2.0 Specification
15:06:37 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:06:39 <d34dh0r53> OAuth 2.0 Implementation
15:06:41 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls
15:06:43 <d34dh0r53> OAuth 2.0 Documentation
15:06:45 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108
15:06:47 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:08:13 <d34dh0r53> I don't think hiromu_ is around so we'll move on
15:08:29 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:08:37 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:08:39 <d34dh0r53> 2024.1 Release Timeline
15:08:41 <d34dh0r53> Update oslo.policy in keystone to enforce_new_defaults=True
15:08:43 <d34dh0r53> Update oslo.policy in keystone to enforce_scope=True
15:09:29 <dmendiza[m]> No updates this week
15:09:35 <dmendiza[m]> haven't had a chance to work on Keystone things lately
15:09:45 <d34dh0r53> ack, thanks dmendiza[m]
15:09:52 <d34dh0r53> #topic open discussion
15:10:00 <d34dh0r53> nothing from me, and nothing on the agenda
15:11:58 <dmendiza[m]> Yeah, I don't have much either
15:12:37 <d34dh0r53> cool, moving on
15:12:42 <d34dh0r53> #topic bug review
15:12:52 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:12:55 <d34dh0r53> nothing new for keystone
15:13:03 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:13:18 <d34dh0r53> python-keystoneclient has a new bug
15:13:28 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/+bug/1993614
15:14:28 <d34dh0r53> hmm, I wonder if that's an openstackclient bug, I'll have to look where that happens
15:15:00 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:15:11 <d34dh0r53> no new bugs for keystoneauth
15:15:42 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:15:50 <d34dh0r53> no new bugs for keystonemiddleware
15:15:58 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:16:06 <d34dh0r53> pycadf is good
15:16:10 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:16:21 <d34dh0r53> as is ldappool
15:16:30 <d34dh0r53> that does it for bug review
15:16:35 <d34dh0r53> #topic conclusion
15:17:00 <d34dh0r53> Reminder to register for the PTG if you haven't yet
15:17:02 <d34dh0r53> #link https://ptg2023.openinfra.dev
15:17:09 <d34dh0r53> That's All Folks!
15:17:12 <d34dh0r53> #endmeeting