15:02:03 <d34dh0r53> #startmeeting keystone
15:02:03 <opendevmeet> Meeting started Wed Jul 26 15:02:03 2023 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:03 <opendevmeet> The meeting name has been set to 'keystone'
15:03:01 <d34dh0r53> #topic roll call
15:03:06 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, reqa, dmendiza[m]
15:03:14 <d34dh0r53> o/
15:03:39 <xek> o/
15:03:49 <dmendiza[m]> 🙋‍♂️
15:04:14 <d34dh0r53> #topic review past meeting work items
15:04:31 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-07-19-14.59.html
15:05:02 <d34dh0r53> there are just two action items, both on me about the known issues section of the documentation
15:05:31 <d34dh0r53> I haven't gotten to either so I'll push those
15:05:41 <d34dh0r53> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:05:48 <d34dh0r53> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:06:11 <d34dh0r53> #topic liaison updates
15:06:16 <d34dh0r53> nothing from VMT
15:08:30 <d34dh0r53> moving on to specifications
15:08:47 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:08:59 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:09:01 <d34dh0r53> External OAuth 2.0 Specification
15:09:03 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:09:05 <d34dh0r53> OAuth 2.0 Implementation
15:09:07 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Fsupport-oauth2-mtls
15:09:09 <d34dh0r53> OAuth 2.0 Documentation
15:09:11 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/838108
15:09:13 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:10:39 <d34dh0r53> It doesn't look like Hiromu is around, please review the patches and docs as you have time
15:11:16 <d34dh0r53> next up
15:11:41 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:11:50 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:11:52 <d34dh0r53> Service Role Implementation
15:11:54 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/863420
15:11:56 <d34dh0r53> Manager Role Implementation
15:11:58 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/822601
15:12:00 <d34dh0r53> Keystone Tempest Plugin Updates
15:12:02 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-tempest-plugin/+/885799
15:12:09 <dmendiza[m]> Hey, sorry no updates.  I've been meaning to test the manager patch but haven't gotten around to it.
15:12:20 <d34dh0r53> ack, thanks dmendiza[m]
15:13:22 <d34dh0r53> #topic open discussion
15:13:32 <d34dh0r53> (drencrom) Remove cache invalidation when using expired token
15:13:35 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystonemiddleware/+/889191
15:14:21 <d34dh0r53> I resubmitted this patch and it looks like it's now passing, can xek and dmendiza[m] take a look, it's really just a backport but due to gerrit confusing zuul we had to abandon the original
15:17:41 <d34dh0r53> once that one is merged all of the backports are in
15:17:44 <d34dh0r53> I think
15:18:18 <d34dh0r53> next up
15:18:21 <d34dh0r53> (reqa) Add openstack cli support for OAuth 2.0 Device Authorization Grant with PKCE:
15:18:23 <d34dh0r53> review request
15:18:25 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystoneauth/+/883852
15:18:27 <d34dh0r53> Reasoning: When switching wsgi-keystone.conf to use PKCE for WebSSO, this also applies to the CLI (e.g. ForgeRock implemented the same)
15:18:48 <d34dh0r53> Needs reviews
15:19:55 <d34dh0r53> moving on to bug review
15:20:01 <d34dh0r53> #topic bug review
15:20:10 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:20:19 <d34dh0r53> no new bugs for keystone
15:20:34 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:21:08 <d34dh0r53> nothing new for python-keystoneclient
15:21:31 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:22:05 <d34dh0r53> nothing new for keystoneauth
15:22:18 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:22:37 <d34dh0r53> keystonemiddleware is also clear
15:22:49 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:23:05 <d34dh0r53> pycadf is good
15:23:17 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:23:27 <d34dh0r53> as is ldappool
15:23:33 <d34dh0r53> #topic conclusion
15:23:44 <d34dh0r53> short and sweet this week :)
15:23:57 <d34dh0r53> thanks for all the hard work on reviews and the like
15:24:10 <d34dh0r53> hope to see everyone at the reviewathon on Friday!
15:24:25 <d34dh0r53> #endmeeting