15:07:43 <dmendiza[m]> #startmeeting keystone
15:07:43 <opendevmeet> Meeting started Tue Jun 20 15:07:43 2023 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:43 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:07:43 <opendevmeet> The meeting name has been set to 'keystone'
15:08:08 <dmendiza[m]> d34dh0r53 is out on PTO so I'm covering for him today
15:08:27 <fungi> drencrom: knikolla: yeah, i can take a look in a bit and roll it back to the last good revision
15:08:39 <dmendiza[m]> #topic Перекличка
15:08:44 <dmendiza[m]> I mean,
15:08:47 <dmendiza[m]> #topic Roll Call
15:08:49 <dmendiza[m]> 😜
15:09:00 <knikolla> thanks fungi :)
15:09:05 <knikolla> dmendiza: lol
15:09:09 <knikolla> o/
15:10:05 <dmendiza[m]> I would ping now, but I have no idea if the list is good on the russian notes
15:11:27 <dmendiza[m]> #topic Review Past Meeting Action Items
15:11:50 <dmendiza[m]> #link https://meetings.opendev.org/meetings/keystone/2023/keystone.2023-06-06-15.04.html
15:12:12 <dmendiza[m]> I'm punting on d34dh0r53 's Action Items until next week when he gets back
15:12:15 <dmendiza[m]> #action d34dh0r53 Look into adding/restoring a known issues section to our documentation
15:12:24 <dmendiza[m]> #action d34dh0r53 add https://bugs.launchpad.net/keystone/+bug/1305950 to the known issues section of our documentation
15:12:35 <dmendiza[m]> #action dmendiza[m] and d34dh0r53 to look at keystonemiddleware stevedore failures
15:12:45 <dmendiza[m]> ^^^  I was out on PTO last week and did not get a chance to look into this
15:12:52 <dmendiza[m]> I assume things are still failing
15:13:08 <dmendiza[m]> seems to be some kind of bad loading of the dynamic backends by stevedore
15:13:17 <dmendiza[m]> but also, can't recreate it locally so that sucks
15:13:28 <dmendiza[m]> #action d34dh0r53 look at https://bugs.launchpad.net/keystone/+bug/2018644
15:13:38 <dmendiza[m]> #action d34dh0r53 figure out why https://review.opendev.org/c/openstack/keystone/+/874844 is failing
15:13:53 <dmendiza[m]> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/874346
15:14:09 <dmendiza[m]> ^^^ we didn't have reviewathons the last couple of weeks, but I think we should be back on track this week
15:14:17 <dmendiza[m]> That's it for the action items
15:14:20 <dmendiza[m]> moving on ...
15:14:28 <dmendiza[m]> #topic Liaison Updates
15:14:39 <dmendiza[m]> I don't have any updates ...
15:14:47 <dmendiza[m]> ... anyone else updating on anything?
15:17:15 <dmendiza[m]> OK, moving on
15:17:37 <dmendiza[m]> #topic OAuth 2.0
15:17:44 <dmendiza[m]> hiromu around?  Any updates this week?
15:17:54 <hiromu> o/
15:18:48 <hiromu> I have some comments for knikolla's comment on Ext OAuth2.0 codes, but it should be done on Gerrit.
15:18:56 <hiromu> I'll add them later
15:21:17 <dmendiza[m]> thanks, hiromu
15:21:24 <dmendiza[m]> #topic Secure RBAC
15:21:37 <dmendiza[m]> No updates this week, sorry.  Just coming back from PTO.
15:23:35 <dmendiza[m]> #topic SqlAlchemy 2.0
15:23:46 <dmendiza[m]> stephenfin: around?  Any updates this week?
15:24:05 <stephenfin> Around, yup
15:24:30 <stephenfin> No big updates. I talked to knikolla at Summit last week and I see there have been some reviews. Just need some more :)
15:25:09 <stephenfin> I have started proposing temporary jobs to run unit tests with SQLAlchemy 2.0. Would be good to do one for Keystone also
15:26:04 <stephenfin> Examples for nova: https://review.opendev.org/c/openstack/nova/+/886230 ironic: https://review.opendev.org/c/openstack/ironic/+/886020 placement: https://review.opendev.org/c/openstack/placement/+/886229
15:26:17 <dmendiza[m]> Nice, yeah would be good to get a job going for us as well
15:27:26 <dmendiza[m]> OK, moving on
15:27:36 <dmendiza[m]> #topic Summit Recap
15:27:45 <dmendiza[m]> knikolla: anything notable we should talk about today?
15:28:28 <knikolla> mmm give me 1 sec to find the notes
15:29:08 <fungi> for reference (sorry to interrupt), you can find the meeting notes prior to corruption with the timeslider button, but the last good state appears to be https://etherpad.opendev.org/p/keystone-weekly-meeting/timeslider#62833
15:29:24 <fungi> i'll roll it back to that state in a momen
15:29:26 <fungi> t
15:29:34 <dmendiza[m]> thanks, fungi
15:30:32 <knikolla> We discussed with gtema who is PTL of OpenStackSDK and agreed to give him core on keystoneauth.
15:30:50 <fungi> (and done)
15:30:59 <knikolla> To get some help on core reviews of a key library for these projects.
15:32:07 <stephenfin> sweet, didn't know you'd discussed that. That's a good move. Any chance you could give openstacksdk-core to include others (basically me)
15:32:17 <stephenfin> (but also others in the future)
15:32:45 <knikolla> We can definitely discuss that on a team level rather than individual level.
15:32:55 <knikolla> And perhaps extend that to keystoneclient as well.
15:33:40 <gtema> stephenfin - atm our core is way too big for that
15:33:41 <opendevreview> Stephen Finucane proposed openstack/keystone master: Add job to test with SQLAlchemy master (2.x)  https://review.opendev.org/c/openstack/keystone/+/886509
15:34:03 <knikolla> stephenfin: this all was discussed on the hallway track of the summit :)
15:34:07 <knikolla> probably the most productive track.
15:34:29 <gtema> that is definitely the most productive track
15:36:32 <knikolla> dmendiza: that's all from me. I think. For now.
15:37:12 <stephenfin> gtema: Okay, cool. Let's work to reduce that (not: core, not service-core) and then I'll bring it up again. Thanks :)
15:37:34 <gtema> agreed
15:37:39 <stephenfin> hallway-tracks++
15:38:22 <dmendiza[m]> thanks, knikolla
15:38:31 <dmendiza[m]> I'll ask d34dh0r53 for his highlights next week
15:38:39 <dmendiza[m]> #toipc Open Discussion
15:38:44 <dmendiza[m]> Anything else y'all want to talk about?
15:39:19 <drencrom> I'm a bit puzzled about this backport https://review.opendev.org/c/openstack/keystonemiddleware/+/884738
15:39:52 <drencrom> zuul seems to run ok but does not add a +1 message
15:40:40 <drencrom> Also need just a WF +1 on this one that was lost on a rebase  https://review.opendev.org/c/openstack/keystonemiddleware/+/877398
15:41:21 <dmendiza[m]> drencrom +W'd
15:41:29 <dmendiza[m]> That's strange
15:41:38 <dmendiza[m]> I wonder if it's because it's waiting on the previous patch in the chain?
15:43:54 <frickler> I mentioned focal jobs earlier, maybe worth taking as an action item
15:44:08 <drencrom> I think usually that works even if there is a dependency that is not merged
15:47:13 <knikolla> frickler: thanks for the note about focal jobs. dmendiza can you capture that as an action item?
15:47:38 <drencrom> I see you approved the dependency knikolla, I'll test again later after it merges to see if something changes.
15:48:19 <dmendiza[m]> #action knikolla to look into focal jobs
15:48:30 <dmendiza[m]> Cool
15:48:44 <dmendiza[m]> OK, moving on ...
15:48:47 <dmendiza[m]> #topic Bug Review
15:49:22 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:49:28 <dmendiza[m]> No new keystone bugs this week
15:49:47 <dmendiza[m]> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:49:51 <dmendiza[m]> no new python-keystone client bugs
15:50:07 <dmendiza[m]> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:50:12 <dmendiza[m]> no new keystoneauth bugs
15:50:28 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:51:17 <dmendiza[m]> Looks like tjereat least one new bug report in keystonemiddleware
15:51:22 <dmendiza[m]> *there's at
15:51:31 <dmendiza[m]> Not sure if we looked at this last meeting:
15:51:32 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bug/2023015
15:51:46 <dmendiza[m]> > Process immediately fails in case cache data can't be decrypted
15:53:45 <dmendiza[m]> And also
15:53:46 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bug/2023689
15:54:08 <dmendiza[m]> > Unit test failures with python 3.10+ "Max retries exceeded with url: /v3/ec2tokens"
15:58:51 <zaitcev> Should be easy to reproduce at least.
15:59:00 <dmendiza[m]> Yeah, I'll try to take a look this week
15:59:51 <dmendiza[m]> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:59:55 <dmendiza[m]> no new pycadf bugs
15:59:55 <zaitcev> The connection refused means the test server died, I guess. So it only needs finding out why.
16:00:17 <dmendiza[m]> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
16:00:30 <dmendiza[m]> No new ldappool bugs
16:00:50 <dmendiza[m]> OK, y'all that's all on the agenda for today
16:01:00 <dmendiza[m]> Thanks for joining
16:01:02 <dmendiza[m]> #endmeeting