15:02:38 <d34dh0r53> #startmeeting keystone
15:02:38 <opendevmeet> Meeting started Tue Mar 14 15:02:38 2023 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:38 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:38 <opendevmeet> The meeting name has been set to 'keystone'
15:02:47 <d34dh0r53> #topic roll call
15:03:10 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla[m], lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev, arequate, dmendiza[m]
15:03:46 <knikolla[m]> d34dh0r53: i will be lurking, but i have a meeting conflict due to DST changing this weekend.
15:04:30 <dmendiza[m]> 🙋‍♂️
15:05:11 <d34dh0r53> ack knikolla[m]
15:05:22 <d34dh0r53> o/
15:05:51 <d34dh0r53> #topic review past meeting work items
15:05:57 <d34dh0r53> no updates here
15:06:12 <d34dh0r53> #action d34dh0r53 look into the keystone-groups members as well https://review.opendev.org/admin/groups/d7203dc55fa9bdf98c578b16ac398e0c754a1a67,members not sure if it's used any more
15:07:10 <d34dh0r53> #topic liaison updates
15:07:15 <d34dh0r53> no updates from me either
15:07:35 <dmendiza[m]> #link https://releases.openstack.org/antelope/schedule.html
15:07:40 <dmendiza[m]> It's final RC week
15:07:56 <d34dh0r53> indeed
15:08:13 <dmendiza[m]> Not sure if we need any patches to land?  Spin a new RC?
15:08:46 <d34dh0r53> I was going to ask when we get to mTLS, not sure what the status of those backports are
15:09:05 <dmendiza[m]> Cool. 👍️
15:10:19 <d34dh0r53> that's the next topic :)
15:10:44 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:11:08 <d34dh0r53> not sure if hiromu is around given the time change
15:14:40 <d34dh0r53> Ok, hiromu if you're reading the meeting log, please reach out with any assistance needed with the backports
15:14:46 <d34dh0r53> next up
15:15:18 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:15:26 <d34dh0r53> any updates dmendiza[m] ?
15:15:49 <dmendiza[m]> Negative
15:16:17 <d34dh0r53> ack, thanks
15:16:38 <d34dh0r53> next up we have
15:16:55 <d34dh0r53> #topic specification SQLAlchemy 2.0 (stephenfin)
15:17:08 <d34dh0r53> #link https://review.opendev.org/q/topic:sqlalchemy-20+is:open+project:openstack/keystone
15:17:11 <d34dh0r53> Can I get reviews on this, while I have context/time to close it out?
15:17:13 <d34dh0r53> What more do you need from me?
15:17:39 <d34dh0r53> I will start reviewing these, cores please do the same
15:17:59 <d34dh0r53> and reach out to stephenfin with any questions
15:18:49 <d34dh0r53> #topic open discussion
15:19:05 <d34dh0r53> (drencrom) Need one more +2 for this backport:
15:19:07 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystonemiddleware/+/873921
15:19:18 <d34dh0r53> dmendiza[m]: mind giving that backport a +2?
15:19:54 <dmendiza[m]> done
15:20:26 <d34dh0r53> thank you!
15:20:46 <d34dh0r53> (mustafakemalgilor) PooledLdapHandler message.clean() patch backports
15:23:10 <d34dh0r53> https://review.opendev.org/c/openstack/keystone/+/866723/1 we need to merge the backports of this
15:23:23 <d34dh0r53> please review when you get a chance
15:23:54 <d34dh0r53> #topic bug review
15:24:08 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:25:46 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/2009752 this is a new bug, I'll look into this as I'm working on federation currently
15:26:03 <d34dh0r53> #action d34dh0r53 investigate https://bugs.launchpad.net/keystone/+bug/2009752
15:26:27 <d34dh0r53> no more new bugs for keystone
15:26:37 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:26:53 <d34dh0r53> nothing new in python-keystoneclient
15:27:03 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:27:16 <d34dh0r53> keystoneauth is clean
15:27:28 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:27:42 <d34dh0r53> no new bugs in keystonemiddleware
15:27:49 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:28:05 <d34dh0r53> pycadf is clean
15:28:08 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:28:16 <d34dh0r53> so is ldappool
15:28:21 <d34dh0r53> #topic conclusion
15:28:47 <d34dh0r53> short meeting today, let me know if I should move it for the next few weeks as DST shifts happen
15:29:05 <d34dh0r53> thanks all, have a great week :)
15:29:13 <d34dh0r53> #endmeeting