15:03:08 <d34dh0r53> #startmeeting keystone
15:03:08 <opendevmeet> Meeting started Tue Jan  3 15:03:08 2023 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:08 <opendevmeet> The meeting name has been set to 'keystone'
15:03:13 <d34dh0r53> #topic roll call
15:03:25 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev
15:04:17 <zaitcev> Happy New Year
15:05:04 <hiromu_> o/ happy new year
15:05:20 <d34dh0r53> o/ Happy New Year!
15:06:21 <knikolla[m]> o/
15:07:22 <d34dh0r53> #topic review past meeting work items
15:07:44 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-12-20-15.00.html
15:08:23 <d34dh0r53> reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:08:55 <d34dh0r53> There wasn't much of a reviewathon at the end of the year so most of these will push
15:09:12 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:09:26 <d34dh0r53> reviewathon https://review.opendev.org/c/openstack/keystone/+/838108
15:10:04 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/838108
15:10:46 <d34dh0r53> reviewathon https://review.opendev.org/c/openstack/keystone/+/860928
15:12:11 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/860928
15:12:19 <d34dh0r53> reviewathon https://review.opendev.org/c/openstack/keystone/+/863420
15:12:53 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/863420
15:13:04 <d34dh0r53> d34dh0r53 update the CrossProjectLiaisons wiki https://wiki.openstack.org/wiki/CrossProjectLiaisons
15:13:15 <d34dh0r53> I still need to to this, will try to take care of it this week
15:13:18 <d34dh0r53> #action d34dh0r53 update the CrossProjectLiaisons wiki https://wiki.openstack.org/wiki/CrossProjectLiaisons
15:13:34 <d34dh0r53> #actiond34dh0r53 look into the keystone-groups members as well https://review.opendev.org/admin/groups/d7203dc55fa9bdf98c578b16ac398e0c754a1a67,members not sure if it's used any more
15:13:40 <d34dh0r53> #actiond34dh0r53 look into the keystone-groups members as well https://review.opendev.org/admin/groups/d7203dc55fa9bdf98c578b16ac398e0c754a1a67,members not sure if it's used any more
15:13:44 <d34dh0r53> :/
15:13:56 <d34dh0r53> #action d34dh0r53 look into the keystone-groups members as well https://review.opendev.org/admin/groups/d7203dc55fa9bdf98c578b16ac398e0c754a1a67,members not sure if it's used any more
15:14:34 <d34dh0r53> reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/867603
15:14:55 <d34dh0r53> this one just needs a final +2+W, maybe knikolla[m] can look at it
15:15:02 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/867603
15:15:12 <d34dh0r53> that does it for the past meeting items
15:15:39 <d34dh0r53> #topic liaison updates
15:15:49 <d34dh0r53> nothing from VMT
15:16:35 <d34dh0r53> as always please let me know if you'd like a liaison position
15:16:47 <d34dh0r53> moving on to specs
15:17:07 <d34dh0r53> #topic specification OAuth 2.0
15:17:52 <d34dh0r53> we have another spec for External OAuth 2.0 Authorization Server Support
15:17:54 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:18:22 <d34dh0r53> hiromu_ and I discussed this during the last reviewathon and I'd like to prioritize it for this week if possible
15:18:42 <hiromu_> yes, I'd like to ask you to review this topic first, then move on to mTLS later.
15:19:15 <hiromu_> we have also submitted a corresponding patch https://review.opendev.org/c/openstack/keystonemiddleware/+/868734
15:20:17 <d34dh0r53> so we'll focus on this spec during the reviewathon this week
15:20:26 <knikolla[m]> I'll try to look at it today, but after today, I'm on vacation for the rest of the week.
15:20:42 <d34dh0r53> thanks knikolla[m]
15:22:08 <hiromu_> thanks. also, revewing them at reviewathon next week would be fine for me.
15:22:24 <d34dh0r53> ack
15:22:40 <d34dh0r53> #topic specification Secure RBAC
15:22:50 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:23:35 <d34dh0r53> the specifications have merged but we still have the implementation patches to review
15:23:49 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/863420
15:24:02 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/822601
15:24:28 <d34dh0r53> there are some -1's on the manager role implementation (2nd link) that need to be addressed
15:25:10 <d34dh0r53> moving on to open discussion
15:25:17 <d34dh0r53> #topic open discussion
15:25:23 <d34dh0r53> we have one item
15:25:27 <d34dh0r53> 2022-01-03 (hiromu)
15:25:29 <d34dh0r53> OAuth2.0 External Authorization Server Support
15:25:31 <d34dh0r53> I'd like to request to review patches for this topic first and then review the mTLS OAuth2.0 later.
15:25:33 <d34dh0r53> Spec: https://review.opendev.org/c/openstack/keystone-specs/+/861554
15:25:35 <d34dh0r53> Patch: https://review.opendev.org/c/openstack/keystonemiddleware/+/868734
15:25:37 <d34dh0r53> Depends on: https://review.opendev.org/c/openstack/keystoneauth/+/860614
15:25:39 <d34dh0r53> is it possible to be a co-author for the OIS2023 submission from Tacker?
15:26:04 <hiromu_> ah, thank you for coping it
15:26:11 <d34dh0r53> we've discussed the review of the spec in next weeks reviewathon
15:26:18 <hiromu_> the first topic has been already discussed the above
15:26:25 <d34dh0r53> yeah
15:27:00 <hiromu_> for the second one, I'd like to ask knikolla: to be co-author for our submission for OIS 2023
15:27:10 <hiromu_> if you don't mind and it's possible
15:27:28 <knikolla[m]> sure
15:27:37 <hiromu_> great. thank you
15:27:46 <hiromu_> I'll share the manuscript as soon as possible
15:27:57 <d34dh0r53> awesome!
15:29:13 <d34dh0r53> anything else on this topic?
15:29:34 <hiromu_> no. that's all from me.
15:29:38 <hiromu_> thank you
15:29:56 <d34dh0r53> great, thank you!
15:30:02 <d34dh0r53> moving on to
15:30:06 <d34dh0r53> #topic bug review
15:30:20 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:30:38 <d34dh0r53> nothing new for keystone
15:30:55 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:31:25 <d34dh0r53> nothing new here either
15:31:37 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:32:12 <d34dh0r53> there is a new bug for keystone auth
15:32:15 <d34dh0r53> x-openstack-request-id changed at redirected request Edit
15:32:23 <d34dh0r53> https://bugs.launchpad.net/keystoneauth/+bug/2000742
15:32:27 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bug/2000742
15:33:50 <d34dh0r53> it looks like the author may be working on a patch
15:34:21 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:34:39 <d34dh0r53> nothing new for keystonemiddleware
15:34:41 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:34:57 <d34dh0r53> pycadf is unchanged
15:35:08 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:35:22 <d34dh0r53> and ldappool is good
15:35:32 <d34dh0r53> that does it for bug review
15:35:37 <d34dh0r53> #topic conclusion
15:36:51 <d34dh0r53> I've started going through the bug backlogs and closing out incomplete or already fixed bugs, if you get an email and/or think I closed something in error please feel free to re-open it or let me know
15:37:26 <d34dh0r53> the Keystone backlog in particular has some *very* old items that are likely now irrelevant or have been fixed
15:37:50 <d34dh0r53> That's it from me for this meeting, anyone have anything else?
15:38:37 <d34dh0r53> Thanks everyone, happy new year! Looking forward to working with y'all this year :)
15:38:40 <d34dh0r53> #endmeeting