15:00:00 <d34dh0r53> #startmeeting keystone
15:00:00 <opendevmeet> Meeting started Tue Dec 13 15:00:00 2022 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:00 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:00 <opendevmeet> The meeting name has been set to 'keystone'
15:00:06 <d34dh0r53> #topic roll call
15:00:14 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek, gmann, zaitcev
15:02:52 <d34dh0r53> #topic review past meeting work items
15:03:09 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-12-06-15.00.html
15:03:22 <gmann> o/
15:03:25 <d34dh0r53> we didn't really have a reviewathon so I'm going to push those items to next week
15:03:28 <d34dh0r53> o/ gmann
15:03:46 <d34dh0r53> err, this week
15:03:52 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/838104
15:03:58 <hiromu> o/
15:04:10 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/838108
15:04:13 <d34dh0r53> o/ hiromu
15:04:26 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/860928
15:04:42 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystoneauth/+/860923
15:05:42 <d34dh0r53> I still haven't had a chance to look at the user-defined attribute control, but things are starting to slow down for the end of the year so I should be able to look into that
15:05:51 <gmann> there is service role implementation also up https://review.opendev.org/c/openstack/keystone/+/863420
15:06:04 <d34dh0r53> #action d34dh0r53 look into user-defined attribute access control
15:07:33 <d34dh0r53> gmann: ack, thanks, I'll add it to the list to look at this week
15:07:42 <d34dh0r53> #action reviewathon https://review.opendev.org/c/openstack/keystone/+/863420
15:08:15 <d34dh0r53> and a couple of house cleaning reviews for knikolla[m] :)
15:08:31 <d34dh0r53> #action knikolla[m] please review https://review.opendev.org/c/openstack/pycadf/+/863702
15:08:44 <d34dh0r53> #action knikolla[m] please review https://review.opendev.org/c/openstack/keystonemiddleware/+/866805
15:09:14 <d34dh0r53> I think that does it for the past meeting work items
15:09:26 <d34dh0r53> #topic liaison updates
15:09:37 <d34dh0r53> nothing from VMT
15:10:12 <d34dh0r53> and I don't think we have anything from release management
15:10:33 <d34dh0r53> #help Please let me know if you're interested in volunteering for a liaison role
15:10:58 <d34dh0r53> #topic specification OAuth 2.0 (hiromu)
15:11:06 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:11:18 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/843765
15:11:36 <hiromu> i've just updated the spec according to knikolla's comment
15:11:45 <hiromu> https://review.opendev.org/c/openstack/keystone-specs/+/843765
15:12:01 <hiromu> https://review.opendev.org/c/openstack/keystone-specs/+/843765/17..18 . this might be better.
15:12:17 <d34dh0r53> hiromu: I saw that, thank you!
15:12:25 <hiromu> :)
15:12:45 <hiromu> i'd like to quickly check it again at the reviewathon this week
15:13:17 <hiromu> also, move forward to the review of codes: https://review.opendev.org/c/openstack/keystone/+/860613, if possible.
15:13:28 <d34dh0r53> hiromu: ok, I'll make sure we hold one and try to ensure that knikolla[m] and xek are there
15:13:51 <hiromu> great. thanks.
15:14:14 <d34dh0r53> no problem, thank you
15:14:52 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:15:00 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:15:10 <d34dh0r53> The Service Role Spec was merged, yay!
15:16:22 <d34dh0r53> now on to reviewing the implementation code
15:17:01 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/863420
15:17:19 <d34dh0r53> also, we need more reviews on the Manager Role Implementation
15:17:27 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/822601
15:18:48 <d34dh0r53> anything I missed for Secure RBAC?
15:19:04 <gmann> I think that is all
15:20:23 <d34dh0r53> ack, thanks gmann!
15:20:33 <d34dh0r53> moving on to open discussion
15:20:39 <d34dh0r53> #topic open discussion
15:21:34 <d34dh0r53> drencrom: zuul failing because test-requirements not compatible with python 3.10 (see https://review.opendev.org/c/openstack/keystonemiddleware/+/860481)
15:21:36 <zaitcev> Is Dave our PTL still?
15:21:45 <d34dh0r53> zaitcev: yes, I'm the PTL
15:25:10 <d34dh0r53> zaitcev: can I help with something?
15:25:57 <zaitcev> d34dh0r53: Did you see my e-mail on Thursday? Maybe it went to wrong Dave.
15:26:35 <d34dh0r53> zaitcev: what was the subject, I was heads down last week and may have missed it
15:26:59 <zaitcev> d34dh0r53: "Keystone work"
15:29:42 <d34dh0r53> zaitcev: ahh, just found it, you sent it to the correct Dave, the correct Dave didn't reply, my bad
15:30:30 <zaitcev> d34dh0r53: np
15:31:02 <d34dh0r53> zaitcev: are you available on Friday from 9-10 Central (15:00-16:00 UTC)?
15:31:40 <zaitcev> d34dh0r53: yes
15:31:40 <d34dh0r53> that is when we have our reviewathons, I'll forward you the invite and it will give you a good idea of what we're prioritizing in terms of reviews/issues
15:31:58 <d34dh0r53> awesome!
15:32:12 <d34dh0r53> back to the meeting
15:32:25 <zaitcev> oh, I tried to make it, but I was unable to find out where review-a-thon was held.
15:32:35 <d34dh0r53> drencrom: zuul failing because test-requirements not compatible with python 3.10 (see https://review.opendev.org/c/openstack/keystonemiddleware/+/860481)
15:32:57 <d34dh0r53> this needs one of the housekeeping reviews to merge: https://review.opendev.org/c/openstack/keystonemiddleware/+/866805
15:33:10 <d34dh0r53> hopefully knikolla[m] can give that one the go ahead
15:33:24 <d34dh0r53> anything else before we move to bug review?
15:33:53 <d34dh0r53> #topic bug review
15:34:02 <d34dh0r53> first up #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:36:29 <d34dh0r53> I just replied to https://bugs.launchpad.net/keystone/+bug/1999294 asking for more information
15:37:22 <d34dh0r53> another new one, https://bugs.launchpad.net/keystone/+bug/1999068
15:38:13 <d34dh0r53> that's interesting, we'll need to dig into that one
15:38:59 <d34dh0r53> that's the new bugs for Keystone
15:39:14 <d34dh0r53> next up we have
15:39:16 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:39:36 <d34dh0r53> nothing new for python-keystoneclient
15:39:53 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:40:11 <d34dh0r53> https://bugs.launchpad.net/keystoneauth/+bug/1999431 is new
15:40:37 <zaitcev> Hooold on. Is this not the time when you make someone volunteer for every specific bug and see it through? Or how it's done in Keystone? The one you answered and asked for logs is fine, but the other is set to fall through cracks.
15:41:15 <d34dh0r53> zaitcev: well, we're running a bit short on volunteers these days :)
15:41:53 <zaitcev> ok, sorry. How about this, I'll try to reproduce 1999068
15:42:02 <d34dh0r53> I'm planning on using some of my EOY time to try to triage and wrangle our bug backlogs
15:42:07 <d34dh0r53> zaitcev: that would be awesome!
15:43:06 <d34dh0r53> https://bugs.launchpad.net/keystoneauth/+bug/1999431 is low-hanging-fruit, any volunteers on that one?
15:44:54 <d34dh0r53> let me know, or I'll take it
15:45:38 <d34dh0r53> that does it for keystoneauth
15:46:04 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:46:22 <d34dh0r53> nothing new for keystonemiddleware
15:46:33 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:46:50 <d34dh0r53> pycadf has nothing new
15:47:05 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:47:15 <d34dh0r53> neither does ldappool
15:47:56 <d34dh0r53> that does it for bug review, thanks for taking the reproducer on the app-cred bug zaitcev
15:48:08 <d34dh0r53> #topic conclusion
15:48:16 <d34dh0r53> anything else before we go?
15:49:06 <d34dh0r53> thanks everyone! see y'all at the reviewathon
15:49:09 <d34dh0r53> #endmeeting