15:02:07 <d34dh0r53> #startmeeting keystone
15:02:07 <opendevmeet> Meeting started Tue Oct 11 15:02:07 2022 UTC and is due to finish in 60 minutes.  The chair is d34dh0r53. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:07 <opendevmeet> The meeting name has been set to 'keystone'
15:02:14 <d34dh0r53> #topic Roll Call
15:02:17 <xek> o/
15:02:20 <d34dh0r53> admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek
15:02:24 <h-asahina> o/
15:02:25 <d34dh0r53> o/
15:02:54 <d34dh0r53> sorry for the late start folks
15:03:10 <dmendiza[m]> 🙋‍♂️
15:03:26 <dmendiza[m]> I don't apologize for late starts until 5 minutes after. 😜
15:03:41 <d34dh0r53> lol, thanks dmendiza[m], noted
15:03:58 <d34dh0r53> #topic Review past meeting work items
15:04:12 <d34dh0r53> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-10-04-15.01.html
15:04:37 <d34dh0r53> looks like there were 4 action items from last week
15:04:45 <d34dh0r53> dmendiza[m] submit a patch to request the release for keystoneauth
15:04:55 <dmendiza[m]> working on that right meow
15:05:29 <d34dh0r53> thanks dmendiza[m], I won't add another action item then
15:05:36 <d34dh0r53> d34dh0r53 work with dmendiza[m] to reserve a slot for the operator hours for keystone at the ptg
15:06:23 <d34dh0r53> this has been done, our operator hours are on Friday 21-Oct to 15:00-16:00
15:06:42 <d34dh0r53> in the Mitaka room
15:06:52 <d34dh0r53> d34dh0r53 work with dmendiza[m] to reserve our regular slots for the PTG (2 hours on 2 days, total of 4 hours)
15:07:17 <d34dh0r53> also done, our schedule is on the PTGBot site
15:07:30 <d34dh0r53> #link https://ptg.opendev.org/ptg.html
15:08:13 <d34dh0r53> Monday and Tuesday 13:00-15:00 UTC
15:08:22 <d34dh0r53> dmendiza[m] will look at https://bugs.launchpad.net/keystone/+bug/1990987
15:08:43 <dmendiza[m]> did not get a chance to look at it, let's bump it to next week
15:08:59 <d34dh0r53> dmendiza[m]: ack
15:09:06 <d34dh0r53> #action dmendiza[m] will look at https://bugs.launchpad.net/keystone/+bug/1990987
15:09:34 <d34dh0r53> next up we have
15:09:35 <d34dh0r53> #topic Liaison Updates
15:10:09 <d34dh0r53> anything from release management?
15:10:52 <d34dh0r53> ok,
15:10:54 <dmendiza[m]> I think all the releases have shipped for Zed?
15:13:10 <d34dh0r53> I think so, it looks like everything other pycadf and ldappool have releases for zed and I don't think we release those per cycle
15:13:49 <d34dh0r53> next up is VMT
15:14:19 <d34dh0r53> I filed a bug regarding a medium CVE in keystone that I'm currently working on
15:15:36 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/1992183
15:15:42 <d34dh0r53> sorry, it's a high
15:16:03 <d34dh0r53> Any other liaison updates?
15:16:38 <d34dh0r53> #help still looking for additional cross-project liaisons
15:16:43 <d34dh0r53> ping me if you're interested
15:17:03 <d34dh0r53> on to specs
15:17:21 <d34dh0r53> #topic specification OAuth 2.0 (h_asahina)
15:17:36 <d34dh0r53> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:17:44 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone-specs/+/843765
15:17:53 <h-asahina> We've submitted patches for mtls OAuth2.0
15:17:56 <h-asahina> https://review.opendev.org/c/openstack/keystoneauth/+/860614
15:17:57 <h-asahina> https://review.opendev.org/c/openstack/keystonemiddleware/+/860615
15:17:59 <h-asahina> https://review.opendev.org/c/openstack/keystone/+/860613
15:18:39 <d34dh0r53> great, thank you!
15:19:03 <h-asahina> :)
15:19:36 * dmendiza[m] adds patches to review queue
15:20:18 <d34dh0r53> thanks dmendiza[m], and we'll look at these during the reviewathon on Friday
15:20:31 <h-asahina> thanks. it's also welcome if you have additional comments for spec after reading these patches.
15:20:58 <d34dh0r53> excellent, thanks again h-asahina
15:21:22 <d34dh0r53> #topic specification Secure RBAC (dmendiza[m])
15:21:39 <d34dh0r53> #link https://governance.openstack.org/tc/goals/selected/consistent-and-secure-rbac.html#z-release-timeline_
15:21:50 <d34dh0r53> dmendiza[m]: any s-rbac updates?
15:24:00 <dmendiza[m]> I added a topic to discuss this during PTG
15:24:26 <dmendiza[m]> I want to make sure we're all on the same page as far as next steps for this cycle
15:24:51 <d34dh0r53> great, thank you
15:25:46 <d34dh0r53> #topic Open Discussion
15:26:07 <d34dh0r53> drencom has added a review request for
15:26:21 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bug/1987355
15:26:52 <d34dh0r53> it looks like there has been a patch submitted, please review that if you have time and we'll look at this one during the reviewathon too
15:28:18 <d34dh0r53> #topic Open Discussion - Antelope PTG
15:28:46 <d34dh0r53> As I said earlier we have slots reserved for the PTG
15:29:13 <d34dh0r53> We have two 2 hour blocks on Monday and Tuesday and an operator-hours on Friday
15:29:33 <d34dh0r53> You can see all of the times on the PTGBot site
15:30:14 <d34dh0r53> #link https://ptg.opendev.org/ptg.html
15:30:27 <d34dh0r53> and our agenda is here
15:30:38 <d34dh0r53> #link https://etherpad.opendev.org/p/antelope-ptg-keystone
15:31:14 <d34dh0r53> If you have conflicts, or if you'd like to suggest different times for our slots please let me know and I'll see what we can do
15:31:30 <d34dh0r53> and please feel free to add any agenda items that you'd like to discuss
15:32:18 <d34dh0r53> anything else for open discussion?
15:32:28 <h-asahina> ah, I have an question.
15:32:38 <d34dh0r53> go ahead h-asahina
15:32:51 <h-asahina> https://etherpad.opendev.org/p/keystone-weekly-meeting
15:33:14 <h-asahina> we're trying to realize fine grained access control in Tacker
15:33:55 <h-asahina> for example, adding "vendor" and "location" attributes to users and use them to control access.
15:34:40 <h-asahina> my question is does keystone allow using user-defined users' attribute for the access control?
15:35:24 <d34dh0r53> hmm, I don't think so, but dmendiza[m] or knikolla[m] might know for sure
15:40:06 <d34dh0r53> #action d34dh0r53 look into user-defined attribute access control
15:40:13 <d34dh0r53> h-asahina: I'll get back to you on that
15:40:29 <h-asahina> great. thanks.
15:40:41 <d34dh0r53> anything else for open discussion?
15:41:15 <d34dh0r53> #topic bug review
15:41:21 <d34dh0r53> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:41:33 <d34dh0r53> looks like we have a couple of new bugs
15:41:47 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/1992186
15:41:56 <d34dh0r53> "int object is not iterable" when using numerical group names
15:42:49 <d34dh0r53> it looks like there is already a patch up for this with several reviews
15:42:56 <d34dh0r53> #link https://review.opendev.org/c/openstack/keystone/+/860726
15:43:30 <d34dh0r53> next up we have the bug I filed
15:43:33 <d34dh0r53> #link https://bugs.launchpad.net/keystone/+bug/1992183
15:43:39 <d34dh0r53> Openstack: Application credential token remains valid longer than expected Edit
15:44:23 <d34dh0r53> #action d34dh0r53 submit fix for Bug/1992183
15:44:38 <d34dh0r53> should have something later in the week
15:44:59 <d34dh0r53> other than those two there aren't any new bugs for Keystone
15:45:14 <d34dh0r53> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:45:38 <d34dh0r53> nothing new for python-keystoneclient
15:45:57 <d34dh0r53> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:46:04 <d34dh0r53> nothing new here either
15:46:30 <d34dh0r53> next up keystonemiddleware
15:46:33 <d34dh0r53> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:47:04 <d34dh0r53> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:47:28 <d34dh0r53> pycadf doesn't have any new bugs either
15:47:43 <d34dh0r53> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:47:50 <d34dh0r53> ldappool is good to go
15:48:05 <d34dh0r53> #topic wrap up
15:48:34 <d34dh0r53> Anyone have anything else to bring up before we close for this week?
15:49:35 <d34dh0r53> one additional housekeeping note, there won't be a weekly meeting next week due to the PTG
15:49:58 <d34dh0r53> we'll resume on 25-Oct
15:50:02 <d34dh0r53> thanks folks!
15:50:06 <d34dh0r53> #endmeeting