15:00:51 <dmendiza[m]> #startmeeting keystone
15:00:51 <opendevmeet> Meeting started Tue Sep  6 15:00:51 2022 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:51 <opendevmeet> The meeting name has been set to 'keystone'
15:02:18 <dmendiza[m]> #topic Roll Call
15:02:23 <dmendiza[m]> Courtesy ping for admiyo, bbobrov, crisloma, d34dh0r53, dpar, dstanek, hrybacki, knikolla, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, ruan_he, wxy, sonuk, vishakha, Ajay, rafaelwe, xek
15:02:59 <dmendiza[m]> ^^ above is from the agenda, which can be found here:
15:03:01 <dmendiza[m]> #link https://etherpad.opendev.org/p/keystone-weekly-meeting
15:04:25 <h_asahina> o/
15:04:26 <knikolla> o/
15:04:44 <xek> ol
15:04:53 <dmendiza[m]> Hi y'all!
15:05:02 <dmendiza[m]> Let's get started
15:05:10 <dmendiza[m]> #topic Review Past Meeting Action Items
15:05:22 <dmendiza[m]> #link https://meetings.opendev.org/meetings/keystone/2022/keystone.2022-08-30-15.00.html
15:05:34 <dmendiza[m]> Looks like we didn't have any
15:05:49 <dmendiza[m]> #topic Liaison Updates
15:07:12 <dmendiza[m]> Zed-3 deadline was last week
15:07:25 <dmendiza[m]> The zed branch patch is up for review:
15:07:26 <dmendiza[m]> #link https://review.opendev.org/c/openstack/releases/+/855904
15:08:56 <dmendiza[m]> I think there was a keystoneauth patch we wanted to make sure was included? 🤔
15:10:02 <dmendiza[m]> Yeah,
15:10:04 <dmendiza[m]> #link https://review.opendev.org/c/openstack/keystoneauth/+/830734
15:10:31 <dmendiza[m]> I'm not sure how to get that in ... looks like we might need a new release of keystoneauth first?
15:11:57 <dmendiza[m]> I can follow up with the release team to see what needs to be done
15:12:12 <dmendiza[m]> #action dmendiza[m] to look into making a new keystoneauth release
15:13:29 <dmendiza[m]> OK, moving on
15:13:49 <dmendiza[m]> #topic OAuth 2.0
15:14:19 <dmendiza[m]> Like I mentioned we did merge the keystoneauth patch
15:14:28 <dmendiza[m]> and I'll look into making a new release that includes it
15:14:57 <h_asahina> got it. Many thanks for your time and help to merge that patch.
15:15:15 <dmendiza[m]> Any other updates this week, h_asahina ?
15:15:48 <h_asahina> ah, I'd like to confirm the status of demo that knikolla mentioned in the last meeting.
15:16:41 <knikolla> Sorry, I was on vacation the latter half of last week.
15:17:01 <h_asahina> it's ok. I asked that because we hasitate to decide whether we have to inmplement it based on our understanding
15:17:42 <knikolla> I understand. I'm sorry I let it slip. I'll prioritize it for next week's meeting.
15:18:33 <h_asahina> thanks a lot
15:18:36 <dmendiza[m]> cool, thanks y'all
15:18:47 <dmendiza[m]> #topic Secure RBAC
15:18:56 <dmendiza[m]> I don't think we made any progress on this the last week?
15:20:14 <dmendiza[m]> Yeah, I don't see any patches waiting for reviews
15:20:40 <dmendiza[m]> we might need a FFE if gmann still wants to get those changes into Zed
15:25:59 <dmendiza[m]> OK, moving on
15:26:42 <dmendiza[m]> #topic Change to role inheritance
15:26:44 <dmendiza[m]> #link https://review.opendev.org/c/openstack/keystone-specs/+/334364
15:26:54 <dmendiza[m]> I'm going to -1 and ask to move this to the new cycle
15:27:19 <dmendiza[m]> Same with
15:27:21 <dmendiza[m]> #topic Keystone identity mapping to support project definition as a JSON
15:27:26 <dmendiza[m]> #link https://review.opendev.org/c/openstack/keystone-specs/+/748748
15:28:02 <dmendiza[m]> #topic Keystonemiddleware Bug 1987355
15:28:04 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bug/1987355
15:28:10 <dmendiza[m]> I did not have a chance to dig into this
15:28:23 <dmendiza[m]> knikolla: did you have any time to look at it?
15:28:44 <knikolla> nope
15:31:40 <dmendiza[m]> Maybe I'll have some time to look at it this week ...
15:31:43 * dmendiza[m] punts
15:31:52 <dmendiza[m]> #topic Open Discussion
15:32:07 <dmendiza[m]> Anything else y'all want to talk about before we look at bugs?
15:37:10 <knikolla> so, are we moving back to a distributed leadership model?
15:37:26 <knikolla> or do we have any volunteers for ptl :)
15:39:04 <dmendiza[m]> I'm trying to see if someone in our team can do it.
15:39:13 <dmendiza[m]> I would, but I will be taking paternity leave for a while during this cycle.
15:39:29 <dmendiza[m]> I might still do it and just have someone help out while I'm out...
15:39:42 <dmendiza[m]> meeting with some folks from my team to figure it out tomorrow.
15:40:29 <knikolla> dmendiza[m]: thanks for the update and for being ptl all this time.
15:40:51 <dmendiza[m]> 👍️
15:41:23 <dmendiza[m]> OK, moving on to bugs
15:41:32 <dmendiza[m]> #topic Bug Review
15:41:33 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:41:48 <dmendiza[m]> We do have one new Keystone bug
15:41:50 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/+bug/1988297
15:41:58 <dmendiza[m]> > Duplicate index external_id in table access_rule of keystone database
15:42:59 <dmendiza[m]> Looks like a straightforward SQL issue
15:45:22 <dmendiza[m]> We also looked at the fix for https://bugs.launchpad.net/keystone/+bug/1988168 last week
15:45:39 <dmendiza[m]> knikolla: should be ready to merge: https://review.opendev.org/c/openstack/keystone/+/855198
15:46:15 <dmendiza[m]> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:46:25 <dmendiza[m]> Looks like no new python-keystoneclient bugs
15:46:40 <dmendiza[m]> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:47:27 <dmendiza[m]> We do have a new keystoneauth bug:
15:47:29 <dmendiza[m]> #link https://bugs.launchpad.net/keystoneauth/+bug/1988668
15:49:25 <dmendiza[m]> Hmm... seems like a bug in tests?  Maybe they're working on a patch for it.
15:50:04 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:50:08 <dmendiza[m]> no new bugs in keystonemiddleware
15:50:19 <dmendiza[m]> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:50:23 <dmendiza[m]> and no new bugs in pycadf
15:51:28 <dmendiza[m]> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:51:40 <dmendiza[m]> Hmm... looks like we might have a new bug there:
15:51:43 <dmendiza[m]> #Link https://bugs.launchpad.net/ldappool/+bug/1987066
15:56:44 <dmendiza[m]> That's it for the bug review
15:56:59 <dmendiza[m]> And that's about all the time we have for the meeting.
15:57:03 <dmendiza[m]> Thanks for joining, y'all!
15:57:06 <dmendiza[m]> #endmeeting