15:01:17 <dmendiza[m]> #startmeeting keystone
15:01:17 <opendevmeet> Meeting started Tue Mar 22 15:01:17 2022 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:17 <opendevmeet> The meeting name has been set to 'keystone'
15:01:31 <dmendiza[m]> #topic Roll Call
15:01:39 <dmendiza[m]> Courtesy ping for ayoung, bbobrov, crisloma, d34dh0r53, dpar, dstanek, gagehugo, hrybacki, knikolla, lamt, lbragstad, lwanderley, kmalloc, rodrigods, samueldmq, spilla, ruan_he, wxy, sonuk, vishakha,Ajay, rafaelweingartner, xek
15:01:48 <xek> o/
15:01:51 <knikolla> o/
15:01:51 <d34dh0r53> o/
15:03:50 <dmendiza[m]> Hi everyone!
15:03:52 <dmendiza[m]> Let's get started
15:03:59 <dmendiza[m]> #topic Review Past Meeting Action Items
15:04:24 <dmendiza[m]> >  dmendiza[m] to look into updating the keystone-stable-maint group
15:04:30 <dmendiza[m]> Ugh, I still have not done this.
15:04:34 <dmendiza[m]> Let's kick the can down the road
15:04:37 <dmendiza[m]> #action
15:04:37 <dmendiza[m]> dmendiza[m] to look into updating the keystone-stable-maint group
15:04:53 <dmendiza[m]> #action dmendiza[m] to look into updating the keystone-stable-maint group
15:05:01 <dmendiza[m]> OK, moving on
15:05:09 <dmendiza[m]> #topic Liaison Updates
15:05:20 <dmendiza[m]> I think we may still need to merge all the Yoga branch stuff
15:05:28 * dmendiza[m] checks gate
15:07:43 <dmendiza[m]> For keystone I think we just need stable patches
15:07:54 <dmendiza[m]> so definitely need to get to that action item soon
15:09:11 <dmendiza[m]> For python-keystoneclient we have a chain of reno patches for the last 4 stable branches:
15:09:15 <dmendiza[m]> https://review.opendev.org/c/openstack/python-keystoneclient/+/751807
15:09:18 <dmendiza[m]> followed by
15:09:28 <dmendiza[m]> https://review.opendev.org/c/openstack/python-keystoneclient/+/781878
15:09:35 <dmendiza[m]> https://review.opendev.org/c/openstack/python-keystoneclient/+/809807
15:09:37 <opendevreview> Merged openstack/oslo.limit master: Add Python3 zed unit tests  https://review.opendev.org/c/openstack/oslo.limit/+/832063
15:09:50 <dmendiza[m]> https://review.opendev.org/c/openstack/python-keystoneclient/+/832027
15:10:18 <dmendiza[m]> knikolla: can you ninja-merge those?  They should be good to go
15:10:36 <knikolla> yes
15:11:06 <dmendiza[m]> Thanks
15:12:48 <dmendiza[m]> https://review.opendev.org/c/openstack/keystonemiddleware/+/832013
15:12:51 <dmendiza[m]> as well
15:14:39 <dmendiza[m]> and another chain of reno patches for keystoneauth:
15:14:44 <dmendiza[m]> https://review.opendev.org/c/openstack/keystoneauth/+/781869
15:14:51 <dmendiza[m]> https://review.opendev.org/c/openstack/keystoneauth/+/809814/
15:14:58 <dmendiza[m]> https://review.opendev.org/c/openstack/keystoneauth/+/833372
15:17:06 <dmendiza[m]> I think that's it for release related patches
15:17:22 <dmendiza[m]> doesn't look like pycadf of ldappool have any
15:17:41 <dmendiza[m]> OK, moving on
15:17:48 <dmendiza[m]> #topic OAuth 2.0
15:18:05 <dmendiza[m]> Still looking for reviews
15:18:07 <dmendiza[m]> #link https://review.opendev.org/q/topic:bp%252Foauth2-client-credentials-ext
15:18:19 <dmendiza[m]> h_asahina: any updates for us this week?
15:20:41 <dmendiza[m]> Probably not around ... let's move on
15:21:12 <dmendiza[m]> #topic Secure RBAC
15:21:25 <dmendiza[m]> I saw gmann added a topic to the PTG etherpad
15:21:55 <dmendiza[m]> We'll have some work to do towards the community goal this cycle.
15:25:38 <opendevreview> Merged openstack/keystoneauth master: Update master for stable/wallaby  https://review.opendev.org/c/openstack/keystoneauth/+/781869
15:25:40 <opendevreview> Merged openstack/keystoneauth master: Update master for stable/xena  https://review.opendev.org/c/openstack/keystoneauth/+/809814
15:26:15 <dmendiza[m]> OK, moving on
15:26:17 <dmendiza[m]> #topic PTG
15:26:25 <dmendiza[m]> Your weekly reminder that the PTG is coming up
15:26:47 <dmendiza[m]> #link https://etherpad.opendev.org/p/z-ptg-keystone
15:26:48 <opendevreview> Merged openstack/keystoneauth master: Update master for stable/yoga  https://review.opendev.org/c/openstack/keystoneauth/+/833372
15:27:05 <dmendiza[m]> It's happening two weeks from today
15:27:17 <dmendiza[m]> so make sure you get signed up
15:27:55 <opendevreview> Merged openstack/python-keystoneclient master: Update master for stable/victoria  https://review.opendev.org/c/openstack/python-keystoneclient/+/751807
15:27:58 <opendevreview> Merged openstack/python-keystoneclient master: Update master for stable/wallaby  https://review.opendev.org/c/openstack/python-keystoneclient/+/781878
15:28:00 <opendevreview> Merged openstack/python-keystoneclient master: Update master for stable/xena  https://review.opendev.org/c/openstack/python-keystoneclient/+/809807
15:28:03 <opendevreview> Merged openstack/python-keystoneclient master: Update master for stable/yoga  https://review.opendev.org/c/openstack/python-keystoneclient/+/832027
15:28:13 <opendevreview> Merged openstack/keystonemiddleware master: Update master for stable/yoga  https://review.opendev.org/c/openstack/keystonemiddleware/+/832013
15:29:51 <dmendiza[m]> Love to see all those merges
15:30:02 <d34dh0r53> yeah, thanks knikolla!
15:30:03 <dmendiza[m]> #topic Bug Review
15:30:45 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/?orderby=-id&start=0
15:31:01 <dmendiza[m]> Looks like we got one new bug
15:31:05 <dmendiza[m]> #link https://bugs.launchpad.net/keystone/+bug/1965316
15:31:29 <dmendiza[m]> >
15:31:29 <dmendiza[m]> No traceback on 400 "sequence item 0: expected str instance, bytes found" (TypeError)
15:31:42 <dmendiza[m]> reported by xek
15:32:05 <xek> there is a fix already submitted
15:32:05 <dmendiza[m]> I think xek will be working on that bug as well
15:32:10 <dmendiza[m]> awesome
15:33:50 <dmendiza[m]> xek: I can't seem to be able to search for your username in launchpad.  Would you mind assigning yourself to that bug?
15:34:02 <xek> dmendiza[m], ok
15:36:21 <dmendiza[m]> Thanks
15:36:42 <dmendiza[m]> #link https://bugs.launchpad.net/python-keystoneclient/?orderby=-id&start=0
15:36:49 <dmendiza[m]> looks like no new bugs
15:36:53 <dmendiza[m]> in python-keystoneclient
15:37:07 <dmendiza[m]> #link https://bugs.launchpad.net/keystoneauth/+bugs?orderby=-id&start=0
15:37:12 <dmendiza[m]> No new bugs in keystoneauth
15:37:23 <dmendiza[m]> #link https://bugs.launchpad.net/keystonemiddleware/+bugs?orderby=-id&start=0
15:37:30 <dmendiza[m]> no new bugs in keystonemiddleware
15:37:42 <dmendiza[m]> #link https://bugs.launchpad.net/pycadf/+bugs?orderby=-id&start=0
15:37:48 <dmendiza[m]> no new bugs in pycadf
15:38:00 <dmendiza[m]> #link https://bugs.launchpad.net/ldappool/+bugs?orderby=-id&start=0
15:38:44 <dmendiza[m]> and one new bug in ldappool 😱
15:38:53 <dmendiza[m]> #link https://bugs.launchpad.net/ldappool/+bug/1965824
15:39:00 <dmendiza[m]> > Need support for SASL binds
15:39:04 <dmendiza[m]> Seems more of an RFE
15:41:55 <d34dh0r53> Yeah, that is a feature request
15:43:11 <dmendiza[m]> That's it for bug review
15:43:15 <dmendiza[m]> #topic Open Discussion
15:43:24 <dmendiza[m]> Anything else y'all want to talk about while we're here?
15:44:45 <knikolla> dmendiza[m]: we talked on Friday during the reviewathon meeting, and agreed on giving you core reviewer status on keystone, if you accept the role.
15:45:09 <dmendiza[m]> 😵
15:45:18 <dmendiza[m]> Yes, of course. :D
15:45:31 <dmendiza[m]> Cue the Spiderman quote:
15:45:38 <dmendiza[m]> "With great power comes great responsibility"
15:46:11 <knikolla> congrats, just added you to the gerrit group
15:46:30 <dmendiza[m]> Thank you knikolla
15:47:15 <d34dh0r53> congrats dmendiza[m]
15:50:29 <dmendiza[m]> Thanks everyone for the vote of confidence.
15:50:40 <dmendiza[m]> On that note, let's end it for today
15:50:43 <dmendiza[m]> See y'all online!
15:50:49 <dmendiza[m]> #endmeeting